All of lore.kernel.org
 help / color / mirror / Atom feed
From: Marc Zyngier <maz@kernel.org>
To: linux-arm-kernel@lists.infradead.org,
	kvmarm@lists.cs.columbia.edu, kvm@vger.kernel.org
Cc: mark.rutland@arm.com, broonie@kernel.org,
	madvenka@linux.microsoft.com, tabba@google.com,
	oliver.upton@linux.dev, qperret@google.com,
	kaleshsingh@google.com, james.morse@arm.com,
	alexandru.elisei@arm.com, suzuki.poulose@arm.com,
	catalin.marinas@arm.com, andreyknvl@gmail.com,
	vincenzo.frascino@arm.com, mhiramat@kernel.org, ast@kernel.org,
	wangkefeng.wang@huawei.com, elver@google.com, keirf@google.com,
	yuzenghui@huawei.com, ardb@kernel.org, oupton@google.com,
	kernel-team@android.com
Subject: [PATCH 0/6] KVM: arm64: nVHE stack unwinder rework
Date: Wed, 27 Jul 2022 15:29:00 +0100	[thread overview]
Message-ID: <20220727142906.1856759-1-maz@kernel.org> (raw)
In-Reply-To: <20220726073750.3219117-18-kaleshsingh@google.com>

Hi all,

As Kalesh's series[1] already went through quite a few rounds and that
it has proved to be an extremely useful debugging help, I'd like to
queue it for 5.20.

However, there is a couple of nits that I'd like to address:

- the code is extremely hard to follow, due to the include maze and
  the various levels of inline functions that have forward
  declarations...

- there is a subtle bug in the way the kernel on_accessible_stack()
  helper has been rewritten

- the config symbol for the protected unwinder is oddly placed

Instead of going for another round and missing the merge window, I
propose to stash the following patches on top, which IMHO result in
something much more readable.

This series directly applies on top of Kalesh's.

[1] https://lore.kernel.org/r/20220726073750.3219117-1-kaleshsingh@google.com

Marc Zyngier (5):
  KVM: arm64: Move PROTECTED_NVHE_STACKTRACE around
  KVM: arm64: Move nVHE stacktrace unwinding into its own compilation
    unit
  KVM: arm64: Make unwind()/on_accessible_stack() per-unwinder functions
  KVM: arm64: Move nVHE-only helpers into kvm/stacktrace.c
  arm64: Update 'unwinder howto'

Oliver Upton (1):
  KVM: arm64: Don't open code ARRAY_SIZE()

 arch/arm64/include/asm/stacktrace.h        |  74 -------
 arch/arm64/include/asm/stacktrace/common.h |  69 ++-----
 arch/arm64/include/asm/stacktrace/nvhe.h   | 125 +-----------
 arch/arm64/kernel/stacktrace.c             |  90 +++++++++
 arch/arm64/kvm/Kconfig                     |  24 ++-
 arch/arm64/kvm/Makefile                    |   2 +-
 arch/arm64/kvm/handle_exit.c               |  98 ---------
 arch/arm64/kvm/hyp/nvhe/stacktrace.c       |  55 +++++-
 arch/arm64/kvm/stacktrace.c                | 218 +++++++++++++++++++++
 9 files changed, 394 insertions(+), 361 deletions(-)
 create mode 100644 arch/arm64/kvm/stacktrace.c

-- 
2.34.1


WARNING: multiple messages have this Message-ID (diff)
From: Marc Zyngier <maz@kernel.org>
To: linux-arm-kernel@lists.infradead.org,
	kvmarm@lists.cs.columbia.edu, kvm@vger.kernel.org
Cc: wangkefeng.wang@huawei.com, catalin.marinas@arm.com,
	ast@kernel.org, vincenzo.frascino@arm.com,
	madvenka@linux.microsoft.com, kernel-team@android.com,
	elver@google.com, broonie@kernel.org, andreyknvl@gmail.com,
	mhiramat@kernel.org
Subject: [PATCH 0/6] KVM: arm64: nVHE stack unwinder rework
Date: Wed, 27 Jul 2022 15:29:00 +0100	[thread overview]
Message-ID: <20220727142906.1856759-1-maz@kernel.org> (raw)
In-Reply-To: <20220726073750.3219117-18-kaleshsingh@google.com>

Hi all,

As Kalesh's series[1] already went through quite a few rounds and that
it has proved to be an extremely useful debugging help, I'd like to
queue it for 5.20.

However, there is a couple of nits that I'd like to address:

- the code is extremely hard to follow, due to the include maze and
  the various levels of inline functions that have forward
  declarations...

- there is a subtle bug in the way the kernel on_accessible_stack()
  helper has been rewritten

- the config symbol for the protected unwinder is oddly placed

Instead of going for another round and missing the merge window, I
propose to stash the following patches on top, which IMHO result in
something much more readable.

This series directly applies on top of Kalesh's.

[1] https://lore.kernel.org/r/20220726073750.3219117-1-kaleshsingh@google.com

Marc Zyngier (5):
  KVM: arm64: Move PROTECTED_NVHE_STACKTRACE around
  KVM: arm64: Move nVHE stacktrace unwinding into its own compilation
    unit
  KVM: arm64: Make unwind()/on_accessible_stack() per-unwinder functions
  KVM: arm64: Move nVHE-only helpers into kvm/stacktrace.c
  arm64: Update 'unwinder howto'

Oliver Upton (1):
  KVM: arm64: Don't open code ARRAY_SIZE()

 arch/arm64/include/asm/stacktrace.h        |  74 -------
 arch/arm64/include/asm/stacktrace/common.h |  69 ++-----
 arch/arm64/include/asm/stacktrace/nvhe.h   | 125 +-----------
 arch/arm64/kernel/stacktrace.c             |  90 +++++++++
 arch/arm64/kvm/Kconfig                     |  24 ++-
 arch/arm64/kvm/Makefile                    |   2 +-
 arch/arm64/kvm/handle_exit.c               |  98 ---------
 arch/arm64/kvm/hyp/nvhe/stacktrace.c       |  55 +++++-
 arch/arm64/kvm/stacktrace.c                | 218 +++++++++++++++++++++
 9 files changed, 394 insertions(+), 361 deletions(-)
 create mode 100644 arch/arm64/kvm/stacktrace.c

-- 
2.34.1

_______________________________________________
kvmarm mailing list
kvmarm@lists.cs.columbia.edu
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm

WARNING: multiple messages have this Message-ID (diff)
From: Marc Zyngier <maz@kernel.org>
To: linux-arm-kernel@lists.infradead.org,
	kvmarm@lists.cs.columbia.edu, kvm@vger.kernel.org
Cc: mark.rutland@arm.com, broonie@kernel.org,
	madvenka@linux.microsoft.com, tabba@google.com,
	oliver.upton@linux.dev, qperret@google.com,
	kaleshsingh@google.com, james.morse@arm.com,
	alexandru.elisei@arm.com, suzuki.poulose@arm.com,
	catalin.marinas@arm.com, andreyknvl@gmail.com,
	vincenzo.frascino@arm.com, mhiramat@kernel.org, ast@kernel.org,
	wangkefeng.wang@huawei.com, elver@google.com, keirf@google.com,
	yuzenghui@huawei.com, ardb@kernel.org, oupton@google.com,
	kernel-team@android.com
Subject: [PATCH 0/6] KVM: arm64: nVHE stack unwinder rework
Date: Wed, 27 Jul 2022 15:29:00 +0100	[thread overview]
Message-ID: <20220727142906.1856759-1-maz@kernel.org> (raw)
In-Reply-To: <20220726073750.3219117-18-kaleshsingh@google.com>

Hi all,

As Kalesh's series[1] already went through quite a few rounds and that
it has proved to be an extremely useful debugging help, I'd like to
queue it for 5.20.

However, there is a couple of nits that I'd like to address:

- the code is extremely hard to follow, due to the include maze and
  the various levels of inline functions that have forward
  declarations...

- there is a subtle bug in the way the kernel on_accessible_stack()
  helper has been rewritten

- the config symbol for the protected unwinder is oddly placed

Instead of going for another round and missing the merge window, I
propose to stash the following patches on top, which IMHO result in
something much more readable.

This series directly applies on top of Kalesh's.

[1] https://lore.kernel.org/r/20220726073750.3219117-1-kaleshsingh@google.com

Marc Zyngier (5):
  KVM: arm64: Move PROTECTED_NVHE_STACKTRACE around
  KVM: arm64: Move nVHE stacktrace unwinding into its own compilation
    unit
  KVM: arm64: Make unwind()/on_accessible_stack() per-unwinder functions
  KVM: arm64: Move nVHE-only helpers into kvm/stacktrace.c
  arm64: Update 'unwinder howto'

Oliver Upton (1):
  KVM: arm64: Don't open code ARRAY_SIZE()

 arch/arm64/include/asm/stacktrace.h        |  74 -------
 arch/arm64/include/asm/stacktrace/common.h |  69 ++-----
 arch/arm64/include/asm/stacktrace/nvhe.h   | 125 +-----------
 arch/arm64/kernel/stacktrace.c             |  90 +++++++++
 arch/arm64/kvm/Kconfig                     |  24 ++-
 arch/arm64/kvm/Makefile                    |   2 +-
 arch/arm64/kvm/handle_exit.c               |  98 ---------
 arch/arm64/kvm/hyp/nvhe/stacktrace.c       |  55 +++++-
 arch/arm64/kvm/stacktrace.c                | 218 +++++++++++++++++++++
 9 files changed, 394 insertions(+), 361 deletions(-)
 create mode 100644 arch/arm64/kvm/stacktrace.c

-- 
2.34.1


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2022-07-27 14:29 UTC|newest]

Thread overview: 112+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-26  7:37 [PATCH v6 00/17] KVM nVHE Hypervisor stack unwinder Kalesh Singh
2022-07-26  7:37 ` Kalesh Singh
2022-07-26  7:37 ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 01/17] arm64: stacktrace: Add shared header for common stack unwinding code Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 02/17] arm64: stacktrace: Factor out on_accessible_stack_common() Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26 16:01   ` Marc Zyngier
2022-07-26 16:01     ` Marc Zyngier
2022-07-26 16:01     ` Marc Zyngier
2022-07-26 16:33     ` Kalesh Singh
2022-07-26 16:33       ` Kalesh Singh
2022-07-26 16:33       ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 03/17] arm64: stacktrace: Factor out unwind_next_common() Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 04/17] arm64: stacktrace: Handle frame pointer from different address spaces Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26 14:34   ` Mark Brown
2022-07-26 14:34     ` Mark Brown
2022-07-26 14:34     ` Mark Brown
2022-07-26 15:30     ` Kalesh Singh
2022-07-26 15:30       ` Kalesh Singh
2022-07-26 15:30       ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 05/17] arm64: stacktrace: Factor out common unwind() Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 06/17] arm64: stacktrace: Add description of stacktrace/common.h Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26 14:49   ` Mark Brown
2022-07-26 14:49     ` Mark Brown
2022-07-26 14:49     ` Mark Brown
2022-07-26  7:37 ` [PATCH v6 07/17] KVM: arm64: On stack overflow switch to hyp overflow_stack Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 08/17] KVM: arm64: Stub implementation of non-protected nVHE HYP stack unwinder Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 09/17] KVM: arm64: Prepare non-protected nVHE hypervisor stacktrace Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26 16:26   ` kernel test robot
2022-07-26  7:37 ` [PATCH v6 10/17] KVM: arm64: Implement non-protected nVHE hyp stack unwinder Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 11/17] KVM: arm64: Introduce hyp_dump_backtrace() Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 12/17] KVM: arm64: Add PROTECTED_NVHE_STACKTRACE Kconfig Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26 10:00   ` Marc Zyngier
2022-07-26 10:00     ` Marc Zyngier
2022-07-26 10:00     ` Marc Zyngier
2022-07-26 15:33     ` Kalesh Singh
2022-07-26 15:33       ` Kalesh Singh
2022-07-26 15:33       ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 13/17] KVM: arm64: Allocate shared pKVM hyp stacktrace buffers Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 14/17] KVM: arm64: Stub implementation of pKVM HYP stack unwinder Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 15/17] KVM: arm64: Save protected-nVHE (pKVM) hyp stacktrace Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 16/17] KVM: arm64: Implement protected nVHE hyp stack unwinder Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37 ` [PATCH v6 17/17] KVM: arm64: Introduce pkvm_dump_backtrace() Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-26  7:37   ` Kalesh Singh
2022-07-27 14:29   ` Marc Zyngier [this message]
2022-07-27 14:29     ` [PATCH 0/6] KVM: arm64: nVHE stack unwinder rework Marc Zyngier
2022-07-27 14:29     ` Marc Zyngier
2022-07-27 14:29     ` [PATCH 1/6] KVM: arm64: Move PROTECTED_NVHE_STACKTRACE around Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29     ` [PATCH 2/6] KVM: arm64: Move nVHE stacktrace unwinding into its own compilation unit Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29     ` [PATCH 3/6] KVM: arm64: Make unwind()/on_accessible_stack() per-unwinder functions Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 17:32       ` Mark Brown
2022-07-27 17:32         ` Mark Brown
2022-07-27 17:32         ` Mark Brown
2022-07-27 14:29     ` [PATCH 4/6] KVM: arm64: Move nVHE-only helpers into kvm/stacktrace.c Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29     ` [PATCH 5/6] KVM: arm64: Don't open code ARRAY_SIZE() Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29     ` [PATCH 6/6] arm64: Update 'unwinder howto' Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 14:29       ` Marc Zyngier
2022-07-27 15:56     ` [PATCH 0/6] KVM: arm64: nVHE stack unwinder rework Kalesh Singh
2022-07-27 15:56       ` Kalesh Singh
2022-07-27 15:56       ` Kalesh Singh
2022-07-27 16:01     ` Oliver Upton
2022-07-27 16:01       ` Oliver Upton
2022-07-27 16:01       ` Oliver Upton
2022-07-27 17:45     ` Marc Zyngier
2022-07-27 17:45       ` Marc Zyngier
2022-07-27 17:45       ` Marc Zyngier
2022-07-27 17:44 ` [PATCH v6 00/17] KVM nVHE Hypervisor stack unwinder Marc Zyngier
2022-07-27 17:44   ` Marc Zyngier
2022-07-27 17:44   ` Marc Zyngier

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220727142906.1856759-1-maz@kernel.org \
    --to=maz@kernel.org \
    --cc=alexandru.elisei@arm.com \
    --cc=andreyknvl@gmail.com \
    --cc=ardb@kernel.org \
    --cc=ast@kernel.org \
    --cc=broonie@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=elver@google.com \
    --cc=james.morse@arm.com \
    --cc=kaleshsingh@google.com \
    --cc=keirf@google.com \
    --cc=kernel-team@android.com \
    --cc=kvm@vger.kernel.org \
    --cc=kvmarm@lists.cs.columbia.edu \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=madvenka@linux.microsoft.com \
    --cc=mark.rutland@arm.com \
    --cc=mhiramat@kernel.org \
    --cc=oliver.upton@linux.dev \
    --cc=oupton@google.com \
    --cc=qperret@google.com \
    --cc=suzuki.poulose@arm.com \
    --cc=tabba@google.com \
    --cc=vincenzo.frascino@arm.com \
    --cc=wangkefeng.wang@huawei.com \
    --cc=yuzenghui@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.