All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andrew Lunn <andrew@lunn.ch>
To: Evan Quan <evan.quan@amd.com>
Cc: rafael@kernel.org, lenb@kernel.org, Alexander.Deucher@amd.com,
	Christian.Koenig@amd.com, Xinhui.Pan@amd.com, airlied@gmail.com,
	daniel@ffwll.ch, johannes@sipsolutions.net, davem@davemloft.net,
	edumazet@google.com, kuba@kernel.org, pabeni@redhat.com,
	Mario.Limonciello@amd.com, mdaenzer@redhat.com,
	maarten.lankhorst@linux.intel.com, tzimmermann@suse.de,
	hdegoede@redhat.com, jingyuwang_vip@163.com, Lijo.Lazar@amd.com,
	jim.cromie@gmail.com, bellosilicio@gmail.com,
	andrealmeid@igalia.com, trix@redhat.com, jsg@jsg.id.au,
	arnd@arndb.de, linux-kernel@vger.kernel.org,
	linux-acpi@vger.kernel.org, amd-gfx@lists.freedesktop.org,
	dri-devel@lists.freedesktop.org, linux-wireless@vger.kernel.org,
	netdev@vger.kernel.org
Subject: Re: [PATCH V5 2/9] driver core: add ACPI based WBRF mechanism introduced by AMD
Date: Sat, 1 Jul 2023 02:51:22 +0200	[thread overview]
Message-ID: <4b2d5e30-1962-40f4-8c36-bfc35eba503c@lunn.ch> (raw)
In-Reply-To: <20230630103240.1557100-3-evan.quan@amd.com>

> +	argv4 = kzalloc(sizeof(*argv4) * (2 * num_of_ranges + 2 + 1), GFP_KERNEL);
> +	if (!argv4)
> +		return -ENOMEM;
> +
> +	argv4[arg_idx].package.type = ACPI_TYPE_PACKAGE;
> +	argv4[arg_idx].package.count = 2 + 2 * num_of_ranges;
> +	argv4[arg_idx++].package.elements = &argv4[1];
> +	argv4[arg_idx].integer.type = ACPI_TYPE_INTEGER;
> +	argv4[arg_idx++].integer.value = num_of_ranges;
> +	argv4[arg_idx].integer.type = ACPI_TYPE_INTEGER;
> +	argv4[arg_idx++].integer.value = action;

There is a lot of magic numbers in that kzalloc. It is being used as
an array, kcalloc() would be a good start to make it more readable.
Can some #define's be used to explain what the other numbers mean?

> +	/*
> +	 * Bit 0 indicates whether there's support for any functions other than
> +	 * function 0.
> +	 */

Please make use of the BIT macro to give the different bits
informative names.

> +	if ((mask & 0x1) && (mask & funcs) == funcs)
> +		return true;
> +
> +	return false;
> +}
> +

> +int acpi_amd_wbrf_retrieve_exclusions(struct device *dev,
> +				      struct wbrf_ranges_out *out)
> +{
> +	struct acpi_device *adev = ACPI_COMPANION(dev);
> +	union acpi_object *obj;
> +
> +	if (!adev)
> +		return -ENODEV;
> +
> +	obj = acpi_evaluate_wbrf(adev->handle,
> +				 WBRF_REVISION,
> +				 WBRF_RETRIEVE);
> +	if (!obj)
> +		return -EINVAL;
> +
> +	WARN(obj->buffer.length != sizeof(*out),
> +		"Unexpected buffer length");
> +	memcpy(out, obj->buffer.pointer, obj->buffer.length);

You WARN, and then overwrite whatever i passed the end of out?  Please
at least use min(obj->buffer.length, sizeof(*out)), but better still:

   if (obj->buffer.length != sizeof(*out)) {
         dev_err(dev, "BIOS FUBAR, ignoring wrong sized WBRT information");
	 return -EINVAL;
   }

> +#if defined(CONFIG_WBRF_GENERIC)
>  static struct exclusion_range_pool wbrf_pool;
>  
>  static int _wbrf_add_exclusion_ranges(struct wbrf_ranges_in *in)
> @@ -89,6 +92,7 @@ static int _wbrf_retrieve_exclusion_ranges(struct wbrf_ranges_out *out)
>  
>  	return 0;
>  }
> +#endif

I was expecting you would keep these tables, and then call into the
BIOS as well. Having this table in debugfs seems like a useful thing
to have for debugging the BIOS.

> +#ifdef CONFIG_WBRF_AMD_ACPI
> +#else
> +static inline bool
> +acpi_amd_wbrf_supported_consumer(struct device *dev) { return false; }
> +static inline bool
> +acpi_amd_wbrf_supported_producer(struct device *dev) {return false; }
> +static inline int
> +acpi_amd_wbrf_remove_exclusion(struct device *dev,
> +			       struct wbrf_ranges_in *in) { return -ENODEV; }
> +static inline int
> +acpi_amd_wbrf_add_exclusion(struct device *dev,
> +			    struct wbrf_ranges_in *in) { return -ENODEV; }
> +static inline int
> +acpi_amd_wbrf_retrieve_exclusions(struct device *dev,
> +				  struct wbrf_ranges_out *out) { return -ENODEV; }

Do you actually need these stub versions?

	Andrew

WARNING: multiple messages have this Message-ID (diff)
From: Andrew Lunn <andrew@lunn.ch>
To: Evan Quan <evan.quan@amd.com>
Cc: jingyuwang_vip@163.com, bellosilicio@gmail.com,
	rafael@kernel.org, trix@redhat.com, Lijo.Lazar@amd.com,
	dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
	mdaenzer@redhat.com, Mario.Limonciello@amd.com,
	amd-gfx@lists.freedesktop.org, linux-acpi@vger.kernel.org,
	kuba@kernel.org, pabeni@redhat.com, lenb@kernel.org,
	andrealmeid@igalia.com, arnd@arndb.de, hdegoede@redhat.com,
	netdev@vger.kernel.org, Xinhui.Pan@amd.com,
	linux-wireless@vger.kernel.org, edumazet@google.com,
	Christian.Koenig@amd.com, tzimmermann@suse.de,
	Alexander.Deucher@amd.com, johannes@sipsolutions.net,
	davem@davemloft.net
Subject: Re: [PATCH V5 2/9] driver core: add ACPI based WBRF mechanism introduced by AMD
Date: Sat, 1 Jul 2023 02:51:22 +0200	[thread overview]
Message-ID: <4b2d5e30-1962-40f4-8c36-bfc35eba503c@lunn.ch> (raw)
In-Reply-To: <20230630103240.1557100-3-evan.quan@amd.com>

> +	argv4 = kzalloc(sizeof(*argv4) * (2 * num_of_ranges + 2 + 1), GFP_KERNEL);
> +	if (!argv4)
> +		return -ENOMEM;
> +
> +	argv4[arg_idx].package.type = ACPI_TYPE_PACKAGE;
> +	argv4[arg_idx].package.count = 2 + 2 * num_of_ranges;
> +	argv4[arg_idx++].package.elements = &argv4[1];
> +	argv4[arg_idx].integer.type = ACPI_TYPE_INTEGER;
> +	argv4[arg_idx++].integer.value = num_of_ranges;
> +	argv4[arg_idx].integer.type = ACPI_TYPE_INTEGER;
> +	argv4[arg_idx++].integer.value = action;

There is a lot of magic numbers in that kzalloc. It is being used as
an array, kcalloc() would be a good start to make it more readable.
Can some #define's be used to explain what the other numbers mean?

> +	/*
> +	 * Bit 0 indicates whether there's support for any functions other than
> +	 * function 0.
> +	 */

Please make use of the BIT macro to give the different bits
informative names.

> +	if ((mask & 0x1) && (mask & funcs) == funcs)
> +		return true;
> +
> +	return false;
> +}
> +

> +int acpi_amd_wbrf_retrieve_exclusions(struct device *dev,
> +				      struct wbrf_ranges_out *out)
> +{
> +	struct acpi_device *adev = ACPI_COMPANION(dev);
> +	union acpi_object *obj;
> +
> +	if (!adev)
> +		return -ENODEV;
> +
> +	obj = acpi_evaluate_wbrf(adev->handle,
> +				 WBRF_REVISION,
> +				 WBRF_RETRIEVE);
> +	if (!obj)
> +		return -EINVAL;
> +
> +	WARN(obj->buffer.length != sizeof(*out),
> +		"Unexpected buffer length");
> +	memcpy(out, obj->buffer.pointer, obj->buffer.length);

You WARN, and then overwrite whatever i passed the end of out?  Please
at least use min(obj->buffer.length, sizeof(*out)), but better still:

   if (obj->buffer.length != sizeof(*out)) {
         dev_err(dev, "BIOS FUBAR, ignoring wrong sized WBRT information");
	 return -EINVAL;
   }

> +#if defined(CONFIG_WBRF_GENERIC)
>  static struct exclusion_range_pool wbrf_pool;
>  
>  static int _wbrf_add_exclusion_ranges(struct wbrf_ranges_in *in)
> @@ -89,6 +92,7 @@ static int _wbrf_retrieve_exclusion_ranges(struct wbrf_ranges_out *out)
>  
>  	return 0;
>  }
> +#endif

I was expecting you would keep these tables, and then call into the
BIOS as well. Having this table in debugfs seems like a useful thing
to have for debugging the BIOS.

> +#ifdef CONFIG_WBRF_AMD_ACPI
> +#else
> +static inline bool
> +acpi_amd_wbrf_supported_consumer(struct device *dev) { return false; }
> +static inline bool
> +acpi_amd_wbrf_supported_producer(struct device *dev) {return false; }
> +static inline int
> +acpi_amd_wbrf_remove_exclusion(struct device *dev,
> +			       struct wbrf_ranges_in *in) { return -ENODEV; }
> +static inline int
> +acpi_amd_wbrf_add_exclusion(struct device *dev,
> +			    struct wbrf_ranges_in *in) { return -ENODEV; }
> +static inline int
> +acpi_amd_wbrf_retrieve_exclusions(struct device *dev,
> +				  struct wbrf_ranges_out *out) { return -ENODEV; }

Do you actually need these stub versions?

	Andrew

WARNING: multiple messages have this Message-ID (diff)
From: Andrew Lunn <andrew@lunn.ch>
To: Evan Quan <evan.quan@amd.com>
Cc: jingyuwang_vip@163.com, bellosilicio@gmail.com,
	rafael@kernel.org, trix@redhat.com, Lijo.Lazar@amd.com,
	dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
	mdaenzer@redhat.com, Mario.Limonciello@amd.com,
	airlied@gmail.com, amd-gfx@lists.freedesktop.org,
	linux-acpi@vger.kernel.org, kuba@kernel.org, pabeni@redhat.com,
	lenb@kernel.org, andrealmeid@igalia.com, daniel@ffwll.ch,
	arnd@arndb.de, maarten.lankhorst@linux.intel.com,
	hdegoede@redhat.com, jsg@jsg.id.au, jim.cromie@gmail.com,
	netdev@vger.kernel.org, Xinhui.Pan@amd.com,
	linux-wireless@vger.kernel.org, edumazet@google.com,
	Christian.Koenig@amd.com, tzimmermann@suse.de,
	Alexander.Deucher@amd.com, johannes@sipsolutions.net,
	davem@davemloft.net
Subject: Re: [PATCH V5 2/9] driver core: add ACPI based WBRF mechanism introduced by AMD
Date: Sat, 1 Jul 2023 02:51:22 +0200	[thread overview]
Message-ID: <4b2d5e30-1962-40f4-8c36-bfc35eba503c@lunn.ch> (raw)
In-Reply-To: <20230630103240.1557100-3-evan.quan@amd.com>

> +	argv4 = kzalloc(sizeof(*argv4) * (2 * num_of_ranges + 2 + 1), GFP_KERNEL);
> +	if (!argv4)
> +		return -ENOMEM;
> +
> +	argv4[arg_idx].package.type = ACPI_TYPE_PACKAGE;
> +	argv4[arg_idx].package.count = 2 + 2 * num_of_ranges;
> +	argv4[arg_idx++].package.elements = &argv4[1];
> +	argv4[arg_idx].integer.type = ACPI_TYPE_INTEGER;
> +	argv4[arg_idx++].integer.value = num_of_ranges;
> +	argv4[arg_idx].integer.type = ACPI_TYPE_INTEGER;
> +	argv4[arg_idx++].integer.value = action;

There is a lot of magic numbers in that kzalloc. It is being used as
an array, kcalloc() would be a good start to make it more readable.
Can some #define's be used to explain what the other numbers mean?

> +	/*
> +	 * Bit 0 indicates whether there's support for any functions other than
> +	 * function 0.
> +	 */

Please make use of the BIT macro to give the different bits
informative names.

> +	if ((mask & 0x1) && (mask & funcs) == funcs)
> +		return true;
> +
> +	return false;
> +}
> +

> +int acpi_amd_wbrf_retrieve_exclusions(struct device *dev,
> +				      struct wbrf_ranges_out *out)
> +{
> +	struct acpi_device *adev = ACPI_COMPANION(dev);
> +	union acpi_object *obj;
> +
> +	if (!adev)
> +		return -ENODEV;
> +
> +	obj = acpi_evaluate_wbrf(adev->handle,
> +				 WBRF_REVISION,
> +				 WBRF_RETRIEVE);
> +	if (!obj)
> +		return -EINVAL;
> +
> +	WARN(obj->buffer.length != sizeof(*out),
> +		"Unexpected buffer length");
> +	memcpy(out, obj->buffer.pointer, obj->buffer.length);

You WARN, and then overwrite whatever i passed the end of out?  Please
at least use min(obj->buffer.length, sizeof(*out)), but better still:

   if (obj->buffer.length != sizeof(*out)) {
         dev_err(dev, "BIOS FUBAR, ignoring wrong sized WBRT information");
	 return -EINVAL;
   }

> +#if defined(CONFIG_WBRF_GENERIC)
>  static struct exclusion_range_pool wbrf_pool;
>  
>  static int _wbrf_add_exclusion_ranges(struct wbrf_ranges_in *in)
> @@ -89,6 +92,7 @@ static int _wbrf_retrieve_exclusion_ranges(struct wbrf_ranges_out *out)
>  
>  	return 0;
>  }
> +#endif

I was expecting you would keep these tables, and then call into the
BIOS as well. Having this table in debugfs seems like a useful thing
to have for debugging the BIOS.

> +#ifdef CONFIG_WBRF_AMD_ACPI
> +#else
> +static inline bool
> +acpi_amd_wbrf_supported_consumer(struct device *dev) { return false; }
> +static inline bool
> +acpi_amd_wbrf_supported_producer(struct device *dev) {return false; }
> +static inline int
> +acpi_amd_wbrf_remove_exclusion(struct device *dev,
> +			       struct wbrf_ranges_in *in) { return -ENODEV; }
> +static inline int
> +acpi_amd_wbrf_add_exclusion(struct device *dev,
> +			    struct wbrf_ranges_in *in) { return -ENODEV; }
> +static inline int
> +acpi_amd_wbrf_retrieve_exclusions(struct device *dev,
> +				  struct wbrf_ranges_out *out) { return -ENODEV; }

Do you actually need these stub versions?

	Andrew

  reply	other threads:[~2023-07-01  0:51 UTC|newest]

Thread overview: 69+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-06-30 10:32 [PATCH V5 0/9] Enable Wifi RFI interference mitigation feature support Evan Quan
2023-06-30 10:32 ` Evan Quan
2023-06-30 10:32 ` [PATCH V5 1/9] drivers core: Add support for Wifi band RF mitigations Evan Quan
2023-06-30 10:32   ` Evan Quan
2023-06-30 13:38   ` Simon Horman
2023-06-30 13:38     ` Simon Horman
2023-06-30 13:38     ` Simon Horman
2023-07-04  3:41     ` Quan, Evan
2023-07-04  3:41       ` Quan, Evan
2023-07-04  3:41       ` Quan, Evan
2023-06-30 16:40   ` Limonciello, Mario
2023-06-30 16:40     ` Limonciello, Mario
2023-07-01  0:25     ` Andrew Lunn
2023-07-01  0:25       ` Andrew Lunn
2023-07-01  0:25       ` Andrew Lunn
2023-07-04  3:25       ` Quan, Evan
2023-07-04  3:25         ` Quan, Evan
2023-07-04  3:25         ` Quan, Evan
2023-07-04  3:40     ` Quan, Evan
2023-07-04  3:40       ` Quan, Evan
2023-07-04  3:53       ` Mario Limonciello
2023-07-04  3:53         ` Mario Limonciello
2023-07-01  0:19   ` Andrew Lunn
2023-07-01  0:19     ` Andrew Lunn
2023-07-01  0:19     ` Andrew Lunn
2023-07-04  3:30     ` Quan, Evan
2023-07-04  3:30       ` Quan, Evan
2023-07-04  3:30       ` Quan, Evan
2023-07-04 13:07       ` Andrew Lunn
2023-07-04 13:07         ` Andrew Lunn
2023-07-04 13:07         ` Andrew Lunn
2023-07-06  2:58         ` Quan, Evan
2023-07-06  2:58           ` Quan, Evan
2023-07-06  2:58           ` Quan, Evan
2023-07-06  3:09           ` Mario Limonciello
2023-07-06  3:09             ` Mario Limonciello
2023-07-06  3:09             ` Mario Limonciello
2023-06-30 10:32 ` [PATCH V5 2/9] driver core: add ACPI based WBRF mechanism introduced by AMD Evan Quan
2023-06-30 10:32   ` Evan Quan
2023-07-01  0:51   ` Andrew Lunn [this message]
2023-07-01  0:51     ` Andrew Lunn
2023-07-01  0:51     ` Andrew Lunn
2023-07-04  3:24     ` Quan, Evan
2023-07-04  3:24       ` Quan, Evan
2023-07-04  3:24       ` Quan, Evan
2023-06-30 10:32 ` [PATCH V5 3/9] cfg80211: expose nl80211_chan_width_to_mhz for wide sharing Evan Quan
2023-06-30 10:32   ` Evan Quan
2023-06-30 10:32 ` [PATCH V5 4/9] wifi: mac80211: Add support for ACPI WBRF Evan Quan
2023-06-30 10:32   ` Evan Quan
2023-06-30 14:08   ` kernel test robot
2023-06-30 14:08     ` kernel test robot
2023-07-01  1:02   ` Andrew Lunn
2023-07-01  1:02     ` Andrew Lunn
2023-07-01  1:02     ` Andrew Lunn
2023-07-04  3:12     ` Quan, Evan
2023-07-04  3:12       ` Quan, Evan
2023-07-04  3:12       ` Quan, Evan
2023-06-30 10:32 ` [PATCH V5 5/9] drm/amd/pm: update driver_if and ppsmc headers for coming wbrf feature Evan Quan
2023-06-30 10:32   ` Evan Quan
2023-06-30 10:32 ` [PATCH V5 6/9] drm/amd/pm: setup the framework to support Wifi RFI mitigation feature Evan Quan
2023-06-30 10:32   ` Evan Quan
2023-06-30 10:32 ` [PATCH V5 7/9] drm/amd/pm: add flood detection for wbrf events Evan Quan
2023-06-30 10:32   ` Evan Quan
2023-06-30 14:29   ` kernel test robot
2023-06-30 14:29     ` kernel test robot
2023-06-30 10:32 ` [PATCH V5 8/9] drm/amd/pm: enable Wifi RFI mitigation feature support for SMU13.0.0 Evan Quan
2023-06-30 10:32   ` Evan Quan
2023-06-30 10:32 ` [PATCH V5 9/9] drm/amd/pm: enable Wifi RFI mitigation feature support for SMU13.0.7 Evan Quan
2023-06-30 10:32   ` Evan Quan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4b2d5e30-1962-40f4-8c36-bfc35eba503c@lunn.ch \
    --to=andrew@lunn.ch \
    --cc=Alexander.Deucher@amd.com \
    --cc=Christian.Koenig@amd.com \
    --cc=Lijo.Lazar@amd.com \
    --cc=Mario.Limonciello@amd.com \
    --cc=Xinhui.Pan@amd.com \
    --cc=airlied@gmail.com \
    --cc=amd-gfx@lists.freedesktop.org \
    --cc=andrealmeid@igalia.com \
    --cc=arnd@arndb.de \
    --cc=bellosilicio@gmail.com \
    --cc=daniel@ffwll.ch \
    --cc=davem@davemloft.net \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=edumazet@google.com \
    --cc=evan.quan@amd.com \
    --cc=hdegoede@redhat.com \
    --cc=jim.cromie@gmail.com \
    --cc=jingyuwang_vip@163.com \
    --cc=johannes@sipsolutions.net \
    --cc=jsg@jsg.id.au \
    --cc=kuba@kernel.org \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=mdaenzer@redhat.com \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    --cc=rafael@kernel.org \
    --cc=trix@redhat.com \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.