All of lore.kernel.org
 help / color / mirror / Atom feed
From: Benjamin Gaignard <benjamin.gaignard@linaro.org>
To: Philippe CORNU <philippe.cornu@st.com>
Cc: Yannick Fertre <yannick.fertre@st.com>,
	Vincent Abriou <vincent.abriou@st.com>,
	David Airlie <airlied@linux.ie>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Fabien Dessenne <fabien.dessenne@st.com>,
	Mickael Reulier <mickael.reulier@st.com>,
	Gabriel Fernandez <gabriel.fernandez@st.com>,
	Ludovic Barre <ludovic.barre@st.com>,
	Alexandre Torgue <alexandre.torgue@st.com>,
	Maxime Coquelin <mcoquelin.stm32@gmail.com>
Subject: Re: [PATCH v1 1/7] drm/stm: drv: Rename platform driver name
Date: Thu, 20 Jul 2017 11:27:04 +0200	[thread overview]
Message-ID: <CA+M3ks5-_f=zh1ozHiWU8JzUGZeWU3hxh23fqeVWrAEQJogUDQ@mail.gmail.com> (raw)
In-Reply-To: <1500373219-20233-2-git-send-email-philippe.cornu@st.com>

2017-07-18 12:20 GMT+02:00 Philippe CORNU <philippe.cornu@st.com>:
> Rename the platform driver name from "stm" to "stm32-display"
> for a better readability in /sys/bus/platform/drivers entries.
>
> Note: We keep "stm" as drm_driver.name because it is better
> when using "modetest -M stm ..." (even if recent modetest patch
> avoids using -M).
>
> Signed-off-by: Philippe CORNU <philippe.cornu@st.com>

Reviewed-by: Benjamin Gaignard <benjamin.gaignard@linaro.org>

> ---
>  drivers/gpu/drm/stm/drv.c | 21 +++++++--------------
>  1 file changed, 7 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/gpu/drm/stm/drv.c b/drivers/gpu/drm/stm/drv.c
> index 83ab48f..095971f 100644
> --- a/drivers/gpu/drm/stm/drv.c
> +++ b/drivers/gpu/drm/stm/drv.c
> @@ -20,13 +20,6 @@
>
>  #include "ltdc.h"
>
> -#define DRIVER_NAME            "stm"
> -#define DRIVER_DESC            "STMicroelectronics SoC DRM"
> -#define DRIVER_DATE            "20170330"
> -#define DRIVER_MAJOR           1
> -#define DRIVER_MINOR           0
> -#define DRIVER_PATCH_LEVEL     0
> -
>  #define STM_MAX_FB_WIDTH       2048
>  #define STM_MAX_FB_HEIGHT      2048 /* same as width to handle orientation */
>
> @@ -59,12 +52,12 @@ static void drv_lastclose(struct drm_device *ddev)
>         .driver_features = DRIVER_MODESET | DRIVER_GEM | DRIVER_PRIME |
>                            DRIVER_ATOMIC,
>         .lastclose = drv_lastclose,
> -       .name = DRIVER_NAME,
> -       .desc = DRIVER_DESC,
> -       .date = DRIVER_DATE,
> -       .major = DRIVER_MAJOR,
> -       .minor = DRIVER_MINOR,
> -       .patchlevel = DRIVER_PATCH_LEVEL,
> +       .name = "stm",
> +       .desc = "STMicroelectronics SoC DRM",
> +       .date = "20170330",
> +       .major = 1,
> +       .minor = 0,
> +       .patchlevel = 0,
>         .fops = &drv_driver_fops,
>         .dumb_create = drm_gem_cma_dumb_create,
>         .dumb_map_offset = drm_gem_cma_dumb_map_offset,
> @@ -206,7 +199,7 @@ static int stm_drm_platform_remove(struct platform_device *pdev)
>         .probe = stm_drm_platform_probe,
>         .remove = stm_drm_platform_remove,
>         .driver = {
> -               .name = DRIVER_NAME,
> +               .name = "stm32-display",
>                 .of_match_table = drv_dt_ids,
>         },
>  };
> --
> 1.9.1
>

WARNING: multiple messages have this Message-ID (diff)
From: Benjamin Gaignard <benjamin.gaignard@linaro.org>
To: Philippe CORNU <philippe.cornu@st.com>
Cc: Alexandre Torgue <alexandre.torgue@st.com>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	Yannick Fertre <yannick.fertre@st.com>,
	Fabien Dessenne <fabien.dessenne@st.com>,
	Maxime Coquelin <mcoquelin.stm32@gmail.com>,
	Mickael Reulier <mickael.reulier@st.com>,
	Vincent Abriou <vincent.abriou@st.com>,
	Gabriel Fernandez <gabriel.fernandez@st.com>,
	Ludovic Barre <ludovic.barre@st.com>
Subject: Re: [PATCH v1 1/7] drm/stm: drv: Rename platform driver name
Date: Thu, 20 Jul 2017 11:27:04 +0200	[thread overview]
Message-ID: <CA+M3ks5-_f=zh1ozHiWU8JzUGZeWU3hxh23fqeVWrAEQJogUDQ@mail.gmail.com> (raw)
In-Reply-To: <1500373219-20233-2-git-send-email-philippe.cornu@st.com>

2017-07-18 12:20 GMT+02:00 Philippe CORNU <philippe.cornu@st.com>:
> Rename the platform driver name from "stm" to "stm32-display"
> for a better readability in /sys/bus/platform/drivers entries.
>
> Note: We keep "stm" as drm_driver.name because it is better
> when using "modetest -M stm ..." (even if recent modetest patch
> avoids using -M).
>
> Signed-off-by: Philippe CORNU <philippe.cornu@st.com>

Reviewed-by: Benjamin Gaignard <benjamin.gaignard@linaro.org>

> ---
>  drivers/gpu/drm/stm/drv.c | 21 +++++++--------------
>  1 file changed, 7 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/gpu/drm/stm/drv.c b/drivers/gpu/drm/stm/drv.c
> index 83ab48f..095971f 100644
> --- a/drivers/gpu/drm/stm/drv.c
> +++ b/drivers/gpu/drm/stm/drv.c
> @@ -20,13 +20,6 @@
>
>  #include "ltdc.h"
>
> -#define DRIVER_NAME            "stm"
> -#define DRIVER_DESC            "STMicroelectronics SoC DRM"
> -#define DRIVER_DATE            "20170330"
> -#define DRIVER_MAJOR           1
> -#define DRIVER_MINOR           0
> -#define DRIVER_PATCH_LEVEL     0
> -
>  #define STM_MAX_FB_WIDTH       2048
>  #define STM_MAX_FB_HEIGHT      2048 /* same as width to handle orientation */
>
> @@ -59,12 +52,12 @@ static void drv_lastclose(struct drm_device *ddev)
>         .driver_features = DRIVER_MODESET | DRIVER_GEM | DRIVER_PRIME |
>                            DRIVER_ATOMIC,
>         .lastclose = drv_lastclose,
> -       .name = DRIVER_NAME,
> -       .desc = DRIVER_DESC,
> -       .date = DRIVER_DATE,
> -       .major = DRIVER_MAJOR,
> -       .minor = DRIVER_MINOR,
> -       .patchlevel = DRIVER_PATCH_LEVEL,
> +       .name = "stm",
> +       .desc = "STMicroelectronics SoC DRM",
> +       .date = "20170330",
> +       .major = 1,
> +       .minor = 0,
> +       .patchlevel = 0,
>         .fops = &drv_driver_fops,
>         .dumb_create = drm_gem_cma_dumb_create,
>         .dumb_map_offset = drm_gem_cma_dumb_map_offset,
> @@ -206,7 +199,7 @@ static int stm_drm_platform_remove(struct platform_device *pdev)
>         .probe = stm_drm_platform_probe,
>         .remove = stm_drm_platform_remove,
>         .driver = {
> -               .name = DRIVER_NAME,
> +               .name = "stm32-display",
>                 .of_match_table = drv_dt_ids,
>         },
>  };
> --
> 1.9.1
>
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2017-07-20  9:27 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-07-18 10:20 [PATCH v1 0/7] drm/stm: Various cleanups Philippe CORNU
2017-07-18 10:20 ` Philippe CORNU
2017-07-18 10:20 ` [PATCH v1 1/7] drm/stm: drv: Rename platform driver name Philippe CORNU
2017-07-18 10:20   ` Philippe CORNU
2017-07-20  9:27   ` Benjamin Gaignard [this message]
2017-07-20  9:27     ` Benjamin Gaignard
2017-07-18 10:20 ` [PATCH v1 2/7] drm/stm: ltdc: Cleanup signal polarity defines Philippe CORNU
2017-07-18 10:20   ` Philippe CORNU
2017-07-20  9:27   ` Benjamin Gaignard
2017-07-18 10:20 ` [PATCH v1 3/7] drm/stm: ltdc: Lindent and minor cleanups Philippe CORNU
2017-07-18 10:20   ` Philippe CORNU
2017-07-20  9:28   ` Benjamin Gaignard
2017-07-20  9:28     ` Benjamin Gaignard
2017-07-18 10:20 ` [PATCH v1 4/7] drm/stm: ltdc: Constify funcs structures Philippe CORNU
2017-07-18 10:20   ` Philippe CORNU
2017-07-20  9:28   ` Benjamin Gaignard
2017-07-20  9:28     ` Benjamin Gaignard
2017-07-18 10:20 ` [PATCH v1 5/7] drm/stm: ltdc: add devm_reset_control & platform_get_ressource Philippe CORNU
2017-07-18 10:20   ` Philippe CORNU
2017-07-20  9:30   ` Benjamin Gaignard
2017-07-20  9:30     ` Benjamin Gaignard
2017-07-18 10:20 ` [PATCH v1 6/7] drm/stm: ltdc: Cleanup rename returned value Philippe CORNU
2017-07-18 10:20   ` Philippe CORNU
2017-07-20  9:31   ` Benjamin Gaignard
2017-07-18 10:20 ` [PATCH v1 7/7] drm/stm: dsi: Constify phy ops structure Philippe CORNU
2017-07-18 10:20   ` Philippe CORNU
2017-07-20  9:32   ` Benjamin Gaignard

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CA+M3ks5-_f=zh1ozHiWU8JzUGZeWU3hxh23fqeVWrAEQJogUDQ@mail.gmail.com' \
    --to=benjamin.gaignard@linaro.org \
    --cc=airlied@linux.ie \
    --cc=alexandre.torgue@st.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=fabien.dessenne@st.com \
    --cc=gabriel.fernandez@st.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ludovic.barre@st.com \
    --cc=mcoquelin.stm32@gmail.com \
    --cc=mickael.reulier@st.com \
    --cc=philippe.cornu@st.com \
    --cc=vincent.abriou@st.com \
    --cc=yannick.fertre@st.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.