All of lore.kernel.org
 help / color / mirror / Atom feed
From: Conor Dooley <conor@kernel.org>
To: Nathan Chancellor <nathan@kernel.org>
Cc: palmer@dabbelt.com, Conor Dooley <conor.dooley@microchip.com>,
	naresh.kamboju@linaro.org, linux-riscv@lists.infradead.org,
	llvm@lists.linux.dev
Subject: Re: [PATCH v1 1/2] RISC-V: move zicsr/zifencei spec version check to Kconfig
Date: Fri, 24 Feb 2023 17:00:09 +0000	[thread overview]
Message-ID: <Y/jtGRrBfKxO6s0c@spud> (raw)
In-Reply-To: <Y/jnyJZNZC1X6IO8@dev-arch.thelio-3990X>

[-- Attachment #1: Type: text/plain, Size: 1101 bytes --]

On Fri, Feb 24, 2023 at 09:37:28AM -0700, Nathan Chancellor wrote:
> On Thu, Feb 23, 2023 at 10:05:45PM +0000, Conor Dooley wrote:

> > ---
> >  arch/riscv/Kconfig  | 10 ++++++++++
> >  arch/riscv/Makefile |  5 +----
> >  2 files changed, 11 insertions(+), 4 deletions(-)
> > 
> > diff --git a/arch/riscv/Kconfig b/arch/riscv/Kconfig
> > index cebf0c5f8824..4eb0ef8314b3 100644
> > --- a/arch/riscv/Kconfig
> > +++ b/arch/riscv/Kconfig
> > @@ -288,6 +288,16 @@ config ARCH_RV64I
> >  
> >  endchoice
> >  
> > +config TOOLCHAIN_NEEDS_SPEC_20191213
> 
> This symbol's name is a little confusing to me, how does the toolchain
> need spec version 20191213. Maybe 'SPEC_20191213' should be something
> like 'EXPLICIT_ZICSR_ZIFENCEI'? Otherwise, maybe it should be something
> like 'TOOLCHAIN_HAS_DEFAULT_SPEC_20191213'? Sorry for the bikeshed but I
> think most Kconfig symbols should be self describing.

Yah I can do that. I actually had this as the DEFAULT_SPEC variant
before and changed it - I'll switch it to the EXPLICIT one.
Thanks for taking a look Nathan :)

Conor.

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

WARNING: multiple messages have this Message-ID (diff)
From: Conor Dooley <conor@kernel.org>
To: Nathan Chancellor <nathan@kernel.org>
Cc: palmer@dabbelt.com, Conor Dooley <conor.dooley@microchip.com>,
	naresh.kamboju@linaro.org, linux-riscv@lists.infradead.org,
	llvm@lists.linux.dev
Subject: Re: [PATCH v1 1/2] RISC-V: move zicsr/zifencei spec version check to Kconfig
Date: Fri, 24 Feb 2023 17:00:09 +0000	[thread overview]
Message-ID: <Y/jtGRrBfKxO6s0c@spud> (raw)
In-Reply-To: <Y/jnyJZNZC1X6IO8@dev-arch.thelio-3990X>


[-- Attachment #1.1: Type: text/plain, Size: 1101 bytes --]

On Fri, Feb 24, 2023 at 09:37:28AM -0700, Nathan Chancellor wrote:
> On Thu, Feb 23, 2023 at 10:05:45PM +0000, Conor Dooley wrote:

> > ---
> >  arch/riscv/Kconfig  | 10 ++++++++++
> >  arch/riscv/Makefile |  5 +----
> >  2 files changed, 11 insertions(+), 4 deletions(-)
> > 
> > diff --git a/arch/riscv/Kconfig b/arch/riscv/Kconfig
> > index cebf0c5f8824..4eb0ef8314b3 100644
> > --- a/arch/riscv/Kconfig
> > +++ b/arch/riscv/Kconfig
> > @@ -288,6 +288,16 @@ config ARCH_RV64I
> >  
> >  endchoice
> >  
> > +config TOOLCHAIN_NEEDS_SPEC_20191213
> 
> This symbol's name is a little confusing to me, how does the toolchain
> need spec version 20191213. Maybe 'SPEC_20191213' should be something
> like 'EXPLICIT_ZICSR_ZIFENCEI'? Otherwise, maybe it should be something
> like 'TOOLCHAIN_HAS_DEFAULT_SPEC_20191213'? Sorry for the bikeshed but I
> think most Kconfig symbols should be self describing.

Yah I can do that. I actually had this as the DEFAULT_SPEC variant
before and changed it - I'll switch it to the EXPLICIT one.
Thanks for taking a look Nathan :)

Conor.

[-- Attachment #1.2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

[-- Attachment #2: Type: text/plain, Size: 161 bytes --]

_______________________________________________
linux-riscv mailing list
linux-riscv@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-riscv

  reply	other threads:[~2023-02-24 17:00 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-02-23 22:05 [PATCH v1 0/2] RISC-V: avoid build issues for clang/llvm-17 with binutils 2.35 Conor Dooley
2023-02-23 22:05 ` Conor Dooley
2023-02-23 22:05 ` [PATCH v1 1/2] RISC-V: move zicsr/zifencei spec version check to Kconfig Conor Dooley
2023-02-23 22:05   ` Conor Dooley
2023-02-24 16:37   ` Nathan Chancellor
2023-02-24 16:37     ` Nathan Chancellor
2023-02-24 17:00     ` Conor Dooley [this message]
2023-02-24 17:00       ` Conor Dooley
2023-03-06 23:52       ` Palmer Dabbelt
2023-03-06 23:52         ` Palmer Dabbelt
2023-03-07 19:14         ` Conor Dooley
2023-03-07 19:14           ` Conor Dooley
2023-03-07 19:24           ` Palmer Dabbelt
2023-03-07 19:24             ` Palmer Dabbelt
2023-02-23 22:05 ` [PATCH v1 2/2] RISC-V: make TOOLCHAIN_NEEDS_SPEC_20191213 gas only Conor Dooley
2023-02-23 22:05   ` Conor Dooley
2023-02-24 16:32   ` Nathan Chancellor
2023-02-24 16:32     ` Nathan Chancellor

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Y/jtGRrBfKxO6s0c@spud \
    --to=conor@kernel.org \
    --cc=conor.dooley@microchip.com \
    --cc=linux-riscv@lists.infradead.org \
    --cc=llvm@lists.linux.dev \
    --cc=naresh.kamboju@linaro.org \
    --cc=nathan@kernel.org \
    --cc=palmer@dabbelt.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.