All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/9] About the SLC/MLC
@ 2013-08-19  2:31 Huang Shijie
  2013-08-19  2:31 ` [PATCH v2 1/9] mtd: nand: rename the cellinfo to bits_per_cell Huang Shijie
                   ` (9 more replies)
  0 siblings, 10 replies; 22+ messages in thread
From: Huang Shijie @ 2013-08-19  2:31 UTC (permalink / raw)
  To: dwmw2
  Cc: dedekind1, akinobu.mita, matthieu.castet, Huang Shijie,
	linux-mtd, computersforpeace

In current mtd code, the MTD_NANDFLASH is used to represent both the
SLC nand MLC(including the TLC). But we already have the MTD_MLCNANDFLASH
to stand for the MLC. What is worse is that the JFFS2 may run on the MLC
nand with current code. For the reason of READ/WRITE disturbance, the JFFS2
should runs on the SLC only,
       
This patch set tries to make clear what is the SLC/MLC by renaming,
adding the macros, adding helpers, adding the comments. ..

After this patch set, the gpmi can support the JFFS2 for some SLC NAND now 
(only when the left oob area is big enough).

Tested this patch set with ONFI SLC: M529F8G08ABACAWP

v1 --> v2:
	[0] rename the @cellinfo to @bits_per_cell
	[1] abandon the patch:
       		"mtd: add more information for the MTD_NANDFLASH case"
	[2] update the ABI for patch 8
	[3] misc

Huang Shijie (9):
  mtd: nand: rename the cellinfo to bits_per_cell
  mtd: set the cell information for ONFI nand
  mtd: print out the cell information for nand chip
  mtd: gpmi: rewrite the gpmi_ecc_write_oob() to support the jffs2
  mtd: add more comment for MTD_NANDFLASH/MTD_MLCNANDFLASH
  mtd: fix the wrong mtd->type for nand chip
  jffs2: init the ret with -EINVAL
  mtd: add MTD_MLCNANDFLASH case for mtd_type_show()
  mtd: add a helper to detect the nand type

 Documentation/ABI/testing/sysfs-class-mtd |    2 +-
 drivers/mtd/inftlcore.c                   |    2 +-
 drivers/mtd/mtdcore.c                     |    3 ++
 drivers/mtd/nand/denali.c                 |    2 +-
 drivers/mtd/nand/gpmi-nand/gpmi-nand.c    |   31 +++++++++++++++++-------
 drivers/mtd/nand/nand_base.c              |   36 ++++++++++++++++++----------
 drivers/mtd/nftlcore.c                    |    2 +-
 drivers/mtd/ssfdc.c                       |    2 +-
 drivers/mtd/tests/nandbiterrs.c           |    2 +-
 drivers/mtd/tests/oobtest.c               |    2 +-
 drivers/mtd/tests/pagetest.c              |    2 +-
 drivers/mtd/tests/subpagetest.c           |    2 +-
 fs/jffs2/fs.c                             |    2 +-
 include/linux/mtd/mtd.h                   |    5 ++++
 include/linux/mtd/nand.h                  |   14 +++++++++-
 include/uapi/mtd/mtd-abi.h                |    4 +-
 16 files changed, 77 insertions(+), 36 deletions(-)

^ permalink raw reply	[flat|nested] 22+ messages in thread

end of thread, other threads:[~2013-08-25  3:59 UTC | newest]

Thread overview: 22+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-08-19  2:31 [PATCH v2 0/9] About the SLC/MLC Huang Shijie
2013-08-19  2:31 ` [PATCH v2 1/9] mtd: nand: rename the cellinfo to bits_per_cell Huang Shijie
2013-08-24  5:49   ` Brian Norris
2013-08-25  3:52     ` Huang Shijie
2013-08-19  2:31 ` [PATCH v2 2/9] mtd: set the cell information for ONFI nand Huang Shijie
2013-08-19  2:31 ` [PATCH v2 3/9] mtd: print out the cell information for nand chip Huang Shijie
2013-08-24  5:58   ` Brian Norris
2013-08-24 21:02     ` Ezequiel Garcia
2013-08-25 16:04       ` Huang Shijie
2013-08-19  2:31 ` [PATCH v2 4/9] mtd: gpmi: rewrite the gpmi_ecc_write_oob() to support the jffs2 Huang Shijie
2013-08-24  6:19   ` Brian Norris
2013-08-24 19:18     ` Huang Shijie
2013-08-24  7:17       ` Brian Norris
2013-08-19  2:31 ` [PATCH v2 5/9] mtd: add more comment for MTD_NANDFLASH/MTD_MLCNANDFLASH Huang Shijie
2013-08-19  2:31 ` [PATCH v2 6/9] mtd: fix the wrong mtd->type for nand chip Huang Shijie
2013-08-19  2:31 ` [PATCH v2 7/9] jffs2: init the ret with -EINVAL Huang Shijie
2013-08-24  6:37   ` Brian Norris
2013-08-25  4:00     ` Huang Shijie
2013-08-19  2:31 ` [PATCH v2 8/9] mtd: add MTD_MLCNANDFLASH case for mtd_type_show() Huang Shijie
2013-08-19  2:31 ` [PATCH v2 9/9] mtd: add a helper to detect the nand type Huang Shijie
2013-08-19  8:59 ` [PATCH v2 append] mtd: mtd-abi: " Huang Shijie
2013-08-20  5:32   ` [PATCH append fix] " Huang Shijie

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.