All of lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Axtens <dja@axtens.net>
To: linuxppc-dev@lists.ozlabs.org
Cc: Daniel Axtens <dja@axtens.net>
Subject: [PATCH 24/27] powerpc: Remove shim for pci_controller_ops.probe_mode
Date: Wed, 25 Mar 2015 16:35:58 +1100	[thread overview]
Message-ID: <1427261761-22952-25-git-send-email-dja@axtens.net> (raw)
In-Reply-To: <1427261761-22952-1-git-send-email-dja@axtens.net>

This also moves back the defines, as explained in the commit that
created the shim.

Signed-off-by: Daniel Axtens <dja@axtens.net>
---
 arch/powerpc/include/asm/machdep.h    |  1 -
 arch/powerpc/include/asm/pci-bridge.h | 16 ----------------
 arch/powerpc/include/asm/pci.h        |  5 +++++
 arch/powerpc/kernel/pci-common.c      |  4 ++--
 arch/powerpc/kernel/pci-hotplug.c     |  6 +++++-
 arch/powerpc/kernel/pci_of_scan.c     |  6 +++++-
 6 files changed, 17 insertions(+), 21 deletions(-)

diff --git a/arch/powerpc/include/asm/machdep.h b/arch/powerpc/include/asm/machdep.h
index 5549b6c..dfc8d2b 100644
--- a/arch/powerpc/include/asm/machdep.h
+++ b/arch/powerpc/include/asm/machdep.h
@@ -127,7 +127,6 @@ struct machdep_calls {
 	/* PCI stuff */
 	/* Called after scanning the bus, before allocating resources */
 	void		(*pcibios_fixup)(void);
-	int		(*pci_probe_mode)(struct pci_bus *);
 	void		(*pci_irq_fixup)(struct pci_dev *dev);
 	int		(*pcibios_root_bridge_prepare)(struct pci_host_bridge
 				*bridge);
diff --git a/arch/powerpc/include/asm/pci-bridge.h b/arch/powerpc/include/asm/pci-bridge.h
index 029def0..b5d8631 100644
--- a/arch/powerpc/include/asm/pci-bridge.h
+++ b/arch/powerpc/include/asm/pci-bridge.h
@@ -12,11 +12,6 @@
 #include <linux/ioport.h>
 #include <asm-generic/pci-bridge.h>
 
-/* Return values for pci_controller_ops.probe_mode function */
-#define PCI_PROBE_NONE		-1	/* Don't look at this bus at all */
-#define PCI_PROBE_NORMAL	0	/* Do normal PCI probing */
-#define PCI_PROBE_DEVTREE	1	/* Instantiate from device tree */
-
 struct device_node;
 
 /*
@@ -305,16 +300,5 @@ static inline void dma_bus_setup(struct pci_bus *bus)
 		ppc_md.pci_dma_bus_setup(bus);
 }
 
-static inline int probe_mode(struct pci_bus *bus)
-{
-	struct pci_controller *hose = pci_bus_to_host(bus);
-
-	if (hose->controller_ops.probe_mode)
-		return hose->controller_ops.probe_mode(bus);
-	if (ppc_md.pci_probe_mode)
-		return ppc_md.pci_probe_mode(bus);
-	return PCI_PROBE_NORMAL;
-}
-
 #endif	/* __KERNEL__ */
 #endif	/* _ASM_POWERPC_PCI_BRIDGE_H */
diff --git a/arch/powerpc/include/asm/pci.h b/arch/powerpc/include/asm/pci.h
index 8745067..4aef8d6 100644
--- a/arch/powerpc/include/asm/pci.h
+++ b/arch/powerpc/include/asm/pci.h
@@ -22,6 +22,11 @@
 
 #include <asm-generic/pci-dma-compat.h>
 
+/* Return values for pci_controller_ops.probe_mode function */
+#define PCI_PROBE_NONE		-1	/* Don't look at this bus at all */
+#define PCI_PROBE_NORMAL	0	/* Do normal PCI probing */
+#define PCI_PROBE_DEVTREE	1	/* Instantiate from device tree */
+
 #define PCIBIOS_MIN_IO		0x1000
 #define PCIBIOS_MIN_MEM		0x10000000
 
diff --git a/arch/powerpc/kernel/pci-common.c b/arch/powerpc/kernel/pci-common.c
index 5b90e99c..a61ecb4 100644
--- a/arch/powerpc/kernel/pci-common.c
+++ b/arch/powerpc/kernel/pci-common.c
@@ -1628,8 +1628,8 @@ void pcibios_scan_phb(struct pci_controller *hose)
 
 	/* Get probe mode and perform scan */
 	mode = PCI_PROBE_NORMAL;
-	if (node)
-		mode = probe_mode(bus);
+	if (node && hose->controller_ops.probe_mode)
+		mode = hose->controller_ops.probe_mode(bus);
 	pr_debug("    probe mode: %d\n", mode);
 	if (mode == PCI_PROBE_DEVTREE)
 		of_scan_bus(node, bus);
diff --git a/arch/powerpc/kernel/pci-hotplug.c b/arch/powerpc/kernel/pci-hotplug.c
index 504d823..e9b0a4a 100644
--- a/arch/powerpc/kernel/pci-hotplug.c
+++ b/arch/powerpc/kernel/pci-hotplug.c
@@ -73,12 +73,16 @@ void pcibios_add_pci_devices(struct pci_bus * bus)
 {
 	int slotno, mode, pass, max;
 	struct pci_dev *dev;
+	struct pci_controller *hose;
 	struct device_node *dn = pci_bus_to_OF_node(bus);
 
 	eeh_add_device_tree_early(dn);
 
+	hose = pci_bus_to_host(bus);
+
 	mode = PCI_PROBE_NORMAL;
-	mode = probe_mode(bus);
+	if (hose->controller_ops.probe_mode)
+		mode = hose->controller_ops.probe_mode(bus);
 
 	if (mode == PCI_PROBE_DEVTREE) {
 		/* use ofdt-based probe */
diff --git a/arch/powerpc/kernel/pci_of_scan.c b/arch/powerpc/kernel/pci_of_scan.c
index ae1767b..8312962 100644
--- a/arch/powerpc/kernel/pci_of_scan.c
+++ b/arch/powerpc/kernel/pci_of_scan.c
@@ -207,6 +207,7 @@ void of_scan_pci_bridge(struct pci_dev *dev)
 {
 	struct device_node *node = dev->dev.of_node;
 	struct pci_bus *bus;
+	struct pci_controller *hose;
 	const __be32 *busrange, *ranges;
 	int len, i, mode;
 	struct pci_bus_region region;
@@ -286,8 +287,11 @@ void of_scan_pci_bridge(struct pci_dev *dev)
 		bus->number);
 	pr_debug("    bus name: %s\n", bus->name);
 
+	hose = pci_bus_to_host(bus);
+
 	mode = PCI_PROBE_NORMAL;
-	mode = probe_mode(bus);
+	if (hose->controller_ops.probe_mode)
+		mode = hose->controller_ops.probe_mode(bus);
 	pr_debug("    probe mode: %d\n", mode);
 
 	if (mode == PCI_PROBE_DEVTREE)
-- 
2.1.4

  parent reply	other threads:[~2015-03-25  5:37 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-25  5:35 [PATCH 00/27] Refactor PCI controller operations Daniel Axtens
2015-03-25  5:35 ` [PATCH 01/27] powerpc: move find_and_init_phbs() to pSeries specific code Daniel Axtens
2015-03-25  7:40   ` Stephen Rothwell
2015-03-25  5:35 ` [PATCH 02/27] powerpc/powermac: move pmac_pci_probe_mode from setup.c to pci.c Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-30 21:46     ` Benjamin Herrenschmidt
2015-03-31  4:23       ` Michael Ellerman
2015-03-30 22:12     ` Daniel Axtens
2015-03-25  5:35 ` [PATCH 03/27] powerpc/swiotlb: give init call a less misleading name Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-25  5:35 ` [PATCH 04/27] powerpc/fsl_pci: Don't change ppc_swiotlb_enable after swiotlb_subsys_init Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-30 23:57     ` Daniel Axtens
2015-03-25  5:35 ` [PATCH 05/27] powerpc: pcibios_enable_device_hook: return bool rather than int Daniel Axtens
2015-03-25  5:35 ` [PATCH 06/27] powerpc: Create the pci_controller_ops struct Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-25  5:35 ` [PATCH 07/27] powerpc: ppc_md.pci_dma_dev_setup -> pci_controller_ops.dma_dev_setup Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-25  5:35 ` [PATCH 08/27] powerpc: ppc_md.pci_dma_bus_setup -> pci_controller_ops.dma_bus_setup Daniel Axtens
2015-03-25  5:35 ` [PATCH 09/27] powerpc: ppc_md.pci_probe_mode -> pci_controller_ops.probe_mode Daniel Axtens
2015-03-25  5:35 ` [PATCH 10/27] powerpc: ppc_md.pcibios_enable_device_hook -> pci_controller_ops.enable_device_hook Daniel Axtens
2015-03-25  5:35 ` [PATCH 11/27] powerpc: ppc_md.pcibios_window_alignment -> pci_controller_ops.window_alignment Daniel Axtens
2015-03-25  5:35 ` [PATCH 12/27] powerpc: ppc_md.pcibios_reset_secondary_bus -> pci_controller_ops.reset_secondary_bus Daniel Axtens
2015-03-25  5:35 ` [PATCH 13/27] powerpc: dart_iommu: optionally populate controller_ops on init Daniel Axtens
2015-03-25  5:35 ` [PATCH 14/27] powerpc/powermac: Move controller ops from ppc_md to controller_ops Daniel Axtens
2015-03-25  5:35 ` [PATCH 15/27] powerpc/pseries: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 16/27] powerpc/powernv: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 17/27] powerpc/pasemi: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 18/27] powerpc/maple: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 19/27] powerpc: fsl_pci, swiotlb: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 20/27] powerpc/cell: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 21/27] powerpc: Remove shim for pci_controller_ops.window_alignment Daniel Axtens
2015-03-25  5:35 ` [PATCH 22/27] powerpc: Remove shim for pci_controller_ops.reset_secondary_bus Daniel Axtens
2015-03-25  5:35 ` [PATCH 23/27] powerpc: Remove shim for pci_controller_ops.enable_device_hook Daniel Axtens
2015-03-25  5:35 ` Daniel Axtens [this message]
2015-03-25  5:35 ` [PATCH 25/27] powerpc: Remove shim for pci_controller_ops.dma_dev_setup Daniel Axtens
2015-03-25  5:36 ` [PATCH 26/27] powerpc: Remove shim for pci_controller_ops.dma_bus_setup Daniel Axtens
2015-03-25  5:36 ` [PATCH 27/27] powerpc: dart_iommu: Remove check for controller_ops == NULL case Daniel Axtens

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1427261761-22952-25-git-send-email-dja@axtens.net \
    --to=dja@axtens.net \
    --cc=linuxppc-dev@lists.ozlabs.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.