All of lore.kernel.org
 help / color / mirror / Atom feed
From: Michael Ellerman <mpe@ellerman.id.au>
To: Daniel Axtens <dja@axtens.net>, linuxppc-dev@lists.ozlabs.org
Cc: Daniel Axtens <dja@axtens.net>
Subject: Re: [PATCH 07/27] powerpc: ppc_md.pci_dma_dev_setup -> pci_controller_ops.dma_dev_setup
Date: Mon, 30 Mar 2015 23:32:16 +1100 (AEDT)	[thread overview]
Message-ID: <20150330123216.3C7E11401AB@ozlabs.org> (raw)
In-Reply-To: <1427261761-22952-8-git-send-email-dja@axtens.net>

On Wed, 2015-25-03 at 05:35:41 UTC, Daniel Axtens wrote:

Write changelogs!

Also this doesn't do what the subject suggests, it just introduces the ops
version and adds the shim. It doesn't do all the conversions.

> Signed-off-by: Daniel Axtens <dja@axtens.net>
> ---
>  arch/powerpc/include/asm/pci-bridge.h | 14 ++++++++++++++
>  arch/powerpc/kernel/pci-common.c      |  3 +--
>  2 files changed, 15 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/powerpc/include/asm/pci-bridge.h b/arch/powerpc/include/asm/pci-bridge.h
> index 3ab8a2d..2474f29 100644
> --- a/arch/powerpc/include/asm/pci-bridge.h
> +++ b/arch/powerpc/include/asm/pci-bridge.h
> @@ -18,6 +18,7 @@ struct device_node;
>   * PCI controller operations
>   */
>  struct pci_controller_ops {
> +	void		(*dma_dev_setup)(struct pci_dev *dev);
>  };
>  
>  /*
> @@ -265,5 +266,18 @@ static inline int pcibios_vaddr_is_ioport(void __iomem *address)
>  }
>  #endif	/* CONFIG_PCI */
>  
> +/*
> + * Shims to prefer pci_controller version over ppc_md where available.
> + */
> +static inline void dma_dev_setup(struct pci_dev *dev)

This should be called pci_dma_dev_setup() while it exists IMHO.

> +{
> +	struct pci_controller *hose = pci_bus_to_host(dev->bus);

I know historically we've called them "hose", but there's also a lot of code
that uses "phb" and that is a MUCH better name, so please use that.

cheers

  reply	other threads:[~2015-03-30 12:32 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-25  5:35 [PATCH 00/27] Refactor PCI controller operations Daniel Axtens
2015-03-25  5:35 ` [PATCH 01/27] powerpc: move find_and_init_phbs() to pSeries specific code Daniel Axtens
2015-03-25  7:40   ` Stephen Rothwell
2015-03-25  5:35 ` [PATCH 02/27] powerpc/powermac: move pmac_pci_probe_mode from setup.c to pci.c Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-30 21:46     ` Benjamin Herrenschmidt
2015-03-31  4:23       ` Michael Ellerman
2015-03-30 22:12     ` Daniel Axtens
2015-03-25  5:35 ` [PATCH 03/27] powerpc/swiotlb: give init call a less misleading name Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-25  5:35 ` [PATCH 04/27] powerpc/fsl_pci: Don't change ppc_swiotlb_enable after swiotlb_subsys_init Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-30 23:57     ` Daniel Axtens
2015-03-25  5:35 ` [PATCH 05/27] powerpc: pcibios_enable_device_hook: return bool rather than int Daniel Axtens
2015-03-25  5:35 ` [PATCH 06/27] powerpc: Create the pci_controller_ops struct Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-25  5:35 ` [PATCH 07/27] powerpc: ppc_md.pci_dma_dev_setup -> pci_controller_ops.dma_dev_setup Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman [this message]
2015-03-25  5:35 ` [PATCH 08/27] powerpc: ppc_md.pci_dma_bus_setup -> pci_controller_ops.dma_bus_setup Daniel Axtens
2015-03-25  5:35 ` [PATCH 09/27] powerpc: ppc_md.pci_probe_mode -> pci_controller_ops.probe_mode Daniel Axtens
2015-03-25  5:35 ` [PATCH 10/27] powerpc: ppc_md.pcibios_enable_device_hook -> pci_controller_ops.enable_device_hook Daniel Axtens
2015-03-25  5:35 ` [PATCH 11/27] powerpc: ppc_md.pcibios_window_alignment -> pci_controller_ops.window_alignment Daniel Axtens
2015-03-25  5:35 ` [PATCH 12/27] powerpc: ppc_md.pcibios_reset_secondary_bus -> pci_controller_ops.reset_secondary_bus Daniel Axtens
2015-03-25  5:35 ` [PATCH 13/27] powerpc: dart_iommu: optionally populate controller_ops on init Daniel Axtens
2015-03-25  5:35 ` [PATCH 14/27] powerpc/powermac: Move controller ops from ppc_md to controller_ops Daniel Axtens
2015-03-25  5:35 ` [PATCH 15/27] powerpc/pseries: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 16/27] powerpc/powernv: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 17/27] powerpc/pasemi: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 18/27] powerpc/maple: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 19/27] powerpc: fsl_pci, swiotlb: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 20/27] powerpc/cell: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 21/27] powerpc: Remove shim for pci_controller_ops.window_alignment Daniel Axtens
2015-03-25  5:35 ` [PATCH 22/27] powerpc: Remove shim for pci_controller_ops.reset_secondary_bus Daniel Axtens
2015-03-25  5:35 ` [PATCH 23/27] powerpc: Remove shim for pci_controller_ops.enable_device_hook Daniel Axtens
2015-03-25  5:35 ` [PATCH 24/27] powerpc: Remove shim for pci_controller_ops.probe_mode Daniel Axtens
2015-03-25  5:35 ` [PATCH 25/27] powerpc: Remove shim for pci_controller_ops.dma_dev_setup Daniel Axtens
2015-03-25  5:36 ` [PATCH 26/27] powerpc: Remove shim for pci_controller_ops.dma_bus_setup Daniel Axtens
2015-03-25  5:36 ` [PATCH 27/27] powerpc: dart_iommu: Remove check for controller_ops == NULL case Daniel Axtens

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150330123216.3C7E11401AB@ozlabs.org \
    --to=mpe@ellerman.id.au \
    --cc=dja@axtens.net \
    --cc=linuxppc-dev@lists.ozlabs.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.