All of lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Axtens <dja@axtens.net>
To: Michael Ellerman <mpe@ellerman.id.au>
Cc: linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH 02/27] powerpc/powermac: move pmac_pci_probe_mode from setup.c to pci.c
Date: Tue, 31 Mar 2015 09:12:52 +1100	[thread overview]
Message-ID: <1427753572.11226.10.camel@axtens.net> (raw)
In-Reply-To: <20150330123214.9EE4014009B@ozlabs.org>

[-- Attachment #1: Type: text/plain, Size: 2846 bytes --]

On Mon, 2015-03-30 at 23:32 +1100, Michael Ellerman wrote:
> On Wed, 2015-25-03 at 05:35:36 UTC, Daniel Axtens wrote:
> 
> Why did we move it? Just for cleanliness?
> 

I move it because in (what is currently) patch 14, I want to hook it
into the PCI controller ops structure, which I define in pci.c. In that
patch I make the definition static again and remove the prototype from
the header.

I saw two other options:
 - Move it to pci.c as part of patch 14
 - Keep it in setup.c and just accept that it won't be static and will
need a prototype in the header.

I thought this was the least bad option, but I'm happy to do it another
way. Either way I will explain it better in the next series.

Regards,
Daniel

> > Signed-off-by: Daniel Axtens <dja@axtens.net>
> > ---
> >  arch/powerpc/platforms/powermac/pci.c   | 17 +++++++++++++++++
> >  arch/powerpc/platforms/powermac/pmac.h  |  4 ++++
> >  arch/powerpc/platforms/powermac/setup.c | 18 ------------------
> >  3 files changed, 21 insertions(+), 18 deletions(-)
> > 
> > diff --git a/arch/powerpc/platforms/powermac/pci.c b/arch/powerpc/platforms/powermac/pci.c
> > index f4071a6..a792f45 100644
> > --- a/arch/powerpc/platforms/powermac/pci.c
> > +++ b/arch/powerpc/platforms/powermac/pci.c
> > @@ -1223,3 +1223,20 @@ static void fixup_u4_pcie(struct pci_dev* dev)
> >  	pci_write_config_dword(dev, PCI_PREF_MEMORY_BASE, 0);
> >  }
> >  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_APPLE, PCI_DEVICE_ID_APPLE_U4_PCIE, fixup_u4_pcie);
> > +
> > +#ifdef CONFIG_PPC64
> > +int pmac_pci_probe_mode(struct pci_bus *bus)
> > +{
> > +	struct device_node *node = pci_bus_to_OF_node(bus);
> > +
> > +	/* We need to use normal PCI probing for the AGP bus,
> > +	 * since the device for the AGP bridge isn't in the tree.
> > +	 * Same for the PCIe host on U4 and the HT host bridge.
> > +	 */
> > +	if (bus->self == NULL && (of_device_is_compatible(node, "u3-agp") ||
> > +				  of_device_is_compatible(node, "u4-pcie") ||
> > +				  of_device_is_compatible(node, "u3-ht")))
> > +		return PCI_PROBE_NORMAL;
> > +	return PCI_PROBE_DEVTREE;
> > +}
> > +#endif /* CONFIG_PPC64 */
> > diff --git a/arch/powerpc/platforms/powermac/pmac.h b/arch/powerpc/platforms/powermac/pmac.h
> > index 8327cce..46d2193 100644
> > --- a/arch/powerpc/platforms/powermac/pmac.h
> > +++ b/arch/powerpc/platforms/powermac/pmac.h
> > @@ -39,4 +39,8 @@ extern void low_cpu_die(void) __attribute__((noreturn));
> >  extern int pmac_nvram_init(void);
> >  extern void pmac_pic_init(void);
> >  
> > +#ifdef CONFIG_PPC64
> > +extern int pmac_pci_probe_mode(struct pci_bus *bus);
> > +#endif
> 
> You don't need to ifdef declarations, and you don't need extern.
> 
> So just:
> 
> > +int pmac_pci_probe_mode(struct pci_bus *bus);
> 
> Is fine.
> 
> cheers


[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 860 bytes --]

  parent reply	other threads:[~2015-03-30 22:12 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-25  5:35 [PATCH 00/27] Refactor PCI controller operations Daniel Axtens
2015-03-25  5:35 ` [PATCH 01/27] powerpc: move find_and_init_phbs() to pSeries specific code Daniel Axtens
2015-03-25  7:40   ` Stephen Rothwell
2015-03-25  5:35 ` [PATCH 02/27] powerpc/powermac: move pmac_pci_probe_mode from setup.c to pci.c Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-30 21:46     ` Benjamin Herrenschmidt
2015-03-31  4:23       ` Michael Ellerman
2015-03-30 22:12     ` Daniel Axtens [this message]
2015-03-25  5:35 ` [PATCH 03/27] powerpc/swiotlb: give init call a less misleading name Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-25  5:35 ` [PATCH 04/27] powerpc/fsl_pci: Don't change ppc_swiotlb_enable after swiotlb_subsys_init Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-30 23:57     ` Daniel Axtens
2015-03-25  5:35 ` [PATCH 05/27] powerpc: pcibios_enable_device_hook: return bool rather than int Daniel Axtens
2015-03-25  5:35 ` [PATCH 06/27] powerpc: Create the pci_controller_ops struct Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-25  5:35 ` [PATCH 07/27] powerpc: ppc_md.pci_dma_dev_setup -> pci_controller_ops.dma_dev_setup Daniel Axtens
2015-03-30 12:32   ` Michael Ellerman
2015-03-25  5:35 ` [PATCH 08/27] powerpc: ppc_md.pci_dma_bus_setup -> pci_controller_ops.dma_bus_setup Daniel Axtens
2015-03-25  5:35 ` [PATCH 09/27] powerpc: ppc_md.pci_probe_mode -> pci_controller_ops.probe_mode Daniel Axtens
2015-03-25  5:35 ` [PATCH 10/27] powerpc: ppc_md.pcibios_enable_device_hook -> pci_controller_ops.enable_device_hook Daniel Axtens
2015-03-25  5:35 ` [PATCH 11/27] powerpc: ppc_md.pcibios_window_alignment -> pci_controller_ops.window_alignment Daniel Axtens
2015-03-25  5:35 ` [PATCH 12/27] powerpc: ppc_md.pcibios_reset_secondary_bus -> pci_controller_ops.reset_secondary_bus Daniel Axtens
2015-03-25  5:35 ` [PATCH 13/27] powerpc: dart_iommu: optionally populate controller_ops on init Daniel Axtens
2015-03-25  5:35 ` [PATCH 14/27] powerpc/powermac: Move controller ops from ppc_md to controller_ops Daniel Axtens
2015-03-25  5:35 ` [PATCH 15/27] powerpc/pseries: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 16/27] powerpc/powernv: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 17/27] powerpc/pasemi: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 18/27] powerpc/maple: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 19/27] powerpc: fsl_pci, swiotlb: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 20/27] powerpc/cell: " Daniel Axtens
2015-03-25  5:35 ` [PATCH 21/27] powerpc: Remove shim for pci_controller_ops.window_alignment Daniel Axtens
2015-03-25  5:35 ` [PATCH 22/27] powerpc: Remove shim for pci_controller_ops.reset_secondary_bus Daniel Axtens
2015-03-25  5:35 ` [PATCH 23/27] powerpc: Remove shim for pci_controller_ops.enable_device_hook Daniel Axtens
2015-03-25  5:35 ` [PATCH 24/27] powerpc: Remove shim for pci_controller_ops.probe_mode Daniel Axtens
2015-03-25  5:35 ` [PATCH 25/27] powerpc: Remove shim for pci_controller_ops.dma_dev_setup Daniel Axtens
2015-03-25  5:36 ` [PATCH 26/27] powerpc: Remove shim for pci_controller_ops.dma_bus_setup Daniel Axtens
2015-03-25  5:36 ` [PATCH 27/27] powerpc: dart_iommu: Remove check for controller_ops == NULL case Daniel Axtens

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1427753572.11226.10.camel@axtens.net \
    --to=dja@axtens.net \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.