All of lore.kernel.org
 help / color / mirror / Atom feed
From: sfeldma@gmail.com
To: netdev@vger.kernel.org
Cc: jiri@resnulli.us, roopa@cumulusnetworks.com, linux@roeck-us.net,
	f.fainelli@gmail.com, sridhar.samudrala@intel.com,
	ronen.arad@intel.com, andrew@lunn.ch, simon.horman@netronome.com
Subject: [PATCH net-next v5 00/21] switchdev: spring cleanup
Date: Tue,  5 May 2015 10:34:36 -0700	[thread overview]
Message-ID: <1430847297-15728-1-git-send-email-sfeldma@gmail.com> (raw)

From: Scott Feldman <sfeldma@gmail.com>

v5:

Address review comments:

 - [Jiri] include Jiri's s/swdev/switchdev rename patches up front.
 - [Jiri] squash some patches.  Now setlink/dellink/getlink patches are in
     three parts: new implementation, convert drivers to new, delete old impl.
 - [Jiri] some minor variable renames
 - [Jiri] use BUG_ON rather than WARN when COMMIT phase fails when PREPARE
     phase said it was safe to come into the water.
 - [Simon] rocker: fix a few transaction prepare-commit cases that were wrong.
     This was the bulk of the changes in v5.

v4:

Well, it was a lot of work, but now prepare-commit transaction model is how
davem advises: if prepare fails, abort the transaction.  The driver must do
resource reservations up front in prepare phase and return those resources if
aborting.  Commit phase would use reserved resources.  The good news is the
driver code (for rocker) now handles resource allocation failures better by not
leaving partially device or driver states.  This is a side-effect of the
prepare phase where state isn't modified; only validation of inputs and
resource reservations happen in the prepare phase.  Since we're supporting
setting attrs and add objs across lower devs in the stacked case, we need to
hold rtnl_lock (or ensure rtnl_lock is held) so lower devs don't move on us
during the prepare-commit transaction.  DSA driver code skips the prepare phase
and goes straight for the commit phase since no up-front allocations are done
and no device failures (that could be detected in the prepare phase) can
happen.

Remove NETIF_F_HW_SWITCH_OFFLOAD from rocker and the swdev_attr_set/get
wrappers.  DSA doesn't set NETIF_F_HW_SWITCH_OFFLOAD, so it can't be in
swdev_attr_set/get.  rocker doesn't need it; or rather can't support
NETIF_F_HW_SWITCH_OFFLOAD being set/cleared at run-time after the device
port is already up and offloading L2/L3.  NETIF_F_HW_SWITCH_OFFLOAD is still
left as a feature flag for drivers that can use it.

Drop the renaming patch for netdev_switch_notifier.  Other renames are a
result of moving to the attr get/set or obj add/del model.  Everything
but the netdev_switch_notifier is still prefixed with "swdev_".

v3:

Move to two-phase prepare-commit transaction model for attr set and obj add.
Driver gets a change in prepare phase to NACK transaction if lack of resources
or support in device.

v2:

Address review comments:

 - [Jiri] squash a few related patches
 - [Roopa] don't remove NETIF_F_HW_SWITCH_OFFLOAD
 - [Roopa] address VLAN setlink/dellink
 - [Ronen] print warning is attr set revert fails

Not address:

 - Using something other than "swdev_" prefix
 - Vendor extentions

The patch set grew a bit to not only support port attr get/set but also add
support for port obj add/del.  Example of port objs are VLAN, FDB entries, and
FIB entries.  The VLAN support now allows the swdev driver to get VLAN ranges
and flags like PVID and "untagged".  Sridhar will be adding FDB obj support
in follow-on patch.


v1:

The main theme of this patch set is to cleanup swdev in preparation for
new features or fixes to be added soon.  We have a pretty good idea now how
to handle stacked drivers in swdev, but there where some loose ends.  For
example, if a set failed in the middle of walking the lower devs, we would
leave the system in an undefined state...there was no way to recover back to
the previous state.  Speaking of sets, also recognize a pattern that most
swdev API accesses are gets or sets of port attributes, so go ahead and make
port attr get/set the central swdev API, and convert everything that is
set-ish/get-ish to this new API.

Features/fixes that should follow from this cleanup:

 - solve the duplicate pkt forwarding issue
 - get/set bridge attrs, like ageing_time, from/to device
 - get/set more bridge port attrs from/to device

There are some rename cleanups tagging along at the end, to give swdev
consistent naming.

And finally, some much needed updates to the switchdev.txt documentation to
hopefully capture the state-of-the-art of swdev.  Hopefully, we can do a better
job keeping this document up-to-date.

Tested with rocker, of course, to make sure nothing functional broke.  There
are a couple minor tweaks to DSA code for getting switch ID and setting STP
updates to use new API, but not expecting amy breakage there.

Jiri Pirko (2):
  switchdev: s/netdev_switch_/switchdev_/ and
    s/NETDEV_SWITCH_/SWITCHDEV_/
  switchdev: s/swdev_/switchdev_/

Scott Feldman (19):
  switchdev: introduce get/set attrs ops
  switchdev: convert parent_id_get to switchdev attr get
  switchdev: convert STP update to switchdev attr set
  switchdev: introduce switchdev add/del obj ops
  switchdev: add port vlan obj
  rocker: use switchdev add/del obj for bridge port vlans
  switchdev: add bridge port flags attr
  switchdev: add new switchdev bridge setlink
  switchdev: cut over to new switchdev_port_bridge_setlink
  switchdev: remove old switchdev_port_bridge_setlink
  switchdev: add new switchdev_port_bridge_dellink
  switchdev: cut over to new switchdev_port_bridge_dellink
  switchdev: remove unused switchdev_port_bridge_dellink
  switchdev: add new switchdev_port_bridge_getlink
  switchdev: cut over to new switchdev_port_bridge_getlink
  switchdev: convert fib_ipv4_add/del over to
    switchdev_port_obj_add/del
  switchdev: remove NETIF_F_HW_SWITCH_OFFLOAD feature flag
  rocker: make checkpatch -f clean
  switchdev: bring documentation up-to-date

 Documentation/networking/switchdev.txt |  414 ++++++++++++++++---
 drivers/net/bonding/bond_main.c        |   10 +-
 drivers/net/ethernet/rocker/rocker.c   |  703 +++++++++++++++++++++-----------
 drivers/net/ethernet/rocker/rocker.h   |   28 +-
 drivers/net/team/team.c                |    7 +-
 include/linux/netdev_features.h        |    5 +-
 include/linux/netdevice.h              |    2 +-
 include/net/switchdev.h                |  213 ++++++----
 net/bridge/br.c                        |   22 +-
 net/bridge/br_netlink.c                |   24 +-
 net/bridge/br_stp.c                    |    6 +-
 net/core/ethtool.c                     |    1 -
 net/core/net-sysfs.c                   |   10 +-
 net/core/rtnetlink.c                   |    9 +-
 net/dsa/slave.c                        |   40 +-
 net/ipv4/fib_trie.c                    |   40 +-
 net/switchdev/switchdev.c              |  662 ++++++++++++++++++++++--------
 17 files changed, 1566 insertions(+), 630 deletions(-)

-- 
1.7.10.4

             reply	other threads:[~2015-05-05 17:34 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-05-05 17:34 sfeldma [this message]
2015-05-05 17:34 ` [PATCH net-next v5 01/21] switchdev: s/netdev_switch_/switchdev_/ and s/NETDEV_SWITCH_/SWITCHDEV_/ sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 02/21] switchdev: s/swdev_/switchdev_/ sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 03/21] switchdev: introduce get/set attrs ops sfeldma
2015-05-06  3:11   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 04/21] switchdev: convert parent_id_get to switchdev attr get sfeldma
2015-05-06  3:13   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 05/21] switchdev: convert STP update to switchdev attr set sfeldma
2015-05-06  3:22   ` Jiri Pirko
2015-05-06  5:32     ` Scott Feldman
2015-05-05 17:34 ` [PATCH net-next v5 06/21] switchdev: introduce switchdev add/del obj ops sfeldma
2015-05-06  6:37   ` Samudrala, Sridhar
2015-05-06 18:23   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 07/21] switchdev: add port vlan obj sfeldma
2015-05-06 18:23   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 08/21] rocker: use switchdev add/del obj for bridge port vlans sfeldma
2015-05-06 18:23   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 09/21] switchdev: add bridge port flags attr sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 10/21] switchdev: add new switchdev bridge setlink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 11/21] switchdev: cut over to new switchdev_port_bridge_setlink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 12/21] switchdev: remove old switchdev_port_bridge_setlink sfeldma
2015-05-06  4:33   ` roopa
2015-05-07 15:33   ` Jiri Pirko
2015-05-07 15:36   ` Jiri Pirko
2015-05-08  5:07     ` Scott Feldman
2015-05-05 17:34 ` [PATCH net-next v5 13/21] switchdev: add new switchdev_port_bridge_dellink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 14/21] switchdev: cut over to " sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 15/21] switchdev: remove unused switchdev_port_bridge_dellink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 16/21] switchdev: add new switchdev_port_bridge_getlink sfeldma
2015-05-07 15:48   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 17/21] switchdev: cut over to " sfeldma
2015-05-07 15:49   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 18/21] switchdev: convert fib_ipv4_add/del over to switchdev_port_obj_add/del sfeldma
2015-05-07 16:10   ` Jiri Pirko
2015-05-08 14:19     ` John Fastabend
2015-05-09  7:10       ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 19/21] switchdev: remove NETIF_F_HW_SWITCH_OFFLOAD feature flag sfeldma
2015-05-07 16:10   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 20/21] rocker: make checkpatch -f clean sfeldma
2015-05-05 17:45   ` Joe Perches
2015-05-05 18:13     ` Jiri Pirko
2015-05-05 20:01     ` Scott Feldman
2015-05-05 18:22   ` Joe Perches
2015-05-05 17:34 ` [PATCH net-next v5 21/21] switchdev: bring documentation up-to-date sfeldma

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1430847297-15728-1-git-send-email-sfeldma@gmail.com \
    --to=sfeldma@gmail.com \
    --cc=andrew@lunn.ch \
    --cc=f.fainelli@gmail.com \
    --cc=jiri@resnulli.us \
    --cc=linux@roeck-us.net \
    --cc=netdev@vger.kernel.org \
    --cc=ronen.arad@intel.com \
    --cc=roopa@cumulusnetworks.com \
    --cc=simon.horman@netronome.com \
    --cc=sridhar.samudrala@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.