All of lore.kernel.org
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: sfeldma@gmail.com
Cc: netdev@vger.kernel.org, jiri@resnulli.us,
	roopa@cumulusnetworks.com, linux@roeck-us.net,
	f.fainelli@gmail.com, sridhar.samudrala@intel.com,
	ronen.arad@intel.com, andrew@lunn.ch, simon.horman@netronome.com
Subject: Re: [PATCH net-next v5 20/21] rocker: make checkpatch -f clean
Date: Tue, 05 May 2015 10:45:47 -0700	[thread overview]
Message-ID: <1430847947.3943.4.camel@perches.com> (raw)
In-Reply-To: <1430847297-15728-21-git-send-email-sfeldma@gmail.com>

On Tue, 2015-05-05 at 10:34 -0700, sfeldma@gmail.com wrote:
> Well almost clean: ignore the CHECKs for space after cast operator.

I think, because this uses relatively long identifiers,
that you might as well ignore > 80 column lines length
warnings.

> diff --git a/drivers/net/ethernet/rocker/rocker.c b/drivers/net/ethernet/rocker/rocker.c
[]
> @@ -1418,9 +1418,10 @@ static int rocker_event_link_change(struct rocker *rocker,
>  	if (!attrs[ROCKER_TLV_EVENT_LINK_CHANGED_PPORT] ||
>  	    !attrs[ROCKER_TLV_EVENT_LINK_CHANGED_LINKUP])
>  		return -EIO;
> -	port_number =
> -		rocker_tlv_get_u32(attrs[ROCKER_TLV_EVENT_LINK_CHANGED_PPORT]) - 1;
> -	link_up = rocker_tlv_get_u8(attrs[ROCKER_TLV_EVENT_LINK_CHANGED_LINKUP]);
> +	port_number = rocker_tlv_get_u32(
> +		attrs[ROCKER_TLV_EVENT_LINK_CHANGED_PPORT]) - 1;
> +	link_up = rocker_tlv_get_u8(
> +		attrs[ROCKER_TLV_EVENT_LINK_CHANGED_LINKUP]);

These would probably be better on single lines.

Maybe it'd be OK to avoid the rocker_tlv_ prefix
and/or add a helper macro/define for the
	rocker_tlv_<foo>(attrs[ROCKER_TLV_<BAR>
style to shorten the line length.

Otherwise, all the line breaks just seem to make
it harder to read.

> @@ -1686,9 +1687,12 @@ rocker_cmd_get_port_settings_ethtool_proc(struct rocker *rocker,
>  	    !info_attrs[ROCKER_TLV_CMD_PORT_SETTINGS_AUTONEG])
>  		return -EIO;
>  
> -	speed = rocker_tlv_get_u32(info_attrs[ROCKER_TLV_CMD_PORT_SETTINGS_SPEED]);
> -	duplex = rocker_tlv_get_u8(info_attrs[ROCKER_TLV_CMD_PORT_SETTINGS_DUPLEX]);
> -	autoneg = rocker_tlv_get_u8(info_attrs[ROCKER_TLV_CMD_PORT_SETTINGS_AUTONEG]);
> +	speed = rocker_tlv_get_u32(
> +		info_attrs[ROCKER_TLV_CMD_PORT_SETTINGS_SPEED]);
> +	duplex = rocker_tlv_get_u8(
> +		info_attrs[ROCKER_TLV_CMD_PORT_SETTINGS_DUPLEX]);
> +	autoneg = rocker_tlv_get_u8(
> +		info_attrs[ROCKER_TLV_CMD_PORT_SETTINGS_AUTONEG]);

etc...

  reply	other threads:[~2015-05-05 17:45 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-05-05 17:34 [PATCH net-next v5 00/21] switchdev: spring cleanup sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 01/21] switchdev: s/netdev_switch_/switchdev_/ and s/NETDEV_SWITCH_/SWITCHDEV_/ sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 02/21] switchdev: s/swdev_/switchdev_/ sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 03/21] switchdev: introduce get/set attrs ops sfeldma
2015-05-06  3:11   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 04/21] switchdev: convert parent_id_get to switchdev attr get sfeldma
2015-05-06  3:13   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 05/21] switchdev: convert STP update to switchdev attr set sfeldma
2015-05-06  3:22   ` Jiri Pirko
2015-05-06  5:32     ` Scott Feldman
2015-05-05 17:34 ` [PATCH net-next v5 06/21] switchdev: introduce switchdev add/del obj ops sfeldma
2015-05-06  6:37   ` Samudrala, Sridhar
2015-05-06 18:23   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 07/21] switchdev: add port vlan obj sfeldma
2015-05-06 18:23   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 08/21] rocker: use switchdev add/del obj for bridge port vlans sfeldma
2015-05-06 18:23   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 09/21] switchdev: add bridge port flags attr sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 10/21] switchdev: add new switchdev bridge setlink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 11/21] switchdev: cut over to new switchdev_port_bridge_setlink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 12/21] switchdev: remove old switchdev_port_bridge_setlink sfeldma
2015-05-06  4:33   ` roopa
2015-05-07 15:33   ` Jiri Pirko
2015-05-07 15:36   ` Jiri Pirko
2015-05-08  5:07     ` Scott Feldman
2015-05-05 17:34 ` [PATCH net-next v5 13/21] switchdev: add new switchdev_port_bridge_dellink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 14/21] switchdev: cut over to " sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 15/21] switchdev: remove unused switchdev_port_bridge_dellink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 16/21] switchdev: add new switchdev_port_bridge_getlink sfeldma
2015-05-07 15:48   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 17/21] switchdev: cut over to " sfeldma
2015-05-07 15:49   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 18/21] switchdev: convert fib_ipv4_add/del over to switchdev_port_obj_add/del sfeldma
2015-05-07 16:10   ` Jiri Pirko
2015-05-08 14:19     ` John Fastabend
2015-05-09  7:10       ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 19/21] switchdev: remove NETIF_F_HW_SWITCH_OFFLOAD feature flag sfeldma
2015-05-07 16:10   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 20/21] rocker: make checkpatch -f clean sfeldma
2015-05-05 17:45   ` Joe Perches [this message]
2015-05-05 18:13     ` Jiri Pirko
2015-05-05 20:01     ` Scott Feldman
2015-05-05 18:22   ` Joe Perches
2015-05-05 17:34 ` [PATCH net-next v5 21/21] switchdev: bring documentation up-to-date sfeldma

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1430847947.3943.4.camel@perches.com \
    --to=joe@perches.com \
    --cc=andrew@lunn.ch \
    --cc=f.fainelli@gmail.com \
    --cc=jiri@resnulli.us \
    --cc=linux@roeck-us.net \
    --cc=netdev@vger.kernel.org \
    --cc=ronen.arad@intel.com \
    --cc=roopa@cumulusnetworks.com \
    --cc=sfeldma@gmail.com \
    --cc=simon.horman@netronome.com \
    --cc=sridhar.samudrala@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.