All of lore.kernel.org
 help / color / mirror / Atom feed
From: sfeldma@gmail.com
To: netdev@vger.kernel.org
Cc: jiri@resnulli.us, roopa@cumulusnetworks.com, linux@roeck-us.net,
	f.fainelli@gmail.com, sridhar.samudrala@intel.com,
	ronen.arad@intel.com, andrew@lunn.ch, simon.horman@netronome.com
Subject: [PATCH net-next v5 14/21] switchdev: cut over to new switchdev_port_bridge_dellink
Date: Tue,  5 May 2015 10:34:50 -0700	[thread overview]
Message-ID: <1430847297-15728-15-git-send-email-sfeldma@gmail.com> (raw)
In-Reply-To: <1430847297-15728-1-git-send-email-sfeldma@gmail.com>

From: Scott Feldman <sfeldma@gmail.com>

Rocker, bonding and team and switch over to the new
switchdev_port_bridge_dellink to avoid duplicating code in each driver.

Signed-off-by: Scott Feldman <sfeldma@gmail.com>
---
 drivers/net/bonding/bond_main.c      |    2 +-
 drivers/net/ethernet/rocker/rocker.c |    1 +
 drivers/net/team/team.c              |    2 +-
 3 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/net/bonding/bond_main.c b/drivers/net/bonding/bond_main.c
index e1d8a03..bb47661 100644
--- a/drivers/net/bonding/bond_main.c
+++ b/drivers/net/bonding/bond_main.c
@@ -4040,7 +4040,7 @@ static const struct net_device_ops bond_netdev_ops = {
 	.ndo_del_slave		= bond_release,
 	.ndo_fix_features	= bond_fix_features,
 	.ndo_bridge_setlink	= switchdev_port_bridge_setlink,
-	.ndo_bridge_dellink	= ndo_dflt_switchdev_port_bridge_dellink,
+	.ndo_bridge_dellink	= switchdev_port_bridge_dellink,
 	.ndo_features_check	= passthru_features_check,
 };
 
diff --git a/drivers/net/ethernet/rocker/rocker.c b/drivers/net/ethernet/rocker/rocker.c
index 1fcc020..2a77c22e 100644
--- a/drivers/net/ethernet/rocker/rocker.c
+++ b/drivers/net/ethernet/rocker/rocker.c
@@ -4289,6 +4289,7 @@ static const struct net_device_ops rocker_port_netdev_ops = {
 	.ndo_fdb_dump			= rocker_port_fdb_dump,
 	.ndo_bridge_setlink		= switchdev_port_bridge_setlink,
 	.ndo_bridge_getlink		= rocker_port_bridge_getlink,
+	.ndo_bridge_dellink		= switchdev_port_bridge_dellink,
 	.ndo_get_phys_port_name		= rocker_port_get_phys_port_name,
 };
 
diff --git a/drivers/net/team/team.c b/drivers/net/team/team.c
index e6c4df2..0283753 100644
--- a/drivers/net/team/team.c
+++ b/drivers/net/team/team.c
@@ -1978,7 +1978,7 @@ static const struct net_device_ops team_netdev_ops = {
 	.ndo_fix_features	= team_fix_features,
 	.ndo_change_carrier     = team_change_carrier,
 	.ndo_bridge_setlink	= switchdev_port_bridge_setlink,
-	.ndo_bridge_dellink     = ndo_dflt_switchdev_port_bridge_dellink,
+	.ndo_bridge_dellink	= switchdev_port_bridge_dellink,
 	.ndo_features_check	= passthru_features_check,
 };
 
-- 
1.7.10.4

  parent reply	other threads:[~2015-05-05 17:34 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-05-05 17:34 [PATCH net-next v5 00/21] switchdev: spring cleanup sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 01/21] switchdev: s/netdev_switch_/switchdev_/ and s/NETDEV_SWITCH_/SWITCHDEV_/ sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 02/21] switchdev: s/swdev_/switchdev_/ sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 03/21] switchdev: introduce get/set attrs ops sfeldma
2015-05-06  3:11   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 04/21] switchdev: convert parent_id_get to switchdev attr get sfeldma
2015-05-06  3:13   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 05/21] switchdev: convert STP update to switchdev attr set sfeldma
2015-05-06  3:22   ` Jiri Pirko
2015-05-06  5:32     ` Scott Feldman
2015-05-05 17:34 ` [PATCH net-next v5 06/21] switchdev: introduce switchdev add/del obj ops sfeldma
2015-05-06  6:37   ` Samudrala, Sridhar
2015-05-06 18:23   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 07/21] switchdev: add port vlan obj sfeldma
2015-05-06 18:23   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 08/21] rocker: use switchdev add/del obj for bridge port vlans sfeldma
2015-05-06 18:23   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 09/21] switchdev: add bridge port flags attr sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 10/21] switchdev: add new switchdev bridge setlink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 11/21] switchdev: cut over to new switchdev_port_bridge_setlink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 12/21] switchdev: remove old switchdev_port_bridge_setlink sfeldma
2015-05-06  4:33   ` roopa
2015-05-07 15:33   ` Jiri Pirko
2015-05-07 15:36   ` Jiri Pirko
2015-05-08  5:07     ` Scott Feldman
2015-05-05 17:34 ` [PATCH net-next v5 13/21] switchdev: add new switchdev_port_bridge_dellink sfeldma
2015-05-05 17:34 ` sfeldma [this message]
2015-05-05 17:34 ` [PATCH net-next v5 15/21] switchdev: remove unused switchdev_port_bridge_dellink sfeldma
2015-05-05 17:34 ` [PATCH net-next v5 16/21] switchdev: add new switchdev_port_bridge_getlink sfeldma
2015-05-07 15:48   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 17/21] switchdev: cut over to " sfeldma
2015-05-07 15:49   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 18/21] switchdev: convert fib_ipv4_add/del over to switchdev_port_obj_add/del sfeldma
2015-05-07 16:10   ` Jiri Pirko
2015-05-08 14:19     ` John Fastabend
2015-05-09  7:10       ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 19/21] switchdev: remove NETIF_F_HW_SWITCH_OFFLOAD feature flag sfeldma
2015-05-07 16:10   ` Jiri Pirko
2015-05-05 17:34 ` [PATCH net-next v5 20/21] rocker: make checkpatch -f clean sfeldma
2015-05-05 17:45   ` Joe Perches
2015-05-05 18:13     ` Jiri Pirko
2015-05-05 20:01     ` Scott Feldman
2015-05-05 18:22   ` Joe Perches
2015-05-05 17:34 ` [PATCH net-next v5 21/21] switchdev: bring documentation up-to-date sfeldma

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1430847297-15728-15-git-send-email-sfeldma@gmail.com \
    --to=sfeldma@gmail.com \
    --cc=andrew@lunn.ch \
    --cc=f.fainelli@gmail.com \
    --cc=jiri@resnulli.us \
    --cc=linux@roeck-us.net \
    --cc=netdev@vger.kernel.org \
    --cc=ronen.arad@intel.com \
    --cc=roopa@cumulusnetworks.com \
    --cc=simon.horman@netronome.com \
    --cc=sridhar.samudrala@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.