All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v8 0/11] Create ref-filter from for-each-ref
@ 2015-06-13 19:34 karthik nayak
  2015-06-13 19:37 ` [PATCH v8 01/11] for-each-ref: extract helper functions out of grab_single_ref() Karthik Nayak
                   ` (2 more replies)
  0 siblings, 3 replies; 16+ messages in thread
From: karthik nayak @ 2015-06-13 19:34 UTC (permalink / raw)
  To: Git; +Cc: Christian Couder, Matthieu Moy, Junio C Hamano

The previous version of the patch can be found at :
http://thread.gmane.org/gmane.comp.version-control.git/271423

Changes :
* Removed an unnecessary commit (v7 3/12)
* Change a comment in 01/11 (v8)

Total changes :

 Makefile               |    1 +
 builtin/for-each-ref.c | 1108
+++-------------------------------------------------------------------------------------------------------------------
 ref-filter.c           | 1101
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 ref-filter.h           |   74 ++++++++
 4 files changed, 1195 insertions(+), 1089 deletions(-)

-- 
Regards,
Karthik Nayak

^ permalink raw reply	[flat|nested] 16+ messages in thread

end of thread, other threads:[~2015-06-15 20:48 UTC | newest]

Thread overview: 16+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-06-13 19:34 [PATCH v8 0/11] Create ref-filter from for-each-ref karthik nayak
2015-06-13 19:37 ` [PATCH v8 01/11] for-each-ref: extract helper functions out of grab_single_ref() Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 02/11] for-each-ref: clean up code Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 03/11] for-each-ref: rename 'refinfo' to 'ref_array_item' Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 04/11] for-each-ref: introduce new structures for better organisation Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 05/11] for-each-ref: introduce 'ref_array_clear()' Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 06/11] for-each-ref: rename some functions and make them public Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 07/11] for-each-ref: rename variables called sort to sorting Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 08/11] ref-filter: add 'ref-filter.h' Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 09/11] ref-filter: move code from 'for-each-ref' Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 10/11] for-each-ref: introduce filter_refs() Karthik Nayak
2015-06-13 19:37   ` [PATCH v8 11/11] ref-filter: make 'ref_array_item' use a FLEX_ARRAY for refname Karthik Nayak
2015-06-14  8:04 ` [PATCH v8 0/11] Create ref-filter from for-each-ref Matthieu Moy
2015-06-14  8:24   ` karthik nayak
2015-06-15 18:49 ` Junio C Hamano
2015-06-15 20:47   ` karthik nayak

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.