All of lore.kernel.org
 help / color / mirror / Atom feed
* [U-Boot] [PATCH 0/4] atmel_nand: misc update in atmel nandflash driver
@ 2015-11-24  8:26 Josh Wu
  2015-11-24  8:26 ` [U-Boot] [PATCH 1/4] atmel_nand: use nand ecc_{strength, step}_ds instead of our own function Josh Wu
                   ` (3 more replies)
  0 siblings, 4 replies; 11+ messages in thread
From: Josh Wu @ 2015-11-24  8:26 UTC (permalink / raw)
  To: u-boot

Since the nand driver is synced with v4.1 kernel, here is a update also
for atmel_nand driver. which includes:
  1. fix format and using definition not magic number.
  2. use ecc_{strength, step}_ds instead of our own function.
  3. add delay time to support MF29F32G08CBADA.


Josh Wu (4):
  atmel_nand: use nand ecc_{strength,step}_ds instead of our own
    function
  atmel_nand: add '\n' in the end of error message for better display
  atmel_nand: increase more delay to support MT29F32G08CBADA
  atmel_nand: use the definition: PMECC_OOB_RESERVED_BYTES instead magic
    number

 drivers/mtd/nand/atmel_nand.c | 52 +++++++++----------------------------------
 1 file changed, 11 insertions(+), 41 deletions(-)

-- 
1.9.1

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2016-01-25  5:51 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-11-24  8:26 [U-Boot] [PATCH 0/4] atmel_nand: misc update in atmel nandflash driver Josh Wu
2015-11-24  8:26 ` [U-Boot] [PATCH 1/4] atmel_nand: use nand ecc_{strength, step}_ds instead of our own function Josh Wu
2016-01-24 21:22   ` Andreas Bießmann
2016-01-25  2:41     ` Yang, Wenyou
2015-11-24  8:26 ` [U-Boot] [PATCH 2/4] atmel_nand: add '\n' in the end of error message for better display Josh Wu
2016-01-24 21:31   ` Andreas Bießmann
2015-11-24  8:26 ` [U-Boot] [PATCH 3/4] atmel_nand: increase more delay to support MT29F32G08CBADA Josh Wu
2016-01-24 21:41   ` Andreas Bießmann
2016-01-25  5:51     ` Yang, Wenyou
2015-11-24  8:26 ` [U-Boot] [PATCH 4/4] atmel_nand: use the definition: PMECC_OOB_RESERVED_BYTES instead magic number Josh Wu
2016-01-24 21:37   ` Andreas Bießmann

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.