All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH RESEND 00/28] staging: unisys: fix visorbus & visorinput issues raised by tglx
@ 2016-06-11  1:47 David Kershner
  2016-06-11  1:47 ` [PATCH RESEND 01/28] staging: unisys: visorbus: remove return values for write_vbus functions David Kershner
                   ` (29 more replies)
  0 siblings, 30 replies; 35+ messages in thread
From: David Kershner @ 2016-06-11  1:47 UTC (permalink / raw)
  To: gregkh, driverdev-devel, sparmaintainer, jes.sorensen, tglx,
	david.binder, nhorman

Resending due to imcomplete distribution list. 

This patchset comprises the first 26 patches of the previously-submitted
patchset (but retracted): 

	[PATCH v4 00/29] Fixed issues raised by tglx, then move visorbus to
			 drivers/virt

then adds 2 patches to visorinput that:
	* fixes a device initialization race condition
	* converts a semaphore to a mutex

As described in the email NAKing the previously-submitted patchset,
the reason we are re-submitting this now is to make things a bit
cleaner by separating the fixes we need to make to the code in
staging from the patchset that actually moves the code out of staging.

The intent of this patchset is to fix all known outstanding
issues with code in drivers/staging/unisys/, so that subsequent
patchsets can move these drivers out of staging.

tglx: The following patchset fixes issues you raised during your
code review of visorbus on 5/18, and visorinput on 6/1. 

Converts visorbus to use a kernel timer for periodic device-specific
callbacks instead of a workqueue, making the implementation in
periodic_work.c and periodic_work.h no longer necessary.  These files
are then deleted.

The visordriver_callback_lock has been switched to a mutex.

Several module parameters and structures were removed that were no
longer being used.

Bryan Thompson (4):
  staging: unisys: visorbus: Make visordriver_callback_lock a mutex
  staging: unisys: visorbus: Remove unnecessary EXPORT_SYMBOL statements
  staging: unisys: visorbus: Remove unused functions
  staging: unisys: Remove reference to unused STANDALONE_CLIENT

David Binder (13):
  staging: unisys: visorbus: remove unused module parameters
  staging: unisys: visorbus: remove unused struct
  staging: unisys: visorbus: modify format string to match argument
  staging: unisys: visornic: Correct comment spelling mistake
  staging: unisys: include: Remove thread-related enum members
  staging: unisys: visorbus: fix commenting in vbusdevinfo.h
  staging: unisys: visorbus: fix commenting in visorbus_main.c
  staging: unisys: visorbus: fix visorchannel.c comments
  staging: unisys: visorbus: Rectify commenting in visorchipset.c
  staging: unisys: visorbus: Move visorbus-unique functions to private
    header
  staging: unisys: visorbus: rectify kerneldoc comment for struct
  staging: unisys: visorbus: Remove notifier-related code from visorbus
  staging: unisys: visorbus: Rename function to follow existing
    convention

David Kershner (1):
  staging: unisys: Move vbushelper.h to visorbus directory

Erik Arfvidson (2):
  staging: unisys: visorbus: remove return values for write_vbus
    functions
  staging: unisys: visorbus: check parahotplug_request_complete_result

Tim Sell (8):
  staging: unisys: visorbus: removed unused periodic_test_workqueue
  staging: unisys: visorinput: remove unnecessary locking
  staging: unisys: visorbus: use kernel timer instead of workqueue
  staging: unisys: visorbus: remove periodic_work.h/.c
  staging: unisys: visorbus: remove unused parameter from function
  staging: unisys: visorbus: fix visorbus_private.h comments
  staging: unisys: visorinput: ensure proper locking wrt creation & ints
  staging: unisys: visorinput: make lock_visor_dev a mutex

 drivers/staging/unisys/include/guestlinuxdebug.h   |   4 +-
 drivers/staging/unisys/include/periodic_work.h     |  40 --
 drivers/staging/unisys/include/vbushelper.h        |  46 --
 drivers/staging/unisys/include/visorbus.h          |  80 +--
 drivers/staging/unisys/visorbus/Makefile           |   1 -
 drivers/staging/unisys/visorbus/periodic_work.c    | 204 -------
 drivers/staging/unisys/visorbus/vbusdeviceinfo.h   |  65 ++-
 drivers/staging/unisys/visorbus/vbushelper.h       |  46 ++
 drivers/staging/unisys/visorbus/visorbus_main.c    | 615 +++++++++++----------
 drivers/staging/unisys/visorbus/visorbus_private.h |  73 ++-
 drivers/staging/unisys/visorbus/visorchannel.c     | 269 +++------
 drivers/staging/unisys/visorbus/visorchipset.c     | 434 ++++++++-------
 drivers/staging/unisys/visorinput/visorinput.c     | 141 +++--
 drivers/staging/unisys/visornic/visornic_main.c    |   2 +-
 14 files changed, 879 insertions(+), 1141 deletions(-)
 delete mode 100644 drivers/staging/unisys/include/periodic_work.h
 delete mode 100644 drivers/staging/unisys/include/vbushelper.h
 delete mode 100644 drivers/staging/unisys/visorbus/periodic_work.c
 create mode 100644 drivers/staging/unisys/visorbus/vbushelper.h

-- 
1.9.1

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply	[flat|nested] 35+ messages in thread

end of thread, other threads:[~2016-07-27 18:02 UTC | newest]

Thread overview: 35+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-06-11  1:47 [PATCH RESEND 00/28] staging: unisys: fix visorbus & visorinput issues raised by tglx David Kershner
2016-06-11  1:47 ` [PATCH RESEND 01/28] staging: unisys: visorbus: remove return values for write_vbus functions David Kershner
2016-06-11  1:48 ` [PATCH RESEND 02/28] staging: unisys: visorbus: check parahotplug_request_complete_result David Kershner
2016-06-11  1:48 ` [PATCH RESEND 03/28] staging: unisys: visorbus: remove unused module parameters David Kershner
2016-06-11  1:48 ` [PATCH RESEND 04/28] staging: unisys: visorbus: remove unused struct David Kershner
2016-06-11  1:48 ` [PATCH RESEND 05/28] staging: unisys: visorbus: modify format string to match argument David Kershner
2016-06-11  1:48 ` [PATCH RESEND 06/28] staging: unisys: visornic: Correct comment spelling mistake David Kershner
2016-06-11  1:48 ` [PATCH RESEND 07/28] staging: unisys: include: Remove thread-related enum members David Kershner
2016-06-11  1:48 ` [PATCH RESEND 08/28] staging: unisys: visorbus: removed unused periodic_test_workqueue David Kershner
2016-06-11  1:48 ` [PATCH RESEND 09/28] staging: unisys: visorinput: remove unnecessary locking David Kershner
2016-06-11  1:48 ` [PATCH RESEND 10/28] staging: unisys: visorbus: use kernel timer instead of workqueue David Kershner
2016-06-11  1:48 ` [PATCH RESEND 11/28] staging: unisys: visorbus: remove periodic_work.h/.c David Kershner
2016-06-11  1:48 ` [PATCH RESEND 12/28] staging: unisys: visorbus: Make visordriver_callback_lock a mutex David Kershner
2016-06-11  1:48 ` [PATCH RESEND 13/28] staging: unisys: visorbus: Remove unnecessary EXPORT_SYMBOL statements David Kershner
2016-06-11  1:48 ` [PATCH RESEND 14/28] staging: unisys: visorbus: Remove unused functions David Kershner
2016-06-11  1:48 ` [PATCH RESEND 15/28] staging: unisys: Remove reference to unused STANDALONE_CLIENT David Kershner
2016-06-11  1:48 ` [PATCH RESEND 16/28] staging: unisys: visorbus: remove unused parameter from function David Kershner
2016-06-11  1:48 ` [PATCH RESEND 17/28] staging: unisys: visorbus: fix commenting in vbusdevinfo.h David Kershner
2016-06-11  1:48 ` [PATCH RESEND 18/28] staging: unisys: visorbus: fix commenting in visorbus_main.c David Kershner
2016-06-11  1:48 ` [PATCH RESEND 19/28] staging: unisys: visorbus: fix visorchannel.c comments David Kershner
2016-06-11  1:48 ` [PATCH RESEND 20/28] staging: unisys: visorbus: Rectify commenting in visorchipset.c David Kershner
2016-06-11  1:48 ` [PATCH RESEND 21/28] staging: unisys: visorbus: Move visorbus-unique functions to private header David Kershner
2016-06-11  1:48 ` [PATCH RESEND 22/28] staging: unisys: visorbus: rectify kerneldoc comment for struct David Kershner
2016-06-11  1:48 ` [PATCH RESEND 23/28] staging: unisys: visorbus: Remove notifier-related code from visorbus David Kershner
2016-06-11  1:48 ` [PATCH RESEND 24/28] staging: unisys: visorbus: Rename function to follow existing convention David Kershner
2016-06-11  1:48 ` [PATCH RESEND 25/28] staging: unisys: visorbus: fix visorbus_private.h comments David Kershner
2016-06-11  1:48 ` [PATCH RESEND 26/28] staging: unisys: Move vbushelper.h to visorbus directory David Kershner
2016-06-11  1:48 ` [PATCH RESEND 27/28] staging: unisys: visorinput: ensure proper locking wrt creation & ints David Kershner
2016-06-11  1:48 ` [PATCH RESEND 28/28] staging: unisys: visorinput: make lock_visor_dev a mutex David Kershner
2016-06-11  9:42 ` [PATCH RESEND 00/28] staging: unisys: fix visorbus & visorinput issues raised by tglx Thomas Gleixner
2016-06-14 13:26 ` Neil Horman
2016-06-16 17:35   ` Kershner, David A
2016-06-16 19:02     ` gregkh
2016-07-27 17:43       ` Kershner, David A
2016-07-27 18:02         ` gregkh

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.