All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/22] staging: wilc1000: cleanup patches to follow linux coding style
@ 2018-04-18 11:39 Ajay Singh
  2018-04-18 11:39 ` [PATCH 01/22] staging: wilc1000: rename WILC_WFI_wep_key & WILC_WFI_wep_key_len Ajay Singh
                   ` (22 more replies)
  0 siblings, 23 replies; 27+ messages in thread
From: Ajay Singh @ 2018-04-18 11:39 UTC (permalink / raw)
  To: linux-wireless
  Cc: devel, gregkh, ganesh.krishna, venkateswara.kaja, aditya.shankar,
	claudiu.beznea, adham.abozaeid, Ajay Singh

This patch series is based on top of
"[PATCH 00/11] staging: wilc1000: fix for checkpatch and handled
malloc memory properly" and its not applied yet.[1]

In this series contains fixes to avoid the checkpatch reported issue.
Also remove the multiple #define for same macros and changes to
follow linux coding style.

[1] https://www.mail-archive.com/linux-wireless@vger.kernel.org/msg43998.html

Ajay Singh (22):
  staging: wilc1000: rename WILC_WFI_wep_key & WILC_WFI_wep_key_len
  staging: wilc1000: rename variable using datatype in their name in
    add_key()
  staging: wilc1000: split add_key() to avoid line over 80 chars
  staging: wilc1000: remove inner block {} and resetting of mode
    variable
  staging: wilc1000: refactor add_key() to avoid duplicated code
  staging: wilc1000: handle error condition in add_key() and remove
    auth_type variable
  staging: wilc1000: use sizeof(variable) for memory allocated to store
    key info
  staging: wilc1000: fix line over 80 chars in change_station()
  staging: wilc1000: rename WID_LOGTerminal_Switch to avoid camelCase
  staging: wilc1000: added identifiers name in function definations
  staging: wilc1000: remove unused macros in wilc module
  staging: wilc1000: remove multiple define used for MAX_SSID_LEN
  staging: wilc1000: remove multiple define for mac connect and
    disconnect
  staging: wilc1000: remove the use of goto label in spi_cmd_complete()
  staging: wilc1000: remove the use of goto label in
    wilc_spi_read_size()
  staging: wilc1000: remove the use of goto label in wilc_spi_read_int()
  staging: wilc1000: remove goto label '_done_' in
    handle_listen_state_expired()
  staging: wilc1000: remove the use of goto label in wilc_init()
  staging: wilc1000: rename goto label '_fail_' linux naming convension
  staging: wilc1000: rename goto labels starting with '_' in
    wilc1000_wlan_init()
  staging: wilc1000: remove the use of goto label in
    wilc_spi_clear_int_ext()
  staging: wilc1000: rename pu32InactiveTime to avoid camelCase issue

 drivers/staging/wilc1000/coreconfigurator.h       |  17 --
 drivers/staging/wilc1000/host_interface.c         |  25 +--
 drivers/staging/wilc1000/host_interface.h         |   3 +-
 drivers/staging/wilc1000/linux_wlan.c             | 118 +++++-----
 drivers/staging/wilc1000/wilc_sdio.c              |  84 ++++----
 drivers/staging/wilc1000/wilc_spi.c               |  21 +-
 drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 250 +++++++++++-----------
 drivers/staging/wilc1000/wilc_wfi_netdevice.h     |   8 +-
 drivers/staging/wilc1000/wilc_wlan.c              |  16 +-
 drivers/staging/wilc1000/wilc_wlan.h              |  26 +--
 drivers/staging/wilc1000/wilc_wlan_if.h           |   4 +-
 11 files changed, 268 insertions(+), 304 deletions(-)

-- 
2.7.4

^ permalink raw reply	[flat|nested] 27+ messages in thread

end of thread, other threads:[~2018-04-23 14:44 UTC | newest]

Thread overview: 27+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-04-18 11:39 [PATCH 00/22] staging: wilc1000: cleanup patches to follow linux coding style Ajay Singh
2018-04-18 11:39 ` [PATCH 01/22] staging: wilc1000: rename WILC_WFI_wep_key & WILC_WFI_wep_key_len Ajay Singh
2018-04-18 11:39 ` [PATCH 02/22] staging: wilc1000: rename variable using datatype in their name in add_key() Ajay Singh
2018-04-18 11:39 ` [PATCH 03/22] staging: wilc1000: split add_key() to avoid line over 80 chars Ajay Singh
2018-04-18 11:39 ` [PATCH 04/22] staging: wilc1000: remove inner block {} and resetting of mode variable Ajay Singh
2018-04-18 11:39 ` [PATCH 05/22] staging: wilc1000: refactor add_key() to avoid duplicated code Ajay Singh
2018-04-18 11:39 ` [PATCH 06/22] staging: wilc1000: handle error condition in add_key() and remove auth_type variable Ajay Singh
2018-04-18 11:39 ` [PATCH 07/22] staging: wilc1000: use sizeof(variable) for memory allocated to store key info Ajay Singh
2018-04-18 11:39 ` [PATCH 08/22] staging: wilc1000: fix line over 80 chars in change_station() Ajay Singh
2018-04-18 11:39 ` [PATCH 09/22] staging: wilc1000: rename WID_LOGTerminal_Switch to avoid camelCase Ajay Singh
2018-04-18 11:39 ` [PATCH 10/22] staging: wilc1000: added identifiers name in function definations Ajay Singh
2018-04-18 11:39 ` [PATCH 11/22] staging: wilc1000: remove unused macros in wilc module Ajay Singh
2018-04-18 11:39 ` [PATCH 12/22] staging: wilc1000: remove multiple define used for MAX_SSID_LEN Ajay Singh
2018-04-18 11:39 ` [PATCH 13/22] staging: wilc1000: remove multiple define for mac connect and disconnect Ajay Singh
2018-04-18 11:39 ` [PATCH 14/22] staging: wilc1000: remove the use of goto label in spi_cmd_complete() Ajay Singh
2018-04-18 11:39 ` [PATCH 15/22] staging: wilc1000: remove the use of goto label in wilc_spi_read_size() Ajay Singh
2018-04-18 11:39 ` [PATCH 16/22] staging: wilc1000: remove the use of goto label in wilc_spi_read_int() Ajay Singh
2018-04-18 11:39 ` [PATCH 17/22] staging: wilc1000: remove goto label '_done_' in handle_listen_state_expired() Ajay Singh
2018-04-18 11:39 ` [PATCH 18/22] staging: wilc1000: remove the use of goto label in wilc_init() Ajay Singh
2018-04-18 11:39 ` [PATCH 19/22] staging: wilc1000: rename goto label '_fail_' linux naming convension Ajay Singh
2018-04-18 11:39 ` [PATCH 20/22] staging: wilc1000: rename goto labels starting with '_' in wilc1000_wlan_init() Ajay Singh
2018-04-18 11:39 ` [PATCH 21/22] staging: wilc1000: remove the use of goto label in wilc_spi_clear_int_ext() Ajay Singh
2018-04-18 11:39 ` [PATCH 22/22] staging: wilc1000: rename pu32InactiveTime to avoid camelCase issue Ajay Singh
2018-04-23 13:45 ` [PATCH 00/22] staging: wilc1000: cleanup patches to follow linux coding style Greg KH
2018-04-23 14:01   ` Ajay Singh
2018-04-23 14:11     ` Greg KH
2018-04-23 14:44     ` Claudiu Beznea

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.