All of lore.kernel.org
 help / color / mirror / Atom feed
* [B.A.T.M.A.N.] no able to switch routing algo to V ?
@ 2016-05-07 14:08 contact
  2016-05-07 14:18 ` Sven Eckelmann
  0 siblings, 1 reply; 17+ messages in thread
From: contact @ 2016-05-07 14:08 UTC (permalink / raw)
  To: The list for a Better Approach To Mobile Ad-hoc Networking

Hello,

I just got openwrt 15.05.1 with batman-adv 2016.1 on 3 picostation HP, 
this time a selected before the build of openwrt batman V option, I can 
see it when it ask for available routing algo ,

root@OpenWrt:/etc/init.d# cat /sys/kernel/debug/batman_adv/routing_algos
Available routing algorithms:
  * BATMAN_IV
  * BATMAN_V

but when I do :

echo BATMAN_V > /sys/module/batman_adv/parameters/routing_algo

It does nothing, still on BATMAN_IV during session and on reboot ?

sysctl -a does not show any routing_algoritms param for batman-adv ?

Best Regards,

Laurent

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 14:08 [B.A.T.M.A.N.] no able to switch routing algo to V ? contact
@ 2016-05-07 14:18 ` Sven Eckelmann
  2016-05-07 16:04   ` contact
  0 siblings, 1 reply; 17+ messages in thread
From: Sven Eckelmann @ 2016-05-07 14:18 UTC (permalink / raw)
  To: b.a.t.m.a.n

[-- Attachment #1: Type: text/plain, Size: 1921 bytes --]

On Saturday 07 May 2016 16:08:35 contact wrote:
> Hello,
> 
> I just got openwrt 15.05.1 with batman-adv 2016.1 on 3 picostation HP,
> this time a selected before the build of openwrt batman V option, I can
> see it when it ask for available routing algo ,
> 
> root@OpenWrt:/etc/init.d# cat /sys/kernel/debug/batman_adv/routing_algos
> Available routing algorithms:
>   * BATMAN_IV
>   * BATMAN_V
> 
> but when I do :
> 
> echo BATMAN_V > /sys/module/batman_adv/parameters/routing_algo
> 
> It does nothing, still on BATMAN_IV during session and on reboot ?

This module parameter only controls what routing algorithm is chosen when a
new batman-adv interface is created. So if you already have created it then
changing the parameter doesn't do anything to the already existing batman-adv
interface. Also rebooting a device will reset it either to the default or to
the one you've explicitly specified during the loading of the modules.

But you seem to use OpenWrt. It allows to specify the routing_algo in
/etc/config/network and should be applied right before the batman-adv
interface is created. You just have to make sure that you don't specify
conflicting things. An example of a simple configuration is:

    config interface 'batnet'
            option mtu '1532'
            option proto 'batadv'
            option mesh 'bat0'
            option routing_algo 'BATMAN_V'

The wireless configuration would then normally reference this batnet network:

    config wifi-iface 'wmesh'
            option device 'radio0'
            option ifname 'adhoc0'
            option network 'batnet'
            option mode 'adhoc'
            option ssid 'mesh'
            option 'mcast_rate' '18000'
            option bssid '02:CA:FE:CA:CA:40'

This information was taken from Batman-adv-openwrt-config wiki page [1]

Kind regards,
	Sven

[1] https://www.open-mesh.org/projects/batman-adv/wiki/Batman-adv-openwrt-config

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 14:18 ` Sven Eckelmann
@ 2016-05-07 16:04   ` contact
  2016-05-07 16:28     ` Sven Eckelmann
  0 siblings, 1 reply; 17+ messages in thread
From: contact @ 2016-05-07 16:04 UTC (permalink / raw)
  To: Sven Eckelmann, b.a.t.m.a.n

Thank you, it is working and it is more clear for me.

I have switched to V but when I switch on other V nodes, my first node 
reset or freeze, probably a kernel panic. Need to plug a rs232 to be 
able to see what could be the problem.
I will switch back to IV.

for info my network file:

config interface 'lan'
         option ifname 'eth0 bat0'
         option force_link '1'
         option type 'bridge'
         option proto 'static'
         option ipaddr '192.168.204.1'
         option netmask '255.255.255.0'
         option ip6assign '60'

config interface 'mesh'
         option mtu '1532'
         option proto 'batadv'
         option mesh 'bat0'
         option routing_algo 'BATMAN_V'

config interface 'bat'
         option ifname 'bat0'
         option proto 'static'
         option mtu '1532'

and my wireless :

config wifi-device  radio0
         option type     mac80211
         option channel  1
         option hwmode   11g
         option path     'pci0000:00/0000:00:00.0'
         option htmode   HT20
         option txpower 22
         option disabled 0

config wifi-iface
         option device   radio0
         option network  mesh
         option mode     adhoc
         option ssid     mesh
         option encryption none
         option bssid 02:CA:FE:CA:CA:42
         option ifnam adhoc0

Best Regards,

Laurent

On 07/05/2016 16:18, Sven Eckelmann wrote:
> On Saturday 07 May 2016 16:08:35 contact wrote:
>> Hello,
>>
>> I just got openwrt 15.05.1 with batman-adv 2016.1 on 3 picostation HP,
>> this time a selected before the build of openwrt batman V option, I can
>> see it when it ask for available routing algo ,
>>
>> root@OpenWrt:/etc/init.d# cat /sys/kernel/debug/batman_adv/routing_algos
>> Available routing algorithms:
>>    * BATMAN_IV
>>    * BATMAN_V
>>
>> but when I do :
>>
>> echo BATMAN_V > /sys/module/batman_adv/parameters/routing_algo
>>
>> It does nothing, still on BATMAN_IV during session and on reboot ?
> This module parameter only controls what routing algorithm is chosen when a
> new batman-adv interface is created. So if you already have created it then
> changing the parameter doesn't do anything to the already existing batman-adv
> interface. Also rebooting a device will reset it either to the default or to
> the one you've explicitly specified during the loading of the modules.
>
> But you seem to use OpenWrt. It allows to specify the routing_algo in
> /etc/config/network and should be applied right before the batman-adv
> interface is created. You just have to make sure that you don't specify
> conflicting things. An example of a simple configuration is:
>
>      config interface 'batnet'
>              option mtu '1532'
>              option proto 'batadv'
>              option mesh 'bat0'
>              option routing_algo 'BATMAN_V'
>
> The wireless configuration would then normally reference this batnet network:
>
>      config wifi-iface 'wmesh'
>              option device 'radio0'
>              option ifname 'adhoc0'
>              option network 'batnet'
>              option mode 'adhoc'
>              option ssid 'mesh'
>              option 'mcast_rate' '18000'
>              option bssid '02:CA:FE:CA:CA:40'
>
> This information was taken from Batman-adv-openwrt-config wiki page [1]
>
> Kind regards,
> 	Sven
>
> [1] https://www.open-mesh.org/projects/batman-adv/wiki/Batman-adv-openwrt-config


^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 16:04   ` contact
@ 2016-05-07 16:28     ` Sven Eckelmann
  2016-05-07 16:42       ` contact
  0 siblings, 1 reply; 17+ messages in thread
From: Sven Eckelmann @ 2016-05-07 16:28 UTC (permalink / raw)
  To: contact; +Cc: b.a.t.m.a.n

[-- Attachment #1: Type: text/plain, Size: 958 bytes --]

On Saturday 07 May 2016 18:04:41 contact wrote:
> Thank you, it is working and it is more clear for me.
> 
> I have switched to V but when I switch on other V nodes, my first node
> reset or freeze, probably a kernel panic. Need to plug a rs232 to be
> able to see what could be the problem.
> I will switch back to IV.

Which version did you build?

https://github.com/openwrt-routing/packages/commit/8dec3dc38b514ed8f1212b51f9f6039af3fb0e04

or 

https://github.com/openwrt-routing/packages/commit/a3cd8a1729779b8a39336a863ba7f97481e81f5c

or a different version/feed? Please make sure that you don't use a legacy feed
together with batman-adv v2016.1 and B.A.T.M.A.N. V. It can only be used when
build directly against the used mac80211 package which is only done in the two
openwrt feeds linked here (and in a devel feed [1] which is building always
against the current master).

Kind regards,
	Sven

[1] https://git.open-mesh.org/openwrt-feed-devel.git

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 16:28     ` Sven Eckelmann
@ 2016-05-07 16:42       ` contact
  2016-05-07 16:44         ` Sven Eckelmann
  0 siblings, 1 reply; 17+ messages in thread
From: contact @ 2016-05-07 16:42 UTC (permalink / raw)
  To: Sven Eckelmann; +Cc: b.a.t.m.a.n

it was the default version present in yesterday openwrt stable 15.05.1

in batman makefile i have :

include $(TOPDIR)/rules.mk

PKG_NAME:=batman-adv

PKG_VERSION:=2016.1
PKG_RELEASE:=1
PKG_MD5SUM:=8c8e449009b4d29512d26ee308960bb5

On 07/05/2016 18:28, Sven Eckelmann wrote:
> On Saturday 07 May 2016 18:04:41 contact wrote:
>> Thank you, it is working and it is more clear for me.
>>
>> I have switched to V but when I switch on other V nodes, my first node
>> reset or freeze, probably a kernel panic. Need to plug a rs232 to be
>> able to see what could be the problem.
>> I will switch back to IV.
> Which version did you build?
>
> https://github.com/openwrt-routing/packages/commit/8dec3dc38b514ed8f1212b51f9f6039af3fb0e04
>
> or
>
> https://github.com/openwrt-routing/packages/commit/a3cd8a1729779b8a39336a863ba7f97481e81f5c
>
> or a different version/feed? Please make sure that you don't use a legacy feed
> together with batman-adv v2016.1 and B.A.T.M.A.N. V. It can only be used when
> build directly against the used mac80211 package which is only done in the two
> openwrt feeds linked here (and in a devel feed [1] which is building always
> against the current master).
>
> Kind regards,
> 	Sven
>
> [1] https://git.open-mesh.org/openwrt-feed-devel.git


^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 16:42       ` contact
@ 2016-05-07 16:44         ` Sven Eckelmann
  2016-05-07 16:51           ` contact
  0 siblings, 1 reply; 17+ messages in thread
From: Sven Eckelmann @ 2016-05-07 16:44 UTC (permalink / raw)
  To: contact; +Cc: b.a.t.m.a.n

[-- Attachment #1: Type: text/plain, Size: 513 bytes --]

On Saturday 07 May 2016 18:42:06 contact wrote:
> it was the default version present in yesterday openwrt stable 15.05.1
> 
> in batman makefile i have :
> 
> include $(TOPDIR)/rules.mk
> 
> PKG_NAME:=batman-adv
> 
> PKG_VERSION:=2016.1
> PKG_RELEASE:=1
> PKG_MD5SUM:=8c8e449009b4d29512d26ee308960bb5

This doesn't say much (and you most likely meant openwrt-routing because 
openwrt itself doesn't provide batman-adv). But and Marek fixed a crash since 
yesterday. Not sure if it is related.

Kind regards,
	Sven

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 16:44         ` Sven Eckelmann
@ 2016-05-07 16:51           ` contact
  2016-05-07 16:53             ` Marek Lindner
  2016-05-07 16:55             ` Sven Eckelmann
  0 siblings, 2 replies; 17+ messages in thread
From: contact @ 2016-05-07 16:51 UTC (permalink / raw)
  To: Sven Eckelmann; +Cc: b.a.t.m.a.n

yes it is in the routing feed I did not change anything from the openwrt 
files.

Ok, so you suggest to use the devel feed with thye last commit ?

Regards,

Laurent

On 07/05/2016 18:44, Sven Eckelmann wrote:
> On Saturday 07 May 2016 18:42:06 contact wrote:
>> it was the default version present in yesterday openwrt stable 15.05.1
>>
>> in batman makefile i have :
>>
>> include $(TOPDIR)/rules.mk
>>
>> PKG_NAME:=batman-adv
>>
>> PKG_VERSION:=2016.1
>> PKG_RELEASE:=1
>> PKG_MD5SUM:=8c8e449009b4d29512d26ee308960bb5
> This doesn't say much (and you most likely meant openwrt-routing because
> openwrt itself doesn't provide batman-adv). But and Marek fixed a crash since
> yesterday. Not sure if it is related.
>
> Kind regards,
> 	Sven


^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 16:51           ` contact
@ 2016-05-07 16:53             ` Marek Lindner
  2016-05-07 16:59               ` contact
  2016-05-07 16:55             ` Sven Eckelmann
  1 sibling, 1 reply; 17+ messages in thread
From: Marek Lindner @ 2016-05-07 16:53 UTC (permalink / raw)
  To: The list for a Better Approach To Mobile Ad-hoc Networking

[-- Attachment #1: Type: text/plain, Size: 303 bytes --]

On Saturday, May 07, 2016 18:51:40 contact wrote:
> yes it is in the routing feed I did not change anything from the openwrt 
> files.
> 
> Ok, so you suggest to use the devel feed with thye last commit ?

Please update your routing feed first. I pushed several stability updates 
today.

Thanks,
Marek

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 473 bytes --]

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 16:51           ` contact
  2016-05-07 16:53             ` Marek Lindner
@ 2016-05-07 16:55             ` Sven Eckelmann
  1 sibling, 0 replies; 17+ messages in thread
From: Sven Eckelmann @ 2016-05-07 16:55 UTC (permalink / raw)
  To: contact; +Cc: b.a.t.m.a.n

[-- Attachment #1: Type: text/plain, Size: 625 bytes --]

On Saturday 07 May 2016 18:51:40 contact wrote:
> yes it is in the routing feed I did not change anything from the openwrt
> files.
> 
> Ok, so you suggest to use the devel feed with thye last commit ?

No, not yet. Maybe you could update openwrt-routing and run:

   make package/batman-adv/clean
   make

to rebuild the the image with a new batman-adv version. You should also check 
that you are using the right openwrt-routing version:

    git -C feeds/routing log

Should be a3cd8a1729779b8a39336a863ba7f97481e81f5c for 15.05 and 
8dec3dc38b514ed8f1212b51f9f6039af3fb0e04 for trunk (at the moment).

Kind regards,
	Sven

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 16:53             ` Marek Lindner
@ 2016-05-07 16:59               ` contact
  2016-05-07 17:01                 ` Marek Lindner
  0 siblings, 1 reply; 17+ messages in thread
From: contact @ 2016-05-07 16:59 UTC (permalink / raw)
  To: b.a.t.m.a.n

I just updated I need to recompile and re-flash my nodes it takes 
sometime, can you check please if all your patches are here ?

user@ubuntuvm:~/openwrt15011/openwrt/scripts$ ./feeds update
Updating feed 'packages' from 
'https://github.com/openwrt/packages.git;for-15.05' ...
Already up-to-date.
Create index file './feeds/packages.index'
Updating feed 'luci' from 
'https://github.com/openwrt/luci.git;for-15.05' ...
Already up-to-date.
Create index file './feeds/luci.index'
Updating feed 'routing' from 
'https://github.com/openwrt-routing/packages.git;for-15.05' ...
remote: Counting objects: 10, done.
remote: Compressing objects: 100% (8/8), done.
remote: Total 10 (delta 2), reused 10 (delta 2), pack-reused 0
Unpacking objects: 100% (10/10), done.
 From https://github.com/openwrt-routing/packages
    16ceff2..a3cd8a1  for-15.05  -> origin/for-15.05
Updating 16ceff2..a3cd8a1
Fast-forward
  ...make-sure-ELP-OGM-orig-MAC-is-updated-on-.patch |  64 ++++++++++++
  ...-adv-Avoid-duplicate-neigh_node-additions.patch |  89 +++++++++++++++++
  ...Avoid-nullptr-derefence-in-batadv_v_neigh.patch |  38 +++++++
  ...an-adv-Fix-refcnt-leak-in-batadv_v_neigh_.patch |  81 +++++++++++++++
  ...Fix-double-neigh_node_put-in-batadv_v_ogm.patch |  40 ++++++++
  ...initialize-ELP-orig-address-on-secondary-.patch | 110 
+++++++++++++++++++++
  6 files changed, 422 insertions(+)
  create mode 100644 
batman-adv/patches/0001-batman-adv-make-sure-ELP-OGM-orig-MAC-is-updated-on-.patch
  create mode 100644 
batman-adv/patches/0002-batman-adv-Avoid-duplicate-neigh_node-additions.patch
  create mode 100644 
batman-adv/patches/0003-batman-adv-Avoid-nullptr-derefence-in-batadv_v_neigh.patch
  create mode 100644 
batman-adv/patches/0004-batman-adv-Fix-refcnt-leak-in-batadv_v_neigh_.patch
  create mode 100644 
batman-adv/patches/0005-batman-adv-Fix-double-neigh_node_put-in-batadv_v_ogm.patch
  create mode 100644 
batman-adv/patches/0006-batman-adv-initialize-ELP-orig-address-on-secondary-.patch
Create index file './feeds/routing.index'
Updating feed 'telephony' from 
'https://github.com/openwrt/telephony.git;for-15.05' ...
Already up-to-date.
Create index file './feeds/telephony.index'
Updating feed 'management' from 
'https://github.com/openwrt-management/packages.git;for-15.05' ...
Already up-to-date.
Create index file './feeds/management.index'


On 07/05/2016 18:53, Marek Lindner wrote:
> On Saturday, May 07, 2016 18:51:40 contact wrote:
>> yes it is in the routing feed I did not change anything from the openwrt
>> files.
>>
>> Ok, so you suggest to use the devel feed with thye last commit ?
> Please update your routing feed first. I pushed several stability updates
> today.
>
> Thanks,
> Marek


^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 16:59               ` contact
@ 2016-05-07 17:01                 ` Marek Lindner
  2016-05-07 17:06                   ` contact
  0 siblings, 1 reply; 17+ messages in thread
From: Marek Lindner @ 2016-05-07 17:01 UTC (permalink / raw)
  To: The list for a Better Approach To Mobile Ad-hoc Networking

[-- Attachment #1: Type: text/plain, Size: 778 bytes --]

On Saturday, May 07, 2016 18:59:14 contact wrote:
> I just updated I need to recompile and re-flash my nodes it takes 
> sometime, can you check please if all your patches are here ?
> 
> [..]
>
> Fast-forward
>   ...make-sure-ELP-OGM-orig-MAC-is-updated-on-.patch |  64 ++++++++++++
>   ...-adv-Avoid-duplicate-neigh_node-additions.patch |  89 +++++++++++++++++
> ...Avoid-nullptr-derefence-in-batadv_v_neigh.patch |  38 +++++++
> ...an-adv-Fix-refcnt-leak-in-batadv_v_neigh_.patch |  81 +++++++++++++++
> ...Fix-double-neigh_node_put-in-batadv_v_ogm.patch |  40 ++++++++
> ...initialize-ELP-orig-address-on-secondary-.patch | 110
> +++++++++++++++++++++

Looks good. However, comparing git revisions (as Sven suggested) is more 
precise than posting such logs.

Cheers,
Marek

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 473 bytes --]

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 17:01                 ` Marek Lindner
@ 2016-05-07 17:06                   ` contact
  2016-05-07 18:09                     ` contact
  0 siblings, 1 reply; 17+ messages in thread
From: contact @ 2016-05-07 17:06 UTC (permalink / raw)
  To: b.a.t.m.a.n

seems ok , I will give a try
(I came today at work only to do some mesh testing on moving robots :-) 
, never have the time during the week ...)

user@ubuntuvm:~/openwrt15011/openwrt$ git -C feeds/routing log
commit a3cd8a1729779b8a39336a863ba7f97481e81f5c
Author: Marek Lindner <mareklindner@neomailbox.ch>
Date:   Sat May 7 20:42:44 2016 +0800

     batman-adv: 2016.1 bugfixes & stability updates

     Signed-off-by: Marek Lindner <mareklindner@neomailbox.ch>

commit 16ceff232dc58aad799bbb3d98915eb5c78ec2af
Author: Axel Neumann <neumann@cgws.de>
Date:   Fri May 6 10:35:47 2016 +0200

     bmx7: bump version (report channel via topology plugin)


On 07/05/2016 19:01, Marek Lindner wrote:
> On Saturday, May 07, 2016 18:59:14 contact wrote:
>> I just updated I need to recompile and re-flash my nodes it takes
>> sometime, can you check please if all your patches are here ?
>>
>> [..]
>>
>> Fast-forward
>>    ...make-sure-ELP-OGM-orig-MAC-is-updated-on-.patch |  64 ++++++++++++
>>    ...-adv-Avoid-duplicate-neigh_node-additions.patch |  89 +++++++++++++++++
>> ...Avoid-nullptr-derefence-in-batadv_v_neigh.patch |  38 +++++++
>> ...an-adv-Fix-refcnt-leak-in-batadv_v_neigh_.patch |  81 +++++++++++++++
>> ...Fix-double-neigh_node_put-in-batadv_v_ogm.patch |  40 ++++++++
>> ...initialize-ELP-orig-address-on-secondary-.patch | 110
>> +++++++++++++++++++++
> Looks good. However, comparing git revisions (as Sven suggested) is more
> precise than posting such logs.
>
> Cheers,
> Marek


^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 17:06                   ` contact
@ 2016-05-07 18:09                     ` contact
  2016-05-07 18:45                       ` contact
  0 siblings, 1 reply; 17+ messages in thread
From: contact @ 2016-05-07 18:09 UTC (permalink / raw)
  To: b.a.t.m.a.n

I flashed 3 nodes (2 fixe and 1 mobile streaming 2mbits of video data) 
,no crash for the moment.

I am making some test to see if all is ok.

Laurent

On 07/05/2016 19:06, contact wrote:
> seems ok , I will give a try
> (I came today at work only to do some mesh testing on moving robots 
> :-) , never have the time during the week ...)
>
> user@ubuntuvm:~/openwrt15011/openwrt$ git -C feeds/routing log
> commit a3cd8a1729779b8a39336a863ba7f97481e81f5c
> Author: Marek Lindner <mareklindner@neomailbox.ch>
> Date:   Sat May 7 20:42:44 2016 +0800
>
>     batman-adv: 2016.1 bugfixes & stability updates
>
>     Signed-off-by: Marek Lindner <mareklindner@neomailbox.ch>
>
> commit 16ceff232dc58aad799bbb3d98915eb5c78ec2af
> Author: Axel Neumann <neumann@cgws.de>
> Date:   Fri May 6 10:35:47 2016 +0200
>
>     bmx7: bump version (report channel via topology plugin)
>
>
> On 07/05/2016 19:01, Marek Lindner wrote:
>> On Saturday, May 07, 2016 18:59:14 contact wrote:
>>> I just updated I need to recompile and re-flash my nodes it takes
>>> sometime, can you check please if all your patches are here ?
>>>
>>> [..]
>>>
>>> Fast-forward
>>>    ...make-sure-ELP-OGM-orig-MAC-is-updated-on-.patch |  64 
>>> ++++++++++++
>>>    ...-adv-Avoid-duplicate-neigh_node-additions.patch |  89 
>>> +++++++++++++++++
>>> ...Avoid-nullptr-derefence-in-batadv_v_neigh.patch |  38 +++++++
>>> ...an-adv-Fix-refcnt-leak-in-batadv_v_neigh_.patch |  81 
>>> +++++++++++++++
>>> ...Fix-double-neigh_node_put-in-batadv_v_ogm.patch |  40 ++++++++
>>> ...initialize-ELP-orig-address-on-secondary-.patch | 110
>>> +++++++++++++++++++++
>> Looks good. However, comparing git revisions (as Sven suggested) is more
>> precise than posting such logs.
>>
>> Cheers,
>> Marek
>
>


^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 18:09                     ` contact
@ 2016-05-07 18:45                       ` contact
  2016-05-07 22:40                         ` Marek Lindner
  0 siblings, 1 reply; 17+ messages in thread
From: contact @ 2016-05-07 18:45 UTC (permalink / raw)
  To: b.a.t.m.a.n

it seems table, I saw a really fast dynamic route creation. With batman 
IV the route took sometime 1 min to come and it was really noisy, i 
tried many settings,
here with V it is good, when I move toward a node it took less than 1 
sec to create a new route and the video stream is not interrupted.

Sometime I loose the route it become a little bit noisy when I stop 
moving  but here I suspect a wifi problem, need to change my channel.

I will make more test by adding other nodes on the path of the robot and 
see how routing is done.

Thank you all :-)

On 07/05/2016 20:09, contact wrote:
> I flashed 3 nodes (2 fixe and 1 mobile streaming 2mbits of video data) 
> ,no crash for the moment.
>
> I am making some test to see if all is ok.
>
> Laurent
>
> On 07/05/2016 19:06, contact wrote:
>> seems ok , I will give a try
>> (I came today at work only to do some mesh testing on moving robots 
>> :-) , never have the time during the week ...)
>>
>> user@ubuntuvm:~/openwrt15011/openwrt$ git -C feeds/routing log
>> commit a3cd8a1729779b8a39336a863ba7f97481e81f5c
>> Author: Marek Lindner <mareklindner@neomailbox.ch>
>> Date:   Sat May 7 20:42:44 2016 +0800
>>
>>     batman-adv: 2016.1 bugfixes & stability updates
>>
>>     Signed-off-by: Marek Lindner <mareklindner@neomailbox.ch>
>>
>> commit 16ceff232dc58aad799bbb3d98915eb5c78ec2af
>> Author: Axel Neumann <neumann@cgws.de>
>> Date:   Fri May 6 10:35:47 2016 +0200
>>
>>     bmx7: bump version (report channel via topology plugin)
>>
>>
>> On 07/05/2016 19:01, Marek Lindner wrote:
>>> On Saturday, May 07, 2016 18:59:14 contact wrote:
>>>> I just updated I need to recompile and re-flash my nodes it takes
>>>> sometime, can you check please if all your patches are here ?
>>>>
>>>> [..]
>>>>
>>>> Fast-forward
>>>>    ...make-sure-ELP-OGM-orig-MAC-is-updated-on-.patch |  64 
>>>> ++++++++++++
>>>>    ...-adv-Avoid-duplicate-neigh_node-additions.patch |  89 
>>>> +++++++++++++++++
>>>> ...Avoid-nullptr-derefence-in-batadv_v_neigh.patch |  38 +++++++
>>>> ...an-adv-Fix-refcnt-leak-in-batadv_v_neigh_.patch |  81 
>>>> +++++++++++++++
>>>> ...Fix-double-neigh_node_put-in-batadv_v_ogm.patch |  40 ++++++++
>>>> ...initialize-ELP-orig-address-on-secondary-.patch | 110
>>>> +++++++++++++++++++++
>>> Looks good. However, comparing git revisions (as Sven suggested) is 
>>> more
>>> precise than posting such logs.
>>>
>>> Cheers,
>>> Marek
>>
>>
>
>


^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 18:45                       ` contact
@ 2016-05-07 22:40                         ` Marek Lindner
  0 siblings, 0 replies; 17+ messages in thread
From: Marek Lindner @ 2016-05-07 22:40 UTC (permalink / raw)
  To: The list for a Better Approach To Mobile Ad-hoc Networking

[-- Attachment #1: Type: text/plain, Size: 888 bytes --]

On Saturday, May 07, 2016 20:45:27 contact wrote:
> it seems table, I saw a really fast dynamic route creation. With batman 
> IV the route took sometime 1 min to come and it was really noisy, i 
> tried many settings,
> here with V it is good, when I move toward a node it took less than 1 
> sec to create a new route and the video stream is not interrupted.
> 
> Sometime I loose the route it become a little bit noisy when I stop 
> moving  but here I suspect a wifi problem, need to change my channel.
> 
> I will make more test by adding other nodes on the path of the robot and 
> see how routing is done.

Thanks for the feedback! By all means, share more results (good or bad) once 
available!

Note that the gateway selection feature isn't working with BATMAN V yet. 
Antonio has posted a couple of patches a few days ago but these require some 
further massage.

Cheers,
Marek

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 473 bytes --]

^ permalink raw reply	[flat|nested] 17+ messages in thread

* Re: [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 12:29   ` [B.A.T.M.A.N.] no able to switch routing algo to V ? contact
@ 2016-05-07 13:14     ` Sven Eckelmann
  0 siblings, 0 replies; 17+ messages in thread
From: Sven Eckelmann @ 2016-05-07 13:14 UTC (permalink / raw)
  To: b.a.t.m.a.n

[-- Attachment #1: Type: text/plain, Size: 615 bytes --]

On Saturday 07 May 2016 14:29:17 contact wrote:
> I just got openwrt 15.05.1 with batman-adv 2016.1 on 3 picostation HP,
> this time a selected before the build of openwrt batman V option, I can
> see it when it ask for available routing algo ,
> 
> root@OpenWrt:/etc/init.d# cat /sys/kernel/debug/batman_adv/routing_algos
> Available routing algorithms:
>   * BATMAN_IV
>   * BATMAN_V
> 
> but when I do :
> 
> echo BATMAN_V > /sys/module/batman_adv/parameters/routing_algo
> 
> It does nothing, still on BATMAN_IV during session and on reboot ?

Please don't hijack other (unrelated) threads,

Kind regards,
	Sven

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

^ permalink raw reply	[flat|nested] 17+ messages in thread

* [B.A.T.M.A.N.] no able to switch routing algo to V ?
  2016-05-07 12:07 ` Marek Lindner
@ 2016-05-07 12:29   ` contact
  2016-05-07 13:14     ` Sven Eckelmann
  0 siblings, 1 reply; 17+ messages in thread
From: contact @ 2016-05-07 12:29 UTC (permalink / raw)
  To: The list for a Better Approach To Mobile Ad-hoc Networking

Hello,

I just got openwrt 15.05.1 with batman-adv 2016.1 on 3 picostation HP, 
this time a selected before the build of openwrt batman V option, I can 
see it when it ask for available routing algo ,

root@OpenWrt:/etc/init.d# cat /sys/kernel/debug/batman_adv/routing_algos
Available routing algorithms:
  * BATMAN_IV
  * BATMAN_V

but when I do :

echo BATMAN_V > /sys/module/batman_adv/parameters/routing_algo

It does nothing, still on BATMAN_IV during session and on reboot ?

Best Regards,

Laurent



^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2016-05-07 22:40 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-05-07 14:08 [B.A.T.M.A.N.] no able to switch routing algo to V ? contact
2016-05-07 14:18 ` Sven Eckelmann
2016-05-07 16:04   ` contact
2016-05-07 16:28     ` Sven Eckelmann
2016-05-07 16:42       ` contact
2016-05-07 16:44         ` Sven Eckelmann
2016-05-07 16:51           ` contact
2016-05-07 16:53             ` Marek Lindner
2016-05-07 16:59               ` contact
2016-05-07 17:01                 ` Marek Lindner
2016-05-07 17:06                   ` contact
2016-05-07 18:09                     ` contact
2016-05-07 18:45                       ` contact
2016-05-07 22:40                         ` Marek Lindner
2016-05-07 16:55             ` Sven Eckelmann
  -- strict thread matches above, loose matches on Subject: below --
2016-05-06 20:27 [B.A.T.M.A.N.] [PATCH maint] batman-adv: Fix double neigh_node_put in batadv_v_ogm_route_update Sven Eckelmann
2016-05-07 12:07 ` Marek Lindner
2016-05-07 12:29   ` [B.A.T.M.A.N.] no able to switch routing algo to V ? contact
2016-05-07 13:14     ` Sven Eckelmann

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.