All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [RFC v3 0/3]  Implement a warning_report function
@ 2017-07-05 17:36 Alistair Francis
  2017-07-05 17:36 ` [Qemu-devel] [RFC v3 1/3] util/qemu-error: Rename error_print_loc() to be more generic Alistair Francis
                   ` (2 more replies)
  0 siblings, 3 replies; 16+ messages in thread
From: Alistair Francis @ 2017-07-05 17:36 UTC (permalink / raw)
  To: qemu-devel; +Cc: alistair.francis, alistair23, philippe, berrange, armbru

QEMU currently has a standard method to report errors with
error_repot(). This ensure a sane and standard format when printing
errors. This series is attempting to extend this functionality for
warnings and information as well.

At the moment only one error is being converted, I wanted to get the
implementation nailed down a little bit before I started converting
others.

This patch renames error_print_loc() function to be more clear, but I
didn't bother renaming the others. It seems silly to change
error_printf() to error_warning_printf() and printf is already taken so
I just left it as is.

I also didn't change the current error output as that would probably
break backwards compatibilty for anyone who is parsing logs.

RFCv3:
 - Use more detailed enum and function names
 - Add wrapper functions for the info and warning reporting
RFCv2:
 - Use enums for ERROR, WARN and INFO with a generic report() function
   instead of adding new functions

Alistair Francis (3):
  util/qemu-error: Rename error_print_loc() to be more generic
  qemu-error: Implement a more generic error reporting
  char-socket: Report TCP socket waiting as information

 chardev/char-socket.c       |  4 +--
 include/qemu/error-report.h | 16 +++++++++
 scripts/checkpatch.pl       |  8 ++++-
 util/qemu-error.c           | 84 ++++++++++++++++++++++++++++++++++++++++++---
 4 files changed, 104 insertions(+), 8 deletions(-)

-- 
2.11.0

^ permalink raw reply	[flat|nested] 16+ messages in thread

end of thread, other threads:[~2017-07-06 18:45 UTC | newest]

Thread overview: 16+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-07-05 17:36 [Qemu-devel] [RFC v3 0/3] Implement a warning_report function Alistair Francis
2017-07-05 17:36 ` [Qemu-devel] [RFC v3 1/3] util/qemu-error: Rename error_print_loc() to be more generic Alistair Francis
2017-07-06  2:36   ` Thomas Huth
2017-07-05 17:36 ` [Qemu-devel] [RFC v3 2/3] qemu-error: Implement a more generic error reporting Alistair Francis
2017-07-06  2:42   ` Thomas Huth
2017-07-06  6:15   ` Markus Armbruster
2017-07-06  8:07     ` Daniel P. Berrange
2017-07-06 11:27       ` Markus Armbruster
2017-07-06 11:45         ` Daniel P. Berrange
2017-07-06 12:20           ` Markus Armbruster
2017-07-06 13:10             ` Daniel P. Berrange
2017-07-06 14:44               ` Markus Armbruster
2017-07-06 18:45                 ` Alistair Francis
2017-07-05 17:36 ` [Qemu-devel] [RFC v3 3/3] char-socket: Report TCP socket waiting as information Alistair Francis
2017-07-06  2:46   ` Thomas Huth
2017-07-06  6:18     ` Markus Armbruster

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.