All of lore.kernel.org
 help / color / mirror / Atom feed
From: Chris Moore <moore@free.fr>
To: Arushi Singhal <arushisinghal19971997@gmail.com>,
	outreachy-kernel@googlegroups.com
Cc: linux-media@vger.kernel.org, gregkh@linuxfoundation.org,
	mchehab@kernel.org, devel@driverdev.osuosl.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 0/3] staging: media: Replace a bit shift.
Date: Thu, 23 Mar 2017 07:46:30 +0100	[thread overview]
Message-ID: <1cdeae57-73b1-c62c-da9a-b9e75d2f2ab1@free.fr> (raw)
In-Reply-To: <20170322042609.23525-1-arushisinghal19971997@gmail.com>

Hi,

Le 22/03/2017 à 05:26, Arushi Singhal a écrit :
> Replace a bit shift by a use of BIT in media driver.
>
> Arushi Singhal (3):
>    staging: media: Replace a bit shift by a use of BIT.
>    staging: media: davinci_vpfe: Replace a bit shift by a use of BIT.
>    staging: media: omap4iss: Replace a bit shift by a use of BIT.
>
>   .../media/atomisp/pci/atomisp2/atomisp_cmd.c       | 12 +++++-----
>   .../atomisp/pci/atomisp2/atomisp_compat_css20.c    |  6 ++---
>   .../media/atomisp/pci/atomisp2/atomisp_drvfs.c     |  6 ++---
>   .../media/atomisp/pci/atomisp2/atomisp_v4l2.c      | 18 +++++++--------
>   .../media/atomisp/pci/atomisp2/hmm/hmm_bo.c        |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_ipipe.c   |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_ipipeif.c |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_isif.c    | 26 +++++++++++-----------
>   drivers/staging/media/davinci_vpfe/dm365_resizer.c |  6 ++---
>   drivers/staging/media/omap4iss/iss_csi2.c          |  2 +-
>   drivers/staging/media/omap4iss/iss_ipipe.c         |  2 +-
>   drivers/staging/media/omap4iss/iss_ipipeif.c       |  2 +-
>   drivers/staging/media/omap4iss/iss_resizer.c       |  2 +-
>   13 files changed, 44 insertions(+), 44 deletions(-)
>

Most of these replacements add redundant parentheses around the BIT macro.
IMHO this makes the code less readable.
So I suggest (BIT(c)) -> BIT(c).

Cheers,
Chris

WARNING: multiple messages have this Message-ID (diff)
From: Chris Moore <moore@free.fr>
To: Arushi Singhal <arushisinghal19971997@gmail.com>,
	outreachy-kernel@googlegroups.com
Cc: linux-media@vger.kernel.org, gregkh@linuxfoundation.org,
	mchehab@kernel.org, devel@driverdev.osuosl.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 0/3] staging: media: Replace a bit shift.
Date: Thu, 23 Mar 2017 07:46:30 +0100	[thread overview]
Message-ID: <1cdeae57-73b1-c62c-da9a-b9e75d2f2ab1@free.fr> (raw)
In-Reply-To: <20170322042609.23525-1-arushisinghal19971997@gmail.com>

Hi,

Le 22/03/2017 � 05:26, Arushi Singhal a �crit :
> Replace a bit shift by a use of BIT in media driver.
>
> Arushi Singhal (3):
>    staging: media: Replace a bit shift by a use of BIT.
>    staging: media: davinci_vpfe: Replace a bit shift by a use of BIT.
>    staging: media: omap4iss: Replace a bit shift by a use of BIT.
>
>   .../media/atomisp/pci/atomisp2/atomisp_cmd.c       | 12 +++++-----
>   .../atomisp/pci/atomisp2/atomisp_compat_css20.c    |  6 ++---
>   .../media/atomisp/pci/atomisp2/atomisp_drvfs.c     |  6 ++---
>   .../media/atomisp/pci/atomisp2/atomisp_v4l2.c      | 18 +++++++--------
>   .../media/atomisp/pci/atomisp2/hmm/hmm_bo.c        |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_ipipe.c   |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_ipipeif.c |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_isif.c    | 26 +++++++++++-----------
>   drivers/staging/media/davinci_vpfe/dm365_resizer.c |  6 ++---
>   drivers/staging/media/omap4iss/iss_csi2.c          |  2 +-
>   drivers/staging/media/omap4iss/iss_ipipe.c         |  2 +-
>   drivers/staging/media/omap4iss/iss_ipipeif.c       |  2 +-
>   drivers/staging/media/omap4iss/iss_resizer.c       |  2 +-
>   13 files changed, 44 insertions(+), 44 deletions(-)
>

Most of these replacements add redundant parentheses around the BIT macro.
IMHO this makes the code less readable.
So I suggest (BIT(c)) -> BIT(c).

Cheers,
Chris



  parent reply	other threads:[~2017-03-23  8:04 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-03-22  4:26 [PATCH 0/3] staging: media: Replace a bit shift Arushi Singhal
2017-03-22  4:26 ` [PATCH 1/3] staging: media: Replace a bit shift by a use of BIT Arushi Singhal
2017-03-22  4:26 ` [PATCH 2/3] staging: media: davinci_vpfe: " Arushi Singhal
2017-03-22  4:26 ` [PATCH 3/3] staging: media: omap4iss: " Arushi Singhal
2017-03-23  6:46 ` Chris Moore [this message]
2017-03-23  6:46   ` [PATCH 0/3] staging: media: Replace a bit shift Chris Moore

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1cdeae57-73b1-c62c-da9a-b9e75d2f2ab1@free.fr \
    --to=moore@free.fr \
    --cc=arushisinghal19971997@gmail.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=outreachy-kernel@googlegroups.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.