All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mel Gorman <mgorman@suse.de>
To: Peter Zijlstra <peterz@infradead.org>
Cc: Linux-MM <linux-mm@kvack.org>, Rik van Riel <riel@redhat.com>,
	Johannes Weiner <hannes@cmpxchg.org>,
	Dave Hansen <dave.hansen@intel.com>,
	Andi Kleen <andi@firstfloor.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 3/4] mm: Gather more PFNs before sending a TLB to flush unmapped pages
Date: Wed, 15 Apr 2015 13:56:20 +0100	[thread overview]
Message-ID: <20150415125620.GE14842@suse.de> (raw)
In-Reply-To: <20150415122440.GV5029@twins.programming.kicks-ass.net>

On Wed, Apr 15, 2015 at 02:24:40PM +0200, Peter Zijlstra wrote:
> On Wed, Apr 15, 2015 at 01:15:53PM +0100, Mel Gorman wrote:
> > On Wed, Apr 15, 2015 at 01:42:20PM +0200, Peter Zijlstra wrote:
> > > On Wed, Apr 15, 2015 at 11:42:55AM +0100, Mel Gorman wrote:
> > > > +/*
> > > > + * Use a page to store as many PFNs as possible for batch unmapping. Adjusting
> > > > + * this trades memory usage for number of IPIs sent
> > > > + */
> > > > +#define BATCH_TLBFLUSH_SIZE \
> > > > +	((PAGE_SIZE - sizeof(struct cpumask) - sizeof(unsigned long)) / sizeof(unsigned long))
> > > >  
> > > >  /* Track pages that require TLB flushes */
> > > >  struct unmap_batch {
> > > > +	/* Update BATCH_TLBFLUSH_SIZE when adjusting this structure */
> > > >  	struct cpumask cpumask;
> > > >  	unsigned long nr_pages;
> > > >  	unsigned long pfns[BATCH_TLBFLUSH_SIZE];
> > > 
> > > The alternative is something like:
> > > 
> > > struct unmap_batch {
> > > 	struct cpumask cpumask;
> > > 	unsigned long nr_pages;
> > > 	unsigned long pfnsp[0];
> > > };
> > > 
> > > #define BATCH_TLBFLUSH_SIZE ((PAGE_SIZE - sizeof(struct unmap_batch)) / sizeof(unsigned long))
> > > 
> > > and unconditionally allocate 1 page. This saves you from having to worry
> > > about the layout of struct unmap_batch.
> > 
> > True but then I need to calculate the size of the real array so it's
> > similar in terms of readability. The plus would be that if the structure
> > changes then the size calculation is not changed but then the allocation
> > site and the size calculation must be kept in sync. I did not see a clear
> > win of one approach over the other so flipped a coin.
> 
> I'm not seeing your argument, in both your an mine variant the
> allocation is hard assumed to be 1 page, right?

No, in mine I can use sizeof to "discover" it even though the answer is
always a page.

> But even then, what's
> more likely to change, extra members in our struct or growing the
> allocation to two (or more) pages?

Either approach requires careful treatment. I can switch to your method
in V2 because to me, they're equivalent in terms of readability and
maintenance.

-- 
Mel Gorman
SUSE Labs

WARNING: multiple messages have this Message-ID (diff)
From: Mel Gorman <mgorman@suse.de>
To: Peter Zijlstra <peterz@infradead.org>
Cc: Linux-MM <linux-mm@kvack.org>, Rik van Riel <riel@redhat.com>,
	Johannes Weiner <hannes@cmpxchg.org>,
	Dave Hansen <dave.hansen@intel.com>,
	Andi Kleen <andi@firstfloor.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 3/4] mm: Gather more PFNs before sending a TLB to flush unmapped pages
Date: Wed, 15 Apr 2015 13:56:20 +0100	[thread overview]
Message-ID: <20150415125620.GE14842@suse.de> (raw)
In-Reply-To: <20150415122440.GV5029@twins.programming.kicks-ass.net>

On Wed, Apr 15, 2015 at 02:24:40PM +0200, Peter Zijlstra wrote:
> On Wed, Apr 15, 2015 at 01:15:53PM +0100, Mel Gorman wrote:
> > On Wed, Apr 15, 2015 at 01:42:20PM +0200, Peter Zijlstra wrote:
> > > On Wed, Apr 15, 2015 at 11:42:55AM +0100, Mel Gorman wrote:
> > > > +/*
> > > > + * Use a page to store as many PFNs as possible for batch unmapping. Adjusting
> > > > + * this trades memory usage for number of IPIs sent
> > > > + */
> > > > +#define BATCH_TLBFLUSH_SIZE \
> > > > +	((PAGE_SIZE - sizeof(struct cpumask) - sizeof(unsigned long)) / sizeof(unsigned long))
> > > >  
> > > >  /* Track pages that require TLB flushes */
> > > >  struct unmap_batch {
> > > > +	/* Update BATCH_TLBFLUSH_SIZE when adjusting this structure */
> > > >  	struct cpumask cpumask;
> > > >  	unsigned long nr_pages;
> > > >  	unsigned long pfns[BATCH_TLBFLUSH_SIZE];
> > > 
> > > The alternative is something like:
> > > 
> > > struct unmap_batch {
> > > 	struct cpumask cpumask;
> > > 	unsigned long nr_pages;
> > > 	unsigned long pfnsp[0];
> > > };
> > > 
> > > #define BATCH_TLBFLUSH_SIZE ((PAGE_SIZE - sizeof(struct unmap_batch)) / sizeof(unsigned long))
> > > 
> > > and unconditionally allocate 1 page. This saves you from having to worry
> > > about the layout of struct unmap_batch.
> > 
> > True but then I need to calculate the size of the real array so it's
> > similar in terms of readability. The plus would be that if the structure
> > changes then the size calculation is not changed but then the allocation
> > site and the size calculation must be kept in sync. I did not see a clear
> > win of one approach over the other so flipped a coin.
> 
> I'm not seeing your argument, in both your an mine variant the
> allocation is hard assumed to be 1 page, right?

No, in mine I can use sizeof to "discover" it even though the answer is
always a page.

> But even then, what's
> more likely to change, extra members in our struct or growing the
> allocation to two (or more) pages?

Either approach requires careful treatment. I can switch to your method
in V2 because to me, they're equivalent in terms of readability and
maintenance.

-- 
Mel Gorman
SUSE Labs

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>

  reply	other threads:[~2015-04-15 12:56 UTC|newest]

Thread overview: 50+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-04-15 10:42 [RFC PATCH 0/4] TLB flush multiple pages with a single IPI Mel Gorman
2015-04-15 10:42 ` Mel Gorman
2015-04-15 10:42 ` [PATCH 1/4] x86, mm: Trace when an IPI is about to be sent Mel Gorman
2015-04-15 10:42   ` Mel Gorman
2015-04-15 10:42 ` [PATCH 2/4] mm: Send a single IPI to TLB flush multiple pages when unmapping Mel Gorman
2015-04-15 10:42   ` Mel Gorman
2015-04-15 21:03   ` Rik van Riel
2015-04-15 21:03     ` Rik van Riel
2015-04-15 21:16     ` Hugh Dickins
2015-04-15 21:16       ` Hugh Dickins
2015-04-15 21:28       ` Mel Gorman
2015-04-15 21:28         ` Mel Gorman
2015-04-15 21:32         ` Dave Hansen
2015-04-15 21:32           ` Dave Hansen
2015-04-16  6:38         ` Minchan Kim
2015-04-16  6:38           ` Minchan Kim
2015-04-16  8:07           ` Mel Gorman
2015-04-16  8:07             ` Mel Gorman
2015-04-16  8:29             ` Minchan Kim
2015-04-16  8:29               ` Minchan Kim
2015-04-16  9:19               ` Mel Gorman
2015-04-16  9:19                 ` Mel Gorman
2015-04-16 23:30                 ` Minchan Kim
2015-04-16 23:30                   ` Minchan Kim
2015-04-15 22:20   ` Andi Kleen
2015-04-15 22:20     ` Andi Kleen
2015-04-15 22:53     ` Mel Gorman
2015-04-15 22:53       ` Mel Gorman
2015-04-15 10:42 ` [PATCH 3/4] mm: Gather more PFNs before sending a TLB to flush unmapped pages Mel Gorman
2015-04-15 10:42   ` Mel Gorman
2015-04-15 11:42   ` Peter Zijlstra
2015-04-15 11:42     ` Peter Zijlstra
2015-04-15 12:15     ` Mel Gorman
2015-04-15 12:15       ` Mel Gorman
2015-04-15 12:24       ` Peter Zijlstra
2015-04-15 12:24         ` Peter Zijlstra
2015-04-15 12:56         ` Mel Gorman [this message]
2015-04-15 12:56           ` Mel Gorman
2015-04-15 10:42 ` [PATCH 4/4] mm: migrate: Batch TLB flushing when unmapping pages for migration Mel Gorman
2015-04-15 10:42   ` Mel Gorman
2015-04-15 21:06   ` Hugh Dickins
2015-04-15 21:06     ` Hugh Dickins
2015-04-15 21:44     ` Mel Gorman
2015-04-15 21:44       ` Mel Gorman
2015-04-15 23:50       ` Hugh Dickins
2015-04-15 23:50         ` Hugh Dickins
2015-04-16 10:22 [RFC PATCH 0/4] TLB flush multiple pages with a single IPI v2 Mel Gorman
2015-04-16 10:22 ` [PATCH 3/4] mm: Gather more PFNs before sending a TLB to flush unmapped pages Mel Gorman
2015-04-16 10:22   ` Mel Gorman
2015-04-16 16:00   ` Rik van Riel
2015-04-16 16:00     ` Rik van Riel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150415125620.GE14842@suse.de \
    --to=mgorman@suse.de \
    --cc=andi@firstfloor.org \
    --cc=dave.hansen@intel.com \
    --cc=hannes@cmpxchg.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=peterz@infradead.org \
    --cc=riel@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.