All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/4] x86: Untangle and standardize x86 system call entry point names
@ 2015-06-08  8:34 Ingo Molnar
  2015-06-08  8:34 ` [PATCH 1/4] x86/asm/entry: Rename compat syscall entry points Ingo Molnar
                   ` (3 more replies)
  0 siblings, 4 replies; 29+ messages in thread
From: Ingo Molnar @ 2015-06-08  8:34 UTC (permalink / raw)
  To: linux-kernel
  Cc: Andy Lutomirski, Denys Vlasenko, Brian Gerst, Peter Zijlstra,
	Borislav Petkov, H. Peter Anvin, Linus Torvalds, Oleg Nesterov,
	Thomas Gleixner

This series does the following renames:

        system_call (32)             -> entry_INT80_32
        system_call (64)             -> entry_SYSCALL_64
        ia32_cstar_target            -> entry_SYSCALL_compat
        ia32_syscall                 -> entry_INT80_compat
        ia32_sysenter_target (32)    -> entry_SYSENTER_32
        ia32_sysenter_target (64)    -> entry_SYSENTER_compat

As can be seen from that list alone, the naming was a mess:

  - system_call() had two distinct uses, depending on
    bitness: INT80 entry on 32-bit, SYSCALL entry on 64-bit.

  - ia32_sysenter_target with its different semantics on
    32-bit and compat kernels had the same name as well.

  - 'ia32' in a generic x86 name makes no sense, neither does 'cstar'.

It was so confusing that even the x86 documentation got it wrong:

   "- ia32_syscall, ia32_sysenter: syscall and sysenter from 32-bit"

In reality ia32_syscall is an INT80 entry.

The new naming scheme is simple, coherent and unambiguous in any context:

	entry_MNEMONIC_qualifier

where:

  - 'MNEMONIC'  is one of INT80, SYSCALL or SYSENTER
  - 'qualifier' is one of _32, _64 or _compat.

Plus while at it I've done some cleanups to the native 32-bit entry code
as well.

Thanks,

    Ingo

====================================>
Ingo Molnar (4):
  x86/asm/entry: Rename compat syscall entry points
  x86/asm/entry: Untangle 'ia32_sysenter_target' into two entry points: entry_SYSENTER_32 and entry_SYSENTER_compat
  x86/asm/entry: Untangle 'system_call' into two entry points: entry_SYSCALL_64 and entry_INT80_32
  x86/asm/entry/32: Clean up entry_32.S

 Documentation/x86/entry_64.txt   |    4 +-
 arch/x86/entry/entry_32.S        | 1149 +++++++++++++++++++++++++++++-----------------------------
 arch/x86/entry/entry_64.S        |   10 +-
 arch/x86/entry/entry_64_compat.S |   12 +-
 arch/x86/entry/syscall_32.c      |    6 +-
 arch/x86/include/asm/proto.h     |   10 +-
 arch/x86/kernel/asm-offsets_64.c |    2 +-
 arch/x86/kernel/cpu/common.c     |    8 +-
 arch/x86/kernel/traps.c          |    7 +-
 arch/x86/xen/xen-asm_64.S        |    6 +-
 10 files changed, 607 insertions(+), 607 deletions(-)

-- 
2.1.4


^ permalink raw reply	[flat|nested] 29+ messages in thread

end of thread, other threads:[~2015-07-10 15:37 UTC | newest]

Thread overview: 29+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-06-08  8:34 [PATCH 0/4] x86: Untangle and standardize x86 system call entry point names Ingo Molnar
2015-06-08  8:34 ` [PATCH 1/4] x86/asm/entry: Rename compat syscall entry points Ingo Molnar
2015-06-08  8:47   ` Borislav Petkov
2015-06-08  8:34 ` [PATCH 2/4] x86/asm/entry: Untangle 'ia32_sysenter_target' into two entry points: entry_SYSENTER_32 and entry_SYSENTER_compat Ingo Molnar
2015-06-09  0:13   ` Andy Lutomirski
2015-06-09  9:33     ` Ingo Molnar
2015-06-09 16:33       ` Andy Lutomirski
2015-06-08  8:35 ` [PATCH 3/4] x86/asm/entry: Untangle 'system_call' into two entry points: entry_SYSCALL_64 and entry_INT80_32 Ingo Molnar
2015-06-08  8:35 ` [PATCH 4/4] x86/asm/entry/32: Clean up entry_32.S Ingo Molnar
2015-06-08 13:14   ` Denys Vlasenko
2015-06-08 18:51     ` [PATCH] x86/asm/entry/64: Clean up entry_64.S Ingo Molnar
2015-07-06 15:00       ` Sasha Levin
2015-07-06 16:07         ` Ingo Molnar
2015-07-06 16:19           ` Sasha Levin
2015-07-06 16:23             ` Ingo Molnar
2015-07-06 16:36               ` Sasha Levin
2015-07-06 16:43                 ` Ingo Molnar
2015-07-06 17:02                   ` Sasha Levin
2015-07-06 17:20         ` Andy Lutomirski
2015-07-06 17:34           ` Sasha Levin
2015-07-06 17:41             ` Ingo Molnar
2015-07-06 18:35               ` Andy Lutomirski
2015-07-06 18:39                 ` Andy Lutomirski
2015-07-08 15:39                   ` Sasha Levin
2015-07-07  7:01                 ` Ingo Molnar
2015-07-09  0:59         ` Andy Lutomirski
2015-07-10 13:27           ` Sasha Levin
2015-07-10 15:26           ` Andrey Ryabinin
2015-07-10 15:36             ` Andy Lutomirski

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.