All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 00/21] drm/i915: Organize most GPU features by platform
@ 2016-07-28 19:12 Carlos Santa
  2016-07-28 19:12 ` [PATCH v2 01/21] drm/i915: Move HAS_PSR definition to platform struct definition Carlos Santa
                   ` (22 more replies)
  0 siblings, 23 replies; 33+ messages in thread
From: Carlos Santa @ 2016-07-28 19:12 UTC (permalink / raw)
  To: intel-gfx

This patchset includes the following changes:

 - organize most GPU features so that they are easy to group by platforms.
   It seems some of the ground work was already done for Gen7 features.
   Reuse some of that work for the rest of the Gen platforms (GEN6, GEN5, GEN4, GEN3
   and GEN2).

 - make most of these GPU features now a device_info flag also based on
   previous work done by others. The idea is here is to have a central place where
   to add new features and also now it should be possible to see what the supported 
   features are for a given platform by dumping of the struct definitions.
   The list of the features that were converted to a device_info flag include: PSR,
   RUNTIME_PM, CORE_RING_FREQ, CSR, GUC, RESOURCE_STREAMER, RC6,
   RC6p, DP_MST, GMBUS_IRQ, FW_BLC, HW_CONTEXTS, LOGICAL_RING_CONTEXTS, L3_DPF, and
   GMCH_DISPLAY.

- Changes since v1, thanks to Rodrigo and others for the comments

- Patch 1: "drm/i915: Make GEN7_FEATURES inherit from GEN6"
  - Avoid further code duplication by making GEN7 inherit from GEN6
  - Disabled RPM for IVB and added a FIXME comment

- Patch 2: "drm/i915: Move HAS_CSR definition to platform definition"
  - Spreads out the features instead of creating a new define for GEN9_FEATURES

- Patch 3: "drm/i915: Move HAS_GUC_UCODE definition to platform definition"
  - Kill off this patch, not needed

- Patch 4: "drm/i915: Move HAS_GUC_SCHED definition to platform definition"
  - Kill off this patch, not needed

- Patch 5: "drm/i915: Move HAS_RC6p definition to platform definition"
  - Eliminate the need of creating yet another macro for IVB_FEATURES, simply list
    the features by platform

- Patch 6: "drm/i915: Move HAS_DP_MST definition to platform definition"
  - Now it correctly list the platforms that support this feature

- Patch 7: "drm/i915: Make GEN6_FEATURES inherit from GEN5"
  - Avoid further code dup by making GEN6 inherit from GEN5

- Patch 8: "drm/i915: Introduce GEN4_FEATURES for device info"
  - Introduce GEN4 features, but kill off creating new sub categories for
    GEN4 platforms.

- Patch 9: "drm/i915: Introduce GEN3_FEATURES for device info"
  - Introduce GEN3 features, but kill off creating new sub categories for
    GEN4 platforms.

- Patch 10: "drm/i915: Introduce GEN2_FEATURES for device info"
  - Introduce GEN2 features, fix a minor bug with num_pipes

- Patch 10: "drm/i915: Move HAS_L3_DPF definition to platform definition"
  - Fix which platforms actually support this feature

Carlos Santa (21):
  drm/i915: Move HAS_PSR definition to platform struct definition
  drm/i915: Introduce GEN6_FEATURES for device info
  drm/i915: Move HAS_RUNTIME_PM definition to platform
  drm/i915: Move HAS_CORE_RING_FREQ definition to platform definition
  drm/i915: Make GEN7_FEATURES inherit from GEN6
  drm/i915: Move HAS_CSR definition to platform definition
  drm/i915: Move HAS_RESOURCE_STREAMER definition to platform definition
  drm/i915: Move HAS_RC6 definition to platform definition
  drm/i915: Move HAS_RC6p definition to platform definition
  drm/i915: Move HAS_DP_MST definition to platform definition
  drm/i915: Make GEN6_FEATURES inherit from GEN5
  drm/i915: Move HAS_AUX_IRQ definition to platform definition
  drm/i915: Move HAS_GMBUS_IRQ definition to platform definition
  drm/i915: Introduce GEN4_FEATURES for device info
  drm/i965: Make GEN4_FEATURES inherit from GEN3
  drm/i915: Introduce GEN2_FEATURES for device info
  drm/i915: Move HAS_FW_BLC definition to platform
  drm/i915: Move HAS_HW_CONTEXTS definition to platform
  drm/i915: Move HAS_LOGICAL_RING_CONTEXTS definition to platform
  drm/i915: Move HAS_L3_DPF definition to platform definition
  drm/i915: Move HAS_GMCH_DISPLAY definition to platform

 drivers/gpu/drm/i915/i915_drv.h |  57 ++++++-----
 drivers/gpu/drm/i915/i915_pci.c | 217 +++++++++++++++++++++++-----------------
 2 files changed, 157 insertions(+), 117 deletions(-)

-- 
1.9.1

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply	[flat|nested] 33+ messages in thread

end of thread, other threads:[~2016-08-02 12:59 UTC | newest]

Thread overview: 33+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-07-28 19:12 [PATCH v2 00/21] drm/i915: Organize most GPU features by platform Carlos Santa
2016-07-28 19:12 ` [PATCH v2 01/21] drm/i915: Move HAS_PSR definition to platform struct definition Carlos Santa
2016-07-29 14:03   ` Ville Syrjälä
2016-07-28 19:12 ` [PATCH v2 02/21] drm/i915: Introduce GEN6_FEATURES for device info Carlos Santa
2016-07-29 14:06   ` Ville Syrjälä
2016-07-29 15:39     ` Chris Wilson
2016-07-28 19:12 ` [PATCH v2 03/21] drm/i915: Move HAS_RUNTIME_PM definition to platform Carlos Santa
2016-07-29 14:07   ` Ville Syrjälä
2016-07-28 19:12 ` [PATCH v2 04/21] drm/i915: Move HAS_CORE_RING_FREQ definition to platform definition Carlos Santa
2016-07-29 14:09   ` Ville Syrjälä
2016-07-28 19:12 ` [PATCH v2 05/21] drm/i915: Make GEN7_FEATURES inherit from GEN6 Carlos Santa
2016-07-28 19:12 ` [PATCH v2 06/21] drm/i915: Move HAS_CSR definition to platform definition Carlos Santa
2016-07-28 19:12 ` [PATCH v2 07/21] drm/i915: Move HAS_RESOURCE_STREAMER " Carlos Santa
2016-07-28 19:12 ` [PATCH v2 08/21] drm/i915: Move HAS_RC6 " Carlos Santa
2016-07-28 19:12 ` [PATCH v2 09/21] drm/i915: Move HAS_RC6p " Carlos Santa
2016-07-28 19:12 ` [PATCH v2 10/21] drm/i915: Move HAS_DP_MST " Carlos Santa
2016-07-28 19:12 ` [PATCH v2 11/21] drm/i915: Make GEN6_FEATURES inherit from GEN5 Carlos Santa
2016-07-28 19:12 ` [PATCH v2 12/21] drm/i915: Move HAS_AUX_IRQ definition to platform definition Carlos Santa
2016-07-29 14:14   ` Ville Syrjälä
2016-08-02 12:59     ` Jani Nikula
2016-07-28 19:12 ` [PATCH v2 13/21] drm/i915: Move HAS_GMBUS_IRQ " Carlos Santa
2016-07-28 19:12 ` [PATCH v2 14/21] drm/i915: Introduce GEN4_FEATURES for device info Carlos Santa
2016-07-28 19:12 ` [PATCH v2 15/21] drm/i965: Make GEN4_FEATURES inherit from GEN3 Carlos Santa
2016-07-28 19:12 ` [PATCH v2 16/21] drm/i915: Introduce GEN2_FEATURES for device info Carlos Santa
2016-07-29 14:17   ` Ville Syrjälä
2016-07-28 19:12 ` [PATCH v2 17/21] drm/i915: Move HAS_FW_BLC definition to platform Carlos Santa
2016-07-29 14:35   ` Ville Syrjälä
2016-07-28 19:12 ` [PATCH v2 18/21] drm/i915: Move HAS_HW_CONTEXTS " Carlos Santa
2016-07-28 19:12 ` [PATCH v2 19/21] drm/i915: Move HAS_LOGICAL_RING_CONTEXTS " Carlos Santa
2016-07-28 19:12 ` [PATCH v2 20/21] drm/i915: Move HAS_L3_DPF definition to platform definition Carlos Santa
2016-07-28 19:12 ` [PATCH v2 21/21] drm/i915: Move HAS_GMCH_DISPLAY definition to platform Carlos Santa
2016-07-29  5:27 ` ✗ Ro.CI.BAT: failure for drm/i915: Organize most GPU features by platform (rev2) Patchwork
2016-07-29 14:01 ` [PATCH v2 00/21] drm/i915: Organize most GPU features by platform Ville Syrjälä

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.