All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 00/21] staging: wilc1000: remove unused code and reorder functions
@ 2018-04-25 17:18 Ajay Singh
  2018-04-25 17:18 ` [PATCH v2 01/21] staging: wilc1000: replace crc7_byte() with inline macro CRC7_BYTE Ajay Singh
                   ` (21 more replies)
  0 siblings, 22 replies; 25+ messages in thread
From: Ajay Singh @ 2018-04-25 17:18 UTC (permalink / raw)
  To: linux-wireless
  Cc: devel, gregkh, ganesh.krishna, venkateswara.kaja, aditya.shankar,
	claudiu.beznea, adham.abozaeid, Ajay Singh

This patch series contains fixes to remove the unused code. It also has patches
to reorganize the function and simplify the function logic.

Ajay Singh (21):
  staging: wilc1000: replace crc7_byte() with inline macro CRC7_BYTE
  staging: wilc1000: align the #define in wilc_spi file
  staging: wilc1000: remove unnecessary assingment from 'if' conditions
  staging: wilc1000: remove 'cmd' variable in wilc_spi functions
  staging: wicl1000: removed the unsed variables in
    wilc_parse_network_info()
  staging: wilc1000: remove inner {} in wilc_parse_network_info()
  staging: wilc1000: simplified if conditions in spi_data_write()
  staging: wilc1000: remove unused variable scan_while_connected
  staging: wilc1000: remove unsed typedef wilc_debug_func
  staging: wilc1000: remove used #define HIF_SDIO_GPIO_IRQ
  staging: wilc1000: remove unused #define related to MAC status
  staging: wilc1000: rename mac status macros and moved related #define
    together
  staging: wilc1000: rename WILC_WFI_stats to avoid uppercase
  staging: wilc1000: rename num_reg_frame macro to have uppercase in
    macro name
  staging: wilc1000: rename wlan init and deinit function prefixed with
    wil1000
  staging: wilc1000: remove unused elements in 'wilc_priv' struct
  staging: wilc1000: remove unused enum 'stats_flags'
  staging: wilc1000: rename P2P_LISTEN_STATE variable to use lowercase
  staging: wilc1000: remove inner block '{}' in handle_remain_on_chan()
  staging: wilc1000: change function to static in linux_wlan
  staging: wilc1000: reorder functions to avoid forward declaration in
    linux_wlan

 drivers/staging/wilc1000/coreconfigurator.c       |  84 +++++++--------
 drivers/staging/wilc1000/host_interface.c         |  64 ++++--------
 drivers/staging/wilc1000/linux_wlan.c             | 122 ++++++++++------------
 drivers/staging/wilc1000/wilc_sdio.c              |  12 +--
 drivers/staging/wilc1000/wilc_spi.c               |  70 ++++++-------
 drivers/staging/wilc1000/wilc_wfi_cfgoperations.c |   2 +-
 drivers/staging/wilc1000/wilc_wfi_netdevice.h     |  23 +---
 drivers/staging/wilc1000/wilc_wlan.h              |   7 --
 drivers/staging/wilc1000/wilc_wlan_if.h           |  11 +-
 9 files changed, 158 insertions(+), 237 deletions(-)

-- 
2.7.4

^ permalink raw reply	[flat|nested] 25+ messages in thread

end of thread, other threads:[~2018-04-26  8:56 UTC | newest]

Thread overview: 25+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-04-25 17:18 [PATCH v2 00/21] staging: wilc1000: remove unused code and reorder functions Ajay Singh
2018-04-25 17:18 ` [PATCH v2 01/21] staging: wilc1000: replace crc7_byte() with inline macro CRC7_BYTE Ajay Singh
2018-04-26  7:40   ` Greg KH
2018-04-26  7:54     ` Ajay Singh
2018-04-25 17:18 ` [PATCH v2 02/21] staging: wilc1000: align the #define in wilc_spi file Ajay Singh
2018-04-25 17:18 ` [PATCH v2 03/21] staging: wilc1000: remove unnecessary assingment from 'if' conditions Ajay Singh
2018-04-25 17:18 ` [PATCH v2 04/21] staging: wilc1000: remove 'cmd' variable in wilc_spi functions Ajay Singh
2018-04-25 17:18 ` [PATCH v2 05/21] staging: wicl1000: removed the unsed variables in wilc_parse_network_info() Ajay Singh
2018-04-25 17:18 ` [PATCH v2 06/21] staging: wilc1000: remove inner {} " Ajay Singh
2018-04-25 17:18 ` [PATCH v2 07/21] staging: wilc1000: simplified if conditions in spi_data_write() Ajay Singh
2018-04-25 17:18 ` [PATCH v2 08/21] staging: wilc1000: remove unused variable scan_while_connected Ajay Singh
2018-04-25 17:18 ` [PATCH v2 09/21] staging: wilc1000: remove unsed typedef wilc_debug_func Ajay Singh
2018-04-25 17:18 ` [PATCH v2 10/21] staging: wilc1000: remove used #define HIF_SDIO_GPIO_IRQ Ajay Singh
2018-04-25 17:18 ` [PATCH v2 11/21] staging: wilc1000: remove unused #define related to MAC status Ajay Singh
2018-04-25 17:18 ` [PATCH v2 12/21] staging: wilc1000: rename mac status macros and moved related #define together Ajay Singh
2018-04-25 17:18 ` [PATCH v2 13/21] staging: wilc1000: rename WILC_WFI_stats to avoid uppercase Ajay Singh
2018-04-25 17:18 ` [PATCH v2 14/21] staging: wilc1000: rename num_reg_frame macro to have uppercase in macro name Ajay Singh
2018-04-25 17:18 ` [PATCH v2 15/21] staging: wilc1000: rename wlan init and deinit function prefixed with wil1000 Ajay Singh
2018-04-25 17:18 ` [PATCH v2 16/21] staging: wilc1000: remove unused elements in 'wilc_priv' struct Ajay Singh
2018-04-25 17:18 ` [PATCH v2 17/21] staging: wilc1000: remove unused enum 'stats_flags' Ajay Singh
2018-04-25 17:18 ` [PATCH v2 18/21] staging: wilc1000: rename P2P_LISTEN_STATE variable to use lowercase Ajay Singh
2018-04-25 17:18 ` [PATCH v2 19/21] staging: wilc1000: remove inner block '{}' in handle_remain_on_chan() Ajay Singh
2018-04-25 17:18 ` [PATCH v2 20/21] staging: wilc1000: change function to static in linux_wlan Ajay Singh
2018-04-25 17:18 ` [PATCH v2 21/21] staging: wilc1000: reorder functions to avoid forward declaration " Ajay Singh
2018-04-26  6:16 ` [PATCH v2 00/21] staging: wilc1000: remove unused code and reorder functions Ajay Singh

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.