All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH net 2/2] net/smc: retain old name for diag_mode field
@ 2018-10-06 20:32 Eugene Syromiatnikov
  2018-10-07  8:34 ` Sergei Shtylyov
  0 siblings, 1 reply; 2+ messages in thread
From: Eugene Syromiatnikov @ 2018-10-06 20:32 UTC (permalink / raw)
  To: netdev
  Cc: David S. Miller, linux-kernel, Ursula Braun, Karsten Graul, Hans Wippel

Commit v4.19-rc1~140^2~285^2~4 changed the name of diag_fallback field
of struct smc_diag_msg structure to diag_mode.  However, this structure
is a part of UAPI, and this change breaks user space applications that
use it ([1], for example).  Since the new name is more suitable, convert
the field to a union that provides access to the data via both the new
and the old name.

[1] https://gitlab.com/strace/strace/blob/v4.24/netlink_smc_diag.c#L165

Fixes: c601171d7a60 ("net/smc: provide smc mode in smc_diag.c")
Signed-off-by: Eugene Syromiatnikov <esyr@redhat.com>
---
 include/uapi/linux/smc_diag.h | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/include/uapi/linux/smc_diag.h b/include/uapi/linux/smc_diag.h
index 6180c6d..8cb3a6f 100644
--- a/include/uapi/linux/smc_diag.h
+++ b/include/uapi/linux/smc_diag.h
@@ -20,7 +20,10 @@ struct smc_diag_req {
 struct smc_diag_msg {
 	__u8		diag_family;
 	__u8		diag_state;
-	__u8		diag_mode;
+	union {
+		__u8	diag_mode;
+		__u8	diag_fallback; /* the old name of the field */
+	};
 	__u8		diag_shutdown;
 	struct inet_diag_sockid id;
 
-- 
2.1.4


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH net 2/2] net/smc: retain old name for diag_mode field
  2018-10-06 20:32 [PATCH net 2/2] net/smc: retain old name for diag_mode field Eugene Syromiatnikov
@ 2018-10-07  8:34 ` Sergei Shtylyov
  0 siblings, 0 replies; 2+ messages in thread
From: Sergei Shtylyov @ 2018-10-07  8:34 UTC (permalink / raw)
  To: Eugene Syromiatnikov, netdev
  Cc: David S. Miller, linux-kernel, Ursula Braun, Karsten Graul, Hans Wippel

On 10/6/2018 11:32 PM, Eugene Syromiatnikov wrote:

> Commit v4.19-rc1~140^2~285^2~4 changed the name of diag_fallback field

    The commit citing style should be the same as in the "Fixes:" tag.

> of struct smc_diag_msg structure to diag_mode.  However, this structure
> is a part of UAPI, and this change breaks user space applications that
> use it ([1], for example).  Since the new name is more suitable, convert
> the field to a union that provides access to the data via both the new
> and the old name.
> 
> [1] https://gitlab.com/strace/strace/blob/v4.24/netlink_smc_diag.c#L165
> 
> Fixes: c601171d7a60 ("net/smc: provide smc mode in smc_diag.c")
> Signed-off-by: Eugene Syromiatnikov <esyr@redhat.com>
[...]

MBR, Sergei

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2018-10-07  8:34 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-10-06 20:32 [PATCH net 2/2] net/smc: retain old name for diag_mode field Eugene Syromiatnikov
2018-10-07  8:34 ` Sergei Shtylyov

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.