All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andrew Murray <andrew.murray@arm.com>
To: Christoffer Dall <christoffer.dall@arm.com>
Cc: Marc Zyngier <marc.zyngier@arm.com>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will.deacon@arm.com>,
	kvmarm@lists.cs.columbia.edu,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v7 2/5] arm64: KVM: encapsulate kvm_cpu_context in kvm_host_data
Date: Tue, 11 Dec 2018 14:00:38 +0000	[thread overview]
Message-ID: <20181211140038.GH13393@e119886-lin.cambridge.arm.com> (raw)
In-Reply-To: <20181211134007.GZ30263@e113682-lin.lund.arm.com>

On Tue, Dec 11, 2018 at 02:40:07PM +0100, Christoffer Dall wrote:
> On Tue, Dec 11, 2018 at 01:11:33PM +0000, Andrew Murray wrote:
> > On Tue, Dec 11, 2018 at 01:29:51PM +0100, Christoffer Dall wrote:
> > > On Tue, Dec 11, 2018 at 12:13:37PM +0000, Andrew Murray wrote:
> > > > The virt/arm core allocates a percpu structure as per the kvm_cpu_context_t
> > > > type, at present this is typedef'd to kvm_cpu_context and used to store
> > > > host cpu context. The kvm_cpu_context structure is also used elsewhere to
> > > > hold vcpu context. In order to use the percpu to hold additional future
> > > > host information we encapsulate kvm_cpu_context in a new structure.
> > > > 
> > > > Signed-off-by: Andrew Murray <andrew.murray@arm.com>
> > > > ---
> > > >  arch/arm64/include/asm/kvm_host.h | 8 ++++++--
> > > >  arch/arm64/kernel/asm-offsets.c   | 3 ++-
> > > >  virt/kvm/arm/arm.c                | 4 +++-
> > > >  3 files changed, 11 insertions(+), 4 deletions(-)
> > > > 
> > > > diff --git a/arch/arm64/include/asm/kvm_host.h b/arch/arm64/include/asm/kvm_host.h
> > > > index 1550192..bcf9d60 100644
> > > > --- a/arch/arm64/include/asm/kvm_host.h
> > > > +++ b/arch/arm64/include/asm/kvm_host.h
> > > > @@ -205,7 +205,11 @@ struct kvm_cpu_context {
> > > >  	struct kvm_vcpu *__hyp_running_vcpu;
> > > >  };
> > > >  
> > > > -typedef struct kvm_cpu_context kvm_cpu_context_t;
> > > > +struct kvm_host_data {
> > > > +	struct kvm_cpu_context __kvm_cpu_state;
> > > > +};
> > > > +
> > > > +typedef struct kvm_host_data kvm_cpu_context_t;
> > > 
> > > Now I'm confused based on the conversation on the last version.
> > > 
> > > I think it's bizarre to use the typedef to rename things in this way.
> > > 
> > > Can you please make this:
> > > 
> > >    struct kvm_cpu_context;
> > >    typedef struct kvm_cpu_context kvm_cpu_context_t;
> > > 
> > >    struct kvm_host_data;
> > >    typedef struct kvm_host_data kvm_host_data_t;
> > > 
> > > And change the code with the fallout from that.
> > 
> > I guess I was trying to avoid similar naming issues on arm32. If we
> > make the above changes (and thus the DEFINE_PER_CPU in virt/kvm/arm/arm.c)
> > then we need to change arm (arch/arm/include/asm/kvm_host.h) such that:
> > 
> > typedef struct kvm_cpu_context kvm_cpu_context_t;
> > 
> > becomes:
> > 
> > typedef struct kvm_cpu_context kvm_host_data_t;
> > 
> > though I guess this may be acceptable?
> 
> I'd prefer it if you just introduce a struct kvm_host_data on the 32-bit
> side only containing a struct kvm_cpu_context (if you wanted to support
> perf on the 32-bit side you would also add additional fields to it,
> similar to arm64).  That avoids the confusing typedef and you get the
> symmmetry on both architectures allowing you to use shared code, which
> is what we want at the end of the day.
> 
> So, on the 32-bit side, change this to:
> 
> struct kvm_host_data {
> 	struct kvm_cpu_context *host_ctxt;
> };
> typedef struct kvm_host_data kvm_host_data_t;
> 
> 
> And use the same naming on both 32-bit and 64-bit arm, consistently.

Sounds good to me.

Thanks,

Andrew Murray

> 
> 
> Thanks,
> 
>     Christoffer

WARNING: multiple messages have this Message-ID (diff)
From: Andrew Murray <andrew.murray@arm.com>
To: Christoffer Dall <christoffer.dall@arm.com>
Cc: Mark Rutland <mark.rutland@arm.com>,
	Julien Thierry <julien.thierry@arm.com>,
	Marc Zyngier <marc.zyngier@arm.com>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Suzuki K Poulose <suzuki.poulose@arm.com>,
	Will Deacon <will.deacon@arm.com>,
	kvmarm@lists.cs.columbia.edu,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v7 2/5] arm64: KVM: encapsulate kvm_cpu_context in kvm_host_data
Date: Tue, 11 Dec 2018 14:00:38 +0000	[thread overview]
Message-ID: <20181211140038.GH13393@e119886-lin.cambridge.arm.com> (raw)
In-Reply-To: <20181211134007.GZ30263@e113682-lin.lund.arm.com>

On Tue, Dec 11, 2018 at 02:40:07PM +0100, Christoffer Dall wrote:
> On Tue, Dec 11, 2018 at 01:11:33PM +0000, Andrew Murray wrote:
> > On Tue, Dec 11, 2018 at 01:29:51PM +0100, Christoffer Dall wrote:
> > > On Tue, Dec 11, 2018 at 12:13:37PM +0000, Andrew Murray wrote:
> > > > The virt/arm core allocates a percpu structure as per the kvm_cpu_context_t
> > > > type, at present this is typedef'd to kvm_cpu_context and used to store
> > > > host cpu context. The kvm_cpu_context structure is also used elsewhere to
> > > > hold vcpu context. In order to use the percpu to hold additional future
> > > > host information we encapsulate kvm_cpu_context in a new structure.
> > > > 
> > > > Signed-off-by: Andrew Murray <andrew.murray@arm.com>
> > > > ---
> > > >  arch/arm64/include/asm/kvm_host.h | 8 ++++++--
> > > >  arch/arm64/kernel/asm-offsets.c   | 3 ++-
> > > >  virt/kvm/arm/arm.c                | 4 +++-
> > > >  3 files changed, 11 insertions(+), 4 deletions(-)
> > > > 
> > > > diff --git a/arch/arm64/include/asm/kvm_host.h b/arch/arm64/include/asm/kvm_host.h
> > > > index 1550192..bcf9d60 100644
> > > > --- a/arch/arm64/include/asm/kvm_host.h
> > > > +++ b/arch/arm64/include/asm/kvm_host.h
> > > > @@ -205,7 +205,11 @@ struct kvm_cpu_context {
> > > >  	struct kvm_vcpu *__hyp_running_vcpu;
> > > >  };
> > > >  
> > > > -typedef struct kvm_cpu_context kvm_cpu_context_t;
> > > > +struct kvm_host_data {
> > > > +	struct kvm_cpu_context __kvm_cpu_state;
> > > > +};
> > > > +
> > > > +typedef struct kvm_host_data kvm_cpu_context_t;
> > > 
> > > Now I'm confused based on the conversation on the last version.
> > > 
> > > I think it's bizarre to use the typedef to rename things in this way.
> > > 
> > > Can you please make this:
> > > 
> > >    struct kvm_cpu_context;
> > >    typedef struct kvm_cpu_context kvm_cpu_context_t;
> > > 
> > >    struct kvm_host_data;
> > >    typedef struct kvm_host_data kvm_host_data_t;
> > > 
> > > And change the code with the fallout from that.
> > 
> > I guess I was trying to avoid similar naming issues on arm32. If we
> > make the above changes (and thus the DEFINE_PER_CPU in virt/kvm/arm/arm.c)
> > then we need to change arm (arch/arm/include/asm/kvm_host.h) such that:
> > 
> > typedef struct kvm_cpu_context kvm_cpu_context_t;
> > 
> > becomes:
> > 
> > typedef struct kvm_cpu_context kvm_host_data_t;
> > 
> > though I guess this may be acceptable?
> 
> I'd prefer it if you just introduce a struct kvm_host_data on the 32-bit
> side only containing a struct kvm_cpu_context (if you wanted to support
> perf on the 32-bit side you would also add additional fields to it,
> similar to arm64).  That avoids the confusing typedef and you get the
> symmmetry on both architectures allowing you to use shared code, which
> is what we want at the end of the day.
> 
> So, on the 32-bit side, change this to:
> 
> struct kvm_host_data {
> 	struct kvm_cpu_context *host_ctxt;
> };
> typedef struct kvm_host_data kvm_host_data_t;
> 
> 
> And use the same naming on both 32-bit and 64-bit arm, consistently.

Sounds good to me.

Thanks,

Andrew Murray

> 
> 
> Thanks,
> 
>     Christoffer

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2018-12-11 14:00 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-12-11 12:13 [PATCH v7 0/5] arm64: Support perf event modifiers :G and :H Andrew Murray
2018-12-11 12:13 ` Andrew Murray
2018-12-11 12:13 ` [PATCH v7 1/5] arm64: arm_pmu: remove unnecessary isb instruction Andrew Murray
2018-12-11 12:13   ` Andrew Murray
2018-12-11 12:13 ` [PATCH v7 2/5] arm64: KVM: encapsulate kvm_cpu_context in kvm_host_data Andrew Murray
2018-12-11 12:13   ` Andrew Murray
2018-12-11 12:29   ` Christoffer Dall
2018-12-11 12:29     ` Christoffer Dall
2018-12-11 13:11     ` Andrew Murray
2018-12-11 13:11       ` Andrew Murray
2018-12-11 13:40       ` Christoffer Dall
2018-12-11 13:40         ` Christoffer Dall
2018-12-11 14:00         ` Andrew Murray [this message]
2018-12-11 14:00           ` Andrew Murray
2018-12-11 12:40   ` Suzuki K Poulose
2018-12-11 12:40     ` Suzuki K Poulose
2018-12-11 13:11     ` Andrew Murray
2018-12-11 13:11       ` Andrew Murray
2018-12-11 12:13 ` [PATCH v7 3/5] arm64: KVM: add accessors to track guest/host only counters Andrew Murray
2018-12-11 12:13   ` Andrew Murray
2018-12-11 12:13 ` [PATCH v7 4/5] arm64: arm_pmu: Add support for exclude_host/exclude_guest attributes Andrew Murray
2018-12-11 12:13   ` Andrew Murray
2018-12-11 12:13 ` [PATCH v7 5/5] arm64: KVM: Enable support for :G/:H perf event modifiers Andrew Murray
2018-12-11 12:13   ` Andrew Murray

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181211140038.GH13393@e119886-lin.cambridge.arm.com \
    --to=andrew.murray@arm.com \
    --cc=catalin.marinas@arm.com \
    --cc=christoffer.dall@arm.com \
    --cc=kvmarm@lists.cs.columbia.edu \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=marc.zyngier@arm.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.