All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/15] ASoC: simple-card: share similar function
@ 2019-03-18  4:49 Kuninori Morimoto
  2019-03-18  4:50 ` [PATCH 01/15] ASoC: simple-card: rename simple_get_conversion() to simple_parse_convert() Kuninori Morimoto
                   ` (15 more replies)
  0 siblings, 16 replies; 21+ messages in thread
From: Kuninori Morimoto @ 2019-03-18  4:49 UTC (permalink / raw)
  To: Mark Brown; +Cc: Linux-ALSA


Hi Mark

These are clean-up patch-set for simple-card / audio-graph.
These are very similar sound card drivers, the difference
is only "using OF-graph" or not.
But these are using very similar or 100% same function on each files.
These patches share these at simple-card-utils.
These are based on asoc/for-5.2

Kuninori Morimoto (15):
  ASoC: simple-card: rename simple_get_conversion() to simple_parse_convert()
  ASoC: simple-card: add simple_parse_mclk_fs()
  ASoC: audio-graph: rename graph_get_conversion() to graph_parse_convert()
  ASoC: audio-graph: add graph_parse_mclk_fs()
  ASoC: simple-card-utils: add asoc_simple_debug_info()
  ASoC: simple_card_utils: share common priv for simple-card/audio-graph
  ASoC: simple-card-utils: share asoc_simple_startup()
  ASoC: simple-card-utils: share asoc_simple_shutdown()
  ASoC: simple-card-utils: share asoc_simple_hw_param()
  ASoC: simple-card-utils: share asoc_simple_dai_init()
  ASoC: simple-card-utils: share asoc_simple_be_hw_params_fixup()
  ASoC: simple-card-utils: share asoc_simple_card_init_priv()
  ASoC: simple-card-utils: separate asoc_simple_card_parse_dai()
  ASoC: simple-card-utils: rename asoc_simple_card_xxx() to asoc_simple_()
  ASoC: simple-card-utils: test memory allocation

 include/sound/simple_card_utils.h     | 236 +++++++++++++------
 sound/soc/generic/audio-graph-card.c  | 429 +++++++++++++++-------------------
 sound/soc/generic/simple-card-utils.c | 378 ++++++++++++++++--------------
 sound/soc/generic/simple-card.c       | 379 +++++++++++-------------------
 4 files changed, 675 insertions(+), 747 deletions(-)

-- 
2.7.4



Best regards
---
Kuninori Morimoto

^ permalink raw reply	[flat|nested] 21+ messages in thread

end of thread, other threads:[~2019-03-20  4:49 UTC | newest]

Thread overview: 21+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-03-18  4:49 [PATCH 00/15] ASoC: simple-card: share similar function Kuninori Morimoto
2019-03-18  4:50 ` [PATCH 01/15] ASoC: simple-card: rename simple_get_conversion() to simple_parse_convert() Kuninori Morimoto
2019-03-18 14:51   ` Applied "ASoC: simple-card: rename simple_get_conversion() to simple_parse_convert()" to the asoc tree Mark Brown
2019-03-18  4:50 ` [PATCH 02/15] ASoC: simple-card: add simple_parse_mclk_fs() Kuninori Morimoto
2019-03-18 14:50   ` Applied "ASoC: simple-card: add simple_parse_mclk_fs()" to the asoc tree Mark Brown
2019-03-18  4:50 ` [PATCH 03/15] ASoC: audio-graph: rename graph_get_conversion() to graph_parse_convert() Kuninori Morimoto
2019-03-18 14:50   ` Applied "ASoC: audio-graph: rename graph_get_conversion() to graph_parse_convert()" to the asoc tree Mark Brown
2019-03-18  4:50 ` [PATCH 04/15] ASoC: audio-graph: add graph_parse_mclk_fs() Kuninori Morimoto
2019-03-18 14:50   ` Applied "ASoC: audio-graph: add graph_parse_mclk_fs()" to the asoc tree Mark Brown
2019-03-18  4:53 ` [PATCH 05/15] ASoC: simple-card-utils: add asoc_simple_debug_info() Kuninori Morimoto
2019-03-18  4:53 ` [PATCH 06/15] ASoC: simple_card_utils: share common priv for simple-card/audio-graph Kuninori Morimoto
2019-03-18  4:53 ` [PATCH 07/15] ASoC: simple-card-utils: share asoc_simple_startup() Kuninori Morimoto
2019-03-18  4:53 ` [PATCH 08/15] ASoC: simple-card-utils: share asoc_simple_shutdown() Kuninori Morimoto
2019-03-18  4:53 ` [PATCH 09/15] ASoC: simple-card-utils: share asoc_simple_hw_param() Kuninori Morimoto
2019-03-18  4:54 ` [PATCH 10/15] ASoC: simple-card-utils: share asoc_simple_dai_init() Kuninori Morimoto
2019-03-18  4:54 ` [PATCH 11/15] ASoC: simple-card-utils: share asoc_simple_be_hw_params_fixup() Kuninori Morimoto
2019-03-18  4:54 ` [PATCH 12/15] ASoC: simple-card-utils: share asoc_simple_card_init_priv() Kuninori Morimoto
2019-03-18  4:55 ` [PATCH 13/15] ASoC: simple-card-utils: separate asoc_simple_card_parse_dai() Kuninori Morimoto
2019-03-18  4:55 ` [PATCH 14/15] ASoC: simple-card-utils: rename asoc_simple_card_xxx() to asoc_simple_() Kuninori Morimoto
2019-03-18  4:55 ` [PATCH 15/15] ASoC: simple-card-utils: test memory allocation Kuninori Morimoto
2019-03-20  4:49 ` [PATCH 00/15] ASoC: simple-card: share similar function Kuninori Morimoto

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.