All of lore.kernel.org
 help / color / mirror / Atom feed
From: Cornelia Huck <cohuck@redhat.com>
To: Halil Pasic <pasic@linux.ibm.com>
Cc: Michael Mueller <mimu@linux.ibm.com>,
	KVM Mailing List <kvm@vger.kernel.org>,
	Linux-S390 Mailing List <linux-s390@vger.kernel.org>,
	Sebastian Ott <sebott@linux.ibm.com>,
	Heiko Carstens <heiko.carstens@de.ibm.com>,
	virtualization@lists.linux-foundation.org,
	"Michael S . Tsirkin" <mst@redhat.com>,
	Christoph Hellwig <hch@infradead.org>,
	Thomas Huth <thuth@redhat.com>,
	Christian Borntraeger <borntraeger@de.ibm.com>,
	Viktor Mihajlovski <mihajlov@linux.ibm.com>,
	Vasily Gorbik <gor@linux.ibm.com>,
	Janosch Frank <frankja@linux.ibm.com>,
	Claudio Imbrenda <imbrenda@linux.ibm.com>,
	Farhan Ali <alifm@linux.ibm.com>,
	Eric Farman <farman@linux.ibm.com>,
	Pierre Morel <pmorel@linux.ibm.com>
Subject: Re: [PATCH v3 7/8] virtio/s390: use DMA memory for ccw I/O and classic notifiers
Date: Tue, 4 Jun 2019 15:36:25 +0200	[thread overview]
Message-ID: <20190604153625.6c03c232.cohuck@redhat.com> (raw)
In-Reply-To: <20190604150819.1f8707b5.pasic@linux.ibm.com>

On Tue, 4 Jun 2019 15:08:19 +0200
Halil Pasic <pasic@linux.ibm.com> wrote:

> On Mon, 3 Jun 2019 18:17:16 +0200
> Cornelia Huck <cohuck@redhat.com> wrote:
> 
> > On Wed, 29 May 2019 14:26:56 +0200
> > Michael Mueller <mimu@linux.ibm.com> wrote:

> > (...)
> >   
> > > @@ -176,6 +180,22 @@ static struct virtio_ccw_device *to_vc_device(struct virtio_device *vdev)
> > >  	return container_of(vdev, struct virtio_ccw_device, vdev);
> > >  }
> > >  
> > > +static inline void *__vc_dma_alloc(struct virtio_device *vdev, size_t size)
> > > +{
> > > +	return ccw_device_dma_zalloc(to_vc_device(vdev)->cdev, size);
> > > +}
> > > +
> > > +static inline void __vc_dma_free(struct virtio_device *vdev, size_t size,
> > > +				 void *cpu_addr)
> > > +{
> > > +	return ccw_device_dma_free(to_vc_device(vdev)->cdev, cpu_addr, size);
> > > +}
> > > +
> > > +#define vc_dma_alloc_struct(vdev, ptr) \
> > > +	({ptr = __vc_dma_alloc(vdev, sizeof(*(ptr))); })
> > > +#define vc_dma_free_struct(vdev, ptr) \
> > > +	__vc_dma_free(vdev, sizeof(*(ptr)), (ptr))
> > > +  
> > 
> > I *still* don't like these #defines (and the __vc_dma_* functions), as I
> > already commented last time. I think they make it harder to follow the
> > code.
> >   
> 
> Sorry! I think we simply forgot to address this comment of yours. 
> 
> > >  static void drop_airq_indicator(struct virtqueue *vq, struct airq_info *info)
> > >  {
> > >  	unsigned long i, flags;
> > > @@ -336,8 +356,7 @@ static void virtio_ccw_drop_indicator(struct virtio_ccw_device *vcdev,
> > >  	struct airq_info *airq_info = vcdev->airq_info;
> > >  
> > >  	if (vcdev->is_thinint) {
> > > -		thinint_area = kzalloc(sizeof(*thinint_area),
> > > -				       GFP_DMA | GFP_KERNEL);
> > > +		vc_dma_alloc_struct(&vcdev->vdev, thinint_area);  
> > 
> > Last time I wrote:
> > 
> > "Any reason why this takes a detour via the virtio device? The ccw
> >  device is already referenced in vcdev, isn't it?
> >
> > thinint_area = ccw_device_dma_zalloc(vcdev->cdev, sizeof(*thinint_area));
> > 
> >  looks much more obvious to me."
> > 
> > It still seems more obvious to me.
> >  
> 
> 
> The reason why I decided to introduce __vc_dma_alloc() back then is
> because I had no clarity what do we want to do there. If you take a look
> the body of __vc_dma_alloc() changed quite a lot, while I the usage not
> so much. 
> 
> Regarding why is the first argument a pointer struct virtio_device, the
> idea was probably to keep the needs to be ZONE_DMA and can use the full
> 64 bit address space separate. But I abandoned the ideal.
> 
> Also vc_dma_alloc_struct() started out more elaborate (I used to manage
> a dma_addr_t as well -- see RFC).

Understood, history is often important :)

> 
> I'm not quite sure what is your problem with the these. As far as I
> understand, this is another of those matter of taste things. But it ain't
> a big deal. 

Two things:
- The call path goes from the vcdev to the vdev, then back to the vcdev
  and then to the cdev. Going from the vcdev to the cdev  directly
  eliminates the roundtrip via the vdev, which I think does not add
  anything.
- I prefer
	variable = function_returning_a_pointer(...);
  over
	function_setting_a_variable(..., variable);
  The latter obscures the fact that we change the value of the
  variable, unless named very obviously.

> 
> I will change this for v4 as you requested. Again sorry for missing it!

np, can happen.

> 
> Regards,
> Halil
> 
>  
> > >  		if (!thinint_area)
> > >  			return;
> > >  		thinint_area->summary_indicator =  
> >   
> 

WARNING: multiple messages have this Message-ID (diff)
From: Cornelia Huck <cohuck@redhat.com>
To: Halil Pasic <pasic@linux.ibm.com>
Cc: Vasily Gorbik <gor@linux.ibm.com>,
	Linux-S390 Mailing List <linux-s390@vger.kernel.org>,
	Thomas Huth <thuth@redhat.com>,
	Claudio Imbrenda <imbrenda@linux.ibm.com>,
	KVM Mailing List <kvm@vger.kernel.org>,
	Sebastian Ott <sebott@linux.ibm.com>,
	"Michael S . Tsirkin" <mst@redhat.com>,
	Pierre Morel <pmorel@linux.ibm.com>,
	Farhan Ali <alifm@linux.ibm.com>,
	Heiko Carstens <heiko.carstens@de.ibm.com>,
	Eric Farman <farman@linux.ibm.com>,
	virtualization@lists.linux-foundation.org,
	Christoph Hellwig <hch@infradead.org>,
	Christian Borntraeger <borntraeger@de.ibm.com>,
	Michael Mueller <mimu@linux.ibm.com>,
	Viktor Mihajlovski <mihajlov@linux.ibm.com>,
	Janosch Frank <frankja@linux.ibm.com>
Subject: Re: [PATCH v3 7/8] virtio/s390: use DMA memory for ccw I/O and classic notifiers
Date: Tue, 4 Jun 2019 15:36:25 +0200	[thread overview]
Message-ID: <20190604153625.6c03c232.cohuck@redhat.com> (raw)
In-Reply-To: <20190604150819.1f8707b5.pasic@linux.ibm.com>

On Tue, 4 Jun 2019 15:08:19 +0200
Halil Pasic <pasic@linux.ibm.com> wrote:

> On Mon, 3 Jun 2019 18:17:16 +0200
> Cornelia Huck <cohuck@redhat.com> wrote:
> 
> > On Wed, 29 May 2019 14:26:56 +0200
> > Michael Mueller <mimu@linux.ibm.com> wrote:

> > (...)
> >   
> > > @@ -176,6 +180,22 @@ static struct virtio_ccw_device *to_vc_device(struct virtio_device *vdev)
> > >  	return container_of(vdev, struct virtio_ccw_device, vdev);
> > >  }
> > >  
> > > +static inline void *__vc_dma_alloc(struct virtio_device *vdev, size_t size)
> > > +{
> > > +	return ccw_device_dma_zalloc(to_vc_device(vdev)->cdev, size);
> > > +}
> > > +
> > > +static inline void __vc_dma_free(struct virtio_device *vdev, size_t size,
> > > +				 void *cpu_addr)
> > > +{
> > > +	return ccw_device_dma_free(to_vc_device(vdev)->cdev, cpu_addr, size);
> > > +}
> > > +
> > > +#define vc_dma_alloc_struct(vdev, ptr) \
> > > +	({ptr = __vc_dma_alloc(vdev, sizeof(*(ptr))); })
> > > +#define vc_dma_free_struct(vdev, ptr) \
> > > +	__vc_dma_free(vdev, sizeof(*(ptr)), (ptr))
> > > +  
> > 
> > I *still* don't like these #defines (and the __vc_dma_* functions), as I
> > already commented last time. I think they make it harder to follow the
> > code.
> >   
> 
> Sorry! I think we simply forgot to address this comment of yours. 
> 
> > >  static void drop_airq_indicator(struct virtqueue *vq, struct airq_info *info)
> > >  {
> > >  	unsigned long i, flags;
> > > @@ -336,8 +356,7 @@ static void virtio_ccw_drop_indicator(struct virtio_ccw_device *vcdev,
> > >  	struct airq_info *airq_info = vcdev->airq_info;
> > >  
> > >  	if (vcdev->is_thinint) {
> > > -		thinint_area = kzalloc(sizeof(*thinint_area),
> > > -				       GFP_DMA | GFP_KERNEL);
> > > +		vc_dma_alloc_struct(&vcdev->vdev, thinint_area);  
> > 
> > Last time I wrote:
> > 
> > "Any reason why this takes a detour via the virtio device? The ccw
> >  device is already referenced in vcdev, isn't it?
> >
> > thinint_area = ccw_device_dma_zalloc(vcdev->cdev, sizeof(*thinint_area));
> > 
> >  looks much more obvious to me."
> > 
> > It still seems more obvious to me.
> >  
> 
> 
> The reason why I decided to introduce __vc_dma_alloc() back then is
> because I had no clarity what do we want to do there. If you take a look
> the body of __vc_dma_alloc() changed quite a lot, while I the usage not
> so much. 
> 
> Regarding why is the first argument a pointer struct virtio_device, the
> idea was probably to keep the needs to be ZONE_DMA and can use the full
> 64 bit address space separate. But I abandoned the ideal.
> 
> Also vc_dma_alloc_struct() started out more elaborate (I used to manage
> a dma_addr_t as well -- see RFC).

Understood, history is often important :)

> 
> I'm not quite sure what is your problem with the these. As far as I
> understand, this is another of those matter of taste things. But it ain't
> a big deal. 

Two things:
- The call path goes from the vcdev to the vdev, then back to the vcdev
  and then to the cdev. Going from the vcdev to the cdev  directly
  eliminates the roundtrip via the vdev, which I think does not add
  anything.
- I prefer
	variable = function_returning_a_pointer(...);
  over
	function_setting_a_variable(..., variable);
  The latter obscures the fact that we change the value of the
  variable, unless named very obviously.

> 
> I will change this for v4 as you requested. Again sorry for missing it!

np, can happen.

> 
> Regards,
> Halil
> 
>  
> > >  		if (!thinint_area)
> > >  			return;
> > >  		thinint_area->summary_indicator =  
> >   
> 

  reply	other threads:[~2019-06-04 13:36 UTC|newest]

Thread overview: 72+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-05-29 12:26 [PATCH v3 0/8] s390: virtio: support protected virtualization Michael Mueller
2019-05-29 12:26 ` Michael Mueller
2019-05-29 12:26 ` [PATCH v3 1/8] s390/mm: force swiotlb for " Michael Mueller
2019-05-29 12:26   ` Michael Mueller
2019-05-29 12:26 ` [PATCH v3 2/8] s390/cio: introduce DMA pools to cio Michael Mueller
2019-05-29 12:26   ` Michael Mueller
2019-06-03 11:37   ` Cornelia Huck
2019-06-03 11:37     ` Cornelia Huck
2019-06-03 12:09     ` Michael Mueller
2019-06-03 12:09       ` Michael Mueller
2019-06-03 12:57       ` Halil Pasic
2019-06-03 12:57         ` Halil Pasic
2019-06-03 13:34         ` Cornelia Huck
2019-06-03 13:34           ` Cornelia Huck
2019-06-03 13:43           ` Michael Mueller
2019-06-03 13:43             ` Michael Mueller
2019-06-03 14:04       ` Halil Pasic
2019-06-03 14:04         ` Halil Pasic
2019-06-03 14:22         ` Halil Pasic
2019-06-03 14:22           ` Halil Pasic
2019-06-03 12:47     ` Halil Pasic
2019-06-03 12:47       ` Halil Pasic
2019-06-03 13:40       ` Cornelia Huck
2019-06-03 13:40         ` Cornelia Huck
2019-05-29 12:26 ` [PATCH v3 3/8] s390/cio: add basic protected virtualization support Michael Mueller
2019-05-29 12:26   ` Michael Mueller
2019-06-03 12:06   ` Cornelia Huck
2019-06-03 12:06     ` Cornelia Huck
2019-06-03 12:45     ` Michael Mueller
2019-06-03 12:45       ` Michael Mueller
2019-06-03 13:42       ` Cornelia Huck
2019-06-03 13:42         ` Cornelia Huck
2019-06-03 13:52         ` Michael Mueller
2019-06-03 13:52           ` Michael Mueller
2019-05-29 12:26 ` [PATCH v3 4/8] s390/airq: use DMA memory for adapter interrupts Michael Mueller
2019-05-29 12:26   ` Michael Mueller
2019-06-03 15:27   ` Cornelia Huck
2019-06-03 15:27     ` Cornelia Huck
2019-06-04 13:22     ` Halil Pasic
2019-06-04 13:22       ` Halil Pasic
2019-06-04 14:51       ` Cornelia Huck
2019-06-04 14:51         ` Cornelia Huck
2019-06-04 15:06         ` Halil Pasic
2019-06-04 15:06           ` Halil Pasic
2019-05-29 12:26 ` [PATCH v3 5/8] virtio/s390: use cacheline aligned airq bit vectors Michael Mueller
2019-05-29 12:26   ` Michael Mueller
2019-06-03  9:10   ` Christian Borntraeger
2019-06-03  9:10     ` Christian Borntraeger
2019-06-03 15:40   ` Cornelia Huck
2019-06-03 15:40     ` Cornelia Huck
2019-05-29 12:26 ` [PATCH v3 6/8] virtio/s390: add indirection to indicators access Michael Mueller
2019-05-29 12:26   ` Michael Mueller
2019-06-03 15:55   ` Cornelia Huck
2019-06-03 15:55     ` Cornelia Huck
2019-06-03 17:55     ` Halil Pasic
2019-06-03 17:55       ` Halil Pasic
2019-05-29 12:26 ` [PATCH v3 7/8] virtio/s390: use DMA memory for ccw I/O and classic notifiers Michael Mueller
2019-05-29 12:26   ` Michael Mueller
2019-06-03 16:17   ` Cornelia Huck
2019-06-03 16:17     ` Cornelia Huck
2019-06-04 13:08     ` Halil Pasic
2019-06-04 13:08       ` Halil Pasic
2019-06-04 13:36       ` Cornelia Huck [this message]
2019-06-04 13:36         ` Cornelia Huck
2019-06-04 14:29         ` Halil Pasic
2019-06-04 14:29           ` Halil Pasic
2019-05-29 12:26 ` [PATCH v3 8/8] virtio/s390: make airq summary indicators DMA Michael Mueller
2019-05-29 12:26   ` Michael Mueller
2019-06-03 16:03   ` Cornelia Huck
2019-06-03 16:03     ` Cornelia Huck
2019-06-03 17:54     ` Halil Pasic
2019-06-03 17:54       ` Halil Pasic

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190604153625.6c03c232.cohuck@redhat.com \
    --to=cohuck@redhat.com \
    --cc=alifm@linux.ibm.com \
    --cc=borntraeger@de.ibm.com \
    --cc=farman@linux.ibm.com \
    --cc=frankja@linux.ibm.com \
    --cc=gor@linux.ibm.com \
    --cc=hch@infradead.org \
    --cc=heiko.carstens@de.ibm.com \
    --cc=imbrenda@linux.ibm.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-s390@vger.kernel.org \
    --cc=mihajlov@linux.ibm.com \
    --cc=mimu@linux.ibm.com \
    --cc=mst@redhat.com \
    --cc=pasic@linux.ibm.com \
    --cc=pmorel@linux.ibm.com \
    --cc=sebott@linux.ibm.com \
    --cc=thuth@redhat.com \
    --cc=virtualization@lists.linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.