All of lore.kernel.org
 help / color / mirror / Atom feed
From: Oscar Carter <oscar.carter@gmx.com>
To: Forest Bond <forest@alittletooquiet.net>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Oscar Carter <oscar.carter@gmx.com>,
	Malcolm Priestley <tvboxspy@gmail.com>,
	Quentin Deslandes <quentin.deslandes@itdev.co.uk>,
	Amir Mahdi Ghorbanian <indigoomega021@gmail.com>,
	devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: [PATCH 0/3] staging: vt6656: Cleanup of the vnt_get_frame_time function
Date: Sat,  4 Apr 2020 16:13:57 +0200	[thread overview]
Message-ID: <20200404141400.3772-1-oscar.carter@gmx.com> (raw)

This patch series makes a cleanup of the vnt_get_frame_time function.

The first patch removes the define RATE_54M and changes it for the
ARRAY_SIZE macro. This way avoid possibles issues if the size of the
vnt_frame_time array change in the future but not change accordingly the
RATE_54M constant.

The second patch makes use of the define RATE_11M instead of a magic
number.

The third patch remove unnecessary local variable initialization.

Oscar Carter (3):
  staging: vt6656: Use ARRAY_SIZE instead of define RATE_54M
  staging: vt6656: Use define instead of magic number for tx_rate
  staging: vt6656: Remove unnecessary local variable initialization

 drivers/staging/vt6656/baseband.c | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

--
2.20.1


WARNING: multiple messages have this Message-ID (diff)
From: Oscar Carter <oscar.carter@gmx.com>
To: Forest Bond <forest@alittletooquiet.net>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: devel@driverdev.osuosl.org, Oscar Carter <oscar.carter@gmx.com>,
	Malcolm Priestley <tvboxspy@gmail.com>,
	linux-kernel@vger.kernel.org
Subject: [PATCH 0/3] staging: vt6656: Cleanup of the vnt_get_frame_time function
Date: Sat,  4 Apr 2020 16:13:57 +0200	[thread overview]
Message-ID: <20200404141400.3772-1-oscar.carter@gmx.com> (raw)

This patch series makes a cleanup of the vnt_get_frame_time function.

The first patch removes the define RATE_54M and changes it for the
ARRAY_SIZE macro. This way avoid possibles issues if the size of the
vnt_frame_time array change in the future but not change accordingly the
RATE_54M constant.

The second patch makes use of the define RATE_11M instead of a magic
number.

The third patch remove unnecessary local variable initialization.

Oscar Carter (3):
  staging: vt6656: Use ARRAY_SIZE instead of define RATE_54M
  staging: vt6656: Use define instead of magic number for tx_rate
  staging: vt6656: Remove unnecessary local variable initialization

 drivers/staging/vt6656/baseband.c | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

--
2.20.1

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

             reply	other threads:[~2020-04-04 14:14 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-04 14:13 Oscar Carter [this message]
2020-04-04 14:13 ` [PATCH 0/3] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2020-04-04 14:13 ` [PATCH 1/3] staging: vt6656: Use ARRAY_SIZE instead of define RATE_54M Oscar Carter
2020-04-04 14:13   ` Oscar Carter
2020-04-06 11:13   ` Dan Carpenter
2020-04-06 11:13     ` Dan Carpenter
2020-04-06 16:27     ` Oscar Carter
2020-04-06 16:27       ` Oscar Carter
2020-04-04 14:13 ` [PATCH 2/3] staging: vt6656: Use define instead of magic number for tx_rate Oscar Carter
2020-04-04 14:13   ` Oscar Carter
2020-04-06 11:16   ` Dan Carpenter
2020-04-06 11:16     ` Dan Carpenter
2020-04-06 14:22   ` Greg Kroah-Hartman
2020-04-06 14:22     ` Greg Kroah-Hartman
2020-04-06 16:38     ` Oscar Carter
2020-04-06 16:38       ` Oscar Carter
2020-04-06 17:58       ` Greg Kroah-Hartman
2020-04-06 17:58         ` Greg Kroah-Hartman
2020-04-07 15:28         ` Oscar Carter
2020-04-07 15:28           ` Oscar Carter
2020-04-04 14:14 ` [PATCH 3/3] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter
2020-04-04 14:14   ` Oscar Carter
2020-04-06 11:17   ` Dan Carpenter
2020-04-06 11:17     ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200404141400.3772-1-oscar.carter@gmx.com \
    --to=oscar.carter@gmx.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=forest@alittletooquiet.net \
    --cc=gregkh@linuxfoundation.org \
    --cc=indigoomega021@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=quentin.deslandes@itdev.co.uk \
    --cc=tvboxspy@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.