All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dan Carpenter <dan.carpenter@oracle.com>
To: Oscar Carter <oscar.carter@gmx.com>
Cc: Forest Bond <forest@alittletooquiet.net>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	devel@driverdev.osuosl.org,
	Malcolm Priestley <tvboxspy@gmail.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/3] staging: vt6656: Use define instead of magic number for tx_rate
Date: Mon, 6 Apr 2020 14:16:22 +0300	[thread overview]
Message-ID: <20200406111622.GE2001@kadam> (raw)
In-Reply-To: <20200404141400.3772-3-oscar.carter@gmx.com>

On Sat, Apr 04, 2020 at 04:13:59PM +0200, Oscar Carter wrote:
> Use the define RATE_11M present in the file "device.h" instead of the
> magic number 3. So the code is more clear.
> 
> Signed-off-by: Oscar Carter <oscar.carter@gmx.com>
> ---
>  drivers/staging/vt6656/baseband.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/vt6656/baseband.c b/drivers/staging/vt6656/baseband.c
> index 3e4bd637849a..a785f91c1566 100644
> --- a/drivers/staging/vt6656/baseband.c
> +++ b/drivers/staging/vt6656/baseband.c
> @@ -24,6 +24,7 @@
> 
>  #include <linux/bits.h>
>  #include <linux/kernel.h>
> +#include "device.h"
>  #include "mac.h"
>  #include "baseband.h"
>  #include "rf.h"
> @@ -141,7 +142,7 @@ unsigned int vnt_get_frame_time(u8 preamble_type, u8 pkt_type,
> 
>  	rate = (unsigned int)vnt_frame_time[tx_rate];
> 
> -	if (tx_rate <= 3) {
> +	if (tx_rate <= RATE_11M) {

This is nice.  And if we don't apply patch 1 then it's even nicer
because then "tx_rate" is treated consistently.

Reviewed-by: Dan Carpenter <dan.carpenter@oracle.com>

regards,
dan carpenter


WARNING: multiple messages have this Message-ID (diff)
From: Dan Carpenter <dan.carpenter@oracle.com>
To: Oscar Carter <oscar.carter@gmx.com>
Cc: devel@driverdev.osuosl.org,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Malcolm Priestley <tvboxspy@gmail.com>,
	Forest Bond <forest@alittletooquiet.net>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/3] staging: vt6656: Use define instead of magic number for tx_rate
Date: Mon, 6 Apr 2020 14:16:22 +0300	[thread overview]
Message-ID: <20200406111622.GE2001@kadam> (raw)
In-Reply-To: <20200404141400.3772-3-oscar.carter@gmx.com>

On Sat, Apr 04, 2020 at 04:13:59PM +0200, Oscar Carter wrote:
> Use the define RATE_11M present in the file "device.h" instead of the
> magic number 3. So the code is more clear.
> 
> Signed-off-by: Oscar Carter <oscar.carter@gmx.com>
> ---
>  drivers/staging/vt6656/baseband.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/vt6656/baseband.c b/drivers/staging/vt6656/baseband.c
> index 3e4bd637849a..a785f91c1566 100644
> --- a/drivers/staging/vt6656/baseband.c
> +++ b/drivers/staging/vt6656/baseband.c
> @@ -24,6 +24,7 @@
> 
>  #include <linux/bits.h>
>  #include <linux/kernel.h>
> +#include "device.h"
>  #include "mac.h"
>  #include "baseband.h"
>  #include "rf.h"
> @@ -141,7 +142,7 @@ unsigned int vnt_get_frame_time(u8 preamble_type, u8 pkt_type,
> 
>  	rate = (unsigned int)vnt_frame_time[tx_rate];
> 
> -	if (tx_rate <= 3) {
> +	if (tx_rate <= RATE_11M) {

This is nice.  And if we don't apply patch 1 then it's even nicer
because then "tx_rate" is treated consistently.

Reviewed-by: Dan Carpenter <dan.carpenter@oracle.com>

regards,
dan carpenter

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

  reply	other threads:[~2020-04-06 11:16 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-04 14:13 [PATCH 0/3] staging: vt6656: Cleanup of the vnt_get_frame_time function Oscar Carter
2020-04-04 14:13 ` Oscar Carter
2020-04-04 14:13 ` [PATCH 1/3] staging: vt6656: Use ARRAY_SIZE instead of define RATE_54M Oscar Carter
2020-04-04 14:13   ` Oscar Carter
2020-04-06 11:13   ` Dan Carpenter
2020-04-06 11:13     ` Dan Carpenter
2020-04-06 16:27     ` Oscar Carter
2020-04-06 16:27       ` Oscar Carter
2020-04-04 14:13 ` [PATCH 2/3] staging: vt6656: Use define instead of magic number for tx_rate Oscar Carter
2020-04-04 14:13   ` Oscar Carter
2020-04-06 11:16   ` Dan Carpenter [this message]
2020-04-06 11:16     ` Dan Carpenter
2020-04-06 14:22   ` Greg Kroah-Hartman
2020-04-06 14:22     ` Greg Kroah-Hartman
2020-04-06 16:38     ` Oscar Carter
2020-04-06 16:38       ` Oscar Carter
2020-04-06 17:58       ` Greg Kroah-Hartman
2020-04-06 17:58         ` Greg Kroah-Hartman
2020-04-07 15:28         ` Oscar Carter
2020-04-07 15:28           ` Oscar Carter
2020-04-04 14:14 ` [PATCH 3/3] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter
2020-04-04 14:14   ` Oscar Carter
2020-04-06 11:17   ` Dan Carpenter
2020-04-06 11:17     ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200406111622.GE2001@kadam \
    --to=dan.carpenter@oracle.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=forest@alittletooquiet.net \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=oscar.carter@gmx.com \
    --cc=tvboxspy@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.