All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/5] hw: Replace some impossible checks by assertions
@ 2020-09-01 10:40 Philippe Mathieu-Daudé
  2020-09-01 10:40 ` [PATCH 1/5] hw/gpio/max7310: Remove impossible check Philippe Mathieu-Daudé
                   ` (4 more replies)
  0 siblings, 5 replies; 22+ messages in thread
From: Philippe Mathieu-Daudé @ 2020-09-01 10:40 UTC (permalink / raw)
  To: qemu-devel
  Cc: Peter Maydell, Aleksandar Rikalo, qemu-trivial,
	Philippe Mathieu-Daudé, Philippe Mathieu-Daudé,
	Aleksandar Markovic, qemu-arm, qemu-ppc, Huacai Chen,
	Aurelien Jarno, David Gibson

Trivial patches removing unreachable code.

Philippe Mathieu-Daudé (5):
  hw/gpio/max7310: Remove impossible check
  hw/mips/fuloong2e: Convert pointless error message to an assert()
  hw/ppc/ppc4xx_pci: Use ARRAY_SIZE() instead of magic value
  hw/ppc/ppc4xx_pci: Replace pointless warning by assert()
  hw/isa/isa-bus: Replace hw_error() by assert()

 hw/gpio/max7310.c   | 4 ----
 hw/isa/isa-bus.c    | 9 ++-------
 hw/mips/fuloong2e.c | 5 +----
 hw/ppc/ppc4xx_pci.c | 8 +++-----
 4 files changed, 6 insertions(+), 20 deletions(-)

-- 
2.26.2



^ permalink raw reply	[flat|nested] 22+ messages in thread

end of thread, other threads:[~2021-01-11 17:47 UTC | newest]

Thread overview: 22+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-01 10:40 [PATCH 0/5] hw: Replace some impossible checks by assertions Philippe Mathieu-Daudé
2020-09-01 10:40 ` [PATCH 1/5] hw/gpio/max7310: Remove impossible check Philippe Mathieu-Daudé
2020-09-01 10:42   ` Peter Maydell
2020-09-01 10:40 ` [PATCH 2/5] hw/mips/fuloong2e: Convert pointless error message to an assert() Philippe Mathieu-Daudé
2020-09-01 11:36   ` chen huacai
2020-09-01 17:49   ` Richard Henderson
2020-09-09 13:23   ` Laurent Vivier
2020-09-01 10:40 ` [PATCH 3/5] hw/ppc/ppc4xx_pci: Use ARRAY_SIZE() instead of magic value Philippe Mathieu-Daudé
2020-09-01 17:50   ` Richard Henderson
2020-09-02  1:16   ` David Gibson
2020-09-02  6:53   ` Cédric Le Goater
2020-09-02  8:12     ` Philippe Mathieu-Daudé
2020-09-01 10:40 ` [PATCH 4/5] hw/ppc/ppc4xx_pci: Replace pointless warning by assert() Philippe Mathieu-Daudé
2020-09-01 17:50   ` Richard Henderson
2020-09-02  1:17   ` David Gibson
2021-01-11  1:11   ` Nathan Chancellor
2021-01-11 10:04     ` Philippe Mathieu-Daudé
2021-01-11 16:46       ` Nathan Chancellor
2021-01-11 17:41     ` Peter Maydell
2020-09-01 10:40 ` [PATCH 5/5] hw/isa/isa-bus: Replace hw_error() " Philippe Mathieu-Daudé
2020-09-01 17:50   ` Richard Henderson
2020-09-09 13:25   ` Laurent Vivier

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.