All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/6] arch_init.c cleanup
@ 2020-11-25 20:56 Eduardo Habkost
  2020-11-25 20:56   ` Eduardo Habkost
                   ` (6 more replies)
  0 siblings, 7 replies; 37+ messages in thread
From: Eduardo Habkost @ 2020-11-25 20:56 UTC (permalink / raw)
  To: qemu-devel; +Cc: Thomas Huth, Gerd Hoffmann

This series gets rid of most of the code in arch_init.c.  It
moves the QEMU_ARCH macro definitions to corresponding cpu.h
files, and gets rid of kvm_available() and xen_available().

After this series, only two things remain in arch_init.c:
- the arch_type variable, which seems to be a useful feature; and
- the initialization of graphic_width/graphic_height/graphic_depth,
  which is a hack we must eventually get rid of.

Gerd got rid of the graphic_* initialization hack once (in 2017),
but the series was never merged:
https://lore.kernel.org/qemu-devel/1487715299-21102-5-git-send-email-kraxel@redhat.com

Eduardo Habkost (6):
  arch_init: Move QEMU_ARCH definitions to cpu.h
  accel: accel_available() function
  kvm: Remove kvm_available() function
  xen: Delete xen_available() function
  Remove unnecessary usage of arch_init.h
  Rename arch_init.h to arch_type.h

 include/sysemu/accel.h                      |  1 +
 include/sysemu/{arch_init.h => arch_type.h} |  3 -
 target/alpha/cpu.h                          |  1 +
 target/arm/cpu.h                            |  1 +
 target/avr/cpu.h                            |  1 +
 target/cris/cpu.h                           |  1 +
 target/hppa/cpu.h                           |  1 +
 target/i386/cpu.h                           |  1 +
 target/lm32/cpu.h                           |  1 +
 target/m68k/cpu.h                           |  1 +
 target/microblaze/cpu.h                     |  1 +
 target/mips/cpu.h                           |  1 +
 target/moxie/cpu.h                          |  1 +
 target/nios2/cpu.h                          |  1 +
 target/openrisc/cpu.h                       |  1 +
 target/ppc/cpu.h                            |  1 +
 target/riscv/cpu.h                          |  1 +
 target/rx/cpu.h                             |  1 +
 target/s390x/cpu.h                          |  1 +
 target/sh4/cpu.h                            |  1 +
 target/sparc/cpu.h                          |  1 +
 target/tricore/cpu.h                        |  1 +
 target/unicore32/cpu.h                      |  1 +
 target/xtensa/cpu.h                         |  1 +
 accel/accel.c                               |  6 +-
 blockdev.c                                  |  2 +-
 hw/i386/pc.c                                |  1 -
 hw/i386/pc_piix.c                           |  1 -
 hw/i386/pc_q35.c                            |  1 -
 hw/mips/jazz.c                              |  1 -
 hw/mips/malta.c                             |  1 -
 hw/ppc/prep.c                               |  1 -
 hw/riscv/sifive_e.c                         |  1 -
 hw/riscv/sifive_u.c                         |  1 -
 hw/riscv/spike.c                            |  1 -
 hw/riscv/virt.c                             |  1 -
 monitor/qmp-cmds.c                          |  3 +-
 softmmu/arch_init.c                         | 66 +--------------------
 softmmu/qdev-monitor.c                      |  2 +-
 softmmu/vl.c                                |  8 +--
 stubs/arch_type.c                           |  2 +-
 target/i386/cpu.c                           |  1 -
 target/s390x/cpu.c                          |  1 -
 target/s390x/cpu_models.c                   |  1 -
 target/ppc/translate_init.c.inc             |  1 -
 45 files changed, 37 insertions(+), 92 deletions(-)
 rename include/sysemu/{arch_init.h => arch_type.h} (94%)

-- 
2.28.0




^ permalink raw reply	[flat|nested] 37+ messages in thread

end of thread, other threads:[~2020-11-27 16:52 UTC | newest]

Thread overview: 37+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-25 20:56 [PATCH v2 0/6] arch_init.c cleanup Eduardo Habkost
2020-11-25 20:56 ` [PATCH v2 1/6] arch_init: Move QEMU_ARCH definitions to cpu.h Eduardo Habkost
2020-11-25 20:56   ` Eduardo Habkost
2020-11-26 12:31   ` Thomas Huth
2020-11-26 12:31     ` Thomas Huth
2020-11-27 11:35   ` Cornelia Huck
2020-11-27 11:35     ` Cornelia Huck
2020-11-25 20:56 ` [PATCH v2 2/6] accel: accel_available() function Eduardo Habkost
2020-11-26  9:14   ` Claudio Fontana
2020-11-26 13:36     ` Eduardo Habkost
2020-11-26 14:13       ` Claudio Fontana
2020-11-26 14:25         ` Paolo Bonzini
2020-11-26 21:06           ` Claudio Fontana
2020-11-26 21:48             ` Eduardo Habkost
2020-11-27  9:04               ` Claudio Fontana
2020-11-27 14:45                 ` Markus Armbruster
2020-11-27 14:58                   ` Claudio Fontana
2020-11-27 16:47                     ` Markus Armbruster
2020-11-27  5:00             ` Paolo Bonzini
2020-11-27 12:08   ` Cornelia Huck
2020-11-25 20:56 ` [PATCH v2 3/6] kvm: Remove kvm_available() function Eduardo Habkost
2020-11-25 20:56   ` Eduardo Habkost
2020-11-27 12:10   ` Cornelia Huck
2020-11-27 12:10     ` Cornelia Huck
2020-11-25 20:56 ` [PATCH v2 4/6] xen: Delete xen_available() function Eduardo Habkost
2020-11-25 20:56   ` Eduardo Habkost
2020-11-27 12:11   ` Cornelia Huck
2020-11-27 12:11     ` Cornelia Huck
2020-11-27 14:52   ` Anthony PERARD via
2020-11-27 14:52     ` Anthony PERARD
2020-11-25 20:56 ` [PATCH v2 5/6] Remove unnecessary usage of arch_init.h Eduardo Habkost
2020-11-25 20:56   ` Eduardo Habkost
2020-11-27 12:23   ` Cornelia Huck
2020-11-27 12:23     ` Cornelia Huck
2020-11-25 20:56 ` [PATCH v2 6/6] Rename arch_init.h to arch_type.h Eduardo Habkost
2020-11-27 12:25   ` Cornelia Huck
2020-11-25 22:23 ` [PATCH v2 0/6] arch_init.c cleanup Roman Bolshakov

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.