All of lore.kernel.org
 help / color / mirror / Atom feed
From: AKASHI Takahiro <takahiro.akashi@linaro.org>
To: Adrian Hunter <adrian.hunter@intel.com>
Cc: ulf.hansson@linaro.org, linux-mmc@vger.kernel.org,
	linux-kernel@vger.kernel.org, ben.chuang@genesyslogic.com.tw,
	greg.tu@genesyslogic.com.tw
Subject: Re: [RFC PATCH v3.1 13/27] mmc: sdhci-uhs2: add set_power() to support vdd2
Date: Mon, 30 Nov 2020 16:15:50 +0900	[thread overview]
Message-ID: <20201130071550.GD48535@laputa> (raw)
In-Reply-To: <3b47a2d4-a281-3fac-29c4-82dd769459a1@intel.com>

On Thu, Nov 26, 2020 at 10:16:27AM +0200, Adrian Hunter wrote:
> On 6/11/20 4:27 am, AKASHI Takahiro wrote:
> > This is a UHS-II version of sdhci's set_power operation.
> > VDD2, as well as VDD, is handled here.
> > 
> > Signed-off-by: Ben Chuang <ben.chuang@genesyslogic.com.tw>
> > Signed-off-by: AKASHI Takahiro <takahiro.akashi@linaro.org>
> > ---
> >  drivers/mmc/host/sdhci-uhs2.c | 80 +++++++++++++++++++++++++++++++++++
> >  drivers/mmc/host/sdhci-uhs2.h |  2 +
> >  drivers/mmc/host/sdhci.c      | 58 +++++++++++++++----------
> >  drivers/mmc/host/sdhci.h      |  2 +
> >  4 files changed, 119 insertions(+), 23 deletions(-)
> > 
> > diff --git a/drivers/mmc/host/sdhci-uhs2.c b/drivers/mmc/host/sdhci-uhs2.c
> > index e2b9743fe17d..2bf78cc4e9ed 100644
> > --- a/drivers/mmc/host/sdhci-uhs2.c
> > +++ b/drivers/mmc/host/sdhci-uhs2.c
> > @@ -98,6 +98,86 @@ void sdhci_uhs2_reset(struct sdhci_host *host, u16 mask)
> >  }
> >  EXPORT_SYMBOL_GPL(sdhci_uhs2_reset);
> >  
> > +void sdhci_uhs2_set_power(struct sdhci_host *host, unsigned char mode,
> > +			  unsigned short vdd)
> 
> This function isn't used, so let's rename it sdhci_uhs2_set_power_noreg and
> drop regulator support.

I have no strong opinion, but here Ben might want to further rework
the new sdhci_uhs2_set_power_noreg() now that it is almost the same as
GLI's gl9755_set_power()(, adding a new quirk?).

> > +{
> > +	struct mmc_host *mmc = host->mmc;
> > +	u8 pwr;
> > +
> > +	/* FIXME: check if flags & MMC_UHS2_SUPPORT? */
> > +	if (!(host->mmc->caps & MMC_CAP_UHS2)) {
> 
> As commented in another patch, please use a helper fn

As said, I would defer this.

> > +		sdhci_set_power(host, mode, vdd);
> > +		return;
> > +	}
> > +
> > +	if (mode != MMC_POWER_OFF) {
> > +		pwr = sdhci_get_vdd_value(vdd);
> 
> Simpler to open code this esp. as there are only 2 valid values:
> 
> 		switch (1 << vdd) {

Can you ignore MMC_VDD_165_195 and MMC_VDD_20_21 here?

> 		case MMC_VDD_29_30..MMC_VDD_30_31:
> 			pwr = SDHCI_POWER_300;
> 			break;
> 		case MMC_VDD_32_33..MMC_VDD_33_34:
> 			pwr = SDHCI_POWER_330;
> 			break;
> 		default:
> 			WARN(1, "%s: Invalid vdd %#x\n",
> 			     mmc_hostname(host->mmc), vdd);
> 			break;
> 		}
> 
> 
> > +		if (!pwr)
> > +			WARN(1, "%s: Invalid vdd %#x\n",
> > +			     mmc_hostname(host->mmc), vdd);
> > +
> > +		pwr |= SDHCI_VDD2_POWER_180;
> > +	}
> > +
> > +	if (host->pwr == pwr)
> > +		return;
> > +	host ->pwr = pwr;
> > +
> > +	if (pwr == 0) {
> > +		sdhci_writeb(host, 0, SDHCI_POWER_CONTROL);
> > +
> > +		if (!IS_ERR(host->mmc->supply.vmmc))
> > +			mmc_regulator_set_ocr(mmc, mmc->supply.vmmc, 0);
> > +		if (!IS_ERR_OR_NULL(host->mmc->supply.vmmc2))
> > +			mmc_regulator_set_ocr(mmc, mmc->supply.vmmc2, 0);
> > +
> > +		if (host->quirks2 & SDHCI_QUIRK2_CARD_ON_NEEDS_BUS_ON)
> 
> Please drop support for legacy quirk SDHCI_QUIRK2_CARD_ON_NEEDS_BUS_ON

Okay.

> 
> > +			sdhci_runtime_pm_bus_off(host);
> > +	} else {
> > +		if (!IS_ERR(host->mmc->supply.vmmc))
> > +			mmc_regulator_set_ocr(mmc, mmc->supply.vmmc, vdd);
> > +		if (!IS_ERR_OR_NULL(host->mmc->supply.vmmc2))
> > +			/* support 1.8v only for now */
> > +			mmc_regulator_set_ocr(mmc, mmc->supply.vmmc2,
> > +					      fls(MMC_VDD2_165_195) - 1);
> > +
> > +		/*
> > +		 * Spec says that we should clear the power reg before setting
> > +		 * a new value. Some controllers don't seem to like this though.
> > +		 */
> > +		if (!(host->quirks & SDHCI_QUIRK_SINGLE_POWER_WRITE))
> 
> Please drop support for legacy quirk here and several cases below.  As I
> mentioned in another patch, just put a comment somewhere listing what is
> not supported for UHS2 host controllers.

Okay.

-Takahiro Akashi

> 
> > +			sdhci_writeb(host, 0, SDHCI_POWER_CONTROL);
> > +
> > +		/*
> > +		 * At least the Marvell CaFe chip gets confused if we set the
> > +		 * voltage and set turn on power at the same time, so set the
> > +		 * voltage first.
> > +		 */
> > +		if (host->quirks & SDHCI_QUIRK_NO_SIMULT_VDD_AND_POWER)
> > +			sdhci_writeb(host, pwr, SDHCI_POWER_CONTROL);
> > +
> > +		/* vdd first */
> > +		pwr |= SDHCI_POWER_ON;
> > +		sdhci_writeb(host, pwr & 0xf, SDHCI_POWER_CONTROL);
> > +		mdelay(5);
> > +
> > +		pwr |= SDHCI_VDD2_POWER_ON;
> > +		sdhci_writeb(host, pwr, SDHCI_POWER_CONTROL);
> > +		mdelay(5);
> > +
> > +		if (host->quirks2 & SDHCI_QUIRK2_CARD_ON_NEEDS_BUS_ON)
> > +			sdhci_runtime_pm_bus_on(host);
> > +
> > +		/*
> > +		 * Some controllers need an extra 10ms delay of 10ms before
> > +		 * they can apply clock after applying power
> > +		 */
> > +		if (host->quirks & SDHCI_QUIRK_DELAY_AFTER_POWER)
> > +			mdelay(10);
> > +	}
> > +}
> > +EXPORT_SYMBOL_GPL(sdhci_uhs2_set_power);
> > +
> >  /*****************************************************************************\
> >   *                                                                           *
> >   * Driver init/exit                                                          *
> > diff --git a/drivers/mmc/host/sdhci-uhs2.h b/drivers/mmc/host/sdhci-uhs2.h
> > index 7bb7a0d67109..3c19d8e44c36 100644
> > --- a/drivers/mmc/host/sdhci-uhs2.h
> > +++ b/drivers/mmc/host/sdhci-uhs2.h
> > @@ -211,5 +211,7 @@ struct sdhci_host;
> >  
> >  void sdhci_uhs2_dump_regs(struct sdhci_host *host);
> >  void sdhci_uhs2_reset(struct sdhci_host *host, u16 mask);
> > +void sdhci_uhs2_set_power(struct sdhci_host *host, unsigned char mode,
> > +			  unsigned short vdd);
> >  
> >  #endif /* __SDHCI_UHS2_H */
> > diff --git a/drivers/mmc/host/sdhci.c b/drivers/mmc/host/sdhci.c
> > index af336bdb4305..0b741eb546cb 100644
> > --- a/drivers/mmc/host/sdhci.c
> > +++ b/drivers/mmc/host/sdhci.c
> > @@ -187,13 +187,14 @@ static void sdhci_disable_card_detection(struct sdhci_host *host)
> >  	sdhci_set_card_detection(host, false);
> >  }
> >  
> > -static void sdhci_runtime_pm_bus_on(struct sdhci_host *host)
> > +void sdhci_runtime_pm_bus_on(struct sdhci_host *host)
> >  {
> >  	if (host->bus_on)
> >  		return;
> >  	host->bus_on = true;
> >  	pm_runtime_get_noresume(host->mmc->parent);
> >  }
> > +EXPORT_SYMBOL_GPL(sdhci_runtime_pm_bus_on);
> >  
> >  void sdhci_runtime_pm_bus_off(struct sdhci_host *host)
> >  {
> > @@ -2017,36 +2018,47 @@ static void sdhci_set_power_reg(struct sdhci_host *host, unsigned char mode,
> >  		sdhci_writeb(host, 0, SDHCI_POWER_CONTROL);
> >  }
> >  
> > +unsigned short sdhci_get_vdd_value(unsigned short vdd)
> > +{
> > +	u8 pwr;
> > +
> > +	switch (1 << vdd) {
> > +	case MMC_VDD_165_195:
> > +	/*
> > +	 * Without a regulator, SDHCI does not support 2.0v
> > +	 * so we only get here if the driver deliberately
> > +	 * added the 2.0v range to ocr_avail. Map it to 1.8v
> > +	 * for the purpose of turning on the power.
> > +	 */
> > +	case MMC_VDD_20_21:
> > +		pwr = SDHCI_POWER_180;
> > +		break;
> > +	case MMC_VDD_29_30:
> > +	case MMC_VDD_30_31:
> > +		pwr = SDHCI_POWER_300;
> > +		break;
> > +	case MMC_VDD_32_33:
> > +	case MMC_VDD_33_34:
> > +		pwr = SDHCI_POWER_330;
> > +		break;
> > +	default:
> > +		pwr = 0;
> > +	}
> > +
> > +	return pwr;
> > +}
> > +EXPORT_SYMBOL_GPL(sdhci_get_vdd_value);
> > +
> >  void sdhci_set_power_noreg(struct sdhci_host *host, unsigned char mode,
> >  			   unsigned short vdd)
> >  {
> >  	u8 pwr = 0;
> >  
> >  	if (mode != MMC_POWER_OFF) {
> > -		switch (1 << vdd) {
> > -		case MMC_VDD_165_195:
> > -		/*
> > -		 * Without a regulator, SDHCI does not support 2.0v
> > -		 * so we only get here if the driver deliberately
> > -		 * added the 2.0v range to ocr_avail. Map it to 1.8v
> > -		 * for the purpose of turning on the power.
> > -		 */
> > -		case MMC_VDD_20_21:
> > -			pwr = SDHCI_POWER_180;
> > -			break;
> > -		case MMC_VDD_29_30:
> > -		case MMC_VDD_30_31:
> > -			pwr = SDHCI_POWER_300;
> > -			break;
> > -		case MMC_VDD_32_33:
> > -		case MMC_VDD_33_34:
> > -			pwr = SDHCI_POWER_330;
> > -			break;
> > -		default:
> > +		pwr = sdhci_get_vdd_value(vdd);
> > +		if (!pwr)
> >  			WARN(1, "%s: Invalid vdd %#x\n",
> >  			     mmc_hostname(host->mmc), vdd);
> > -			break;
> > -		}
> >  	}
> >  
> >  	if (host->pwr == pwr)
> > diff --git a/drivers/mmc/host/sdhci.h b/drivers/mmc/host/sdhci.h
> > index b9932423db08..2b5b8295cf92 100644
> > --- a/drivers/mmc/host/sdhci.h
> > +++ b/drivers/mmc/host/sdhci.h
> > @@ -831,6 +831,7 @@ static inline void sdhci_read_caps(struct sdhci_host *host)
> >  	__sdhci_read_caps(host, NULL, NULL, NULL);
> >  }
> >  
> > +void sdhci_runtime_pm_bus_on(struct sdhci_host *host);
> >  void sdhci_runtime_pm_bus_off(struct sdhci_host *host);
> >  u16 sdhci_calc_clk(struct sdhci_host *host, unsigned int clock,
> >  		   unsigned int *actual_clock);
> > @@ -841,6 +842,7 @@ void sdhci_set_power(struct sdhci_host *host, unsigned char mode,
> >  void sdhci_set_power_and_bus_voltage(struct sdhci_host *host,
> >  				     unsigned char mode,
> >  				     unsigned short vdd);
> > +unsigned short sdhci_get_vdd_value(unsigned short vdd);
> >  void sdhci_set_power_noreg(struct sdhci_host *host, unsigned char mode,
> >  			   unsigned short vdd);
> >  void sdhci_request(struct mmc_host *mmc, struct mmc_request *mrq);
> > 
> 

  reply	other threads:[~2020-11-30  7:16 UTC|newest]

Thread overview: 74+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-06  2:26 [RFC PATCH v3.1 00/27] Add support UHS-II for GL9755 AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 01/27] mmc: add UHS-II related definitions in public headers AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 02/27] mmc: core: UHS-II support, modify power-up sequence AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 03/27] mmc: core: UHS-II support, skip set_chip_select() AKASHI Takahiro
2020-11-10  7:15   ` Bough Chen
2020-11-06  2:27 ` [RFC PATCH v3.1 04/27] mmc: core: UHS-II support, try to select UHS-II interface AKASHI Takahiro
2020-11-06  4:24   ` kernel test robot
2020-11-06  2:27 ` [RFC PATCH v3.1 05/27] mmc: core: UHS-II support, skip TMODE setup in some cases AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 06/27] mmc: core: UHS-II support, generate UHS-II SD command packet AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 07/27] mmc: core: UHS-II support, set APP_CMD bit if necessary AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 08/27] mmc: sdhci: add a kernel configuration for enabling UHS-II support AKASHI Takahiro
2020-11-26  8:14   ` Adrian Hunter
2020-11-30  5:17     ` AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 09/27] mmc: sdhci: add UHS-II related definitions in headers AKASHI Takahiro
2020-11-26  8:15   ` Adrian Hunter
2020-11-30  5:21     ` AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 10/27] mmc: sdhci: add UHS-II module AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 11/27] mmc: sdhci-uhs2: dump UHS-II registers AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 12/27] mmc: sdhci-uhs2: add reset function AKASHI Takahiro
2020-11-26  8:16   ` Adrian Hunter
2020-11-30  6:20     ` AKASHI Takahiro
2020-11-30  7:37       ` Adrian Hunter
2020-11-06  2:27 ` [RFC PATCH v3.1 13/27] mmc: sdhci-uhs2: add set_power() to support vdd2 AKASHI Takahiro
2020-11-06  8:11   ` kernel test robot
2020-11-26  8:16   ` Adrian Hunter
2020-11-30  7:15     ` AKASHI Takahiro [this message]
2020-11-30  7:44       ` Adrian Hunter
2020-11-06  2:27 ` [RFC PATCH v3.1 14/27] mmc: sdhci-uhs2: skip signal_voltage_switch() AKASHI Takahiro
2020-11-26  8:16   ` Adrian Hunter
2020-11-30  7:38     ` AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 15/27] mmc: sdhci-uhs2: add set_timeout() AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 16/27] mmc: sdhci-uhs2: add set_ios() AKASHI Takahiro
2020-11-06  4:06   ` kernel test robot
2020-11-06  8:40   ` kernel test robot
2020-11-26  8:17   ` Adrian Hunter
2020-11-30  7:51     ` AKASHI Takahiro
2020-12-03  9:51       ` Adrian Hunter
2020-11-06  2:27 ` [RFC PATCH v3.1 17/27] mmc: sdhci-uhs2: add detect_init() to detect the interface AKASHI Takahiro
2020-11-26  8:17   ` Adrian Hunter
2020-12-01  2:25     ` AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 18/27] mmc: sdhci-uhs2: add clock operations AKASHI Takahiro
2020-11-26  8:17   ` Adrian Hunter
2020-12-01  2:27     ` AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 19/27] mmc: sdhci-uhs2: add set_reg() to initialise the interface AKASHI Takahiro
2020-11-26  8:18   ` Adrian Hunter
2020-12-01  2:28     ` AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 20/27] mmc: sdhci-uhs2: add request() and others AKASHI Takahiro
2020-11-06  4:47   ` kernel test robot
2020-11-26  8:18   ` Adrian Hunter
2020-12-01  2:40     ` AKASHI Takahiro
2020-12-01 11:24       ` Adrian Hunter
2020-11-06  2:27 ` [RFC PATCH v3.1 21/27] mmc: sdhci-uhs2: add irq() " AKASHI Takahiro
2020-12-01 16:46   ` Adrian Hunter
2020-12-08  7:37     ` AKASHI Takahiro
2020-12-08  8:37       ` Adrian Hunter
2020-11-06  2:27 ` [RFC PATCH v3.1 22/27] mmc: sdhci-uhs2: add add_host() and others to set up the driver AKASHI Takahiro
2020-12-03  9:42   ` Adrian Hunter
2020-12-08  7:42     ` AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 23/27] mmc: sdhci-uhs2: add pre-detect_init hook AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 24/27] mmc: core: add post-mmc_attach_sd hook AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 25/27] mmc: sdhci-uhs2: " AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 26/27] mmc: sdhci-pci: add UHS-II support framework AKASHI Takahiro
2020-11-06  2:27 ` [RFC PATCH v3.1 27/27] mmc: sdhci-pci-gli: enable UHS-II mode for GL9755 AKASHI Takahiro
2020-11-06  4:47   ` kernel test robot
2020-11-09  4:38   ` kernel test robot
2020-11-25  7:41 ` [RFC PATCH v3.1 00/27] Add support UHS-II " AKASHI Takahiro
2020-11-25 10:43   ` Ulf Hansson
2020-11-26  0:06     ` AKASHI Takahiro
2020-11-26  8:18   ` Adrian Hunter
2020-12-01  3:09     ` AKASHI Takahiro
2020-12-03  9:55       ` Adrian Hunter
2020-12-08  7:58         ` AKASHI Takahiro
2020-12-08  8:48           ` Adrian Hunter
2020-12-03 10:02       ` Adrian Hunter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201130071550.GD48535@laputa \
    --to=takahiro.akashi@linaro.org \
    --cc=adrian.hunter@intel.com \
    --cc=ben.chuang@genesyslogic.com.tw \
    --cc=greg.tu@genesyslogic.com.tw \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mmc@vger.kernel.org \
    --cc=ulf.hansson@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.