All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v3 0/4] console: remove #ifdef CONFIG when it is possible
@ 2020-12-18 11:46 Patrick Delaunay
  2020-12-18 11:46 ` [PATCH v3 1/4] " Patrick Delaunay
                   ` (3 more replies)
  0 siblings, 4 replies; 13+ messages in thread
From: Patrick Delaunay @ 2020-12-18 11:46 UTC (permalink / raw)
  To: u-boot


Hi,

It is the V3 of serie [1] after Simon Glass comments.

Use 'if (IS_ENABLED(CONFIG...))' instead of '#if or #ifdef' where possible

This patchset can applied on master branch after the serie [2]
(for the new order of test in function putc() and puts()
 done in "console: allow to record console output before ready"
)

For information:

I try to remove the sandox code in [3] (with the associated tests
#ifdef CONFIG_SANDBOX) but it wasn't a correct idea.

I will pushed a separate serie to remove the remaining
#ifdef CONFIG_VIDCONSOLE_AS_LCD [4]

[1] http://patchwork.ozlabs.org/project/uboot/list/?series=218309

[2] http://patchwork.ozlabs.org/project/uboot/list/?series=217079
    "log: don't build the trace buffer when log is not ready"

[3] http://patchwork.ozlabs.org/project/uboot/patch/20201127114927.2.Ida70f4fb1524187703e9240d63e436f8ae5adaab at changeid/
    "[2/2] console: sandbox: remove unnecessary sandbox code"

[4] http://patchwork.ozlabs.org/project/uboot/list/?series=218307
    "video: remove VIDCONSOLE_AS_LCD and VIDCONSOLE_AS_NAME"


Changes in v3:
- update commit message with new function name console_has_tstc

Changes in v2:
- update also #ifdef CONFIG_SANDBOX after Simon Glass remark
  (code can't be removed to avoid to rely sandbox on debug uart)
- move the tests on gd->flags & GD_FLG_RECORD in helper functions
- remove test on IS_ENABLED(CONFIG_CONSOLE_RECORD)
  before to call helper functions
- add comment for tstcdev variable
- rename console_tstc_check to console_has_tstc

Patrick Delaunay (4):
  console: remove #ifdef CONFIG when it is possible
  console: add function console_devices_set
  console: remove #ifdef CONFIG_CONSOLE_RECORD
  console: add console_has_tstc helper function for CONSOLE_MUX

 common/console.c | 310 ++++++++++++++++++++++++++---------------------
 1 file changed, 175 insertions(+), 135 deletions(-)

-- 
2.17.1

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2021-01-16 16:24 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-12-18 11:46 [PATCH v3 0/4] console: remove #ifdef CONFIG when it is possible Patrick Delaunay
2020-12-18 11:46 ` [PATCH v3 1/4] " Patrick Delaunay
2020-12-19  3:34   ` Simon Glass
2021-01-16 16:24   ` Tom Rini
2020-12-18 11:46 ` [PATCH v3 2/4] console: add function console_devices_set Patrick Delaunay
2021-01-16 16:24   ` Tom Rini
2020-12-18 11:46 ` [PATCH v3 3/4] console: remove #ifdef CONFIG_CONSOLE_RECORD Patrick Delaunay
2020-12-19  3:34   ` Simon Glass
2021-01-04 13:18     ` Patrick DELAUNAY
2021-01-16 16:24   ` Tom Rini
2020-12-18 11:46 ` [PATCH v3 4/4] console: add console_has_tstc helper function for CONSOLE_MUX Patrick Delaunay
2020-12-19  3:34   ` Simon Glass
2021-01-16 16:24   ` Tom Rini

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.