All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v3 00/11] gpio: implement the configfs testing module
@ 2021-03-09 20:59 Bartosz Golaszewski
  2021-03-09 20:59 ` [PATCH v3 01/11] configfs: increase the item name length Bartosz Golaszewski
                   ` (11 more replies)
  0 siblings, 12 replies; 18+ messages in thread
From: Bartosz Golaszewski @ 2021-03-09 20:59 UTC (permalink / raw)
  To: Joel Becker, Christoph Hellwig, Shuah Khan, Linus Walleij,
	Andy Shevchenko, Uwe Kleine-König, Geert Uytterhoeven,
	Kent Gibson, Jonathan Corbet, Greg Kroah-Hartman
  Cc: linux-gpio, linux-kernel, linux-doc, Bartosz Golaszewski

From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

This series adds a new GPIO testing module based on configfs committable items
and sysfs. The goal is to provide a testing driver that will be configurable
at runtime (won't need module reload) and easily extensible. The control over
the attributes is also much more fine-grained than in gpio-mockup.

This series also contains a respin of the patches I sent separately to the
configfs maintainers - these patches implement the concept of committable
items that was well defined for a long time but never actually completed.

Apart from the new driver itself, its selftests and the configfs patches, this
series contains some changes to the bitmap API - most importantly: it adds
devres managed variants of bitmap_alloc() and bitmap_zalloc().

v1 -> v2:
- add selftests for gpio-sim
- add helper programs for selftests
- update the configfs rename callback to work with the new API introduced in
  v5.11
- fix a missing quote in the documentation
- use !! whenever using bits operation that are required to return 0 or 1
- use provided bitmap API instead of reimplementing copy or fill operations
- fix a deadlock in gpio_sim_direction_output()
- add new read-only configfs attributes for mapping of configfs items to GPIO
  device names
- and address other minor issues pointed out in reviews of v1

v2 -> v3:
- use devm_bitmap_alloc() instead of the zalloc variant if we're initializing
  the bitmap with 1s
- drop the patch exporting device_is_bound()
- don't return -ENODEV from dev_nam and chip_name configfs attributes, return
  a string indicating that the device is not available yet ('n/a')
- fix indentation where it makes sense
- don't protect IDA functions which use their own locking and where it's not
  needed
- use kmemdup() instead of kzalloc() + memcpy()
- collected review tags
- minor coding style fixes

Bartosz Golaszewski (11):
  configfs: increase the item name length
  configfs: use (1UL << bit) for internal flags
  configfs: implement committable items
  samples: configfs: add a committable group
  lib: bitmap: remove the 'extern' keyword from function declarations
  lib: bitmap: order includes alphabetically
  lib: bitmap: provide devm_bitmap_alloc() and devm_bitmap_zalloc()
  gpio: sim: new testing module
  selftests: gpio: provide a helper for reading chip info
  selftests: gpio: add a helper for reading GPIO line names
  selftests: gpio: add test cases for gpio-sim

 Documentation/admin-guide/gpio/gpio-sim.rst   |  72 ++
 Documentation/filesystems/configfs.rst        |   6 +-
 drivers/gpio/Kconfig                          |   8 +
 drivers/gpio/Makefile                         |   1 +
 drivers/gpio/gpio-sim.c                       | 879 ++++++++++++++++++
 fs/configfs/configfs_internal.h               |  22 +-
 fs/configfs/dir.c                             | 245 ++++-
 include/linux/bitmap.h                        | 127 +--
 include/linux/configfs.h                      |   3 +-
 lib/bitmap.c                                  |  42 +-
 samples/configfs/configfs_sample.c            | 153 +++
 tools/testing/selftests/gpio/.gitignore       |   2 +
 tools/testing/selftests/gpio/Makefile         |   4 +-
 tools/testing/selftests/gpio/config           |   1 +
 tools/testing/selftests/gpio/gpio-chip-info.c |  57 ++
 tools/testing/selftests/gpio/gpio-line-name.c |  55 ++
 tools/testing/selftests/gpio/gpio-sim.sh      | 229 +++++
 17 files changed, 1820 insertions(+), 86 deletions(-)
 create mode 100644 Documentation/admin-guide/gpio/gpio-sim.rst
 create mode 100644 drivers/gpio/gpio-sim.c
 create mode 100644 tools/testing/selftests/gpio/gpio-chip-info.c
 create mode 100644 tools/testing/selftests/gpio/gpio-line-name.c
 create mode 100755 tools/testing/selftests/gpio/gpio-sim.sh

-- 
2.30.1


^ permalink raw reply	[flat|nested] 18+ messages in thread

end of thread, other threads:[~2021-03-12 11:05 UTC | newest]

Thread overview: 18+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-03-09 20:59 [PATCH v3 00/11] gpio: implement the configfs testing module Bartosz Golaszewski
2021-03-09 20:59 ` [PATCH v3 01/11] configfs: increase the item name length Bartosz Golaszewski
2021-03-09 20:59 ` [PATCH v3 02/11] configfs: use (1UL << bit) for internal flags Bartosz Golaszewski
2021-03-09 20:59 ` [PATCH v3 03/11] configfs: implement committable items Bartosz Golaszewski
2021-03-09 20:59 ` [PATCH v3 04/11] samples: configfs: add a committable group Bartosz Golaszewski
2021-03-09 20:59 ` [PATCH v3 05/11] lib: bitmap: remove the 'extern' keyword from function declarations Bartosz Golaszewski
2021-03-09 20:59 ` [PATCH v3 06/11] lib: bitmap: order includes alphabetically Bartosz Golaszewski
2021-03-09 20:59 ` [PATCH v3 07/11] lib: bitmap: provide devm_bitmap_alloc() and devm_bitmap_zalloc() Bartosz Golaszewski
2021-03-10  9:48   ` Greg Kroah-Hartman
2021-03-09 20:59 ` [PATCH v3 08/11] gpio: sim: new testing module Bartosz Golaszewski
2021-03-10 12:28   ` Andy Shevchenko
2021-03-12  8:54     ` Bartosz Golaszewski
2021-03-12 11:03       ` Andy Shevchenko
2021-03-11  0:07   ` Linus Walleij
2021-03-09 20:59 ` [PATCH v3 09/11] selftests: gpio: provide a helper for reading chip info Bartosz Golaszewski
2021-03-09 20:59 ` [PATCH v3 10/11] selftests: gpio: add a helper for reading GPIO line names Bartosz Golaszewski
2021-03-09 20:59 ` [PATCH v3 11/11] selftests: gpio: add test cases for gpio-sim Bartosz Golaszewski
2021-03-10  9:51 ` [PATCH v3 00/11] gpio: implement the configfs testing module Greg Kroah-Hartman

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.