All of lore.kernel.org
 help / color / mirror / Atom feed
From: Guenter Roeck <linux@roeck-us.net>
To: Krzysztof Adamski <krzysztof.adamski@nokia.com>
Cc: Jean Delvare <jdelvare@suse.com>,
	Rob Herring <robh+dt@kernel.org>,
	linux-hwmon@vger.kernel.org, devicetree@vger.kernel.org
Subject: Re: [PATCH v3 11/11] dt-bindings: hwmon: allow specifying channels for tmp421
Date: Sat, 2 Oct 2021 07:22:19 -0700	[thread overview]
Message-ID: <20211002142219.GC34532@roeck-us.net> (raw)
In-Reply-To: <3ff7b4cc57dab2073fa091072366c1e524631729.1632984254.git.krzysztof.adamski@nokia.com>

On Thu, Sep 30, 2021 at 09:19:49AM +0200, Krzysztof Adamski wrote:
> Add binding description for the per temperature channel configuration
> like labels and n-factor.
> 
> Signed-off-by: Krzysztof Adamski <krzysztof.adamski@nokia.com>
> ---
>  .../devicetree/bindings/hwmon/ti,tmp421.yaml  | 66 +++++++++++++++++++
>  1 file changed, 66 insertions(+)
> 
> diff --git a/Documentation/devicetree/bindings/hwmon/ti,tmp421.yaml b/Documentation/devicetree/bindings/hwmon/ti,tmp421.yaml
> index 47040ace4f73..0d4ea2209500 100644
> --- a/Documentation/devicetree/bindings/hwmon/ti,tmp421.yaml
> +++ b/Documentation/devicetree/bindings/hwmon/ti,tmp421.yaml
> @@ -24,12 +24,49 @@ properties:
>    reg:
>      maxItems: 1
>  
> +  '#address-cells':
> +    const: 1
> +
> +  '#size-cells':
> +    const: 0
> +
>  required:
>    - compatible
>    - reg
>  
>  additionalProperties: false
>  
> +patternProperties:
> +  "^input@([0-4])$":

Was there agreement on "input" ? It is a somewhat odd name for a temperature
sensor. If that name can be used to distinguish child sensor types, it might
make sense to have a well defined name to state that this is a temperature
sensor.

> +    type: object
> +    description: |
> +      Represents channels of the device and their specific configuration.
> +
> +    properties:
> +      reg:
> +        description: |
> +          The channel number. 0 is local channel, 1-4 are remote channels

Which of the supported chips has 4 remote channels ?

> +        items:
> +          minimum: 0
> +          maximum: 4
> +
> +      label:
> +        description: |
> +          A descriptive name for this channel, like "ambient" or "psu".
> +
> +      n-factor:

n-factor or "ti,n-factor" ? The unit is chip specific, after all.

> +        description: |
> +          The value (two's complement) to be programmed in the channel specific N correction register.
> +          For remote channels only.
> +        items:
> +          minimum: 0
> +          maximum: 1

Is this the correct value range ? The value range (in integer form) is
-128 .. 127 (or 0 .. 255 as unsigned), not 0..1.

> +
> +    required:
> +      - reg
> +
> +    additionalProperties: false
> +
>  examples:
>    - |
>      i2c {
> @@ -41,3 +78,32 @@ examples:
>          reg = <0x4c>;
>        };
>      };
> +  - |
> +    i2c {
> +      #address-cells = <1>;
> +      #size-cells = <0>;
> +
> +      sensor@4c {
> +        compatible = "ti,tmp422";
> +        reg = <0x4c>;
> +        #address-cells = <1>;
> +        #size-cells = <0>;
> +
> +        input@0 {
> +          reg = <0x0>;
> +          n-factor = <0x1>;
> +          label = "local";
> +        };
> +
> +        input@1 {
> +          reg = <0x1>;
> +          n-factor = <0x0>;
> +          label = "somelabel";
> +        };
> +
> +        input@2 {
> +          reg = <0x2>;
> +          status = "disabled";
> +        };
> +      };
> +    };
> -- 
> 2.31.1
> 

  reply	other threads:[~2021-10-02 14:22 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-09-30  6:47 [PATCH v3 00/11] Add per channel properies support in tmp421 Krzysztof Adamski
2021-09-30  6:57 ` [PATCH v3 01/11] dt-bindings: hwmon: add missing tmp421 binding Krzysztof Adamski
2021-10-04 16:46   ` Rob Herring
2021-09-30  6:58 ` [PATCH v3 02/11] hwmon: (tmp421) introduce MAX_CHANNELS define Krzysztof Adamski
2021-09-30  6:58 ` [PATCH v3 03/11] hwmon: (tmp421) introduce a channel struct Krzysztof Adamski
2021-09-30  6:59 ` [PATCH v3 04/11] hwmon: (tmp421) add support for defining labels from DT Krzysztof Adamski
2021-10-02 14:08   ` Guenter Roeck
2021-10-04  7:27     ` Krzysztof Adamski
2021-09-30  7:05 ` [PATCH v3 05/11] hwmon: (tmp421) support disabling channels " Krzysztof Adamski
2021-09-30  7:08 ` [PATCH v3 06/11] hwmon: (tmp421) support specifying n-factor via DT Krzysztof Adamski
2021-09-30  7:09 ` [PATCH v3 07/11] hwmon: (tmp421) really disable channels Krzysztof Adamski
2021-09-30  7:15 ` [PATCH v3 08/11] hwmon: (tmp421) support HWMON_T_ENABLE Krzysztof Adamski
2021-09-30  7:16 ` [PATCH v3 09/11] hwmon: (tmp421) update documentation Krzysztof Adamski
2021-09-30  7:17 ` [PATCH v3 10/11] hwmon: (tmp421) ignore non input related DT nodes Krzysztof Adamski
2021-09-30  7:19 ` [PATCH v3 11/11] dt-bindings: hwmon: allow specifying channels for tmp421 Krzysztof Adamski
2021-10-02 14:22   ` Guenter Roeck [this message]
2021-10-04  7:36     ` Krzysztof Adamski
2021-10-05 14:14       ` Guenter Roeck
2021-10-06  8:31         ` Krzysztof Adamski
2021-10-06 20:55         ` Rob Herring
2021-10-07  7:51           ` Krzysztof Adamski
2021-10-08 14:33             ` Guenter Roeck
2021-10-08 19:18               ` Rob Herring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20211002142219.GC34532@roeck-us.net \
    --to=linux@roeck-us.net \
    --cc=devicetree@vger.kernel.org \
    --cc=jdelvare@suse.com \
    --cc=krzysztof.adamski@nokia.com \
    --cc=linux-hwmon@vger.kernel.org \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.