All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sekhar Nori <nsekhar@ti.com>
To: Bartosz Golaszewski <bgolaszewski@baylibre.com>,
	David Lechner <david@lechnology.com>,
	Kevin Hilman <khilman@baylibre.com>,
	Michael Turquette <mturquette@baylibre.com>,
	Patrick Titiano <ptitiano@baylibre.com>,
	Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
	Russell King <linux@armlinux.org.uk>
Cc: <linux-arm-kernel@lists.infradead.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v3 3/6] ARM: davinci: da8xx: add pdata-quirks for VPIF capture
Date: Tue, 28 Feb 2017 14:27:23 +0530	[thread overview]
Message-ID: <2a3c9c5e-b61b-806e-0bd2-e6989328780a@ti.com> (raw)
In-Reply-To: <1487772805-19021-4-git-send-email-bgolaszewski@baylibre.com>

On Wednesday 22 February 2017 07:43 PM, Bartosz Golaszewski wrote:
> From: Kevin Hilman <khilman@baylibre.com>
> 
> For da8xx DT platforms, use pdata-quirks to add legacy platform data for
> vpif_capture driver.
> 
> Passing legacy platform_data is required until the V4L2 framework, and
> subdevice drivers (such as the tvp514x) grow a way of selecting input
> and output routing  (c.f. V4L2 s_routing API)
> 
> Signed-off-by: Kevin Hilman <khilman@baylibre.com>
> [Bartosz: removed unnecessary #ifdefs]
> Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
> ---
>  arch/arm/mach-davinci/da8xx-dt.c     |   1 +
>  arch/arm/mach-davinci/pdata-quirks.c | 104 +++++++++++++++++++++++++++++++++++
>  2 files changed, 105 insertions(+)
> 
> diff --git a/arch/arm/mach-davinci/da8xx-dt.c b/arch/arm/mach-davinci/da8xx-dt.c
> index e3cef50..5699ce3 100644
> --- a/arch/arm/mach-davinci/da8xx-dt.c
> +++ b/arch/arm/mach-davinci/da8xx-dt.c
> @@ -53,6 +53,7 @@ static struct of_dev_auxdata da850_auxdata_lookup[] __initdata = {
>  	OF_DEV_AUXDATA("ti,da830-musb", 0x01e00000, "musb-da8xx", NULL),
>  	OF_DEV_AUXDATA("ti,da830-usb-phy", 0x01c1417c, "da8xx-usb-phy", NULL),
>  	OF_DEV_AUXDATA("ti,da850-ahci", 0x01e18000, "ahci_da850", NULL),
> +	OF_DEV_AUXDATA("ti,da850-vpif", 0x01e17000, "vpif", NULL),

You don't talk about adding OF_DEV_AUXDATA in patch description. Can you
either add description for this change or spin it into a separate patch?
I prefer the later, but will take it either way.

> +static void __init da850_vpif_legacy_init(void)
> +{
> +	int ret;
> +
> +	/* LCDK doesn't have the 2nd TVP514x on CH1 */
> +	if (of_machine_is_compatible("ti,da850-lcdk"))
> +		da850_vpif_capture_config.subdev_count = 1;

Since you anyway register quirk for lcdk separately, you can as well
create da850_lcdk_vpif_capture_init() which sets subdev_count to 1
unconditionally.

Also, since you rename the function to add "capture" down the series,
you can as well have that name from the start. It will make the later
patches easier to read.

Thanks,
Sekhar

WARNING: multiple messages have this Message-ID (diff)
From: nsekhar@ti.com (Sekhar Nori)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v3 3/6] ARM: davinci: da8xx: add pdata-quirks for VPIF capture
Date: Tue, 28 Feb 2017 14:27:23 +0530	[thread overview]
Message-ID: <2a3c9c5e-b61b-806e-0bd2-e6989328780a@ti.com> (raw)
In-Reply-To: <1487772805-19021-4-git-send-email-bgolaszewski@baylibre.com>

On Wednesday 22 February 2017 07:43 PM, Bartosz Golaszewski wrote:
> From: Kevin Hilman <khilman@baylibre.com>
> 
> For da8xx DT platforms, use pdata-quirks to add legacy platform data for
> vpif_capture driver.
> 
> Passing legacy platform_data is required until the V4L2 framework, and
> subdevice drivers (such as the tvp514x) grow a way of selecting input
> and output routing  (c.f. V4L2 s_routing API)
> 
> Signed-off-by: Kevin Hilman <khilman@baylibre.com>
> [Bartosz: removed unnecessary #ifdefs]
> Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
> ---
>  arch/arm/mach-davinci/da8xx-dt.c     |   1 +
>  arch/arm/mach-davinci/pdata-quirks.c | 104 +++++++++++++++++++++++++++++++++++
>  2 files changed, 105 insertions(+)
> 
> diff --git a/arch/arm/mach-davinci/da8xx-dt.c b/arch/arm/mach-davinci/da8xx-dt.c
> index e3cef50..5699ce3 100644
> --- a/arch/arm/mach-davinci/da8xx-dt.c
> +++ b/arch/arm/mach-davinci/da8xx-dt.c
> @@ -53,6 +53,7 @@ static struct of_dev_auxdata da850_auxdata_lookup[] __initdata = {
>  	OF_DEV_AUXDATA("ti,da830-musb", 0x01e00000, "musb-da8xx", NULL),
>  	OF_DEV_AUXDATA("ti,da830-usb-phy", 0x01c1417c, "da8xx-usb-phy", NULL),
>  	OF_DEV_AUXDATA("ti,da850-ahci", 0x01e18000, "ahci_da850", NULL),
> +	OF_DEV_AUXDATA("ti,da850-vpif", 0x01e17000, "vpif", NULL),

You don't talk about adding OF_DEV_AUXDATA in patch description. Can you
either add description for this change or spin it into a separate patch?
I prefer the later, but will take it either way.

> +static void __init da850_vpif_legacy_init(void)
> +{
> +	int ret;
> +
> +	/* LCDK doesn't have the 2nd TVP514x on CH1 */
> +	if (of_machine_is_compatible("ti,da850-lcdk"))
> +		da850_vpif_capture_config.subdev_count = 1;

Since you anyway register quirk for lcdk separately, you can as well
create da850_lcdk_vpif_capture_init() which sets subdev_count to 1
unconditionally.

Also, since you rename the function to add "capture" down the series,
you can as well have that name from the start. It will make the later
patches easier to read.

Thanks,
Sekhar

  reply	other threads:[~2017-02-28  8:59 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-02-22 14:13 [PATCH v3 0/6] ARM: davinci: vpif capture & display support Bartosz Golaszewski
2017-02-22 14:13 ` Bartosz Golaszewski
2017-02-22 14:13 ` [PATCH v3 1/6] ARM: davinci: da8xx: allow having multiple pdata-quirks Bartosz Golaszewski
2017-02-22 14:13   ` Bartosz Golaszewski
2017-02-28 18:00   ` Kevin Hilman
2017-02-28 18:00     ` Kevin Hilman
2017-02-22 14:13 ` [PATCH v3 2/6] ARM: davinci: board-da850-evm: add I2C ID for VPIF Bartosz Golaszewski
2017-02-22 14:13   ` Bartosz Golaszewski
2017-02-22 14:13 ` [PATCH v3 3/6] ARM: davinci: da8xx: add pdata-quirks for VPIF capture Bartosz Golaszewski
2017-02-22 14:13   ` Bartosz Golaszewski
2017-02-28  8:57   ` Sekhar Nori [this message]
2017-02-28  8:57     ` Sekhar Nori
2017-02-22 14:13 ` [PATCH v3 4/6] ARM: da850-evm: add a fixed regulator for the UI board IO expander Bartosz Golaszewski
2017-02-22 14:13   ` Bartosz Golaszewski
2017-02-22 14:13 ` [PATCH v3 5/6] ARM: davinci: add pdata-quirks for da850-evm vpif display Bartosz Golaszewski
2017-02-22 14:13   ` Bartosz Golaszewski
2017-02-22 14:13 ` [PATCH v3 6/6] ARM: davinci: add enable GPIOs for vpif capture to pdata-quirks Bartosz Golaszewski
2017-02-22 14:13   ` Bartosz Golaszewski
2017-02-28  8:49   ` Sekhar Nori
2017-02-28  8:49     ` Sekhar Nori
2017-02-28  9:42     ` Bartosz Golaszewski
2017-02-28  9:42       ` Bartosz Golaszewski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2a3c9c5e-b61b-806e-0bd2-e6989328780a@ti.com \
    --to=nsekhar@ti.com \
    --cc=bgolaszewski@baylibre.com \
    --cc=david@lechnology.com \
    --cc=khilman@baylibre.com \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=mturquette@baylibre.com \
    --cc=ptitiano@baylibre.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.