All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sagi Grimberg <sagi@grimberg.me>
To: Bart Van Assche <Bart.VanAssche@wdc.com>,
	"hch@infradead.org" <hch@infradead.org>,
	"axboe@kernel.dk" <axboe@kernel.dk>
Cc: "keith.busch@intel.com" <keith.busch@intel.com>,
	"linux-block@vger.kernel.org" <linux-block@vger.kernel.org>,
	"linux-nvme@lists.infradead.org" <linux-nvme@lists.infradead.org>
Subject: Re: [GIT PULL] nvme update for Linux 4.14, take 2
Date: Wed, 30 Aug 2017 23:59:26 +0300	[thread overview]
Message-ID: <36296474-da73-8f1b-2a3c-e64b318d3efa@grimberg.me> (raw)
In-Reply-To: <1504112187.2526.47.camel@wdc.com>


>> That would mean that I need to open-code the tagset iteration in nvme
>> which does not feel like something a driver should do.
> 
> How about renaming blk_mq_reinit_tagset() into blk_mq_tagset_iter() and
> to make the argument list of blk_mq_tagset_iter() more similar to that of
> blk_mq_queue_tag_busy_iter() such that callers of blk_mq_tagset_iter()
> can pass a pointer to any structure through the @priv argument? That would
> make this function more general and maybe also more useful to other block
> drivers.

We could do that. But it feels like trying to go head over heals just to
keep a change titled:

"blk-mq: Make blk_mq_reinit_tagset() calls easier to read"

Which I'm not exactly sure I share the motivation. Also, I kinda liked
the symmetry of init/exit/reinit_request calling convention.

But, if you absolutely think its necessary to keep the change, we can
add an "all tags" iterator and use that to implement reinit_request in
nvme.

Christoph? Jens? verdict before we go forward here?

WARNING: multiple messages have this Message-ID (diff)
From: sagi@grimberg.me (Sagi Grimberg)
Subject: [GIT PULL] nvme update for Linux 4.14, take 2
Date: Wed, 30 Aug 2017 23:59:26 +0300	[thread overview]
Message-ID: <36296474-da73-8f1b-2a3c-e64b318d3efa@grimberg.me> (raw)
In-Reply-To: <1504112187.2526.47.camel@wdc.com>


>> That would mean that I need to open-code the tagset iteration in nvme
>> which does not feel like something a driver should do.
> 
> How about renaming blk_mq_reinit_tagset() into blk_mq_tagset_iter() and
> to make the argument list of blk_mq_tagset_iter() more similar to that of
> blk_mq_queue_tag_busy_iter() such that callers of blk_mq_tagset_iter()
> can pass a pointer to any structure through the @priv argument? That would
> make this function more general and maybe also more useful to other block
> drivers.

We could do that. But it feels like trying to go head over heals just to
keep a change titled:

"blk-mq: Make blk_mq_reinit_tagset() calls easier to read"

Which I'm not exactly sure I share the motivation. Also, I kinda liked
the symmetry of init/exit/reinit_request calling convention.

But, if you absolutely think its necessary to keep the change, we can
add an "all tags" iterator and use that to implement reinit_request in
nvme.

Christoph? Jens? verdict before we go forward here?

  reply	other threads:[~2017-08-30 20:59 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-08-29 15:05 [GIT PULL] nvme update for Linux 4.14, take 2 Christoph Hellwig
2017-08-29 15:05 ` Christoph Hellwig
2017-08-29 15:10 ` Jens Axboe
2017-08-29 15:10   ` Jens Axboe
2017-08-30 15:10   ` Sagi Grimberg
2017-08-30 15:10     ` Sagi Grimberg
2017-08-30 15:28     ` Bart Van Assche
2017-08-30 15:28       ` Bart Van Assche
2017-08-30 15:33       ` Sagi Grimberg
2017-08-30 15:33         ` Sagi Grimberg
2017-08-30 15:46         ` Bart Van Assche
2017-08-30 15:46           ` Bart Van Assche
2017-08-30 15:53           ` Jens Axboe
2017-08-30 15:53             ` Jens Axboe
2017-08-30 16:05             ` Sagi Grimberg
2017-08-30 16:05               ` Sagi Grimberg
2017-08-30 16:11               ` Bart Van Assche
2017-08-30 16:11                 ` Bart Van Assche
2017-08-30 16:47                 ` Sagi Grimberg
2017-08-30 16:47                   ` Sagi Grimberg
2017-08-30 16:56                   ` Bart Van Assche
2017-08-30 16:56                     ` Bart Van Assche
2017-08-30 20:59                     ` Sagi Grimberg [this message]
2017-08-30 20:59                       ` Sagi Grimberg
2017-08-31 13:10                     ` hch
2017-08-31 13:10                       ` hch

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=36296474-da73-8f1b-2a3c-e64b318d3efa@grimberg.me \
    --to=sagi@grimberg.me \
    --cc=Bart.VanAssche@wdc.com \
    --cc=axboe@kernel.dk \
    --cc=hch@infradead.org \
    --cc=keith.busch@intel.com \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-nvme@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.