All of lore.kernel.org
 help / color / mirror / Atom feed
From: Grygorii Strashko <grygorii.strashko@ti.com>
To: Santosh Shilimkar <santosh.shilimkar@ti.com>
Cc: Linus Walleij <linus.walleij@linaro.org>,
	Sekhar Nori <nsekhar@ti.com>,
	Rob Herring <rob.herring@calxeda.com>,
	prabhakar.csengg@gmail.com, linux-gpio@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	davinci-linux-open-source@linux.davincidsp.com,
	linux-arm-kernel@lists.infradead.org, devicetree@vger.kernel.org
Subject: Re: [PATCH 2/2] gpio: davinci: reuse for Keystone SoC
Date: Mon, 16 Dec 2013 20:02:25 +0200	[thread overview]
Message-ID: <52AF4031.7000205@ti.com> (raw)
In-Reply-To: <52AF2C87.1060700@ti.com>

On 12/16/2013 06:38 PM, Santosh Shilimkar wrote:
> On Thursday 12 December 2013 01:12 PM, Grygorii Strashko wrote:
>> The similar GPIO HW block is used by keystone SoCs as
>> in Davinci SoCs.
>> Hence, reuse Davinci GPIO driver for Keystone taking into
>> account that Keystone contains ARM GIC IRQ controller which
>> is implemented using IRQ Chip.
>>
>> Documentation:
>> 	http://www.ti.com/lit/ug/sprugv1/sprugv1.pdf
>>
>> CC: Linus Walleij <linus.walleij@linaro.org>
>> CC: Sekhar Nori <nsekhar@ti.com>
>> CC: Santosh Shilimkar <santosh.shilimkar@ti.com>
>> CC: devicetree@vger.kernel.org
>>
>> Signed-off-by: Grygorii Strashko <grygorii.strashko@ti.com>
>> ---
>>   .../devicetree/bindings/gpio/gpio-davinci.txt      |    4 +-
>>   drivers/gpio/gpio-davinci.c                        |   49 +++++++++++++++-----
>>   2 files changed, 40 insertions(+), 13 deletions(-)
>>
>> diff --git a/Documentation/devicetree/bindings/gpio/gpio-davinci.txt b/Documentation/devicetree/bindings/gpio/gpio-davinci.txt
>> index a2e839d..4ce9862 100644
>> --- a/Documentation/devicetree/bindings/gpio/gpio-davinci.txt
>> +++ b/Documentation/devicetree/bindings/gpio/gpio-davinci.txt
>> @@ -1,7 +1,7 @@
>> -Davinci GPIO controller bindings
>> +Davinci/Keystone GPIO controller bindings
>>
>>   Required Properties:
>> -- compatible: should be "ti,dm6441-gpio"
>> +- compatible: should be "ti,dm6441-gpio", "ti,keystone-gpio"
>>
>>   - reg: Physical base address of the controller and the size of memory mapped
>>          registers.
>> diff --git a/drivers/gpio/gpio-davinci.c b/drivers/gpio/gpio-davinci.c
>> index 73f65ca..3e44e0c 100644
>> --- a/drivers/gpio/gpio-davinci.c
>> +++ b/drivers/gpio/gpio-davinci.c
>> @@ -413,6 +413,27 @@ static const struct irq_domain_ops davinci_gpio_irq_ops = {
>>   	.xlate = irq_domain_xlate_onetwocell,
>>   };
>>
>> +static struct irq_chip *davinci_gpio_get_irq_chip(unsigned int irq)
>> +{
>> +	static struct irq_chip_type gpio_unbanked;
>> +
>> +	gpio_unbanked = *container_of(irq_get_chip(irq),
>> +				      struct irq_chip_type, chip);
>> +
>> +	return &gpio_unbanked.chip;
>> +};
>> +
>> +static struct irq_chip *keystone_gpio_get_irq_chip(unsigned int irq)
>> +{
>> +	static struct irq_chip gpio_unbanked;
>> +
>> +	gpio_unbanked = *irq_get_chip(irq);
>> +	pr_err("keystone_gpio_get_irq_chip\n");
>> +	return &gpio_unbanked;
>> +};
>> +
>> +static const struct of_device_id davinci_gpio_ids[];
>> +
>>   /*
>>    * NOTE:  for suspend/resume, probably best to make a platform_device with
>>    * suspend_late/resume_resume calls hooking into results of the set_wake()
>> @@ -433,6 +454,15 @@ static int davinci_gpio_irq_setup(struct platform_device *pdev)
>>   	struct davinci_gpio_platform_data *pdata = dev->platform_data;
>>   	struct davinci_gpio_regs __iomem *g;
>>   	struct irq_domain	*irq_domain = NULL;
>> +	const struct of_device_id *match;
>> +	struct irq_chip *irq_chip;
>> +	struct irq_chip *(*gpio_get_irq_chip)(unsigned int irq);
>> +
>> +	gpio_get_irq_chip = davinci_gpio_get_irq_chip;
>> +	match = of_match_device(of_match_ptr(davinci_gpio_ids),
>> +				dev);
>> +	if (match)
>> +		gpio_get_irq_chip = match->data;
> and if the DT node is not populated ?
>>
>>   	ngpio = pdata->ngpio;
>>   	res = platform_get_resource(pdev, IORESOURCE_IRQ, 0);
>> @@ -442,7 +472,6 @@ static int davinci_gpio_irq_setup(struct platform_device *pdev)
>>   	}
>>
>>   	bank_irq = res->start;
>> -
> stray change..
>
>>   	if (!bank_irq) {
>>   		dev_err(dev, "Invalid IRQ resource\n");
>>   		return -ENODEV;
>> @@ -484,25 +513,22 @@ static int davinci_gpio_irq_setup(struct platform_device *pdev)
>>   	}
>>
>>   	/*
>> -	 * AINTC can handle direct/unbanked IRQs for GPIOs, with the GPIO
>> +	 * INTC can handle direct/unbanked IRQs for GPIOs, with the GPIO
> So you want to have a generic name here. If you are changing it, change it
> across the driver in a separate patch or leave it as is...
> I don't think it matters much..

Uh. Ok. I'll drop renaming.


>
> With those comments addressed, you can add my ack.
> Acked-by: Santosh Shilimkar <santosh.shilimkar@ti.com>
>


WARNING: multiple messages have this Message-ID (diff)
From: Grygorii Strashko <grygorii.strashko@ti.com>
To: Santosh Shilimkar <santosh.shilimkar@ti.com>
Cc: Linus Walleij <linus.walleij@linaro.org>,
	Sekhar Nori <nsekhar@ti.com>,
	Rob Herring <rob.herring@calxeda.com>,
	<prabhakar.csengg@gmail.com>, <linux-gpio@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>,
	<davinci-linux-open-source@linux.davincidsp.com>,
	<linux-arm-kernel@lists.infradead.org>,
	<devicetree@vger.kernel.org>
Subject: Re: [PATCH 2/2] gpio: davinci: reuse for Keystone SoC
Date: Mon, 16 Dec 2013 20:02:25 +0200	[thread overview]
Message-ID: <52AF4031.7000205@ti.com> (raw)
In-Reply-To: <52AF2C87.1060700@ti.com>

On 12/16/2013 06:38 PM, Santosh Shilimkar wrote:
> On Thursday 12 December 2013 01:12 PM, Grygorii Strashko wrote:
>> The similar GPIO HW block is used by keystone SoCs as
>> in Davinci SoCs.
>> Hence, reuse Davinci GPIO driver for Keystone taking into
>> account that Keystone contains ARM GIC IRQ controller which
>> is implemented using IRQ Chip.
>>
>> Documentation:
>> 	http://www.ti.com/lit/ug/sprugv1/sprugv1.pdf
>>
>> CC: Linus Walleij <linus.walleij@linaro.org>
>> CC: Sekhar Nori <nsekhar@ti.com>
>> CC: Santosh Shilimkar <santosh.shilimkar@ti.com>
>> CC: devicetree@vger.kernel.org
>>
>> Signed-off-by: Grygorii Strashko <grygorii.strashko@ti.com>
>> ---
>>   .../devicetree/bindings/gpio/gpio-davinci.txt      |    4 +-
>>   drivers/gpio/gpio-davinci.c                        |   49 +++++++++++++++-----
>>   2 files changed, 40 insertions(+), 13 deletions(-)
>>
>> diff --git a/Documentation/devicetree/bindings/gpio/gpio-davinci.txt b/Documentation/devicetree/bindings/gpio/gpio-davinci.txt
>> index a2e839d..4ce9862 100644
>> --- a/Documentation/devicetree/bindings/gpio/gpio-davinci.txt
>> +++ b/Documentation/devicetree/bindings/gpio/gpio-davinci.txt
>> @@ -1,7 +1,7 @@
>> -Davinci GPIO controller bindings
>> +Davinci/Keystone GPIO controller bindings
>>
>>   Required Properties:
>> -- compatible: should be "ti,dm6441-gpio"
>> +- compatible: should be "ti,dm6441-gpio", "ti,keystone-gpio"
>>
>>   - reg: Physical base address of the controller and the size of memory mapped
>>          registers.
>> diff --git a/drivers/gpio/gpio-davinci.c b/drivers/gpio/gpio-davinci.c
>> index 73f65ca..3e44e0c 100644
>> --- a/drivers/gpio/gpio-davinci.c
>> +++ b/drivers/gpio/gpio-davinci.c
>> @@ -413,6 +413,27 @@ static const struct irq_domain_ops davinci_gpio_irq_ops = {
>>   	.xlate = irq_domain_xlate_onetwocell,
>>   };
>>
>> +static struct irq_chip *davinci_gpio_get_irq_chip(unsigned int irq)
>> +{
>> +	static struct irq_chip_type gpio_unbanked;
>> +
>> +	gpio_unbanked = *container_of(irq_get_chip(irq),
>> +				      struct irq_chip_type, chip);
>> +
>> +	return &gpio_unbanked.chip;
>> +};
>> +
>> +static struct irq_chip *keystone_gpio_get_irq_chip(unsigned int irq)
>> +{
>> +	static struct irq_chip gpio_unbanked;
>> +
>> +	gpio_unbanked = *irq_get_chip(irq);
>> +	pr_err("keystone_gpio_get_irq_chip\n");
>> +	return &gpio_unbanked;
>> +};
>> +
>> +static const struct of_device_id davinci_gpio_ids[];
>> +
>>   /*
>>    * NOTE:  for suspend/resume, probably best to make a platform_device with
>>    * suspend_late/resume_resume calls hooking into results of the set_wake()
>> @@ -433,6 +454,15 @@ static int davinci_gpio_irq_setup(struct platform_device *pdev)
>>   	struct davinci_gpio_platform_data *pdata = dev->platform_data;
>>   	struct davinci_gpio_regs __iomem *g;
>>   	struct irq_domain	*irq_domain = NULL;
>> +	const struct of_device_id *match;
>> +	struct irq_chip *irq_chip;
>> +	struct irq_chip *(*gpio_get_irq_chip)(unsigned int irq);
>> +
>> +	gpio_get_irq_chip = davinci_gpio_get_irq_chip;
>> +	match = of_match_device(of_match_ptr(davinci_gpio_ids),
>> +				dev);
>> +	if (match)
>> +		gpio_get_irq_chip = match->data;
> and if the DT node is not populated ?
>>
>>   	ngpio = pdata->ngpio;
>>   	res = platform_get_resource(pdev, IORESOURCE_IRQ, 0);
>> @@ -442,7 +472,6 @@ static int davinci_gpio_irq_setup(struct platform_device *pdev)
>>   	}
>>
>>   	bank_irq = res->start;
>> -
> stray change..
>
>>   	if (!bank_irq) {
>>   		dev_err(dev, "Invalid IRQ resource\n");
>>   		return -ENODEV;
>> @@ -484,25 +513,22 @@ static int davinci_gpio_irq_setup(struct platform_device *pdev)
>>   	}
>>
>>   	/*
>> -	 * AINTC can handle direct/unbanked IRQs for GPIOs, with the GPIO
>> +	 * INTC can handle direct/unbanked IRQs for GPIOs, with the GPIO
> So you want to have a generic name here. If you are changing it, change it
> across the driver in a separate patch or leave it as is...
> I don't think it matters much..

Uh. Ok. I'll drop renaming.


>
> With those comments addressed, you can add my ack.
> Acked-by: Santosh Shilimkar <santosh.shilimkar@ti.com>
>


WARNING: multiple messages have this Message-ID (diff)
From: grygorii.strashko@ti.com (Grygorii Strashko)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 2/2] gpio: davinci: reuse for Keystone SoC
Date: Mon, 16 Dec 2013 20:02:25 +0200	[thread overview]
Message-ID: <52AF4031.7000205@ti.com> (raw)
In-Reply-To: <52AF2C87.1060700@ti.com>

On 12/16/2013 06:38 PM, Santosh Shilimkar wrote:
> On Thursday 12 December 2013 01:12 PM, Grygorii Strashko wrote:
>> The similar GPIO HW block is used by keystone SoCs as
>> in Davinci SoCs.
>> Hence, reuse Davinci GPIO driver for Keystone taking into
>> account that Keystone contains ARM GIC IRQ controller which
>> is implemented using IRQ Chip.
>>
>> Documentation:
>> 	http://www.ti.com/lit/ug/sprugv1/sprugv1.pdf
>>
>> CC: Linus Walleij <linus.walleij@linaro.org>
>> CC: Sekhar Nori <nsekhar@ti.com>
>> CC: Santosh Shilimkar <santosh.shilimkar@ti.com>
>> CC: devicetree at vger.kernel.org
>>
>> Signed-off-by: Grygorii Strashko <grygorii.strashko@ti.com>
>> ---
>>   .../devicetree/bindings/gpio/gpio-davinci.txt      |    4 +-
>>   drivers/gpio/gpio-davinci.c                        |   49 +++++++++++++++-----
>>   2 files changed, 40 insertions(+), 13 deletions(-)
>>
>> diff --git a/Documentation/devicetree/bindings/gpio/gpio-davinci.txt b/Documentation/devicetree/bindings/gpio/gpio-davinci.txt
>> index a2e839d..4ce9862 100644
>> --- a/Documentation/devicetree/bindings/gpio/gpio-davinci.txt
>> +++ b/Documentation/devicetree/bindings/gpio/gpio-davinci.txt
>> @@ -1,7 +1,7 @@
>> -Davinci GPIO controller bindings
>> +Davinci/Keystone GPIO controller bindings
>>
>>   Required Properties:
>> -- compatible: should be "ti,dm6441-gpio"
>> +- compatible: should be "ti,dm6441-gpio", "ti,keystone-gpio"
>>
>>   - reg: Physical base address of the controller and the size of memory mapped
>>          registers.
>> diff --git a/drivers/gpio/gpio-davinci.c b/drivers/gpio/gpio-davinci.c
>> index 73f65ca..3e44e0c 100644
>> --- a/drivers/gpio/gpio-davinci.c
>> +++ b/drivers/gpio/gpio-davinci.c
>> @@ -413,6 +413,27 @@ static const struct irq_domain_ops davinci_gpio_irq_ops = {
>>   	.xlate = irq_domain_xlate_onetwocell,
>>   };
>>
>> +static struct irq_chip *davinci_gpio_get_irq_chip(unsigned int irq)
>> +{
>> +	static struct irq_chip_type gpio_unbanked;
>> +
>> +	gpio_unbanked = *container_of(irq_get_chip(irq),
>> +				      struct irq_chip_type, chip);
>> +
>> +	return &gpio_unbanked.chip;
>> +};
>> +
>> +static struct irq_chip *keystone_gpio_get_irq_chip(unsigned int irq)
>> +{
>> +	static struct irq_chip gpio_unbanked;
>> +
>> +	gpio_unbanked = *irq_get_chip(irq);
>> +	pr_err("keystone_gpio_get_irq_chip\n");
>> +	return &gpio_unbanked;
>> +};
>> +
>> +static const struct of_device_id davinci_gpio_ids[];
>> +
>>   /*
>>    * NOTE:  for suspend/resume, probably best to make a platform_device with
>>    * suspend_late/resume_resume calls hooking into results of the set_wake()
>> @@ -433,6 +454,15 @@ static int davinci_gpio_irq_setup(struct platform_device *pdev)
>>   	struct davinci_gpio_platform_data *pdata = dev->platform_data;
>>   	struct davinci_gpio_regs __iomem *g;
>>   	struct irq_domain	*irq_domain = NULL;
>> +	const struct of_device_id *match;
>> +	struct irq_chip *irq_chip;
>> +	struct irq_chip *(*gpio_get_irq_chip)(unsigned int irq);
>> +
>> +	gpio_get_irq_chip = davinci_gpio_get_irq_chip;
>> +	match = of_match_device(of_match_ptr(davinci_gpio_ids),
>> +				dev);
>> +	if (match)
>> +		gpio_get_irq_chip = match->data;
> and if the DT node is not populated ?
>>
>>   	ngpio = pdata->ngpio;
>>   	res = platform_get_resource(pdev, IORESOURCE_IRQ, 0);
>> @@ -442,7 +472,6 @@ static int davinci_gpio_irq_setup(struct platform_device *pdev)
>>   	}
>>
>>   	bank_irq = res->start;
>> -
> stray change..
>
>>   	if (!bank_irq) {
>>   		dev_err(dev, "Invalid IRQ resource\n");
>>   		return -ENODEV;
>> @@ -484,25 +513,22 @@ static int davinci_gpio_irq_setup(struct platform_device *pdev)
>>   	}
>>
>>   	/*
>> -	 * AINTC can handle direct/unbanked IRQs for GPIOs, with the GPIO
>> +	 * INTC can handle direct/unbanked IRQs for GPIOs, with the GPIO
> So you want to have a generic name here. If you are changing it, change it
> across the driver in a separate patch or leave it as is...
> I don't think it matters much..

Uh. Ok. I'll drop renaming.


>
> With those comments addressed, you can add my ack.
> Acked-by: Santosh Shilimkar <santosh.shilimkar@ti.com>
>

  reply	other threads:[~2013-12-16 17:05 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-12-12 18:12 [PATCH 0/2] gpio: davinci: reuse for keystone arch Grygorii Strashko
2013-12-12 18:12 ` Grygorii Strashko
2013-12-12 18:12 ` Grygorii Strashko
2013-12-12 18:12 ` [PATCH 1/2] gpio: davinci: don't create irq_domain in case of unbanked irqs Grygorii Strashko
2013-12-12 18:12   ` Grygorii Strashko
2013-12-12 18:12   ` Grygorii Strashko
     [not found]   ` <1386871973-26762-2-git-send-email-grygorii.strashko-l0cyMroinI0@public.gmane.org>
2013-12-16 16:24     ` Santosh Shilimkar
2013-12-16 16:24       ` Santosh Shilimkar
2013-12-16 16:24       ` Santosh Shilimkar
     [not found] ` <1386871973-26762-1-git-send-email-grygorii.strashko-l0cyMroinI0@public.gmane.org>
2013-12-12 18:12   ` [PATCH 2/2] gpio: davinci: reuse for Keystone SoC Grygorii Strashko
2013-12-12 18:12     ` Grygorii Strashko
2013-12-12 18:12     ` Grygorii Strashko
2013-12-16  7:29     ` Alexandre Courbot
2013-12-16  7:29       ` Alexandre Courbot
2013-12-16  7:29       ` Alexandre Courbot
     [not found]       ` <CAAVeFuJSe_BZ+cr8ZVz-etAzsUbe_taS+0EqM+pXhKhTdyuWiQ-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
2013-12-16 11:18         ` Grygorii Strashko
2013-12-16 11:18           ` Grygorii Strashko
2013-12-16 11:18           ` Grygorii Strashko
     [not found]     ` <1386871973-26762-3-git-send-email-grygorii.strashko-l0cyMroinI0@public.gmane.org>
2013-12-16 16:38       ` Santosh Shilimkar
2013-12-16 16:38         ` Santosh Shilimkar
2013-12-16 16:38         ` Santosh Shilimkar
2013-12-16 18:02         ` Grygorii Strashko [this message]
2013-12-16 18:02           ` Grygorii Strashko
2013-12-16 18:02           ` Grygorii Strashko
2013-12-14 19:11 ` [PATCH 0/2] gpio: davinci: reuse for keystone arch Santosh Shilimkar
2013-12-14 19:11   ` Santosh Shilimkar
2013-12-14 19:11   ` Santosh Shilimkar
     [not found]   ` <52ACAD50.6060003-l0cyMroinI0@public.gmane.org>
2013-12-15 13:50     ` Sekhar Nori
2013-12-15 13:50       ` Sekhar Nori
2013-12-15 13:50       ` Sekhar Nori
     [not found]       ` <52ADB3BC.3080605-l0cyMroinI0@public.gmane.org>
2013-12-15 13:54         ` Sekhar Nori
2013-12-15 13:54           ` Sekhar Nori
2013-12-15 13:54           ` Sekhar Nori
     [not found]           ` <52ADB47E.1080505-l0cyMroinI0@public.gmane.org>
2013-12-16 11:18             ` Grygorii Strashko
2013-12-16 11:18               ` Grygorii Strashko
2013-12-16 11:18               ` Grygorii Strashko
2013-12-16 15:09         ` Santosh Shilimkar
2013-12-16 15:09           ` Santosh Shilimkar
2013-12-16 15:09           ` Santosh Shilimkar
     [not found]           ` <52AF17A6.3060007-l0cyMroinI0@public.gmane.org>
2013-12-16 16:39             ` Santosh Shilimkar
2013-12-16 16:39               ` Santosh Shilimkar
2013-12-16 16:39               ` Santosh Shilimkar
2013-12-20  9:39               ` Linus Walleij
2013-12-20  9:39                 ` Linus Walleij
2013-12-20  9:39                 ` Linus Walleij

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=52AF4031.7000205@ti.com \
    --to=grygorii.strashko@ti.com \
    --cc=davinci-linux-open-source@linux.davincidsp.com \
    --cc=devicetree@vger.kernel.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nsekhar@ti.com \
    --cc=prabhakar.csengg@gmail.com \
    --cc=rob.herring@calxeda.com \
    --cc=santosh.shilimkar@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.