All of lore.kernel.org
 help / color / mirror / Atom feed
From: "PaX Team" <pageexec@freemail.hu>
To: linux-kernel@vger.kernel.org, Kees Cook <keescook@chromium.org>
Cc: Kees Cook <keescook@chromium.org>,
	Andy Lutomirski <luto@amacapital.net>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Mathias Krause <minipli@googlemail.com>,
	Ingo Molnar <mingo@redhat.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	x86@kernel.org, Arnd Bergmann <arnd@arndb.de>,
	Emese Revfy <re.emese@gmail.com>,
	kernel-hardening@lists.openwall.com,
	linux-arch <linux-arch@vger.kernel.org>
Subject: Re: [PATCH v2 1/4] init: create cmdline param to disable readonly
Date: Thu, 26 Nov 2015 01:37:51 +0100	[thread overview]
Message-ID: <5656545F.29919.10A1CE2B@pageexec.freemail.hu> (raw)
In-Reply-To: <1448494286-16029-2-git-send-email-keescook@chromium.org>

On 25 Nov 2015 at 15:31, Kees Cook wrote:

> +	rodata=		[KNL]
> +		on	Mark read-only kernel memory as read-only (default).
> +		off	Leave read-only kernel memory writable for debugging.
> +

> +#ifdef CONFIG_DEBUG_RODATA
> +bool disable_mark_readonly;

__initdata?

> +static int __init set_debug_rodata(char *str)
> +{
> +	if (!str)
> +		return -EINVAL;
> +	if (!strncmp(str, "on", 2))
> +		disable_mark_readonly = false;
> +	else if (!strncmp(str, "off", 3))
> +		disable_mark_readonly = true;

maybe it's just me but the double negatives make my head spin,
perhaps call it enable_rodata instead (so that the variable name
isn't so disconnected from the option name)?

> +
> +	return 0;
> +}
> +__setup("rodata=", set_debug_rodata);
> +
> +static void mark_readonly(void)
> +{
> +	if (disable_mark_readonly)
> +		pr_info("Kernel read-only memory marking disabled.\n");
> +	else
> +		mark_rodata_ro();
> +}



WARNING: multiple messages have this Message-ID (diff)
From: "PaX Team" <pageexec@freemail.hu>
To: linux-kernel@vger.kernel.org
Cc: Kees Cook <keescook@chromium.org>,
	Andy Lutomirski <luto@amacapital.net>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Mathias Krause <minipli@googlemail.com>,
	Ingo Molnar <mingo@redhat.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	x86@kernel.org, Arnd Bergmann <arnd@arndb.de>,
	Emese Revfy <re.emese@gmail.com>,
	kernel-hardening@lists.openwall.com,
	linux-arch <linux-arch@vger.kernel.org>
Subject: Re: [PATCH v2 1/4] init: create cmdline param to disable readonly
Date: Thu, 26 Nov 2015 01:37:51 +0100	[thread overview]
Message-ID: <5656545F.29919.10A1CE2B@pageexec.freemail.hu> (raw)
In-Reply-To: <1448494286-16029-2-git-send-email-keescook@chromium.org>

On 25 Nov 2015 at 15:31, Kees Cook wrote:

> +	rodata=		[KNL]
> +		on	Mark read-only kernel memory as read-only (default).
> +		off	Leave read-only kernel memory writable for debugging.
> +

> +#ifdef CONFIG_DEBUG_RODATA
> +bool disable_mark_readonly;

__initdata?

> +static int __init set_debug_rodata(char *str)
> +{
> +	if (!str)
> +		return -EINVAL;
> +	if (!strncmp(str, "on", 2))
> +		disable_mark_readonly = false;
> +	else if (!strncmp(str, "off", 3))
> +		disable_mark_readonly = true;

maybe it's just me but the double negatives make my head spin,
perhaps call it enable_rodata instead (so that the variable name
isn't so disconnected from the option name)?

> +
> +	return 0;
> +}
> +__setup("rodata=", set_debug_rodata);
> +
> +static void mark_readonly(void)
> +{
> +	if (disable_mark_readonly)
> +		pr_info("Kernel read-only memory marking disabled.\n");
> +	else
> +		mark_rodata_ro();
> +}

WARNING: multiple messages have this Message-ID (diff)
From: "PaX Team" <pageexec@freemail.hu>
To: linux-kernel@vger.kernel.org, Kees Cook <keescook@chromium.org>
Cc: Andy Lutomirski <luto@amacapital.net>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Mathias Krause <minipli@googlemail.com>,
	Ingo Molnar <mingo@redhat.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	x86@kernel.org, Arnd Bergmann <arnd@arndb.de>,
	Emese Revfy <re.emese@gmail.com>,
	kernel-hardening@lists.openwall.com,
	linux-arch <linux-arch@vger.kernel.org>
Subject: Re: [PATCH v2 1/4] init: create cmdline param to disable readonly
Date: Thu, 26 Nov 2015 01:37:51 +0100	[thread overview]
Message-ID: <5656545F.29919.10A1CE2B@pageexec.freemail.hu> (raw)
Message-ID: <20151126003751.MzQvujsImUQb2pSGi_vdt7F1usNV57eJGex8NWJowAM@z> (raw)
In-Reply-To: <1448494286-16029-2-git-send-email-keescook@chromium.org>

On 25 Nov 2015 at 15:31, Kees Cook wrote:

> +	rodata=		[KNL]
> +		on	Mark read-only kernel memory as read-only (default).
> +		off	Leave read-only kernel memory writable for debugging.
> +

> +#ifdef CONFIG_DEBUG_RODATA
> +bool disable_mark_readonly;

__initdata?

> +static int __init set_debug_rodata(char *str)
> +{
> +	if (!str)
> +		return -EINVAL;
> +	if (!strncmp(str, "on", 2))
> +		disable_mark_readonly = false;
> +	else if (!strncmp(str, "off", 3))
> +		disable_mark_readonly = true;

maybe it's just me but the double negatives make my head spin,
perhaps call it enable_rodata instead (so that the variable name
isn't so disconnected from the option name)?

> +
> +	return 0;
> +}
> +__setup("rodata=", set_debug_rodata);
> +
> +static void mark_readonly(void)
> +{
> +	if (disable_mark_readonly)
> +		pr_info("Kernel read-only memory marking disabled.\n");
> +	else
> +		mark_rodata_ro();
> +}



WARNING: multiple messages have this Message-ID (diff)
From: "PaX Team" <pageexec@freemail.hu>
To: linux-kernel@vger.kernel.org, Kees Cook <keescook@chromium.org>
Cc: Andy Lutomirski <luto@amacapital.net>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Mathias Krause <minipli@googlemail.com>,
	Ingo Molnar <mingo@redhat.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	x86@kernel.org, Arnd Bergmann <arnd@arndb.de>,
	Emese Revfy <re.emese@gmail.com>,
	kernel-hardening@lists.openwall.com,
	linux-arch <linux-arch@vger.kernel.org>
Subject: [kernel-hardening] Re: [PATCH v2 1/4] init: create cmdline param to disable readonly
Date: Thu, 26 Nov 2015 01:37:51 +0100	[thread overview]
Message-ID: <5656545F.29919.10A1CE2B@pageexec.freemail.hu> (raw)
In-Reply-To: <1448494286-16029-2-git-send-email-keescook@chromium.org>

On 25 Nov 2015 at 15:31, Kees Cook wrote:

> +	rodata=		[KNL]
> +		on	Mark read-only kernel memory as read-only (default).
> +		off	Leave read-only kernel memory writable for debugging.
> +

> +#ifdef CONFIG_DEBUG_RODATA
> +bool disable_mark_readonly;

__initdata?

> +static int __init set_debug_rodata(char *str)
> +{
> +	if (!str)
> +		return -EINVAL;
> +	if (!strncmp(str, "on", 2))
> +		disable_mark_readonly = false;
> +	else if (!strncmp(str, "off", 3))
> +		disable_mark_readonly = true;

maybe it's just me but the double negatives make my head spin,
perhaps call it enable_rodata instead (so that the variable name
isn't so disconnected from the option name)?

> +
> +	return 0;
> +}
> +__setup("rodata=", set_debug_rodata);
> +
> +static void mark_readonly(void)
> +{
> +	if (disable_mark_readonly)
> +		pr_info("Kernel read-only memory marking disabled.\n");
> +	else
> +		mark_rodata_ro();
> +}

  reply	other threads:[~2015-11-26  0:38 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-25 23:31 [PATCH v2 0/4] introduce post-init read-only memory Kees Cook
2015-11-25 23:31 ` [kernel-hardening] " Kees Cook
2015-11-25 23:31 ` [PATCH v2 1/4] init: create cmdline param to disable readonly Kees Cook
2015-11-25 23:31   ` [kernel-hardening] " Kees Cook
2015-11-26  0:37   ` PaX Team [this message]
2015-11-26  0:37     ` [kernel-hardening] " PaX Team
2015-11-26  0:37     ` PaX Team
2015-11-26  0:37     ` PaX Team
2015-11-26  0:44   ` [kernel-hardening] " Greg KH
2015-11-26  0:44     ` Greg KH
2015-11-26  7:51   ` Ingo Molnar
2015-11-26  7:51     ` [kernel-hardening] " Ingo Molnar
2015-11-30 21:52     ` Kees Cook
2015-11-30 21:52       ` [kernel-hardening] " Kees Cook
2015-11-30 21:52       ` Kees Cook
2015-11-30 22:24       ` Russell King - ARM Linux
2015-11-30 22:24         ` [kernel-hardening] " Russell King - ARM Linux
2015-11-30 22:24         ` Russell King - ARM Linux
2015-11-30 22:34         ` Kees Cook
2015-11-30 22:34           ` [kernel-hardening] " Kees Cook
2015-11-30 22:34           ` Kees Cook
2015-12-01  7:24         ` Ingo Molnar
2015-12-01  7:24           ` [kernel-hardening] " Ingo Molnar
2015-12-01  7:24           ` Ingo Molnar
2015-12-01  7:19       ` Heiko Carstens
2015-12-01  7:19         ` [kernel-hardening] " Heiko Carstens
2015-12-01  7:19         ` Heiko Carstens
2015-11-25 23:31 ` [PATCH v2 2/4] introduce post-init read-only memory Kees Cook
2015-11-25 23:31   ` [kernel-hardening] " Kees Cook
2015-11-26  0:15   ` PaX Team
2015-11-26  0:15     ` [kernel-hardening] " PaX Team
2015-11-26  0:15     ` PaX Team
2015-11-26  0:15     ` PaX Team
2015-11-30 22:24     ` H. Peter Anvin
2015-11-30 22:24       ` [kernel-hardening] " H. Peter Anvin
2015-12-09 19:35       ` Kees Cook
2015-12-09 19:35         ` [kernel-hardening] " Kees Cook
2015-12-09 19:35         ` Kees Cook
2015-11-25 23:31 ` [PATCH v2 3/4] lkdtm: verify that __ro_after_init works correctly Kees Cook
2015-11-25 23:31   ` [kernel-hardening] " Kees Cook
2015-11-25 23:31 ` [PATCH v2 4/4] x86, vdso: mark vDSO read-only after init Kees Cook
2015-11-25 23:31   ` [kernel-hardening] " Kees Cook

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5656545F.29919.10A1CE2B@pageexec.freemail.hu \
    --to=pageexec@freemail.hu \
    --cc=arnd@arndb.de \
    --cc=hpa@zytor.com \
    --cc=keescook@chromium.org \
    --cc=kernel-hardening@lists.openwall.com \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@amacapital.net \
    --cc=mingo@redhat.com \
    --cc=minipli@googlemail.com \
    --cc=mpe@ellerman.id.au \
    --cc=re.emese@gmail.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.