All of lore.kernel.org
 help / color / mirror / Atom feed
From: Thomas Hellstrom <thellstrom@vmware.com>
To: Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Arnd Bergmann <arnd@arndb.de>,
	"pv-drivers@vmware.com" <pv-drivers@vmware.com>,
	X86 ML <x86@kernel.org>, lkml <linux-kernel@vger.kernel.org>,
	<virtualization@lists.linux-foundation.org>,
	"linux-graphics-maintainer@vmware.com" 
	<linux-graphics-maintainer@vmware.com>,
	"linux-input@vger.kernel.org" <linux-input@vger.kernel.org>
Subject: Re: [Linux-graphics-maintainer] [PATCH 3/6] Input: Update vmmouse.c to use the common VMW_PORT macros
Date: Wed, 2 Dec 2015 18:29:11 +0100	[thread overview]
Message-ID: <565F2A67.3040104@vmware.com> (raw)
In-Reply-To: <20151202172634.GA15531@dtor-ws>

On 12/02/2015 06:26 PM, Dmitry Torokhov wrote:
> On Wed, Dec 02, 2015 at 07:31:24AM -0800, Greg Kroah-Hartman wrote:
>> On Tue, Dec 01, 2015 at 06:21:06PM -0800, Sinclair Yeh wrote:
>>> On Tue, Dec 01, 2015 at 04:04:08PM -0800, Greg Kroah-Hartman wrote:
>>>> On Tue, Dec 01, 2015 at 02:54:20PM -0800, Sinclair Yeh wrote:
>>>>> Hi,
>>>>>
>>>>> On Tue, Dec 01, 2015 at 02:45:27PM -0800, Dmitry Torokhov wrote:
>>>>>> On Tue, Dec 1, 2015 at 2:32 PM, Sinclair Yeh <syeh@vmware.com> wrote:
>>>>>>> Hi,
>>>>>>>
>>>>> <snip>
>>>>>
>>>>>>>>>   */
>>>>>>>>> -#define VMMOUSE_CMD(cmd, in1, out1, out2, out3, out4)      \
>>>>>>>>> -({                                                 \
>>>>>>>>> -   unsigned long __dummy1, __dummy2;               \
>>>>>>>>> -   __asm__ __volatile__ ("inl %%dx" :              \
>>>>>>>>> -           "=a"(out1),                             \
>>>>>>>>> -           "=b"(out2),                             \
>>>>>>>>> -           "=c"(out3),                             \
>>>>>>>>> -           "=d"(out4),                             \
>>>>>>>>> -           "=S"(__dummy1),                         \
>>>>>>>>> -           "=D"(__dummy2) :                        \
>>>>>>>>> -           "a"(VMMOUSE_PROTO_MAGIC),               \
>>>>>>>>> -           "b"(in1),                               \
>>>>>>>>> -           "c"(VMMOUSE_PROTO_CMD_##cmd),           \
>>>>>>>>> -           "d"(VMMOUSE_PROTO_PORT) :               \
>>>>>>>>> -           "memory");                              \
>>>>>>>>> +#define VMMOUSE_CMD(cmd, in1, out1, out2, out3, out4)                 \
>>>>>>>>> +({                                                            \
>>>>>>>>> +   unsigned long __dummy1 = 0, __dummy2 = 0;                  \
>>>>>>>> Why do we need to initialize dummies?
>>>>>>> Because for some commands those parameters to VMW_PORT() can be both
>>>>>>> input and outout.
>>>>>> The vmmouse commands do not use them as input though, so it seems we
>>>>>> are simply wasting CPU cycles setting them to 0 just because we are
>>>>>> using the new VMW_PORT here. Why do we need to switch? What is the
>>>>>> benefit of doing this?
>>>>> There are two reasons.  One is to make the code more readable and
>>>>> maintainable.  Rather than having mostly similar inline assembly
>>>>> code sprinkled across multiple modules, we can just use the macros
>>>>> and document that.
>>>> But the macro is only used here, and the variables aren't used at all,
>>>> so it makes no sense in this file.
>>> Maybe it's because I didn't CC you on the rest of the series.  I wasn't
>>> sure what the proper distribution list is for each part.
>> Use scripts/get_maintainer.pl, that's what it is there for.  A number of
>> those patches should go through me, if not all of them, if you want them
>> merged...
>>
>>> This new macro is also used in arch/x86/kernel/cpu/vmware.c and
>>> vmw_balloon.c
>> And it's used inconsistantly in those patches (you don't set the dummy
>> variables to 0 in all of them...)  Now maybe that's just how the asm
>> functions work, but it's not very obvious as to why this is at all.
>>
>>>>> The second reason is this organization makes some on-going future
>>>>> development easier.
>>>> We don't plan for "future" development other than a single patch series,
>>>> as we have no idea what that development is, nor if it will really
>>>> happen.  You can always change this file later if you need to, nothing
>>>> is keeping that from happening.
>>> So the intent of this series is to centralize similar lines of inline
>>> assembly code that are currently used by 3 different kernel modules
>>> to a central place.  The new vmware.h [patch 0/6] becomes the one header
>>> to include for common guest-host communication needs.
>> Why can't it go into vmw_vmci_defs.h instead, or your other .h file, why
>> create yet-another-.h-file for your bus?  You already have 2, this would
>> make it 3, which seems like a lot...
> Umm, you are not saying that vmmouse should include vmci header file(s),
> are you? Because the 2 are unrelated and vmci does not use the
> hypervisor port to communicate with host IIRC.

Also the platform setup code uses the hypervisor port, so it's a natural
place for the macro defines.

/Thomas


>
> Thanks.
>


WARNING: multiple messages have this Message-ID (diff)
From: Thomas Hellstrom <thellstrom@vmware.com>
To: Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Arnd Bergmann <arnd@arndb.de>,
	"pv-drivers@vmware.com" <pv-drivers@vmware.com>,
	X86 ML <x86@kernel.org>, lkml <linux-kernel@vger.kernel.org>,
	virtualization@lists.linux-foundation.org,
	"linux-graphics-maintainer@vmware.com"
	<linux-graphics-maintainer@vmware.com>,
	"linux-input@vger.kernel.org" <linux-input@vger.kernel.org>
Subject: Re: [Linux-graphics-maintainer] [PATCH 3/6] Input: Update vmmouse.c to use the common VMW_PORT macros
Date: Wed, 2 Dec 2015 18:29:11 +0100	[thread overview]
Message-ID: <565F2A67.3040104@vmware.com> (raw)
In-Reply-To: <20151202172634.GA15531@dtor-ws>

On 12/02/2015 06:26 PM, Dmitry Torokhov wrote:
> On Wed, Dec 02, 2015 at 07:31:24AM -0800, Greg Kroah-Hartman wrote:
>> On Tue, Dec 01, 2015 at 06:21:06PM -0800, Sinclair Yeh wrote:
>>> On Tue, Dec 01, 2015 at 04:04:08PM -0800, Greg Kroah-Hartman wrote:
>>>> On Tue, Dec 01, 2015 at 02:54:20PM -0800, Sinclair Yeh wrote:
>>>>> Hi,
>>>>>
>>>>> On Tue, Dec 01, 2015 at 02:45:27PM -0800, Dmitry Torokhov wrote:
>>>>>> On Tue, Dec 1, 2015 at 2:32 PM, Sinclair Yeh <syeh@vmware.com> wrote:
>>>>>>> Hi,
>>>>>>>
>>>>> <snip>
>>>>>
>>>>>>>>>   */
>>>>>>>>> -#define VMMOUSE_CMD(cmd, in1, out1, out2, out3, out4)      \
>>>>>>>>> -({                                                 \
>>>>>>>>> -   unsigned long __dummy1, __dummy2;               \
>>>>>>>>> -   __asm__ __volatile__ ("inl %%dx" :              \
>>>>>>>>> -           "=a"(out1),                             \
>>>>>>>>> -           "=b"(out2),                             \
>>>>>>>>> -           "=c"(out3),                             \
>>>>>>>>> -           "=d"(out4),                             \
>>>>>>>>> -           "=S"(__dummy1),                         \
>>>>>>>>> -           "=D"(__dummy2) :                        \
>>>>>>>>> -           "a"(VMMOUSE_PROTO_MAGIC),               \
>>>>>>>>> -           "b"(in1),                               \
>>>>>>>>> -           "c"(VMMOUSE_PROTO_CMD_##cmd),           \
>>>>>>>>> -           "d"(VMMOUSE_PROTO_PORT) :               \
>>>>>>>>> -           "memory");                              \
>>>>>>>>> +#define VMMOUSE_CMD(cmd, in1, out1, out2, out3, out4)                 \
>>>>>>>>> +({                                                            \
>>>>>>>>> +   unsigned long __dummy1 = 0, __dummy2 = 0;                  \
>>>>>>>> Why do we need to initialize dummies?
>>>>>>> Because for some commands those parameters to VMW_PORT() can be both
>>>>>>> input and outout.
>>>>>> The vmmouse commands do not use them as input though, so it seems we
>>>>>> are simply wasting CPU cycles setting them to 0 just because we are
>>>>>> using the new VMW_PORT here. Why do we need to switch? What is the
>>>>>> benefit of doing this?
>>>>> There are two reasons.  One is to make the code more readable and
>>>>> maintainable.  Rather than having mostly similar inline assembly
>>>>> code sprinkled across multiple modules, we can just use the macros
>>>>> and document that.
>>>> But the macro is only used here, and the variables aren't used at all,
>>>> so it makes no sense in this file.
>>> Maybe it's because I didn't CC you on the rest of the series.  I wasn't
>>> sure what the proper distribution list is for each part.
>> Use scripts/get_maintainer.pl, that's what it is there for.  A number of
>> those patches should go through me, if not all of them, if you want them
>> merged...
>>
>>> This new macro is also used in arch/x86/kernel/cpu/vmware.c and
>>> vmw_balloon.c
>> And it's used inconsistantly in those patches (you don't set the dummy
>> variables to 0 in all of them...)  Now maybe that's just how the asm
>> functions work, but it's not very obvious as to why this is at all.
>>
>>>>> The second reason is this organization makes some on-going future
>>>>> development easier.
>>>> We don't plan for "future" development other than a single patch series,
>>>> as we have no idea what that development is, nor if it will really
>>>> happen.  You can always change this file later if you need to, nothing
>>>> is keeping that from happening.
>>> So the intent of this series is to centralize similar lines of inline
>>> assembly code that are currently used by 3 different kernel modules
>>> to a central place.  The new vmware.h [patch 0/6] becomes the one header
>>> to include for common guest-host communication needs.
>> Why can't it go into vmw_vmci_defs.h instead, or your other .h file, why
>> create yet-another-.h-file for your bus?  You already have 2, this would
>> make it 3, which seems like a lot...
> Umm, you are not saying that vmmouse should include vmci header file(s),
> are you? Because the 2 are unrelated and vmci does not use the
> hypervisor port to communicate with host IIRC.

Also the platform setup code uses the hypervisor port, so it's a natural
place for the macro defines.

/Thomas


>
> Thanks.
>

  reply	other threads:[~2015-12-02 17:29 UTC|newest]

Thread overview: 96+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <1449008047-8252-1-git-send-email-syeh@vmware.com>
2015-12-01 22:18 ` [PATCH 1/6] x86: Add VMWare Host Communication Macros Sinclair Yeh
2015-12-01 22:18   ` Sinclair Yeh
2015-12-01 22:18   ` [PATCH 2/6] x86: Update vmware.c to use the common VMW_PORT macros Sinclair Yeh
2015-12-01 22:18     ` Sinclair Yeh
2015-12-01 22:18   ` [PATCH 3/6] Input: Update vmmouse.c " Sinclair Yeh
2015-12-01 22:18     ` Sinclair Yeh
2015-12-01 22:24     ` Dmitry Torokhov
2015-12-01 22:32       ` Sinclair Yeh
2015-12-01 22:45         ` Dmitry Torokhov
2015-12-01 22:45         ` Dmitry Torokhov
2015-12-01 22:45           ` Dmitry Torokhov
2015-12-01 22:54           ` Sinclair Yeh
2015-12-01 22:54             ` Sinclair Yeh
2015-12-01 23:56             ` Dmitry Torokhov
2015-12-01 23:56             ` Dmitry Torokhov
2015-12-01 23:56               ` Dmitry Torokhov
2015-12-02  0:04             ` Greg Kroah-Hartman
2015-12-02  0:04               ` Greg Kroah-Hartman
2015-12-02  2:21               ` Sinclair Yeh
2015-12-02  2:21                 ` Sinclair Yeh
2015-12-02 15:31                 ` Greg Kroah-Hartman
2015-12-02 15:31                   ` Greg Kroah-Hartman
2015-12-02 15:57                   ` Sinclair Yeh
2015-12-02 15:57                     ` Sinclair Yeh
2015-12-02 15:57                   ` Sinclair Yeh
2015-12-02 17:26                   ` Dmitry Torokhov
2015-12-02 17:26                     ` Dmitry Torokhov
2015-12-02 17:29                     ` Thomas Hellstrom [this message]
2015-12-02 17:29                       ` [Linux-graphics-maintainer] " Thomas Hellstrom
2015-12-02 18:45                     ` Greg Kroah-Hartman
2015-12-02 18:45                       ` Greg Kroah-Hartman
2015-12-02 18:58                       ` Dmitry Torokhov
2015-12-02 18:58                         ` Dmitry Torokhov
2015-12-02 18:58                       ` Dmitry Torokhov
2015-12-02 19:02                       ` Sinclair Yeh
2015-12-02 19:02                         ` Sinclair Yeh
2015-12-02  2:21               ` Sinclair Yeh
2015-12-02  7:07               ` [Linux-graphics-maintainer] " Thomas Hellstrom
2015-12-02  7:07               ` Thomas Hellstrom
2015-12-02  7:07                 ` Thomas Hellstrom
2015-12-01 22:32       ` Sinclair Yeh
2015-12-01 22:24     ` Dmitry Torokhov
2015-12-02  0:01     ` Greg Kroah-Hartman
2015-12-02  0:01     ` Greg Kroah-Hartman
2015-12-01 22:18   ` [PATCH 4/6] Input: Remove vmmouse port reservation Sinclair Yeh
2015-12-01 22:30     ` Dmitry Torokhov
2015-12-01 22:30       ` Dmitry Torokhov
2015-12-01 23:04       ` Sinclair Yeh
2015-12-01 23:04         ` Sinclair Yeh
2015-12-01 23:52         ` Dmitry Torokhov
2015-12-01 23:52           ` Dmitry Torokhov
2015-12-01 22:18   ` Sinclair Yeh
2015-12-01 22:18   ` [PATCH 5/6] x86: Remove address from the vmware.c header Sinclair Yeh
2015-12-01 22:18   ` [PATCH 6/6] VMware balloon: Update vmw_balloon.c to use the VMW_PORT macro Sinclair Yeh
2015-12-01 22:38     ` Xavier Deguillard
2015-12-01 23:17       ` Sinclair Yeh
2015-12-01 23:17       ` Sinclair Yeh
2015-12-01 22:38     ` Xavier Deguillard
2015-12-01 22:18   ` Sinclair Yeh
2015-12-01 22:32   ` [PATCH 1/6] x86: Add VMWare Host Communication Macros Xavier Deguillard
2015-12-01 22:32   ` Xavier Deguillard
2015-12-01 22:49   ` H. Peter Anvin
2015-12-04 22:33     ` Sinclair Yeh
2015-12-04 22:33       ` Sinclair Yeh
2015-12-01 22:49   ` H. Peter Anvin
     [not found] ` <1449271183-1746-1-git-send-email-syeh@vmware.com>
2015-12-04 23:19   ` Sinclair Yeh
2015-12-04 23:19     ` Sinclair Yeh
2015-12-04 23:19   ` [PATCH 2/6] x86: Update vmware.c to use the common VMW_PORT macros Sinclair Yeh
2015-12-04 23:19     ` Sinclair Yeh
2015-12-04 23:19   ` [PATCH 3/6] Input: Update vmmouse.c " Sinclair Yeh
2015-12-04 23:19     ` Sinclair Yeh
2015-12-04 23:19   ` [PATCH 4/6] Input: Remove vmmouse port reservation Sinclair Yeh
2015-12-04 23:19     ` Sinclair Yeh
2015-12-04 23:19   ` [PATCH 5/6] x86: Remove address from the vmware.c header Sinclair Yeh
2015-12-04 23:19   ` [PATCH 6/6] VMware balloon: Update vmw_balloon.c to use the VMW_PORT macro Sinclair Yeh
2015-12-04 23:19   ` Sinclair Yeh
2016-01-19 21:45   ` [PATCH 0/6] Create common VMWare host port communication macros v3 Sinclair Yeh
2016-01-19 21:46     ` [PATCH 1/6] x86: Add VMWare Host Communication Macros Sinclair Yeh
2016-01-19 21:46       ` Sinclair Yeh
2016-01-19 21:46     ` [PATCH 2/6] x86: Update vmware.c to use the common VMW_PORT macros Sinclair Yeh
2016-01-19 21:46       ` Sinclair Yeh
2016-01-19 21:46     ` [PATCH 3/6] Input: Update vmmouse.c " Sinclair Yeh
2016-01-19 21:46     ` Sinclair Yeh
2016-01-19 21:46     ` [PATCH 4/6] Input: Remove vmmouse port reservation Sinclair Yeh
2016-01-19 21:46       ` Sinclair Yeh
2016-01-19 21:46     ` [PATCH 5/6] x86: Remove address from the vmware.c header Sinclair Yeh
2016-01-19 21:46     ` [PATCH 6/6] VMware balloon: Update vmw_balloon.c to use the VMW_PORT macro Sinclair Yeh
2016-01-19 21:46       ` Sinclair Yeh
2016-02-08 19:41       ` Greg KH
2016-02-08 19:41         ` Greg KH
2016-03-31 14:39         ` Sinclair Yeh
2016-03-31 14:39         ` Sinclair Yeh
2016-03-31 16:30           ` Greg KH
2016-03-31 16:30             ` Greg KH
2016-03-31 17:32             ` Sinclair Yeh
2016-03-31 17:32               ` Sinclair Yeh

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=565F2A67.3040104@vmware.com \
    --to=thellstrom@vmware.com \
    --cc=arnd@arndb.de \
    --cc=dmitry.torokhov@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-graphics-maintainer@vmware.com \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pv-drivers@vmware.com \
    --cc=virtualization@lists.linux-foundation.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.