All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Michael Kerrisk (man-pages)" <mtk.manpages@gmail.com>
To: Andreas Dilger <adilger@dilger.ca>
Cc: mtk.manpages@gmail.com, David Howells <dhowells@redhat.com>,
	linux-fsdevel@vger.kernel.org, linux-api@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/4] statx: Add a system call to make enhanced file info available [ver #3]
Date: Thu, 24 Nov 2016 09:13:49 +0100	[thread overview]
Message-ID: <5a4327bd-06ef-d24e-cc87-715bc2de6f62@gmail.com> (raw)
In-Reply-To: <19284F6D-73B9-4A1A-8227-2B2B87F29FE9@dilger.ca>

Hi Andreas,

On 11/23/2016 11:57 PM, Andreas Dilger wrote:
> On Nov 23, 2016, at 1:37 AM, Michael Kerrisk <mtk.manpages@gmail.com> wrote:
>>

[...]

>>> ===============
>>> NEW SYSTEM CALL
>>> ===============
>>>
>>> The new system call is:
>>>
>>> 	int ret = statx(int dfd,
>>> 			const char *filename,
>>> 			unsigned int flags,
>>
>> In the 0/4 of this patch series, this argument is called 'atflags'.
>> These should be consistent. 'flags' seems correct to me.
> 
> Given that there are a number of different flags and masks in use for
> this syscall, naming this field "atflags" makes it more clear what it
> is used for.

Well, yes, but in all of the "at" calls the argument is just flags.
So, better to be consistent in that dimension, I'd say, and then 
make sure we perhaps have meaningfil names for the fiellds, as you suggest next:


>>> 			unsigned int mask,
> 
> Similarly, naming this field "request_mask" would also be more clear,
> and matches what is used elsewhere in the code.
> 
> That said, I don't care enough about this detail to request a patch refresh,
> but it would be useful for the man pages.


-- 
Michael Kerrisk
Linux man-pages maintainer; http://www.kernel.org/doc/man-pages/
Linux/UNIX System Programming Training: http://man7.org/training/

WARNING: multiple messages have this Message-ID (diff)
From: "Michael Kerrisk (man-pages)" <mtk.manpages-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>
To: Andreas Dilger <adilger-m1MBpc4rdrD3fQ9qLvQP4Q@public.gmane.org>
Cc: mtk.manpages-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org,
	David Howells <dhowells-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org>,
	linux-fsdevel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	linux-api-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
Subject: Re: [PATCH 1/4] statx: Add a system call to make enhanced file info available [ver #3]
Date: Thu, 24 Nov 2016 09:13:49 +0100	[thread overview]
Message-ID: <5a4327bd-06ef-d24e-cc87-715bc2de6f62@gmail.com> (raw)
In-Reply-To: <19284F6D-73B9-4A1A-8227-2B2B87F29FE9-m1MBpc4rdrD3fQ9qLvQP4Q@public.gmane.org>

Hi Andreas,

On 11/23/2016 11:57 PM, Andreas Dilger wrote:
> On Nov 23, 2016, at 1:37 AM, Michael Kerrisk <mtk.manpages-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org> wrote:
>>

[...]

>>> ===============
>>> NEW SYSTEM CALL
>>> ===============
>>>
>>> The new system call is:
>>>
>>> 	int ret = statx(int dfd,
>>> 			const char *filename,
>>> 			unsigned int flags,
>>
>> In the 0/4 of this patch series, this argument is called 'atflags'.
>> These should be consistent. 'flags' seems correct to me.
> 
> Given that there are a number of different flags and masks in use for
> this syscall, naming this field "atflags" makes it more clear what it
> is used for.

Well, yes, but in all of the "at" calls the argument is just flags.
So, better to be consistent in that dimension, I'd say, and then 
make sure we perhaps have meaningfil names for the fiellds, as you suggest next:


>>> 			unsigned int mask,
> 
> Similarly, naming this field "request_mask" would also be more clear,
> and matches what is used elsewhere in the code.
> 
> That said, I don't care enough about this detail to request a patch refresh,
> but it would be useful for the man pages.


-- 
Michael Kerrisk
Linux man-pages maintainer; http://www.kernel.org/doc/man-pages/
Linux/UNIX System Programming Training: http://man7.org/training/

  reply	other threads:[~2016-11-24  8:14 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-11-23  0:55 [RFC][PATCH 0/4] Enhanced file stat system call [ver #3] David Howells
2016-11-23  0:55 ` David Howells
2016-11-23  0:55 ` [PATCH 1/4] statx: Add a system call to make enhanced file info available " David Howells
2016-11-23  8:37   ` Michael Kerrisk (man-pages)
2016-11-23 22:42     ` Andreas Dilger
2016-11-23 22:42       ` Andreas Dilger
2016-11-23 22:57     ` Andreas Dilger
2016-11-23 22:57       ` Andreas Dilger
2016-11-24  8:13       ` Michael Kerrisk (man-pages) [this message]
2016-11-24  8:13         ` Michael Kerrisk (man-pages)
2016-11-24  2:08   ` Andreas Dilger
2016-11-24  2:08     ` Andreas Dilger
2016-11-24  7:27   ` David Howells
2016-11-24  7:27     ` David Howells
2016-12-04  4:00   ` Al Viro
2016-12-04  4:38   ` Al Viro
2016-12-04 16:05     ` Al Viro
2016-12-04 17:33     ` Al Viro
2016-12-04 17:33       ` Al Viro
2016-12-05 14:49       ` Miklos Szeredi
2016-12-05 14:49         ` Miklos Szeredi
2016-12-05 15:37     ` David Howells
2016-12-05 15:37       ` David Howells
2016-11-23  0:55 ` [PATCH 2/4] statx: Ext4: Return enhanced file attributes " David Howells
2016-11-23 17:59   ` Andreas Dilger
2016-11-23 17:59     ` Andreas Dilger
2016-11-23  0:56 ` [PATCH 3/4] statx: NFS: " David Howells
2016-11-23  0:56 ` [PATCH 4/4] statx: AFS: " David Howells
2016-11-23  0:56   ` David Howells
2016-11-24  2:06   ` Andreas Dilger
2016-11-24  2:06     ` Andreas Dilger

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5a4327bd-06ef-d24e-cc87-715bc2de6f62@gmail.com \
    --to=mtk.manpages@gmail.com \
    --cc=adilger@dilger.ca \
    --cc=dhowells@redhat.com \
    --cc=linux-api@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.