All of lore.kernel.org
 help / color / mirror / Atom feed
From: michael.christie@oracle.com
To: Jens Axboe <axboe@kernel.dk>,
	Christian Brauner <christian.brauner@ubuntu.com>
Cc: geert@linux-m68k.org, vverma@digitalocean.com, hdanton@sina.com,
	hch@infradead.org, stefanha@redhat.com, jasowang@redhat.com,
	mst@redhat.com, sgarzare@redhat.com,
	virtualization@lists.linux-foundation.org,
	linux-kernel@vger.kernel.org, Christoph Hellwig <hch@lst.de>
Subject: Re: [PATCH V5 07/10] io_uring: switch to kernel_worker
Date: Mon, 22 Nov 2021 10:47:28 -0600	[thread overview]
Message-ID: <766e8487-c83f-5ed1-1e49-0f17ef5ad97d@oracle.com> (raw)
In-Reply-To: <f2a421da-1bb0-c65a-d8e2-7cbbb2cccfab@kernel.dk>

On 11/22/21 8:20 AM, Jens Axboe wrote:
> On 11/22/21 3:02 AM, Christian Brauner wrote:
>> On Sun, Nov 21, 2021 at 11:17:11AM -0700, Jens Axboe wrote:
>>> On 11/21/21 10:49 AM, Mike Christie wrote:
>>>> Convert io_uring and io-wq to use kernel_worker.
>>>
>>> I don't like the kernel_worker name, that implies it's always giving you
>>> a kernel thread or kthread. That's not the io_uring use case, it's
>>> really just a thread off the original task that just happens to never
>>> exit to userspace.
>>>
>>> Can we do a better name? At least io_thread doesn't imply that.
>>
>> Yeah, I had thought about that as well and at first had kernel_uworker()
>> locally but wasn't convinced. Maybe we should just make it
>> create_user_worker()?
> 
> That's better, or maybe even create_user_inkernel_thread() or something?
> Pretty long, though... I'd be fine with create_user_worker().
> 

Ok, I'll do:

create_user_worker()
start_user_worker()

since you guys agree. It will also match the PF flag naming.

I'll also add more details to the commit message you requested.

WARNING: multiple messages have this Message-ID (diff)
From: michael.christie@oracle.com
To: Jens Axboe <axboe@kernel.dk>,
	Christian Brauner <christian.brauner@ubuntu.com>
Cc: hdanton@sina.com, mst@redhat.com, linux-kernel@vger.kernel.org,
	virtualization@lists.linux-foundation.org, hch@infradead.org,
	vverma@digitalocean.com, geert@linux-m68k.org,
	stefanha@redhat.com, Christoph Hellwig <hch@lst.de>
Subject: Re: [PATCH V5 07/10] io_uring: switch to kernel_worker
Date: Mon, 22 Nov 2021 10:47:28 -0600	[thread overview]
Message-ID: <766e8487-c83f-5ed1-1e49-0f17ef5ad97d@oracle.com> (raw)
In-Reply-To: <f2a421da-1bb0-c65a-d8e2-7cbbb2cccfab@kernel.dk>

On 11/22/21 8:20 AM, Jens Axboe wrote:
> On 11/22/21 3:02 AM, Christian Brauner wrote:
>> On Sun, Nov 21, 2021 at 11:17:11AM -0700, Jens Axboe wrote:
>>> On 11/21/21 10:49 AM, Mike Christie wrote:
>>>> Convert io_uring and io-wq to use kernel_worker.
>>>
>>> I don't like the kernel_worker name, that implies it's always giving you
>>> a kernel thread or kthread. That's not the io_uring use case, it's
>>> really just a thread off the original task that just happens to never
>>> exit to userspace.
>>>
>>> Can we do a better name? At least io_thread doesn't imply that.
>>
>> Yeah, I had thought about that as well and at first had kernel_uworker()
>> locally but wasn't convinced. Maybe we should just make it
>> create_user_worker()?
> 
> That's better, or maybe even create_user_inkernel_thread() or something?
> Pretty long, though... I'd be fine with create_user_worker().
> 

Ok, I'll do:

create_user_worker()
start_user_worker()

since you guys agree. It will also match the PF flag naming.

I'll also add more details to the commit message you requested.
_______________________________________________
Virtualization mailing list
Virtualization@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/virtualization

  reply	other threads:[~2021-11-22 16:48 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-11-21 17:49 [PATCH V5 00/10] Use copy_process/create_io_thread in vhost layer Mike Christie
2021-11-21 17:49 ` Mike Christie
2021-11-21 17:49 ` [PATCH V5 01/10] fork: Make IO worker options flag based Mike Christie
2021-11-21 17:49   ` Mike Christie
2021-11-21 17:49 ` [PATCH V5 02/10] fork/vm: Move common PF_IO_WORKER behavior to new flag Mike Christie
2021-11-21 17:49   ` Mike Christie
2021-11-22  8:08   ` Geert Uytterhoeven
2021-11-22  8:08     ` Geert Uytterhoeven
2021-11-21 17:49 ` [PATCH V5 03/10] fork: add KERNEL_WORKER flag to not dup/clone files Mike Christie
2021-11-21 17:49   ` Mike Christie
2021-11-21 17:49 ` [PATCH V5 04/10] fork: Add KERNEL_WORKER flag to ignore signals Mike Christie
2021-11-21 17:49   ` Mike Christie
2021-11-21 17:49 ` [PATCH V5 05/10] signal: Perfom autoreap for PF_USER_WORKER Mike Christie
2021-11-21 17:49   ` Mike Christie
2021-11-21 17:49 ` [PATCH V5 06/10] fork: add helper to clone a process Mike Christie
2021-11-21 17:49   ` Mike Christie
2021-11-21 17:49 ` [PATCH V5 07/10] io_uring: switch to kernel_worker Mike Christie
2021-11-21 17:49   ` Mike Christie
2021-11-21 18:17   ` Jens Axboe
2021-11-21 18:17     ` Jens Axboe
2021-11-22 10:02     ` Christian Brauner
2021-11-22 14:20       ` Jens Axboe
2021-11-22 14:20         ` Jens Axboe
2021-11-22 16:47         ` michael.christie [this message]
2021-11-22 16:47           ` michael.christie
2021-11-23 14:23           ` Christian Brauner
2021-11-21 17:49 ` [PATCH V5 08/10] fork: remove create_io_thread Mike Christie
2021-11-21 17:49   ` Mike Christie
2021-11-21 17:49 ` [PATCH V5 09/10] vhost: move worker thread fields to new struct Mike Christie
2021-11-21 17:49   ` Mike Christie
2021-11-21 17:49 ` [PATCH V5 10/10] vhost: use kernel_worker to check RLIMITs Mike Christie
2021-11-21 17:49   ` Mike Christie

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=766e8487-c83f-5ed1-1e49-0f17ef5ad97d@oracle.com \
    --to=michael.christie@oracle.com \
    --cc=axboe@kernel.dk \
    --cc=christian.brauner@ubuntu.com \
    --cc=geert@linux-m68k.org \
    --cc=hch@infradead.org \
    --cc=hch@lst.de \
    --cc=hdanton@sina.com \
    --cc=jasowang@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mst@redhat.com \
    --cc=sgarzare@redhat.com \
    --cc=stefanha@redhat.com \
    --cc=virtualization@lists.linux-foundation.org \
    --cc=vverma@digitalocean.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.