All of lore.kernel.org
 help / color / mirror / Atom feed
From: Paolo Bonzini <pbonzini@redhat.com>
To: "Radim Krčmář" <rkrcmar@redhat.com>
Cc: kvm@vger.kernel.org, Drew Jones <drjones@redhat.com>,
	Laurent Vivier <lvivier@redhat.com>,
	Thomas Huth <thuth@redhat.com>,
	David Hildenbrand <david@redhat.com>
Subject: Re: [kvm-unit-tests PATCH 5/5] arch/run: unify accelerator detection
Date: Thu, 29 Jun 2017 15:49:37 +0200	[thread overview]
Message-ID: <7f4b57cf-4283-2ce3-6358-c38bbf87bd69@redhat.com> (raw)
In-Reply-To: <20170629134657.GA14932@potion>



On 29/06/2017 15:46, Radim Krčmář wrote:
> 2017-06-29 14:45+0200, Radim Krčmář:
>> 2017-06-28 22:48+0200, Paolo Bonzini:
>>> On 28/06/2017 22:08, Radim Krčmář wrote:
>>>> -if [ "$ACCEL" = "kvm" ] && [ "$kvm_available" != "yes" ]; then
>>>> -	echo "KVM is needed, but not available on this host"
>>>> +ACCEL=$(get_accel '([ "$HOST" = "arm" ] && [ "$ARCH" = "arm" ]) || [ "$HOST" = "aarch64" ]') ||
>>>>  	exit 2
>>>
>>> Should x86 do the same as ARM (follow-up patch)?
>>
>> Yeah, I'll prepare it when we've agreed on the format.
>>
>>> And maybe the test could move from an argument of get_accel to a
>>> function "arch_kvm_available" that returns 0 if available and 1 if not?
>>
>> Right, the arm condition needs to be fixed as
>>
>>   ([ "$HOST" = "arm" ] && [ "$ARCH" = "arm" ]) ||
>>   ([ "$HOST" = "aarch64" ] && [ "$ARCH" = arm -o "$ARCH" = arm64 ])
>>
>> and it would look even worse in the argument ...
>>
>> Would it be ok like this?
> 
> No, we can make a better use of the $HOST variable:

Either is okay.

Paolo

> diff --git a/arm/run b/arm/run
> index f2e71eca022d..1245d42edae7 100755
> --- a/arm/run
> +++ b/arm/run
> @@ -10,7 +10,7 @@ if [ -z "$STANDALONE" ]; then
>  fi
>  processor="$PROCESSOR"
>  
> -ACCEL=$(get_accel '([ "$HOST" = "arm" ] && [ "$ARCH" = "arm" ]) || [ "$HOST" = "aarch64" ]') ||
> +ACCEL=$(get_accel) ||
>  	exit 2
>  
>  qemu=$(search_qemu_binary) ||
> diff --git a/powerpc/run b/powerpc/run
> index 55b987c5efc5..58921e81eb8f 100755
> --- a/powerpc/run
> +++ b/powerpc/run
> @@ -9,7 +9,7 @@ if [ -z "$STANDALONE" ]; then
>  	source scripts/arch-run.bash
>  fi
>  
> -ACCEL=$(get_accel '[ "$HOST" = "ppc64" ] && [ "$ARCH" = "ppc64" ]') ||
> +ACCEL=$(get_accel) ||
>  	exit 2
>  
>  qemu=$(search_qemu_binary) ||
> diff --git a/s390x/run b/s390x/run
> index 67d6e88ea7e4..2242ebb79fbc 100755
> --- a/s390x/run
> +++ b/s390x/run
> @@ -9,7 +9,7 @@ if [ -z "$STANDALONE" ]; then
>  	source scripts/arch-run.bash
>  fi
>  
> -ACCEL=$(get_accel '[ "$HOST" = "s390x" ] && [ "$ARCH" = "s390x" ]') ||
> +ACCEL=$(get_accel) ||
>  	exit 2
>  
>  qemu=$(search_qemu_binary) ||
> diff --git a/scripts/arch-run.bash b/scripts/arch-run.bash
> index a696652c61b1..77071216ff99 100644
> --- a/scripts/arch-run.bash
> +++ b/scripts/arch-run.bash
> @@ -273,22 +273,26 @@ trap_exit_push ()
>  	trap -- "$1; $old_exit" EXIT
>  }
>  
> +kvm_available ()
> +{
> +	[ -c /dev/kvm ] ||
> +		return 1
> +
> +	[ "$HOST" = "$ARCH_NAME" ] ||
> +		[ "$HOST" = aarch64 -a "$ARCH" = arm ] ||
> +		[ "$HOST" = x86_64 -a "$ARCH" = i386 ]
> +}
> +
>  get_accel ()
>  {
> -	local kvm_available
> -
> -	if [ -c /dev/kvm ] && eval "$@"; then
> -		kvm_available=yes
> -	fi
> -
> -	if [ "$ACCEL" = "kvm" ] && [ "$kvm_available" != "yes" ]; then
> +	if [ "$ACCEL" = "kvm" ] && ! kvm_available; then
>  		echo "KVM is needed, but not available on this host" >&2
>  		return 2
>  	fi
>  
>  	if [ "$ACCEL" ]; then
>  		echo $ACCEL
> -	elif [ "$kvm_available" = "yes" ]; then
> +	elif kvm_available; then
>  		echo kvm
>  	else
>  		echo tcg
> 

  reply	other threads:[~2017-06-29 13:49 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-06-28 20:08 [kvm-unit-tests PATCH 0/5] Minor fixes while getting rid of code duplication Radim Krčmář
2017-06-28 20:08 ` [kvm-unit-tests PATCH 1/5] arch/run: simplify copy-paste of the command line Radim Krčmář
2017-06-28 20:08 ` [kvm-unit-tests PATCH 2/5] run_tests: add summary to powerpc and s390 Radim Krčmář
2017-06-29  5:30   ` Thomas Huth
2017-06-29 12:53     ` Radim Krčmář
2017-06-28 20:08 ` [kvm-unit-tests PATCH 3/5] s390+powerpc/run: improve output handling Radim Krčmář
2017-06-28 20:08 ` [kvm-unit-tests PATCH 4/5] scripts/arch-run: fix qemu binary search failure path Radim Krčmář
2017-06-28 20:46   ` Paolo Bonzini
2017-06-29 12:32     ` Radim Krčmář
2017-06-28 20:08 ` [kvm-unit-tests PATCH 5/5] arch/run: unify accelerator detection Radim Krčmář
2017-06-28 20:48   ` Paolo Bonzini
2017-06-29 12:45     ` Radim Krčmář
2017-06-29 13:46       ` Radim Krčmář
2017-06-29 13:49         ` Paolo Bonzini [this message]
2017-06-29 14:28   ` [kvm-unit-tests PATCH v2 " Radim Krčmář
2017-06-29 14:32   ` [kvm-unit-tests PATCH v2 6/5] x86/run: support accelerator controls Radim Krčmář
2017-06-30 10:42     ` Paolo Bonzini
2017-06-29 11:41 ` [kvm-unit-tests PATCH 0/5] Minor fixes while getting rid of code duplication Andrew Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7f4b57cf-4283-2ce3-6358-c38bbf87bd69@redhat.com \
    --to=pbonzini@redhat.com \
    --cc=david@redhat.com \
    --cc=drjones@redhat.com \
    --cc=kvm@vger.kernel.org \
    --cc=lvivier@redhat.com \
    --cc=rkrcmar@redhat.com \
    --cc=thuth@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.