All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH 0/5] Remove old MigrationParams
@ 2017-05-18 11:18 Juan Quintela
  2017-05-18 11:18 ` [Qemu-devel] [PATCH 1/5] hmp: Use visitor api for hmp_migrate_set_parameter() Juan Quintela
                   ` (5 more replies)
  0 siblings, 6 replies; 24+ messages in thread
From: Juan Quintela @ 2017-05-18 11:18 UTC (permalink / raw)
  To: qemu-devel; +Cc: dgilbert, lvivier, peterx, eblake, armbru

Hi

Changes from v4:
- make suggested logic change by eric
- remove extra space in error message
- allow migrate_set_capability block off when block migration is complied off
  (eric request)

Please review

[v4]

- Address Markus review
  * better documentation messages (thanks)
  * reorganize error checking to have small data
  * Use g_new0
  * Improve commints messages

[v4]

- patch 1 included again. We have a 'block' capability and a
  'block_incremental' parameter
  Make Dave happy: rename shared into incremental
  Make Eric and Markus happy:

    block: off -> no block migration, we don't care about
                  block_incremental value
    block: on block_incremental: off -> no incremental block migration
    block: on block_incremental: on  -> incremental block migration

- Use visitors.
  You ask if there is not a better way than hand coding a boolean parser.
  QAPI people (a.k.a. Markus) answer to use a visitor.
  Once there, I used it also for integers, not only booleans.

- Use -b/-i parameters.  OK, I bit the bullet: You can't use
  capabilities/parameters and -b/-i: it gives you one error If you use
  -b/-i, capability parameter is cleanup after the migration ends (Who
  would have guessed that there are cases where we call
  migration_fd_error(), but not migration_fd_cleanup()
  I think this should make Peter and Markus and Dave happy.

- Integrate migrate block compile time disabling
  Well, it conflicted left and right, so I fixed it
  Once there, I disable setting/getting block capability if it is disabled.

[v3]

- Patch 1 included in pull request
- disable block_shared when we disable block_enable
- enable block_enabled when we enable block_shared

[v2]

- make migrate_block_set_* take a boolean
- disable block migration in colo to maintain semantics.

[v1]
Upon a time there were MigrationParms (only used for block migration)
and then MigrationParams used for everything else.  This series:

- create migration capabilities for block parameters
- make the migrate command line parameters to use capabilities
- remove MigrationParams completely


Dr. David Alan Gilbert (1):
  block migration: Allow compile time disable

Juan Quintela (4):
  hmp: Use visitor api for hmp_migrate_set_parameter()
  migration: Create block capability
  migration: Remove use of old MigrationParams
  migration: Remove old MigrationParams

 configure                     | 11 +++++
 hmp.c                         | 23 +++++++++--
 include/migration/block.h     | 24 +++++++++++
 include/migration/migration.h | 17 ++++----
 include/migration/vmstate.h   |  1 -
 include/qemu/typedefs.h       |  1 -
 include/sysemu/sysemu.h       |  3 +-
 migration/Makefile.objs       |  2 +-
 migration/block.c             | 17 +-------
 migration/colo.c              |  6 +--
 migration/migration.c         | 96 +++++++++++++++++++++++++++++++++++++++----
 migration/savevm.c            | 24 ++++-------
 qapi-schema.json              | 28 +++++++++++--
 13 files changed, 191 insertions(+), 62 deletions(-)

-- 
2.9.3

^ permalink raw reply	[flat|nested] 24+ messages in thread
* [Qemu-devel] [PATCH v5 0/5] Remove old MigrationParams
@ 2017-05-17 15:38 Juan Quintela
  2017-05-17 15:38 ` [Qemu-devel] [PATCH 3/5] migration: Remove use of " Juan Quintela
  0 siblings, 1 reply; 24+ messages in thread
From: Juan Quintela @ 2017-05-17 15:38 UTC (permalink / raw)
  To: qemu-devel; +Cc: dgilbert, lvivier, peterx, eblake, armbru

Hi

changes from v4:

- Address Markus review
  * better documentation messages (thanks)
  * reorganize error checking to have small data
  * Use g_new0
  * Improve commints messages

Please review.

[v4]

- patch 1 included again. We have a 'block' capability and a
  'block_incremental' parameter
  Make Dave happy: rename shared into incremental
  Make Eric and Markus happy:

    block: off -> no block migration, we don't care about
                  block_incremental value
    block: on block_incremental: off -> no incremental block migration
    block: on block_incremental: on  -> incremental block migration

- Use visitors.
  You ask if there is not a better way than hand coding a boolean parser.
  QAPI people (a.k.a. Markus) answer to use a visitor.
  Once there, I used it also for integers, not only booleans.

- Use -b/-i parameters.  OK, I bit the bullet: You can't use
  capabilities/parameters and -b/-i: it gives you one error If you use
  -b/-i, capability parameter is cleanup after the migration ends (Who
  would have guessed that there are cases where we call
  migration_fd_error(), but not migration_fd_cleanup()
  I think this should make Peter and Markus and Dave happy.

- Integrate migrate block compile time disabling
  Well, it conflicted left and right, so I fixed it
  Once there, I disable setting/getting block capability if it is disabled.

[v3]

- Patch 1 included in pull request
- disable block_shared when we disable block_enable
- enable block_enabled when we enable block_shared

[v2]

- make migrate_block_set_* take a boolean
- disable block migration in colo to maintain semantics.

[v1]
Upon a time there were MigrationParms (only used for block migration)
and then MigrationParams used for everything else.  This series:

- create migration capabilities for block parameters
- make the migrate command line parameters to use capabilities
- remove MigrationParams completely


Dr. David Alan Gilbert (1):
  block migration: Allow compile time disable

Juan Quintela (4):
  hmp: Use visitor api for hmp_migrate_set_parameter()
  migration: Create block capability
  migration: Remove use of old MigrationParams
  migration: Remove old MigrationParams

 configure                     | 11 +++++
 hmp.c                         | 23 ++++++++--
 include/migration/block.h     | 24 +++++++++++
 include/migration/migration.h | 17 ++++----
 include/migration/vmstate.h   |  1 -
 include/qemu/typedefs.h       |  1 -
 include/sysemu/sysemu.h       |  3 +-
 migration/Makefile.objs       |  2 +-
 migration/block.c             | 17 +-------
 migration/colo.c              |  6 +--
 migration/migration.c         | 97 +++++++++++++++++++++++++++++++++++++++----
 migration/savevm.c            | 24 ++++-------
 qapi-schema.json              | 28 +++++++++++--
 13 files changed, 192 insertions(+), 62 deletions(-)

-- 
2.9.3

^ permalink raw reply	[flat|nested] 24+ messages in thread
* [Qemu-devel] [PATCH v4 0/5] Remove old MigrationParams
@ 2017-05-16 11:11 Juan Quintela
  2017-05-16 11:11 ` [Qemu-devel] [PATCH 3/5] migration: Remove use of " Juan Quintela
  0 siblings, 1 reply; 24+ messages in thread
From: Juan Quintela @ 2017-05-16 11:11 UTC (permalink / raw)
  To: qemu-devel; +Cc: dgilbert, lvivier, peterx, eblake, armbru


changes from v3

- patch 1 included again. We have a 'block' capability and a
  'block_incremental' parameter
  Make Dave happy: rename shared into incremental
  Make Eric and Markus happy:

    block: off -> no block migration, we don't care about
                  block_incremental value
    block: on block_incremental: off -> no incremental block migration
    block: on block_incremental: on  -> incremental block migration

- Use visitors.
  You ask if there is not a better way than hand coding a boolean parser.
  QAPI people (a.k.a. Markus) answer to use a visitor.
  Once there, I used it also for integers, not only booleans.

- Use -b/-i parameters.  OK, I bit the bullet: You can't use
  capabilities/parameters and -b/-i: it gives you one error If you use
  -b/-i, capability parameter is cleanup after the migration ends (Who
  would have guessed that there are cases where we call
  migration_fd_error(), but not migration_fd_cleanup()
  I think this should make Peter and Markus and Dave happy.

- Integrate migrate block compile time disabling
  Well, it conflicted left and right, so I fixed it
  Once there, I disable setting/getting block capability if it is disabled.

Please review.

[v3]

- Patch 1 included in pull request
- disable block_shared when we disable block_enable
- enable block_enabled when we enable block_shared

Please, review.

[v2]

- make migrate_block_set_* take a boolean
- disable block migration in colo to maintain semantics.

[v1]
Upon a time there were MigrationParms (only used for block migration)
and then MigrationParams used for everything else.  This series:

- create migration capabilities for block parameters
- make the migrate command line parameters to use capabilities
- remove MigrationParams completely


Dr. David Alan Gilbert (1):
  block migration: Allow compile time disable

Juan Quintela (4):
  hmp: Use visitor api for hmp_migrate_set_parameter()
  migration: Create block capability
  migration: Remove use of old MigrationParams
  migration: Remove old MigrationParams

 configure                     |  11 +++++
 hmp.c                         |  23 +++++++--
 include/migration/block.h     |  24 +++++++++
 include/migration/migration.h |  18 +++----
 include/migration/vmstate.h   |   1 -
 include/qemu/typedefs.h       |   1 -
 include/sysemu/sysemu.h       |   3 +-
 migration/Makefile.objs       |   2 +-
 migration/block.c             |  17 +------
 migration/colo.c              |   6 +--
 migration/migration.c         | 112 +++++++++++++++++++++++++++++++++++++++---
 migration/savevm.c            |  24 ++++-----
 qapi-schema.json              |  14 ++++--
 13 files changed, 194 insertions(+), 62 deletions(-)

-- 
2.9.3

^ permalink raw reply	[flat|nested] 24+ messages in thread

end of thread, other threads:[~2017-05-24 12:48 UTC | newest]

Thread overview: 24+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-05-18 11:18 [Qemu-devel] [PATCH 0/5] Remove old MigrationParams Juan Quintela
2017-05-18 11:18 ` [Qemu-devel] [PATCH 1/5] hmp: Use visitor api for hmp_migrate_set_parameter() Juan Quintela
2017-05-18 11:18 ` [Qemu-devel] [PATCH 2/5] migration: Create block capability Juan Quintela
2017-05-18 14:49   ` Eric Blake
2017-05-19  9:20   ` Markus Armbruster
2017-05-18 11:18 ` [Qemu-devel] [PATCH 3/5] migration: Remove use of old MigrationParams Juan Quintela
2017-05-19 10:54   ` Markus Armbruster
2017-05-24 12:48     ` Markus Armbruster
2017-05-18 11:18 ` [Qemu-devel] [PATCH 4/5] migration: Remove " Juan Quintela
2017-05-18 11:18 ` [Qemu-devel] [PATCH 5/5] block migration: Allow compile time disable Juan Quintela
2017-05-18 12:19   ` Dr. David Alan Gilbert
2017-05-18 13:08     ` Juan Quintela
2017-05-18 14:50   ` Eric Blake
2017-05-18 12:15 ` [Qemu-devel] [PATCH 0/5] Remove old MigrationParams Dr. David Alan Gilbert
2017-05-18 13:10   ` Juan Quintela
  -- strict thread matches above, loose matches on Subject: below --
2017-05-17 15:38 [Qemu-devel] [PATCH v5 " Juan Quintela
2017-05-17 15:38 ` [Qemu-devel] [PATCH 3/5] migration: Remove use of " Juan Quintela
2017-05-17 15:54   ` Eric Blake
2017-05-17 16:18     ` Juan Quintela
2017-05-24 12:28   ` Markus Armbruster
2017-05-24 12:44     ` Markus Armbruster
2017-05-16 11:11 [Qemu-devel] [PATCH v4 0/5] Remove " Juan Quintela
2017-05-16 11:11 ` [Qemu-devel] [PATCH 3/5] migration: Remove use of " Juan Quintela
2017-05-16 14:22   ` Markus Armbruster
2017-05-16 14:36     ` Juan Quintela
2017-05-16 15:35       ` Markus Armbruster

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.