All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/12 v2 RFC]  Generic zcopy_* functions
@ 2020-12-22  0:09 Jonathan Lemon
  2020-12-22  0:09 ` [PATCH 01/12 v2 RFC] net: group skb_shinfo zerocopy related bits together Jonathan Lemon
                   ` (11 more replies)
  0 siblings, 12 replies; 33+ messages in thread
From: Jonathan Lemon @ 2020-12-22  0:09 UTC (permalink / raw)
  To: netdev, edumazet, willemdebruijn.kernel; +Cc: kernel-team

From: Jonathan Lemon <bsd@fb.com>

This is set of cleanup patches for zerocopy which are intended
to allow a introduction of a different zerocopy implementation.

The top level API will use the skb_zcopy_*() functions, while
the current TCP specific zerocopy ends up using msg_zerocopy_*()
calls.

There should be no functional changes from these patches.

v1->v2:
 Break changes to skb_zcopy_put into 3 patches, in order to
 make it easier to follow the changes.  Add Willem's suggestion
 about renaming sock_zerocopy_

Patch 1:
  Move zerocopy bits from tx_flags into zc_flags for clarity.
  These bits will be used in the RX path in the future.
Patch 2: remove dead function
Patch 3: simplify sock_zerocopy_put
Patch 4: push status/refcounts into sock_zerocopy_callback
Patch 5: replace sock_zerocopy_put with skb_zcopy_put
Patch 6: rename sock_zerocopy_get
Patch 7:
  Add an optional skb parameter to callback, allowing access to
  the attached skb from the callback.
Patch 8:
  Add skb_zcopy_put_abort, and move zerocopy logic into the
  callback function.  There unfortunately is still a check
  against the callback type here.
Patch 9:
  Set the skb zc_flags from the ubuf being attached, instead
  of a fixed value, allowing different initialization types.
Patch 10: Replace open-coded assignments
Patch 11: Relocate skb_zcopy_clear() in skb_release_data()
Patch 12: rename sock_zerocopy_ to msg_zerocpy_

Jonathan Lemon (12):
  net: group skb_shinfo zerocopy related bits together.
  skbuff: remove unused skb_zcopy_abort function
  skbuff: simplify sock_zerocopy_put
  skbuff: Push status and refcounts into sock_zerocopy_callback
  skbuff: replace sock_zerocopy_put() with skb_zcopy_put()
  skbuff: replace sock_zerocopy_get with skb_zcopy_get
  skbuff: Add skb parameter to the ubuf zerocopy callback
  skbuff: Call sock_zerocopy_put_abort from skb_zcopy_put_abort
  skbuff: add zc_flags to ubuf_info for ubuf setup
  tap/tun: use skb_zcopy_set() instead of open coded assignment
  skbuff: Call skb_zcopy_clear() before unref'ing fragments
  skbuff: rename sock_zerocopy_* to msg_zerocopy_*

 drivers/net/tap.c                   |  6 +-
 drivers/net/tun.c                   |  6 +-
 drivers/net/xen-netback/common.h    |  3 +-
 drivers/net/xen-netback/interface.c |  4 +-
 drivers/net/xen-netback/netback.c   |  7 ++-
 drivers/vhost/net.c                 |  4 +-
 include/linux/skbuff.h              | 95 +++++++++++++++--------------
 net/core/skbuff.c                   | 66 ++++++++++----------
 net/ipv4/ip_output.c                |  5 +-
 net/ipv4/tcp.c                      |  8 +--
 net/ipv6/ip6_output.c               |  5 +-
 net/kcm/kcmsock.c                   |  4 +-
 12 files changed, 106 insertions(+), 107 deletions(-)

-- 
2.24.1


^ permalink raw reply	[flat|nested] 33+ messages in thread

end of thread, other threads:[~2020-12-22 22:57 UTC | newest]

Thread overview: 33+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-12-22  0:09 [PATCH 00/12 v2 RFC] Generic zcopy_* functions Jonathan Lemon
2020-12-22  0:09 ` [PATCH 01/12 v2 RFC] net: group skb_shinfo zerocopy related bits together Jonathan Lemon
2020-12-22 14:43   ` Willem de Bruijn
2020-12-22 17:21     ` Jonathan Lemon
2020-12-22 22:26       ` Willem de Bruijn
2020-12-22 22:40         ` Jonathan Lemon
2020-12-22 22:56           ` Willem de Bruijn
2020-12-22  0:09 ` [PATCH 02/12 v2 RFC] skbuff: remove unused skb_zcopy_abort function Jonathan Lemon
2020-12-22 15:00   ` Willem de Bruijn
2020-12-22  0:09 ` [PATCH 03/12 v2 RFC] skbuff: simplify sock_zerocopy_put Jonathan Lemon
2020-12-22 14:43   ` Willem de Bruijn
2020-12-22 16:52   ` David Ahern
2020-12-22 16:56     ` David Ahern
2020-12-22  0:09 ` [PATCH 04/12 v2 RFC] skbuff: Push status and refcounts into sock_zerocopy_callback Jonathan Lemon
2020-12-22 14:43   ` Willem de Bruijn
2020-12-22 16:49     ` David Ahern
2020-12-22 17:48     ` Jonathan Lemon
2020-12-22 22:38       ` Willem de Bruijn
2020-12-22  0:09 ` [PATCH 05/12 v2 RFC] skbuff: replace sock_zerocopy_put() with skb_zcopy_put() Jonathan Lemon
2020-12-22 14:42   ` Willem de Bruijn
2020-12-22 17:19     ` Jonathan Lemon
2020-12-22 22:36       ` Willem de Bruijn
2020-12-22  0:09 ` [PATCH 06/12 v2 RFC] skbuff: replace sock_zerocopy_get with skb_zcopy_get Jonathan Lemon
2020-12-22  0:09 ` [PATCH 07/12 v2 RFC] skbuff: Add skb parameter to the ubuf zerocopy callback Jonathan Lemon
2020-12-22  0:09 ` [PATCH 08/12 v2 RFC] skbuff: Call sock_zerocopy_put_abort from skb_zcopy_put_abort Jonathan Lemon
2020-12-22  0:09 ` [PATCH 09/12 v2 RFC] skbuff: add zc_flags to ubuf_info for ubuf setup Jonathan Lemon
2020-12-22 15:00   ` Willem de Bruijn
2020-12-22 18:17     ` Jonathan Lemon
2020-12-22 18:29       ` Willem de Bruijn
2020-12-22  0:09 ` [PATCH 10/12 v2 RFC] tap/tun: use skb_zcopy_set() instead of open coded assignment Jonathan Lemon
2020-12-22  0:09 ` [PATCH 11/12 v2 RFC] skbuff: Call skb_zcopy_clear() before unref'ing fragments Jonathan Lemon
2020-12-22  0:09 ` [PATCH 12/12 v2 RFC] skbuff: rename sock_zerocopy_* to msg_zerocopy_* Jonathan Lemon
2020-12-22 14:55   ` Willem de Bruijn

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.