All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v7 0/5] Add new MFD driver for MAX77843
@ 2015-03-02 10:10 Jaewon Kim
  2015-03-02 10:10   ` Jaewon Kim
                   ` (4 more replies)
  0 siblings, 5 replies; 42+ messages in thread
From: Jaewon Kim @ 2015-03-02 10:10 UTC (permalink / raw)
  To: linux-kernel, devicetree, linux-pm, linux-input
  Cc: Inki Dae, SangBae Lee, Rob Herring, Pawel Moll, Mark Rutland,
	Ian Campbell, Kumar Gala, Lee Jones, Chanwoo Choi,
	Sebastian Reichel, Beomho Seo, Jaewon Kim, Dmitry Torokhov

This patch series adds MAX77843(Multi Function Device) driver.
The MAX77843 includes MUIC(Micro USB Interface Controller), Li+ Charger
with Fuel Gauge, 2 safeout LDOs for USB device and haptic controller using PWM.
It is interfaced to host controller using I2C. 

Changes in v7:
MFD Core
 - Fix indentation
 - Remove file name, MODULE information
POWER
 - Fix typos

Changes in v6:
HAPTIC
 - fixed a situation where holding a Mutex return.
 
Changes in v5: 
MFD Core
 - Use bracket in complex define.
 - Delete unnecessary letter '++'     
Charger
 - fix Kconfig merge conflict with Kernel version4.0
     
Changes in v4:
MFD Core
 - Fix indentation
 - Add haptic register define in header
HAPTIC
 - Add haptic driver

Changes in v3:
MFD Core
 - Fix wrong description and indentation in header.
 - Remove unnecessary variable.
Regulator
 - Use ARRAY_SIZE() instead of define.
   
Changes in v2:
MFD Core
 - Fix charger regmap handle and typo.
MUIC
 - Cleanup enum list.
 - Set path before send excon event.
 - Fix variable names and typos for readability.
Charger
 - Remove unnecessary header.
 - Chnage error message more readable.
 - Remove unnecessary lines.
Fuelgauge
 - Fix regmap_config and use regmap_read.
 - Add i2c_unregister_device function on *_remove function.
 - Fix typo in Kconfig.
Doc
 - Remove unnecessary lines.
 - Add example of charger regulator.Beomho Seo (2):

Jaewon Kim (3):
  mfd: max77843: Add max77843 MFD driver core driver
  Input: add haptic drvier on max77843
  Documentation: Add device tree bindings document for max77843

 Documentation/devicetree/bindings/mfd/max77843.txt |  110 +++++
 drivers/input/misc/Kconfig                         |   12 +
 drivers/input/misc/Makefile                        |    1 +
 drivers/input/misc/max77843-haptic.c               |  358 ++++++++++++++
 drivers/mfd/Kconfig                                |   14 +
 drivers/mfd/Makefile                               |    1 +
 drivers/mfd/max77843.c                             |  243 ++++++++++
 drivers/power/Kconfig                              |   16 +
 drivers/power/Makefile                             |    2 +
 drivers/power/max77843_battery.c                   |  286 +++++++++++
 drivers/power/max77843_charger.c                   |  508 ++++++++++++++++++++
 include/linux/mfd/max77843-private.h               |  454 +++++++++++++++++
 12 files changed, 2005 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/mfd/max77843.txt
 create mode 100644 drivers/input/misc/max77843-haptic.c
 create mode 100644 drivers/mfd/max77843.c
 create mode 100644 drivers/power/max77843_battery.c
 create mode 100644 drivers/power/max77843_charger.c
 create mode 100644 include/linux/mfd/max77843-private.h

-- 
1.7.9.5


^ permalink raw reply	[flat|nested] 42+ messages in thread

end of thread, other threads:[~2015-03-27 10:09 UTC | newest]

Thread overview: 42+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-03-02 10:10 [PATCH v7 0/5] Add new MFD driver for MAX77843 Jaewon Kim
2015-03-02 10:10 ` [PATCH v7 1/5] mfd: max77843: Add max77843 MFD driver core driver Jaewon Kim
2015-03-02 10:10   ` Jaewon Kim
2015-03-02 10:20   ` Lee Jones
2015-03-02 10:20     ` Lee Jones
2015-03-02 10:36     ` Jaewon Kim
2015-03-02 10:41   ` Lee Jones
2015-03-02 10:10 ` [PATCH v7 2/5] power: max77843_charger: Add Max77843 charger device driver Jaewon Kim
2015-03-07 20:13   ` Sebastian Reichel
2015-03-09  0:35     ` Beomho Seo
2015-03-09 11:02       ` Krzysztof Kozlowski
2015-03-09 11:46         ` Beomho Seo
2015-03-09 12:13           ` Krzysztof Kozlowski
2015-03-10 13:44             ` Beomho Seo
2015-03-24  8:01               ` Beomho Seo
2015-03-24  8:01                 ` Beomho Seo
2015-03-24  8:38                 ` Krzysztof Kozlowski
2015-03-25  0:39                   ` Beomho Seo
2015-03-26  7:16                     ` Krzysztof Kozlowski
2015-03-26 13:25                   ` Beomho Seo
2015-03-26 13:54                     ` Lee Jones
2015-03-26 13:54                       ` Lee Jones
2015-03-26 23:49                       ` Beomho Seo
2015-03-27  7:57                         ` Lee Jones
2015-03-27  8:45                           ` Beomho Seo
2015-03-27 10:08                             ` Lee Jones
2015-03-27 10:08                               ` Lee Jones
2015-03-02 10:10 ` [PATCH v7 3/5] power: max77843_battery: Add Max77843 fuel gauge " Jaewon Kim
2015-03-07 20:14   ` Sebastian Reichel
2015-03-09  0:36     ` Beomho Seo
2015-03-09 10:01       ` Krzysztof Kozlowski
2015-03-10 13:44         ` Beomho Seo
2015-03-10 13:44           ` Beomho Seo
2015-03-24  8:02           ` Beomho Seo
2015-03-24  8:39             ` Krzysztof Kozlowski
2015-03-02 10:10 ` [PATCH v7 4/5] Input: add haptic drvier on max77843 Jaewon Kim
2015-03-02 17:32   ` Dmitry Torokhov
2015-03-03  1:35     ` Jaewon Kim
2015-03-04 22:47       ` Dmitry Torokhov
2015-03-07 20:21         ` Sebastian Reichel
2015-03-08  4:55           ` Dmitry Torokhov
2015-03-02 10:10 ` [PATCH v7 5/5] Documentation: Add device tree bindings document for max77843 Jaewon Kim

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.