All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH-for-5.2 0/5] hw/usb/hcd-xhci: Fix xhci-pci devices
@ 2020-11-07 11:13 Philippe Mathieu-Daudé
  2020-11-07 11:13 ` [PATCH-for-5.2 1/5] hw/usb/hcd-xhci: Make xhci base model abstract Philippe Mathieu-Daudé
                   ` (4 more replies)
  0 siblings, 5 replies; 13+ messages in thread
From: Philippe Mathieu-Daudé @ 2020-11-07 11:13 UTC (permalink / raw)
  To: qemu-devel; +Cc: Sai Pavan Boddu, Philippe Mathieu-Daudé, Gerd Hoffmann

Fix few regressions introduced while introducing xhci-sysbus.

Cleaned a bit code style while here, patches included for 6.0.

Philippe Mathieu-Daudé (5):
  hw/usb/hcd-xhci: Make xhci base model abstract
  hw/usb/Kconfig: Fix USB_XHCI_NEC (depends on USB_XHCI_PCI)
  hw/usb/hcd-xhci: Rename "base-xhci" as TYPE_XHCI_COMMON
  hw/usb/hcd-xhci-pci: Use OBJECT_DECLARE_SIMPLE_TYPE() macro
  hw/usb/hcd-xhci-pci: Rename "pci-xhci" as TYPE_XHCI_PCI_COMMON

 hw/usb/hcd-xhci-pci.h    |  6 ++----
 hw/usb/hcd-xhci.h        |  4 +++-
 include/hw/usb/xhci.h    |  1 -
 hw/usb/hcd-xhci-nec.c    |  2 +-
 hw/usb/hcd-xhci-pci.c    | 18 +++++++++---------
 hw/usb/hcd-xhci-sysbus.c |  2 +-
 hw/usb/hcd-xhci.c        | 11 ++++++-----
 hw/usb/Kconfig           |  4 +---
 8 files changed, 23 insertions(+), 25 deletions(-)

-- 
2.26.2




^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2020-11-09 13:48 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-07 11:13 [PATCH-for-5.2 0/5] hw/usb/hcd-xhci: Fix xhci-pci devices Philippe Mathieu-Daudé
2020-11-07 11:13 ` [PATCH-for-5.2 1/5] hw/usb/hcd-xhci: Make xhci base model abstract Philippe Mathieu-Daudé
2020-11-08 13:38   ` Sai Pavan Boddu
2020-11-09  9:51   ` Gerd Hoffmann
2020-11-09 11:00     ` Philippe Mathieu-Daudé
2020-11-09 11:30       ` Gerd Hoffmann
2020-11-09 13:40         ` Philippe Mathieu-Daudé
2020-11-07 11:13 ` [PATCH-for-5.2 2/5] hw/usb/Kconfig: Fix USB_XHCI_NEC (depends on USB_XHCI_PCI) Philippe Mathieu-Daudé
2020-11-08 13:40   ` Sai Pavan Boddu
2020-11-09 11:08   ` Gerd Hoffmann
2020-11-07 11:13 ` [PATCH-for-6.0 3/5] hw/usb/hcd-xhci: Rename "base-xhci" as TYPE_XHCI_COMMON Philippe Mathieu-Daudé
2020-11-07 11:13 ` [PATCH-for-6.0 4/5] hw/usb/hcd-xhci-pci: Use OBJECT_DECLARE_SIMPLE_TYPE() macro Philippe Mathieu-Daudé
2020-11-07 11:13 ` [PATCH-for-6.0 5/5] hw/usb/hcd-xhci-pci: Rename "pci-xhci" as TYPE_XHCI_PCI_COMMON Philippe Mathieu-Daudé

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.