All of lore.kernel.org
 help / color / mirror / Atom feed
* [CRYPTO-LUKS v1 00/19] Fixes and improvements for cryptodisks+luks2 and a few other things.
@ 2020-07-31 12:01 Glenn Washburn
  2020-07-31 12:01 ` [CRYPTO-LUKS v1 01/19] configure: Add Ubuntu dejavu font path Glenn Washburn
                   ` (19 more replies)
  0 siblings, 20 replies; 32+ messages in thread
From: Glenn Washburn @ 2020-07-31 12:01 UTC (permalink / raw)
  To: grub-devel; +Cc: Glenn Washburn, Daniel Kiper, Patrick Steinhardt

I've changed the name of the patch series to make it more self-explanatory, but
still incremented the version number.  All of Patrick's suggestions have been
added in.  I've added 2 new patches, one suggested by Patrick for rename
cryptodisk's offset member to offset_sectors. And another to rename 'disk' to
'source' where appropriate in luks2.c.

Glenn Washburn (19):
  configure: Add Ubuntu dejavu font path.
  cryptodisk: Fix cipher IV mode 'plain64' always being set as 'plain'.
  cryptodisk: Incorrect calculation of start sector for grub_disk_read
    in grub_cryptodisk_read.
  cryptodisk: Add more verbosity when reading/writing cryptodisks.
  luks2: Add support for LUKS2 in (proc)/luks_script
  luks2: Rename source disk variabled named 'disk' to 'source' as in
    luks.c.
  luks2: grub_cryptodisk_t->total_length is the max number of device
    native sectors.
  cryptodisk,luks: Allow special processing for comparing UUIDs.
  cryptodisk: Unregister cryptomount command when removing module.
  fs: Fix block lists not being able to address to end of disk
    sometimes.
  cryptodisk: Properly handle non-512 byte sized sectors.
  cryptodisk: Rename total_length field in grub_cryptodisk_t to
    total_sectors.
  fs: Allow number of blocks in block list to be optional, where length
    will be defaulted to the length of the device.
  loopback: Add procfs entry 'loopbacks' to output configured loopback
    devices.
  cryptodisk,luks2: Add header line to procfs entry and crypto and
    source device names.
  cryptodisk: Add a couple comments noting the usage of a couple fields
    in grub_cryptodisk_t as is done for grub_disk_t.
  luks2: Ensure that bit fields of grub_luks2_digest_t in
    luks2_parse_digest are initialized before returning.
  luks2: Fix use of incorrect index and some error messages.
  cryptodisk: Rename offset in grub_cryptodisk_t to offset_sectors to
    improve readability.

 configure.ac                |   2 +-
 grub-core/disk/cryptodisk.c | 115 +++++++++++++++++++++++-------------
 grub-core/disk/geli.c       |   4 +-
 grub-core/disk/loopback.c   |  56 ++++++++++++++++++
 grub-core/disk/luks.c       |  29 +++------
 grub-core/disk/luks2.c      |  78 +++++++++++++-----------
 grub-core/kern/fs.c         |  10 +++-
 include/grub/cryptodisk.h   |  12 +++-
 include/grub/misc.h         |  21 +++++++
 9 files changed, 224 insertions(+), 103 deletions(-)

-- 
2.25.1



^ permalink raw reply	[flat|nested] 32+ messages in thread

end of thread, other threads:[~2020-08-25  2:39 UTC | newest]

Thread overview: 32+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-31 12:01 [CRYPTO-LUKS v1 00/19] Fixes and improvements for cryptodisks+luks2 and a few other things Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 01/19] configure: Add Ubuntu dejavu font path Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 02/19] cryptodisk: Fix cipher IV mode 'plain64' always being set as 'plain' Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 03/19] cryptodisk: Incorrect calculation of start sector for grub_disk_read in grub_cryptodisk_read Glenn Washburn
2020-08-23 10:39   ` Patrick Steinhardt
2020-08-24  4:31     ` Glenn Washburn
2020-08-24  5:10       ` Patrick Steinhardt
2020-08-24 23:42         ` [CRYPTO-LUKS v2 03/19] cryptodisk: Incorrect calculation of sector in grub_cryptodisk_read/write Glenn Washburn
2020-08-25  2:09           ` Glenn Washburn
2020-08-24 23:58         ` [CRYPTO-LUKS v1 03/19] cryptodisk: Incorrect calculation of start sector for grub_disk_read in grub_cryptodisk_read Glenn Washburn
2020-08-25  2:39         ` [CRYPTO-LUKS v3 " Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 04/19] cryptodisk: Add more verbosity when reading/writing cryptodisks Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 05/19] luks2: Add support for LUKS2 in (proc)/luks_script Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 06/19] luks2: Rename source disk variabled named 'disk' to 'source' as in luks.c Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 07/19] luks2: grub_cryptodisk_t->total_length is the max number of device native sectors Glenn Washburn
2020-08-23 10:20   ` Patrick Steinhardt
2020-07-31 12:01 ` [CRYPTO-LUKS v1 08/19] cryptodisk, luks: Allow special processing for comparing UUIDs Glenn Washburn
2020-07-31 15:34   ` Patrick Steinhardt
2020-07-31 12:01 ` [CRYPTO-LUKS v1 09/19] cryptodisk: Unregister cryptomount command when removing module Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 10/19] fs: Fix block lists not being able to address to end of disk sometimes Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 11/19] cryptodisk: Properly handle non-512 byte sized sectors Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 12/19] cryptodisk: Rename total_length field in grub_cryptodisk_t to total_sectors Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 13/19] fs: Allow number of blocks in block list to be optional, where length will be defaulted to the length of the device Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 14/19] loopback: Add procfs entry 'loopbacks' to output configured loopback devices Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 15/19] cryptodisk, luks2: Add header line to procfs entry and crypto and source device names Glenn Washburn
2020-07-31 15:37   ` [CRYPTO-LUKS v1 15/19] cryptodisk,luks2: " Patrick Steinhardt
2020-07-31 16:22     ` Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 16/19] cryptodisk: Add a couple comments noting the usage of a couple fields in grub_cryptodisk_t as is done for grub_disk_t Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 17/19] luks2: Ensure that bit fields of grub_luks2_digest_t in luks2_parse_digest are initialized before returning Glenn Washburn
2020-07-31 12:01 ` [CRYPTO-LUKS v1 18/19] luks2: Fix use of incorrect index and some error messages Glenn Washburn
2020-07-31 12:02 ` [CRYPTO-LUKS v1 19/19] cryptodisk: Rename offset in grub_cryptodisk_t to offset_sectors to improve readability Glenn Washburn
2020-07-31 15:59 ` [CRYPTO-LUKS v1 00/19] Fixes and improvements for cryptodisks+luks2 and a few other things Patrick Steinhardt

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.