All of lore.kernel.org
 help / color / mirror / Atom feed
* [Outreachy Kernel][PATCH v5] staging:comedi:comedi_pci.h Prefer a maximum 75 chars per line
@ 2018-10-06 19:02 Bhanusree Pola
  2018-10-06 19:06 ` [Outreachy kernel] " Julia Lawall
  2018-10-06 19:31 ` Himanshu Jha
  0 siblings, 2 replies; 5+ messages in thread
From: Bhanusree Pola @ 2018-10-06 19:02 UTC (permalink / raw)
  To: outreachy-kernel; +Cc: abbotti, gregkh, hsweeten

Adjust all lines exceeding 75 chars per line to fix checkpatch warning. 

Signed-off-by: Bhanusree Pola <bhanusreemahesh@gmail.com>
---

changes in v5:
-Fixed Change log
-Change in subject line.Do not send as 'Re:'

changes in v4:
-Remove Whitespace in comment section of module_comedi_pci_driver()
 to fix checkpatch Error.

changes in v3:
-Comment section of module_pci_driver() exceeds 75 characters.
 Adjust the chars to 75 per line
-Modified log message.
-Added change log.

changes in v2:
-comedi_pci_auto_config() function prototype is exceeds
 75 characters per line. Adjust to 75 chars to improve
 readability and also adjust the arguments to match open
 parantheses.
-Comment section of module_comedi_pci_driver() exceeds 75
 characters. Modified contents to adjust 75 chars per line.

 drivers/staging/comedi/comedi_pci.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/comedi/comedi_pci.h b/drivers/staging/comedi/comedi_pci.h
index 1cc5436cb415..7291d3c0b7dc 100644
--- a/drivers/staging/comedi/comedi_pci.h
+++ b/drivers/staging/comedi/comedi_pci.h
@@ -42,7 +42,7 @@ void comedi_pci_driver_unregister(struct comedi_driver *comedi_driver,
 				  struct pci_driver *pci_driver);
 
 /**
- * module_comedi_pci_driver()-Helper macro for registering a comedi PCI 
+ * module_comedi_pci_driver()-Helper macro for registering a comedi PCI
  * driver
  * @__comedi_driver: comedi_driver struct
  * @__pci_driver: pci_driver struct
-- 
2.17.1



^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [Outreachy kernel] [Outreachy Kernel][PATCH v5] staging:comedi:comedi_pci.h Prefer a maximum 75 chars per line
  2018-10-06 19:02 [Outreachy Kernel][PATCH v5] staging:comedi:comedi_pci.h Prefer a maximum 75 chars per line Bhanusree Pola
@ 2018-10-06 19:06 ` Julia Lawall
  2018-10-06 19:13   ` Bhanusree
  2018-10-06 19:31 ` Himanshu Jha
  1 sibling, 1 reply; 5+ messages in thread
From: Julia Lawall @ 2018-10-06 19:06 UTC (permalink / raw)
  To: Bhanusree Pola; +Cc: outreachy-kernel, abbotti, gregkh, hsweeten



On Sun, 7 Oct 2018, Bhanusree Pola wrote:

> Adjust all lines exceeding 75 chars per line to fix checkpatch warning.
>
> Signed-off-by: Bhanusree Pola <bhanusreemahesh@gmail.com>
> ---
>
> changes in v5:
> -Fixed Change log
> -Change in subject line.Do not send as 'Re:'

It doesn't matter here, because this text will go away, but please get in
the habit of putting at least one space after punctuation.  That is:

Change in subject line. Do not send as 'Re:'

Then things don't run together, and it is easier to read.

julia

>
> changes in v4:
> -Remove Whitespace in comment section of module_comedi_pci_driver()
>  to fix checkpatch Error.
>
> changes in v3:
> -Comment section of module_pci_driver() exceeds 75 characters.
>  Adjust the chars to 75 per line
> -Modified log message.
> -Added change log.
>
> changes in v2:
> -comedi_pci_auto_config() function prototype is exceeds
>  75 characters per line. Adjust to 75 chars to improve
>  readability and also adjust the arguments to match open
>  parantheses.
> -Comment section of module_comedi_pci_driver() exceeds 75
>  characters. Modified contents to adjust 75 chars per line.
>
>  drivers/staging/comedi/comedi_pci.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/comedi/comedi_pci.h b/drivers/staging/comedi/comedi_pci.h
> index 1cc5436cb415..7291d3c0b7dc 100644
> --- a/drivers/staging/comedi/comedi_pci.h
> +++ b/drivers/staging/comedi/comedi_pci.h
> @@ -42,7 +42,7 @@ void comedi_pci_driver_unregister(struct comedi_driver *comedi_driver,
>  				  struct pci_driver *pci_driver);
>
>  /**
> - * module_comedi_pci_driver()-Helper macro for registering a comedi PCI
> + * module_comedi_pci_driver()-Helper macro for registering a comedi PCI
>   * driver
>   * @__comedi_driver: comedi_driver struct
>   * @__pci_driver: pci_driver struct
> --
> 2.17.1
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20181006190246.GA14037%40veda-VGN-CS3AGH-R.
> For more options, visit https://groups.google.com/d/optout.
>


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Outreachy kernel] [Outreachy Kernel][PATCH v5] staging:comedi:comedi_pci.h Prefer a maximum 75 chars per line
  2018-10-06 19:06 ` [Outreachy kernel] " Julia Lawall
@ 2018-10-06 19:13   ` Bhanusree
  0 siblings, 0 replies; 5+ messages in thread
From: Bhanusree @ 2018-10-06 19:13 UTC (permalink / raw)
  To: Julia Lawall; +Cc: outreachy-kernel, abbotti, gregkh, hsweeten



On Sunday 07 October 2018 12:36 AM, Julia Lawall wrote:
>
> On Sun, 7 Oct 2018, Bhanusree Pola wrote:
>
>> Adjust all lines exceeding 75 chars per line to fix checkpatch warning.
>>
>> Signed-off-by: Bhanusree Pola <bhanusreemahesh@gmail.com>
>> ---
>>
>> changes in v5:
>> -Fixed Change log
>> -Change in subject line.Do not send as 'Re:'
> It doesn't matter here, because this text will go away, but please get in
> the habit of putting at least one space after punctuation.  That is:
>
> Change in subject line. Do not send as 'Re:'
>
> Then things don't run together, and it is easier to read.
It is taking time for me to understand. Sometimes I'm doing it in haste. 
Thank you for making me understand.


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Outreachy kernel] [Outreachy Kernel][PATCH v5] staging:comedi:comedi_pci.h Prefer a maximum 75 chars per line
  2018-10-06 19:02 [Outreachy Kernel][PATCH v5] staging:comedi:comedi_pci.h Prefer a maximum 75 chars per line Bhanusree Pola
  2018-10-06 19:06 ` [Outreachy kernel] " Julia Lawall
@ 2018-10-06 19:31 ` Himanshu Jha
  2018-10-06 19:41   ` Julia Lawall
  1 sibling, 1 reply; 5+ messages in thread
From: Himanshu Jha @ 2018-10-06 19:31 UTC (permalink / raw)
  To: Bhanusree Pola; +Cc: outreachy-kernel, abbotti, gregkh, hsweeten

On Sun, Oct 07, 2018 at 12:32:47AM +0530, Bhanusree Pola wrote:
> Adjust all lines exceeding 75 chars per line to fix checkpatch warning. 
> 
> Signed-off-by: Bhanusree Pola <bhanusreemahesh@gmail.com>
> ---
> 
> changes in v5:
> -Fixed Change log
> -Change in subject line.Do not send as 'Re:'
> 
> changes in v4:
> -Remove Whitespace in comment section of module_comedi_pci_driver()
>  to fix checkpatch Error.
> 
> changes in v3:
> -Comment section of module_pci_driver() exceeds 75 characters.
>  Adjust the chars to 75 per line
> -Modified log message.
> -Added change log.
> 
> changes in v2:
> -comedi_pci_auto_config() function prototype is exceeds
>  75 characters per line. Adjust to 75 chars to improve
>  readability and also adjust the arguments to match open
>  parantheses.
> -Comment section of module_comedi_pci_driver() exceeds 75
>  characters. Modified contents to adjust 75 chars per line.
> 
>  drivers/staging/comedi/comedi_pci.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/comedi/comedi_pci.h b/drivers/staging/comedi/comedi_pci.h
> index 1cc5436cb415..7291d3c0b7dc 100644
> --- a/drivers/staging/comedi/comedi_pci.h
> +++ b/drivers/staging/comedi/comedi_pci.h
> @@ -42,7 +42,7 @@ void comedi_pci_driver_unregister(struct comedi_driver *comedi_driver,
>  				  struct pci_driver *pci_driver);
>  
>  /**
> - * module_comedi_pci_driver()-Helper macro for registering a comedi PCI 
> + * module_comedi_pci_driver()-Helper macro for registering a comedi PCI

The original line is:

* module_comedi_pci_driver() - Helper macro for registering a comedi PCI driver

https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/tree/drivers/staging/comedi/comedi_pci.h#n44

The patch looks dubious to me.

Always base your work on latest -next tree.
https://www.kernel.org/doc/man-pages/linux-next.html

-- 
Himanshu Jha
Undergraduate Student
Department of Electronics & Communication
Guru Tegh Bahadur Institute of Technology


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Outreachy kernel] [Outreachy Kernel][PATCH v5] staging:comedi:comedi_pci.h Prefer a maximum 75 chars per line
  2018-10-06 19:31 ` Himanshu Jha
@ 2018-10-06 19:41   ` Julia Lawall
  0 siblings, 0 replies; 5+ messages in thread
From: Julia Lawall @ 2018-10-06 19:41 UTC (permalink / raw)
  To: Himanshu Jha; +Cc: Bhanusree Pola, outreachy-kernel, abbotti, gregkh, hsweeten



On Sun, 7 Oct 2018, Himanshu Jha wrote:

> On Sun, Oct 07, 2018 at 12:32:47AM +0530, Bhanusree Pola wrote:
> > Adjust all lines exceeding 75 chars per line to fix checkpatch warning.
> >
> > Signed-off-by: Bhanusree Pola <bhanusreemahesh@gmail.com>
> > ---
> >
> > changes in v5:
> > -Fixed Change log
> > -Change in subject line.Do not send as 'Re:'
> >
> > changes in v4:
> > -Remove Whitespace in comment section of module_comedi_pci_driver()
> >  to fix checkpatch Error.
> >
> > changes in v3:
> > -Comment section of module_pci_driver() exceeds 75 characters.
> >  Adjust the chars to 75 per line
> > -Modified log message.
> > -Added change log.
> >
> > changes in v2:
> > -comedi_pci_auto_config() function prototype is exceeds
> >  75 characters per line. Adjust to 75 chars to improve
> >  readability and also adjust the arguments to match open
> >  parantheses.
> > -Comment section of module_comedi_pci_driver() exceeds 75
> >  characters. Modified contents to adjust 75 chars per line.
> >
> >  drivers/staging/comedi/comedi_pci.h | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/drivers/staging/comedi/comedi_pci.h b/drivers/staging/comedi/comedi_pci.h
> > index 1cc5436cb415..7291d3c0b7dc 100644
> > --- a/drivers/staging/comedi/comedi_pci.h
> > +++ b/drivers/staging/comedi/comedi_pci.h
> > @@ -42,7 +42,7 @@ void comedi_pci_driver_unregister(struct comedi_driver *comedi_driver,
> >  				  struct pci_driver *pci_driver);
> >
> >  /**
> > - * module_comedi_pci_driver()-Helper macro for registering a comedi PCI
> > + * module_comedi_pci_driver()-Helper macro for registering a comedi PCI
>
> The original line is:
>
> * module_comedi_pci_driver() - Helper macro for registering a comedi PCI driver
>
> https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/tree/drivers/staging/comedi/comedi_pci.h#n44
>
> The patch looks dubious to me.
>
> Always base your work on latest -next tree.
> https://www.kernel.org/doc/man-pages/linux-next.html

Bhanusree,

I think you made your new patch on top of your old one.

julia

>
> --
> Himanshu Jha
> Undergraduate Student
> Department of Electronics & Communication
> Guru Tegh Bahadur Institute of Technology
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20181006193150.GA8922%40himanshu-Vostro-3559.
> For more options, visit https://groups.google.com/d/optout.
>


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2018-10-06 19:41 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-10-06 19:02 [Outreachy Kernel][PATCH v5] staging:comedi:comedi_pci.h Prefer a maximum 75 chars per line Bhanusree Pola
2018-10-06 19:06 ` [Outreachy kernel] " Julia Lawall
2018-10-06 19:13   ` Bhanusree
2018-10-06 19:31 ` Himanshu Jha
2018-10-06 19:41   ` Julia Lawall

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.