All of lore.kernel.org
 help / color / mirror / Atom feed
From: Stefano Stabellini <sstabellini@kernel.org>
To: Boris Ostrovsky <boris.ostrovsky@oracle.com>
Cc: Stefano Stabellini <sstabellini@kernel.org>,
	jgross@suse.com, konrad.wilk@oracle.com,
	xen-devel@lists.xenproject.org, linux-kernel@vger.kernel.org,
	Stefano Stabellini <stefano.stabellini@xilinx.com>
Subject: Re: [PATCH 08/10] swiotlb-xen: introduce phys_to_dma/dma_to_phys translations
Date: Fri, 22 May 2020 10:34:13 -0700 (PDT)	[thread overview]
Message-ID: <alpine.DEB.2.21.2005221033180.27502@sstabellini-ThinkPad-T480s> (raw)
In-Reply-To: <7aab1c00-c115-b989-61e5-fd7d28fa0d07@oracle.com>

On Thu, 21 May 2020, Boris Ostrovsky wrote:
> On 5/20/20 7:45 PM, Stefano Stabellini wrote:
> > From: Stefano Stabellini <stefano.stabellini@xilinx.com>
> >
> > Call dma_to_phys in is_xen_swiotlb_buffer.
> > Call phys_to_dma in xen_phys_to_bus.
> > Call dma_to_phys in xen_bus_to_phys.
> >
> > Everything is taken care of by these changes except for
> > xen_swiotlb_alloc_coherent and xen_swiotlb_free_coherent, which need a
> > few explicit phys_to_dma/dma_to_phys calls.
> >
> > Signed-off-by: Stefano Stabellini <stefano.stabellini@xilinx.com>
> > ---
> >  drivers/xen/swiotlb-xen.c | 20 ++++++++++++--------
> >  1 file changed, 12 insertions(+), 8 deletions(-)
> >
> > diff --git a/drivers/xen/swiotlb-xen.c b/drivers/xen/swiotlb-xen.c
> > index c50448fd9b75..d011c4c7aa72 100644
> > --- a/drivers/xen/swiotlb-xen.c
> > +++ b/drivers/xen/swiotlb-xen.c
> > @@ -64,14 +64,16 @@ static inline dma_addr_t xen_phys_to_bus(struct device *dev, phys_addr_t paddr)
> >  
> >  	dma |= paddr & ~XEN_PAGE_MASK;
> >  
> > -	return dma;
> > +	return phys_to_dma(dev, dma);
> >  }
> >  
> > -static inline phys_addr_t xen_bus_to_phys(struct device *dev, dma_addr_t baddr)
> > +static inline phys_addr_t xen_bus_to_phys(struct device *dev,
> > +					  dma_addr_t dma_addr)
> 
> 
> Since now dma address != bus address this is no longer
> xen_bus_to_phys(). (And I guess the same is rue for xen_phys_to_bus()).

Should I rename them to xen_dma_to_phys and xen_phys_to_dma?

 
> >  {
> > +	phys_addr_t baddr = dma_to_phys(dev, dma_addr);
> >  	unsigned long xen_pfn = bfn_to_pfn(XEN_PFN_DOWN(baddr));
> > -	dma_addr_t dma = (dma_addr_t)xen_pfn << XEN_PAGE_SHIFT;
> > -	phys_addr_t paddr = dma;
> > +	phys_addr_t paddr = (xen_pfn << XEN_PAGE_SHIFT) |
> > +			    (baddr & ~XEN_PAGE_MASK);
> >  
> >  	paddr |= baddr & ~XEN_PAGE_MASK;
> 
> 
> This line needs to go, no?

Yes, good point

WARNING: multiple messages have this Message-ID (diff)
From: Stefano Stabellini <sstabellini@kernel.org>
To: Boris Ostrovsky <boris.ostrovsky@oracle.com>
Cc: jgross@suse.com, Stefano Stabellini <sstabellini@kernel.org>,
	konrad.wilk@oracle.com, linux-kernel@vger.kernel.org,
	xen-devel@lists.xenproject.org,
	Stefano Stabellini <stefano.stabellini@xilinx.com>
Subject: Re: [PATCH 08/10] swiotlb-xen: introduce phys_to_dma/dma_to_phys translations
Date: Fri, 22 May 2020 10:34:13 -0700 (PDT)	[thread overview]
Message-ID: <alpine.DEB.2.21.2005221033180.27502@sstabellini-ThinkPad-T480s> (raw)
In-Reply-To: <7aab1c00-c115-b989-61e5-fd7d28fa0d07@oracle.com>

On Thu, 21 May 2020, Boris Ostrovsky wrote:
> On 5/20/20 7:45 PM, Stefano Stabellini wrote:
> > From: Stefano Stabellini <stefano.stabellini@xilinx.com>
> >
> > Call dma_to_phys in is_xen_swiotlb_buffer.
> > Call phys_to_dma in xen_phys_to_bus.
> > Call dma_to_phys in xen_bus_to_phys.
> >
> > Everything is taken care of by these changes except for
> > xen_swiotlb_alloc_coherent and xen_swiotlb_free_coherent, which need a
> > few explicit phys_to_dma/dma_to_phys calls.
> >
> > Signed-off-by: Stefano Stabellini <stefano.stabellini@xilinx.com>
> > ---
> >  drivers/xen/swiotlb-xen.c | 20 ++++++++++++--------
> >  1 file changed, 12 insertions(+), 8 deletions(-)
> >
> > diff --git a/drivers/xen/swiotlb-xen.c b/drivers/xen/swiotlb-xen.c
> > index c50448fd9b75..d011c4c7aa72 100644
> > --- a/drivers/xen/swiotlb-xen.c
> > +++ b/drivers/xen/swiotlb-xen.c
> > @@ -64,14 +64,16 @@ static inline dma_addr_t xen_phys_to_bus(struct device *dev, phys_addr_t paddr)
> >  
> >  	dma |= paddr & ~XEN_PAGE_MASK;
> >  
> > -	return dma;
> > +	return phys_to_dma(dev, dma);
> >  }
> >  
> > -static inline phys_addr_t xen_bus_to_phys(struct device *dev, dma_addr_t baddr)
> > +static inline phys_addr_t xen_bus_to_phys(struct device *dev,
> > +					  dma_addr_t dma_addr)
> 
> 
> Since now dma address != bus address this is no longer
> xen_bus_to_phys(). (And I guess the same is rue for xen_phys_to_bus()).

Should I rename them to xen_dma_to_phys and xen_phys_to_dma?

 
> >  {
> > +	phys_addr_t baddr = dma_to_phys(dev, dma_addr);
> >  	unsigned long xen_pfn = bfn_to_pfn(XEN_PFN_DOWN(baddr));
> > -	dma_addr_t dma = (dma_addr_t)xen_pfn << XEN_PAGE_SHIFT;
> > -	phys_addr_t paddr = dma;
> > +	phys_addr_t paddr = (xen_pfn << XEN_PAGE_SHIFT) |
> > +			    (baddr & ~XEN_PAGE_MASK);
> >  
> >  	paddr |= baddr & ~XEN_PAGE_MASK;
> 
> 
> This line needs to go, no?

Yes, good point


  reply	other threads:[~2020-05-22 17:34 UTC|newest]

Thread overview: 62+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-20 23:45 [PATCH 00/10] fix swiotlb-xen for RPi4 Stefano Stabellini
2020-05-20 23:45 ` Stefano Stabellini
2020-05-20 23:45 ` [PATCH 01/10] swiotlb-xen: use vmalloc_to_page on vmalloc virt addresses Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-21  8:01   ` Julien Grall
2020-05-21  8:01     ` Julien Grall
2020-05-22  3:54     ` Stefano Stabellini
2020-05-22  3:54       ` Stefano Stabellini
2020-05-22 18:11       ` Julien Grall
2020-05-22 18:11         ` Julien Grall
2020-05-22 20:36         ` Stefano Stabellini
2020-05-22 20:36           ` Stefano Stabellini
2020-05-20 23:45 ` [PATCH 02/10] swiotlb-xen: remove start_dma_addr Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-21  8:05   ` Julien Grall
2020-05-21  8:05     ` Julien Grall
2020-05-22  3:55     ` Stefano Stabellini
2020-05-22  3:55       ` Stefano Stabellini
2020-05-22 18:16       ` Julien Grall
2020-05-22 18:16         ` Julien Grall
2020-05-22 20:47         ` Stefano Stabellini
2020-05-22 20:47           ` Stefano Stabellini
2020-05-20 23:45 ` [PATCH 03/10] swiotlb-xen: add struct device* parameter to xen_phys_to_bus Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-20 23:45 ` [PATCH 04/10] swiotlb-xen: add struct device* parameter to xen_bus_to_phys Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-20 23:45 ` [PATCH 05/10] swiotlb-xen: add struct device* parameter to xen_dma_sync_for_cpu Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-20 23:45 ` [PATCH 06/10] swiotlb-xen: add struct device* parameter to xen_dma_sync_for_device Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-20 23:45 ` [PATCH 07/10] swiotlb-xen: add struct device* parameter to is_xen_swiotlb_buffer Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-20 23:45 ` [PATCH 08/10] swiotlb-xen: introduce phys_to_dma/dma_to_phys translations Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-21  8:07   ` Julien Grall
2020-05-21  8:07     ` Julien Grall
2020-05-21 22:59   ` Boris Ostrovsky
2020-05-21 22:59     ` Boris Ostrovsky
2020-05-22 17:34     ` Stefano Stabellini [this message]
2020-05-22 17:34       ` Stefano Stabellini
2020-05-22 18:29       ` Boris Ostrovsky
2020-05-22 18:29         ` Boris Ostrovsky
2020-05-20 23:45 ` [PATCH 09/10] xen/arm: introduce phys/dma translations in xen_dma_sync_for_* Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-21  8:18   ` Julien Grall
2020-05-21  8:18     ` Julien Grall
2020-05-21 20:08     ` Stefano Stabellini
2020-05-21 20:08       ` Stefano Stabellini
2020-05-21 20:17       ` Julien Grall
2020-05-21 20:17         ` Julien Grall
2020-05-20 23:45 ` [PATCH 10/10] xen/arm: call dma_to_phys on the dma_addr_t parameter of dma_cache_maint Stefano Stabellini
2020-05-20 23:45   ` Stefano Stabellini
2020-05-21  8:25   ` Julien Grall
2020-05-21  8:25     ` Julien Grall
2020-05-20 23:51 ` [PATCH 00/10] fix swiotlb-xen for RPi4 Roman Shaposhnik
2020-05-20 23:51   ` Roman Shaposhnik
2020-05-20 23:56   ` Stefano Stabellini
2020-05-20 23:56     ` Stefano Stabellini
2020-06-02 21:51 ` Stefano Stabellini
2020-06-02 21:51   ` Stefano Stabellini
2020-06-03  0:15   ` Boris Ostrovsky
2020-06-03  0:15     ` Boris Ostrovsky

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.21.2005221033180.27502@sstabellini-ThinkPad-T480s \
    --to=sstabellini@kernel.org \
    --cc=boris.ostrovsky@oracle.com \
    --cc=jgross@suse.com \
    --cc=konrad.wilk@oracle.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=stefano.stabellini@xilinx.com \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.