All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kirti Wankhede <kwankhede@nvidia.com>
To: "Tian, Kevin" <kevin.tian@intel.com>,
	Alex Williamson <alex.williamson@redhat.com>
Cc: "pbonzini@redhat.com" <pbonzini@redhat.com>,
	"kraxel@redhat.com" <kraxel@redhat.com>,
	"cjia@nvidia.com" <cjia@nvidia.com>,
	"qemu-devel@nongnu.org" <qemu-devel@nongnu.org>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"Song, Jike" <jike.song@intel.com>,
	"bjsdjshi@linux.vnet.ibm.com" <bjsdjshi@linux.vnet.ibm.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v9 04/12] vfio iommu: Add support for mediated devices
Date: Wed, 26 Oct 2016 20:36:01 +0530	[thread overview]
Message-ID: <b05e5856-a9f3-a7b5-32d5-bf3a9e0f2bfa@nvidia.com> (raw)
In-Reply-To: <AADFC41AFE54684AB9EE6CBC0274A5D18DFE32A9@SHSMSX101.ccr.corp.intel.com>



On 10/26/2016 12:49 PM, Tian, Kevin wrote:
>> From: Alex Williamson [mailto:alex.williamson@redhat.com]
>> Sent: Monday, October 24, 2016 10:32 AM
>>
>>>>> -static long vfio_unpin_pages(unsigned long pfn, long npage,
>>>>> -			     int prot, bool do_accounting)
>>>>> +static long __vfio_unpin_pages_remote(struct vfio_iommu *iommu,
>>>>> +				      unsigned long pfn, long npage, int prot,
>>>>> +				      bool do_accounting)
>>>>
>>>> Have you noticed that it's kind of confusing that
>>>> __vfio_{un}pin_pages_remote() uses current, which does a
>>>> get_user_pages_fast() while "local" uses a provided task_struct and
>>>> uses get_user_pages_*remote*()?  And also what was effectively local
>>>> (ie. we're pinning for our own use here) is now "remote" and pinning
>>>> for a remote, vendor driver consumer, is now "local".  It's not very
>>>> intuitive.
>>>>
> 
> I questioned this confusing naming in v8 too...
> 

I do tried to address your concerns on v8.

>>>
>>> 'local' in local_domain was suggested to describe the domain for local
>>> page tracking. Earlier suggestions to have 'mdev' or 'noimmu' in this
>>> name were discarded. May be we should revisit what the name should be.
>>> Any suggestion?
>>>
>>> For local_domain, to pin pages, flow is:
>>>
>>> for local_domain
>>>     |- vfio_pin_pages()
>>>         |- vfio_iommu_type1_pin_pages()
>>>             |- __vfio_pin_page_local()
>>>                 |-  vaddr_get_pfn(task->mm)
>>>                     |- get_user_pages_remote()
>>>
>>> __vfio_pin_page_local() --> get_user_pages_remote()
>>
>>
>> In vfio.c we have the concept of an external user, perhaps that could
>> be continued here.  An mdev driver would be an external, or remote
>> pinning.
>>
> 
> I prefer to use remote here. It's aligned with underlying mm operations
> 

Using 'remote' in this case is also confusing since it is already used
in this file. I liked Alex's suggestion to use external and I'll have
those changed in next version of patch set.

Kirti

WARNING: multiple messages have this Message-ID (diff)
From: Kirti Wankhede <kwankhede@nvidia.com>
To: "Tian, Kevin" <kevin.tian@intel.com>,
	Alex Williamson <alex.williamson@redhat.com>
Cc: "pbonzini@redhat.com" <pbonzini@redhat.com>,
	"kraxel@redhat.com" <kraxel@redhat.com>,
	"cjia@nvidia.com" <cjia@nvidia.com>,
	"qemu-devel@nongnu.org" <qemu-devel@nongnu.org>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"Song, Jike" <jike.song@intel.com>,
	"bjsdjshi@linux.vnet.ibm.com" <bjsdjshi@linux.vnet.ibm.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [Qemu-devel] [PATCH v9 04/12] vfio iommu: Add support for mediated devices
Date: Wed, 26 Oct 2016 20:36:01 +0530	[thread overview]
Message-ID: <b05e5856-a9f3-a7b5-32d5-bf3a9e0f2bfa@nvidia.com> (raw)
In-Reply-To: <AADFC41AFE54684AB9EE6CBC0274A5D18DFE32A9@SHSMSX101.ccr.corp.intel.com>



On 10/26/2016 12:49 PM, Tian, Kevin wrote:
>> From: Alex Williamson [mailto:alex.williamson@redhat.com]
>> Sent: Monday, October 24, 2016 10:32 AM
>>
>>>>> -static long vfio_unpin_pages(unsigned long pfn, long npage,
>>>>> -			     int prot, bool do_accounting)
>>>>> +static long __vfio_unpin_pages_remote(struct vfio_iommu *iommu,
>>>>> +				      unsigned long pfn, long npage, int prot,
>>>>> +				      bool do_accounting)
>>>>
>>>> Have you noticed that it's kind of confusing that
>>>> __vfio_{un}pin_pages_remote() uses current, which does a
>>>> get_user_pages_fast() while "local" uses a provided task_struct and
>>>> uses get_user_pages_*remote*()?  And also what was effectively local
>>>> (ie. we're pinning for our own use here) is now "remote" and pinning
>>>> for a remote, vendor driver consumer, is now "local".  It's not very
>>>> intuitive.
>>>>
> 
> I questioned this confusing naming in v8 too...
> 

I do tried to address your concerns on v8.

>>>
>>> 'local' in local_domain was suggested to describe the domain for local
>>> page tracking. Earlier suggestions to have 'mdev' or 'noimmu' in this
>>> name were discarded. May be we should revisit what the name should be.
>>> Any suggestion?
>>>
>>> For local_domain, to pin pages, flow is:
>>>
>>> for local_domain
>>>     |- vfio_pin_pages()
>>>         |- vfio_iommu_type1_pin_pages()
>>>             |- __vfio_pin_page_local()
>>>                 |-  vaddr_get_pfn(task->mm)
>>>                     |- get_user_pages_remote()
>>>
>>> __vfio_pin_page_local() --> get_user_pages_remote()
>>
>>
>> In vfio.c we have the concept of an external user, perhaps that could
>> be continued here.  An mdev driver would be an external, or remote
>> pinning.
>>
> 
> I prefer to use remote here. It's aligned with underlying mm operations
> 

Using 'remote' in this case is also confusing since it is already used
in this file. I liked Alex's suggestion to use external and I'll have
those changed in next version of patch set.

Kirti

  reply	other threads:[~2016-10-26 15:06 UTC|newest]

Thread overview: 148+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-17 21:22 [PATCH v9 00/12] Add Mediated device support Kirti Wankhede
2016-10-17 21:22 ` [Qemu-devel] " Kirti Wankhede
2016-10-17 21:22 ` [PATCH v9 01/12] vfio: Mediated device Core driver Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-18 23:16   ` Alex Williamson
2016-10-18 23:16     ` [Qemu-devel] " Alex Williamson
2016-10-19 19:16     ` Kirti Wankhede
2016-10-19 19:16       ` [Qemu-devel] " Kirti Wankhede
2016-10-19 22:20       ` Alex Williamson
2016-10-19 22:20         ` [Qemu-devel] " Alex Williamson
2016-10-19 22:20         ` Alex Williamson
2016-10-20  7:23   ` Jike Song
2016-10-20  7:23     ` [Qemu-devel] " Jike Song
2016-10-20 17:12     ` Alex Williamson
2016-10-20 17:12       ` [Qemu-devel] " Alex Williamson
2016-10-21  2:41       ` Jike Song
2016-10-21  2:41         ` [Qemu-devel] " Jike Song
2016-10-27  5:56       ` Jike Song
2016-10-27  5:56         ` [Qemu-devel] " Jike Song
2016-10-26  6:52   ` Tian, Kevin
2016-10-26  6:52     ` [Qemu-devel] " Tian, Kevin
2016-10-26 14:58     ` Kirti Wankhede
2016-10-26 14:58       ` [Qemu-devel] " Kirti Wankhede
2016-10-17 21:22 ` [PATCH v9 02/12] vfio: VFIO based driver for Mediated devices Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-26  6:57   ` Tian, Kevin
2016-10-26  6:57     ` [Qemu-devel] " Tian, Kevin
2016-10-26 15:01     ` Kirti Wankhede
2016-10-26 15:01       ` [Qemu-devel] " Kirti Wankhede
2016-10-17 21:22 ` [PATCH v9 03/12] vfio: Rearrange functions to get vfio_group from dev Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-19 17:26   ` Alex Williamson
2016-10-19 17:26     ` [Qemu-devel] " Alex Williamson
2016-10-17 21:22 ` [PATCH v9 04/12] vfio iommu: Add support for mediated devices Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-17 21:22   ` Kirti Wankhede
2016-10-19 21:02   ` Alex Williamson
2016-10-19 21:02     ` [Qemu-devel] " Alex Williamson
2016-10-20 20:17     ` Kirti Wankhede
2016-10-20 20:17       ` [Qemu-devel] " Kirti Wankhede
2016-10-24  2:32       ` Alex Williamson
2016-10-24  2:32         ` [Qemu-devel] " Alex Williamson
2016-10-26  7:19         ` Tian, Kevin
2016-10-26  7:19           ` [Qemu-devel] " Tian, Kevin
2016-10-26 15:06           ` Kirti Wankhede [this message]
2016-10-26 15:06             ` Kirti Wankhede
2016-10-26  7:53     ` Tian, Kevin
2016-10-26  7:53       ` [Qemu-devel] " Tian, Kevin
2016-10-26 15:16       ` Alex Williamson
2016-10-26 15:16         ` [Qemu-devel] " Alex Williamson
2016-10-26  7:54     ` Tian, Kevin
2016-10-26  7:54       ` [Qemu-devel] " Tian, Kevin
2016-10-26 15:19       ` Alex Williamson
2016-10-26 15:19         ` [Qemu-devel] " Alex Williamson
2016-10-21  7:49   ` Jike Song
2016-10-21  7:49     ` [Qemu-devel] " Jike Song
2016-10-21 14:36     ` Alex Williamson
2016-10-21 14:36       ` [Qemu-devel] " Alex Williamson
2016-10-24 10:35       ` Kirti Wankhede
2016-10-24 10:35         ` [Qemu-devel] " Kirti Wankhede
2016-10-27  7:20   ` Alexey Kardashevskiy
2016-10-27 12:31     ` Kirti Wankhede
2016-10-27 12:31       ` Kirti Wankhede
2016-10-27 12:31       ` Kirti Wankhede
2016-10-27 14:30       ` [Qemu-devel] " Alex Williamson
2016-10-27 14:30         ` Alex Williamson
2016-10-27 14:30         ` Alex Williamson
2016-10-27 15:59         ` [Qemu-devel] " Kirti Wankhede
2016-10-27 15:59           ` Kirti Wankhede
2016-10-28  2:18       ` Alexey Kardashevskiy
2016-11-01 14:01         ` Kirti Wankhede
2016-11-01 14:01           ` Kirti Wankhede
2016-11-02  1:24           ` Alexey Kardashevskiy
2016-11-02  3:29             ` Kirti Wankhede
2016-11-02  3:29               ` Kirti Wankhede
2016-11-02  4:09               ` Alexey Kardashevskiy
2016-11-02 12:21                 ` Jike Song
2016-11-02 12:21                   ` Jike Song
2016-11-02 12:41                   ` [Qemu-devel] " Kirti Wankhede
2016-11-02 12:41                     ` Kirti Wankhede
2016-11-02 13:00                     ` Jike Song
2016-11-02 13:18                       ` Kirti Wankhede
2016-11-02 13:18                         ` Kirti Wankhede
2016-11-02 13:35                         ` Jike Song
2016-11-02 13:35                           ` Jike Song
2016-11-03  4:29                         ` [Qemu-devel] " Alexey Kardashevskiy
2016-11-03  4:29                           ` Alexey Kardashevskiy
2016-10-17 21:22 ` [PATCH v9 05/12] vfio: Introduce common function to add capabilities Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-20 19:24   ` Alex Williamson
2016-10-20 19:24     ` [Qemu-devel] " Alex Williamson
2016-10-24 21:27     ` Kirti Wankhede
2016-10-24 21:27       ` [Qemu-devel] " Kirti Wankhede
2016-10-24 21:39       ` Alex Williamson
2016-10-24 21:39         ` [Qemu-devel] " Alex Williamson
2016-10-17 21:22 ` [PATCH v9 06/12] vfio_pci: Update vfio_pci to use vfio_info_add_capability() Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-20 19:24   ` Alex Williamson
2016-10-20 19:24     ` [Qemu-devel] " Alex Williamson
2016-10-24 21:22     ` Kirti Wankhede
2016-10-24 21:22       ` [Qemu-devel] " Kirti Wankhede
2016-10-24 21:37       ` Alex Williamson
2016-10-24 21:37         ` [Qemu-devel] " Alex Williamson
2016-10-17 21:22 ` [PATCH v9 07/12] vfio: Introduce vfio_set_irqs_validate_and_prepare() Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-17 21:22 ` [PATCH v9 08/12] vfio_pci: Updated to use vfio_set_irqs_validate_and_prepare() Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-17 21:22 ` [PATCH v9 09/12] vfio_platform: " Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-17 21:22 ` [PATCH v9 10/12] vfio: Add function to get device_api string from vfio_device_info.flags Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-20 19:34   ` Alex Williamson
2016-10-20 19:34     ` [Qemu-devel] " Alex Williamson
2016-10-20 20:29     ` Kirti Wankhede
2016-10-20 20:29       ` [Qemu-devel] " Kirti Wankhede
2016-10-20 21:05       ` Alex Williamson
2016-10-20 21:05         ` [Qemu-devel] " Alex Williamson
2016-10-20 21:14         ` Kirti Wankhede
2016-10-20 21:14           ` [Qemu-devel] " Kirti Wankhede
2016-10-20 21:22           ` Alex Williamson
2016-10-20 21:22             ` [Qemu-devel] " Alex Williamson
2016-10-21  3:00             ` Kirti Wankhede
2016-10-21  3:00               ` [Qemu-devel] " Kirti Wankhede
2016-10-21  3:20               ` Alex Williamson
2016-10-21  3:20                 ` [Qemu-devel] " Alex Williamson
2016-10-17 21:22 ` [PATCH v9 11/12] docs: Add Documentation for Mediated devices Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-25 16:17   ` Alex Williamson
2016-10-25 16:17     ` [Qemu-devel] " Alex Williamson
2016-10-17 21:22 ` [PATCH v9 12/12] docs: Sample driver to demonstrate how to use Mediated device framework Kirti Wankhede
2016-10-17 21:22   ` [Qemu-devel] " Kirti Wankhede
2016-10-18  2:54   ` Dong Jia Shi
2016-10-18 17:17     ` Alex Williamson
2016-10-18 17:17       ` [Qemu-devel] " Alex Williamson
2016-10-19 19:19       ` Kirti Wankhede
2016-10-19 19:19         ` [Qemu-devel] " Kirti Wankhede
2016-10-18  2:54   ` Dong Jia Shi
2016-10-17 21:41 ` [PATCH v9 00/12] Add Mediated device support Alex Williamson
2016-10-17 21:41   ` [Qemu-devel] " Alex Williamson
2016-10-24  7:07 ` Jike Song
2016-10-24  7:07   ` [Qemu-devel] " Jike Song
2016-12-05 17:44   ` Gerd Hoffmann
2016-12-05 17:44     ` [Qemu-devel] " Gerd Hoffmann
2016-12-05 17:44     ` Gerd Hoffmann
2016-12-06  2:24     ` Jike Song
2016-12-06  2:24       ` [Qemu-devel] " Jike Song
2016-12-07 14:40       ` Gerd Hoffmann
2016-12-07 14:40         ` [Qemu-devel] " Gerd Hoffmann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b05e5856-a9f3-a7b5-32d5-bf3a9e0f2bfa@nvidia.com \
    --to=kwankhede@nvidia.com \
    --cc=alex.williamson@redhat.com \
    --cc=bjsdjshi@linux.vnet.ibm.com \
    --cc=cjia@nvidia.com \
    --cc=jike.song@intel.com \
    --cc=kevin.tian@intel.com \
    --cc=kraxel@redhat.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pbonzini@redhat.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.